Feisty 0.90~rc3-1ubuntu1 - After install of clamav, Freshclam does not update

Bug #85573 reported by Scott Kitterman on 2007-02-16
14
Affects Status Importance Assigned to Milestone
clamav (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: clamav

After install, freshclam is active:

$ ps -AF|grep clam
clamav 7093 1 0 1413 368 0 Feb12 ? 00:00:00 /usr/bin/freshclam -d --quiet
kitterma 7399 6717 0 708 548 0 Feb12 pts/1 00:00:00 tail -f freshclam.log
kitterma 12446 3501 0 721 744 0 09:18 pts/4 00:00:00 grep clam

but nothing is logged and no updates are made:

$ ls -l /var/lib/clamav
total 8432
-rw-r--r-- 1 root root 425120 2007-02-12 21:49 daily.cvd
-rw-r--r-- 1 root root 8189490 2007-02-12 21:49 main.cvd

Note: Date/time of the file are when I did the initial install.

Related branches

garybrlow (garybrlow) wrote :

Clam AV not functioning on 0.90 update in feisty. Seems to have internal log permission errors. ClamTK fails to find the ClamAV virus definitions as well rendering it useless. freshcalm and other related programs inherit the permission problems.

Scott Kitterman (kitterman) wrote :

Still a problem with 0.90.1-1ubuntu1.

Changed in clamav:
status: Unconfirmed → Confirmed
William Grant (wgrant) wrote :

This is a dupe of bug #85573, isn't it?

William Grant (wgrant) wrote :

Bug #85572, sorry.

Scott Kitterman (kitterman) wrote :

No. #85572 was about clamav itseld, not freshclam. It was also an invalid bug (my bad).

I've made some progress on this. The current Edgy clamav-freshclam init will start (with errors) the Feisty freshclam so that it runs and updates correctly.

Scott Kitterman (kitterman) wrote :

Fix attached. In the Edgy/Feisty update process the freshclam init stopped specifying a pid file.

To test the fix, I first made the change directly to the installed clamav-freshclam init. Then I built the updated package and installed the new binary and verified that the problem was corrected. This is on an i386 machine.

Barry deFreese (bddebian) wrote :

Uploaded to feisty. Please keep an eye on it. Thanks.

Changed in clamav:
status: Confirmed → Fix Committed
Scott Kitterman (kitterman) wrote :

Released as clamav 0.90.1-1ubuntu2.

Changed in clamav:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers