(could not find var/log/clamav DIR to create file in; did not autocreate directory) package clamav-daemon 0.97.3+dfsg-1ubuntu0.11.04.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1

Bug #1001725 reported by pakopako on 2012-05-19
26
This bug affects 4 people
Affects Status Importance Assigned to Milestone
clamav (Ubuntu)
High
Unassigned

Bug Description

Entry-level Ubuntu user, please bear with me. Using Ubuntu's Update Manager, one of the updates stopped because it could not find the directory /var/log/clamav when it was trying to touch/create a logfile because my install of clamav from the Ubuntu Software Center either did not create one or the system flushes out the /var/log directory upon logout.
In either case, the updater could not find the directory to create the file in and did not autocreate directory. I will manually create said directory and try the update again.

ProblemType: Package
DistroRelease: Ubuntu 11.04
Package: clamav-daemon 0.97.3+dfsg-1ubuntu0.11.04.1
ProcVersionSignature: Ubuntu 2.6.38-15.59-generic 2.6.38.8
Uname: Linux 2.6.38-15-generic i686
NonfreeKernelModules: nvidia
Architecture: i386
Date: Sat May 19 13:36:14 2012
ErrorMessage: subprocess installed post-installation script returned error exit status 1
SourcePackage: clamav
Title: package clamav-daemon 0.97.3+dfsg-1ubuntu0.11.04.1 failed to install/upgrade: subprocess installed post-installation script returned error exit status 1
UpgradeStatus: No upgrade log present (probably fresh install)

pakopako (pakopako) wrote :
Marc Cluet (lynxman) on 2012-05-21
Changed in clamav (Ubuntu):
status: New → Invalid
status: Invalid → New
Marc Cluet (lynxman) wrote :

Confirmed and reproduced, postinst packages don't have /var/log/clamav creation and it's not created by the package postinst or available in the dirs file

Changed in clamav (Ubuntu):
status: New → Confirmed
James Page (james-page) on 2012-05-31
Changed in clamav (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Scott Kitterman (kitterman) wrote :

No. That's not the correct diagnosis. You're right it's not created in the postinst. It's shipped directly in the clamav-base package. I think it's /var/log/clamav/clamav.log itself that's missing. I don't know how that can happen, however.

Changed in clamav (Ubuntu):
status: Triaged → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in clamav (Ubuntu):
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers