[SRU] Spotify album icon shows optimal CD disk instead of album/cover image

Bug #1901344 reported by Joshua Peisach on 2020-10-24
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cinnamon (Ubuntu)
Low
Joshua Peisach
Focal
Low
Joshua Peisach
Groovy
Low
Joshua Peisach
cinnamon-screensaver (Ubuntu)
Low
Joshua Peisach
Focal
Low
Joshua Peisach
Groovy
Low
Joshua Peisach

Bug Description

The Spotify Album Icon in the Sound Applet should show the Album/Song cover of the Spotify song. Instead it shows the default CD icon.

According to upstream, the Spotify link has changed. A fix for this (and in the cinnamon-screensaver) is available.

An SRU for BOTH PACKAGES, cinnamon, and cinnamon-screensaver in Focal and Groovy is required. (4 projects, 2 packages, 2 versions)

SRU Template:
[Impact]

 * When users are playing a Song via Spotify:
      * Cinnamon Package: In the sound applet, the Spotify album cover should show, but instead the plain 'CD'/Disk icon shows.
      * Cinnamon Screensaver Package: On the top left, the song information, including the album cover should show but the album cover doesn't appear.

[Test Case]

 * Cinnamon Package: Play a song via Spotify and open the Sound applet to see the CD/Disk icon rather than the album.
 * Cinnamon Screensaver Package: Play a song via Spotify and lock the screen to see no album on the top left when you unlock when it asks for password input.

[Regression Potential]

 * Regressions through other Spotify updates, or any link updates (the main cause of this bug) can cause possible regression.

 * The main cause of this bug was broken links-so another link change can also cause regression, so this may need to be SRU'd again sometime in the future.

 * Python is always known for breaking compatibility with plugins and such; while this is unlikely if it were to happen, it probably shouldn't happen before the support for Focal/Groovy expires.

[Other Info]

 * This package requires a patch for BOTH Focal and Groovy.
 * Review the Focal patch first before we move onto the Groovy patch
 * Both will be tested.

ProblemType: Bug
DistroRelease: Ubuntu 20.10
Package: cinnamon 4.6.7-1ubuntu1
ProcVersionSignature: Ubuntu 5.8.0-25.26-generic 5.8.14
Uname: Linux 5.8.0-25-generic x86_64
ApportVersion: 2.20.11-0ubuntu50
Architecture: amd64
CasperMD5CheckResult: skip
CurrentDesktop: Unity
Date: Sat Oct 24 15:10:36 2020
InstallationDate: Installed on 2020-10-23 (1 days ago)
InstallationMedia: Ubuntu 20.10 "Groovy Gorilla" - Release amd64 (20201022)
ProcEnviron:
 TERM=xterm-color
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: cinnamon
UpgradeStatus: No upgrade log present (probably fresh install)

Joshua Peisach (itzswirlz) wrote :
no longer affects: cinnamon-desktop
Changed in cinnamon (Ubuntu):
assignee: nobody → Joshua Peisach (itzswirlz)
Changed in cinnamon-screensaver (Ubuntu):
assignee: nobody → Joshua Peisach (itzswirlz)
tags: added: focal
Joshua Peisach (itzswirlz) wrote :

Cinnamon's Patch (Sound Applet)

description: updated
tags: added: sru
Joshua Peisach (itzswirlz) wrote :

Cinnamon Screensavers Patch

(The one above and this is for Focal aswell)

The attachment "cinnamon_4.4.8-4ubuntu0.1.debdiff" seems to be a debdiff. The ubuntu-sponsors team has been subscribed to the bug report so that they can review and hopefully sponsor the debdiff. If the attachment isn't a patch, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are member of the ~ubuntu-sponsors, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issue please contact him.]

tags: added: patch
Mathew Hodson (mhodson) on 2020-11-15
Changed in cinnamon (Ubuntu):
importance: Undecided → Low
Changed in cinnamon-screensaver (Ubuntu):
importance: Undecided → Low
summary: - [SRU Required] Spotify album icon shows optimal CD disk instead of
- album/cover image
+ [SRU] Spotify album icon shows optimal CD disk instead of album/cover
+ image
Changed in cinnamon (Ubuntu):
status: New → Confirmed
Changed in cinnamon-screensaver (Ubuntu):
status: New → Confirmed
Joshua Peisach (itzswirlz) wrote :

Fixed/updated patches

description: updated
Joshua Peisach (itzswirlz) wrote :

Final updated patch - for cinnamon focal 4.4.8-4ubuntu0.2

Robie Basak (racb) wrote :

This looks good from a quick glance. What's the status of the bug in Hirsute? I appreciate you might not have been able to add bug tasks, but just a comment would help me create the tasks and set the status you state.

To save review time, could you also prepare the Groovy debdiffs please? If the quilt patch files can be kept the same, then that really helps. But even if not, a reviewer can do both faster than two reviewers reviewing the two series separately at different times.

Joshua Peisach (itzswirlz) wrote :

Fixed in Hirsute. I can get the Groovy patches ready later today and send it to you, they are probably going to be two different patches as the line numbers may have changed.

Robie Basak (racb) wrote :

Patch and quilt will cope fine with line numbers changing. But if the context has changed and it doesn't work or applies only with fuzz, then the patches will need reworking. Otherwise, if it works, please try to keep the quilt patch files identical - this makes review easier.

Joshua Peisach (itzswirlz) wrote :

The .patch files will work on the same-on groovy build you will just get this applying quilt:

Applying patch debian/patches/fix-spotify-artwork-url.patch
patching file <email address hidden>/applet.js
Hunk #1 succeeded at 687 (offset -4 lines).

If it works, I'll take your word for it. So I guess on that note they both work.

Only thing needed to do is update the changelog versions, patches work for focal and groovy.

On Tue, Jan 12, 2021 at 05:14:12PM -0000, Joshua Peisach wrote:
> The .patch files will work on the same-on groovy build you will just get
> this applying quilt:
>
> Applying patch debian/patches/fix-spotify-artwork-url.patch
> patching file <email address hidden>/applet.js
> Hunk #1 succeeded at 687 (offset -4 lines).
>
> If it works, I'll take your word for it. So I guess on that note they
> both work.

Yeah, that'll be fine, and I prefer that to refreshing the patch because
the patch files being the same means there's less to review. The key
thing is to look for the word "fuzz". If it says it applied with fuzz (I
forget the exact wording), then that's acceptable to quilt but not to
dpkg.

Joshua Peisach (itzswirlz) wrote :

The patch files are the same, they both build identically without any fuzz complaints

Mathew Hodson (mhodson) wrote :
Changed in cinnamon (Ubuntu Focal):
importance: Undecided → Low
Changed in cinnamon (Ubuntu Groovy):
importance: Undecided → Low
Changed in cinnamon-screensaver (Ubuntu Focal):
importance: Undecided → Low
Changed in cinnamon-screensaver (Ubuntu Groovy):
importance: Undecided → Low
Changed in cinnamon (Ubuntu):
status: Confirmed → Fix Released
Mathew Hodson (mhodson) wrote :

cinnamon-screensaver (4.8.1-2) unstable; urgency=medium

  * Release to unstable.

 -- Norbert Preining <email address hidden> Wed, 16 Dec 2020 12:37:58 +0900

Changed in cinnamon-screensaver (Ubuntu):
status: Confirmed → Fix Released
Joshua Peisach (itzswirlz) wrote :

Set all tasks assigned to me as I made the patches, In Progress as awaiting sponsorship

Changed in cinnamon (Ubuntu Focal):
status: New → Fix Committed
Changed in cinnamon (Ubuntu Groovy):
status: New → Fix Committed
Changed in cinnamon-screensaver (Ubuntu Focal):
status: New → Fix Committed
Changed in cinnamon-screensaver (Ubuntu Groovy):
status: New → In Progress
Changed in cinnamon (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in cinnamon (Ubuntu Groovy):
status: Fix Committed → In Progress
Changed in cinnamon-screensaver (Ubuntu Focal):
status: Fix Committed → In Progress
Changed in cinnamon (Ubuntu Focal):
assignee: nobody → Joshua Peisach (itzswirlz)
Changed in cinnamon (Ubuntu Groovy):
assignee: nobody → Joshua Peisach (itzswirlz)
Changed in cinnamon-screensaver (Ubuntu Groovy):
assignee: nobody → Joshua Peisach (itzswirlz)
Changed in cinnamon-screensaver (Ubuntu Focal):
assignee: nobody → Joshua Peisach (itzswirlz)
Robie Basak (racb) wrote :

I'm expecting four debdiffs here. cinnamon and cinnamon-screensaver for Focal, and again for Groovy. Even if the quilt patches themselves are the same (as above, ideally they would be), the different debdiffs would still need separate changelog headers (stating different release version numbers). Am I missing something?

Joshua Peisach (itzswirlz) wrote :

I thought you just wanted the two debdiffs, if you want i guess i can generate the other two? The physical .patch file is the same its just the changelogs

Joshua Peisach (itzswirlz) wrote :
Robie Basak (racb) wrote :

I fixed a few things up, figuring we'd done enough back and forthing on this already. For the record:

The cinnamon Groovy debdiff didn't apply, but as it's supposed to be the same as the patch being applied to Focal, I picked up your changelog entry and manually took the quilt patch from Focal. This seems to work.

The cinnamon-screensaver patch (update-spotify-album-art-url.patch) varies very slightly between Focal and Groovy, including one statement-ending semicolon disappearing in Groovy. Since it's Python, I trust this makes no functional difference.

The Groovy changelog entries said "groovy-updates" in their header. I'm not sure how that'll be handled by Launchpad; it may redirect just fine. But to save another iteration to find out, I just changed both to "groovy" to match convention and your debdiffs for Focal.

The SRU information in this bug looks good, and the bug references in the changelog entries and version numbers are all correct. Sponsored and unsubscribed ~ubuntu-sponsors. Thanks!

Now awaiting SRU team review (I shouldn't do that myself as I sponsored).

Hello Joshua, or anyone else affected,

Accepted cinnamon into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cinnamon/4.6.7-1ubuntu1.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in cinnamon (Ubuntu Groovy):
status: In Progress → Fix Committed
tags: added: verification-needed verification-needed-groovy
Łukasz Zemczak (sil2100) wrote :

Hello Joshua, or anyone else affected,

Accepted cinnamon into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cinnamon/4.4.8-4ubuntu0.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in cinnamon (Ubuntu Focal):
status: In Progress → Fix Committed
tags: added: verification-needed-focal
Joshua Peisach (itzswirlz) wrote :

Cinnamon Sound Applet Focal Verification Complete

1) Boot up focal
2) Update system
3) Install spotify, login, open sound applet while playing song to see no album art is there
4) Enable proposed
5) Update and reboot
6) Play spotify song, check sound applet and the album art is there

Joshua Peisach (itzswirlz) wrote :

Cinnamon verification for groovy done

Brian Murray (brian-murray) wrote :

Hello Joshua, or anyone else affected,

Accepted cinnamon-screensaver into groovy-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cinnamon-screensaver/4.6.0-2ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-groovy to verification-done-groovy. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-groovy. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Changed in cinnamon-screensaver (Ubuntu Groovy):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

For what it's worth the semi-colon in the patch is unnecessary.

Changed in cinnamon-screensaver (Ubuntu Focal):
status: In Progress → Fix Committed
Brian Murray (brian-murray) wrote :

Hello Joshua, or anyone else affected,

Accepted cinnamon-screensaver into focal-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/cinnamon-screensaver/4.4.1-3ubuntu0.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, what testing has been performed on the package and change the tag from verification-needed-focal to verification-done-focal. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-focal. In either case, without details of your testing we will not be able to proceed.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance for helping!

N.B. The updated package will be released to -updates after the bug(s) fixed by this package have been verified and the package has been in -proposed for a minimum of 7 days.

Joshua Peisach (itzswirlz) wrote :

Verification done, groovy and focal

tags: added: verification-done-focal verification-done-groovy
removed: verification-needed-focal verification-needed-groovy
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cinnamon - 4.6.7-1ubuntu1.1

---------------
cinnamon (4.6.7-1ubuntu1.1) groovy; urgency=medium

  * Update spotify artwork url (LP: #1901344)

 -- Joshua Peisach <email address hidden> Wed, 10 Feb 2021 15:50:40 -0500

Changed in cinnamon (Ubuntu Groovy):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for cinnamon has completed successfully and the package is now being released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cinnamon-screensaver - 4.6.0-2ubuntu0.1

---------------
cinnamon-screensaver (4.6.0-2ubuntu0.1) groovy; urgency=medium

  * album art: Adjust the album art url for Spotify. (LP: #1901344)

 -- Joshua Peisach <email address hidden> Wed, 10 Feb 2021 15:40:21 -0500

Changed in cinnamon-screensaver (Ubuntu Groovy):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cinnamon-screensaver - 4.4.1-3ubuntu0.1

---------------
cinnamon-screensaver (4.4.1-3ubuntu0.1) focal; urgency=medium

  * album art: Adjust the album art url for Spotify. (LP: #1901344)

 -- Joshua Peisach <email address hidden> Sat, 26 Oct 2020 18:19:16 -0500

Changed in cinnamon-screensaver (Ubuntu Focal):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cinnamon - 4.4.8-4ubuntu0.2

---------------
cinnamon (4.4.8-4ubuntu0.2) focal; urgency=medium

  * Update spotify artwork url (LP: #1901344)

 -- Joshua Peisach <email address hidden> Sat, 09 Jan 2021 11:43:54 -0500

Changed in cinnamon (Ubuntu Focal):
status: Fix Committed → Fix Released
Changed in cinnamon-screensaver (Ubuntu Focal):
status: Fix Released → In Progress
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.