Chromium doesn't use Icedtea Java NPAPI plugin

Bug #1309508 reported by Никола Павловић on 2014-04-18
94
This bug affects 19 people
Affects Status Importance Assigned to Milestone
Iced Tea
Won't Fix
High
chromium-browser (Ubuntu)
High
Unassigned
icedtea-web (Ubuntu)
Wishlist
Unassigned

Bug Description

I've installed openjdk-7-jre and icedtea-7-plugin, but chromium can't launch java applets. Java doesn't show in about:plugins.
How to reproduce:
1) Install openjdk-7-jre and icedtea-7-plugin
2) Open chromium
3) Go to about:plugins and look for java or icedtea, or try to run an applet
What happens: the plugin is not listed, applets won't run
What is expected: the plugin is listed and applets work

Note: Firefox detects the plugin and applets work in Firefox, which means the plugin is properly installed.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: chromium-browser 34.0.1847.116-0ubuntu2
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
ApportVersion: 2.14.1-0ubuntu3
Architecture: amd64
CurrentDesktop: Unity
Date: Fri Apr 18 14:42:43 2014
Desktop-Session:
 DESKTOP_SESSION = ubuntu
 XDG_CONFIG_DIRS = /etc/xdg/xdg-ubuntu:/usr/share/upstart/xdg:/etc/xdg
 XDG_DATA_DIRS = /usr/share/ubuntu:/usr/share/gnome:/usr/local/share/:/usr/share/
DetectedPlugins:

DiskUsage:
 b'Filesystem Type Size Used Avail Use% Mounted on\n/dev/sda5 ext4 47G 7,3G 38G 17% /\nnone tmpfs 4,0K 0 4,0K 0% /sys/fs/cgroup\nudev devtmpfs 1,9G 4,0K 1,9G 1% /dev\ntmpfs tmpfs 381M 1,2M 380M 1% /run\nnone tmpfs 5,0M 0 5,0M 0% /run/lock\nnone tmpfs 1,9G 7,9M 1,9G 1% /run/shm\nnone tmpfs 100M 100K 100M 1% /run/user\n/dev/sda6 ext4 160G 110G 43G 73% /home\n'

 Inodes:
 b'Filesystem Inodes IUsed IFree IUse% Mounted on\n/dev/sda5 3,0M 285K 2,8M 10% /\nnone 476K 2 476K 1% /sys/fs/cgroup\nudev 474K 524 473K 1% /dev\ntmpfs 476K 534 476K 1% /run\nnone 476K 3 476K 1% /run/lock\nnone 476K 13 476K 1% /run/shm\nnone 476K 46 476K 1% /run/user\n/dev/sda6 11M 517K 9,7M 5% /home\n'
Env:
 MOZ_PLUGIN_PATH = None
 LD_LIBRARY_PATH = None
InstallationDate: Installed on 2014-04-18 (0 days ago)
InstallationMedia: Ubuntu 14.04 LTS "Trusty Tahr" - Alpha amd64 (20140215)
SourcePackage: chromium-browser
UpgradeStatus: No upgrade log present (probably fresh install)
gconf-keys: /desktop/gnome/applications/browser/exec = b'/usr/bin/chromium-browser\n'/desktop/gnome/url-handlers/https/command = b'/usr/bin/chromium-browser %s\n'/desktop/gnome/url-handlers/https/enabled = b'true\n'/desktop/gnome/url-handlers/http/command = b'/usr/bin/chromium-browser %s\n'/desktop/gnome/url-handlers/http/enabled = b'true\n'/desktop/gnome/session/required_components/windowmanager = b''/apps/metacity/general/compositing_manager = b''/desktop/gnome/interface/icon_theme = b'gnome\n'/desktop/gnome/interface/gtk_theme = b'Clearlooks\n'
modified.conffile..etc.default.chromium.browser: [deleted]
mtime.conffile..etc.chromium.browser.default: 2014-04-18T13:16:04.211524

Chad Miller (cmiller) wrote :

Chrome and Chromium will no longer support Netscape Plugin API plugins. All should implement Pepper Plugin API now.

Changed in chromium-browser (Ubuntu):
status: New → Won't Fix
summary: - Chromium doesn't detect Icedtea Java plugin
+ Chromium doesn't use Icedtea Java NPAPI plugin

Is there any way to get Java working in Chromium then?

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in icedtea-web (Ubuntu):
status: New → Confirmed

Google Chrome 35 has dropped support for NPAPI plugins (so icedtea no longer works there). Is there a plan to make a PPAPI-compatible version of icedtea?

I have tracked down to this bug, which seems to be the source of java applets not working on chromium.

Is any update on this bug?

Yes, this is indeed the cause for Java applets no longer working in Chrome/Chromium - Google has removed the plugin API which IcedTea-Web uses. We haven't yet determined if it is even possible to create a port of IcedTea-Web to PPAPI, due to the sandboxing and other restrictions Google places on extensions built with Pepper/Native Client.

There are a relevant discussion about this here: http://www.firebreath.org/display/documentation/Browser+Plugins+in+a+post-NPAPI+world

The short answer are that there are no sufficient replacement for NPAPI in Chrome. Chromium are open source so it could potentially be modified.

Currently my brightest idea are to use DLL injection and override the entire engine component with something similar to Chrome Frame. If we simply run another browser engine, such as a modified Chromium engine with NPAPI-support, that might work. Or an engine that do not require any hacking such as Qt WebKit which supports NPAPI plugins out of the box.

Another option would be to make a completely Chrome-compatible browser out of Chromium, which are what the Qt WebEngine are all about. Such a browser could be entirely FOSS and shipped with Linux distributions. A mayor problem would be the Flash plugin which may require that Chrome are also installed. As a system admin I would like to avoid installing Chrome in such a scenario, or at least hide it well.

Altough a bug report is not the best place to chat, I'll give you my 2 cents:

 - Assume you arent going to use Chrome for a while. Firefox, Safari and IE will work.
 - If possible, use JNLP. AFAIK it will continue working.
 - If you, like me, are using applets for electronic signature, probably the best option is to keep praying for Webcrypto+FIDO

Regards.

Changed in icedtea:
importance: Unknown → High
status: Unknown → Confirmed

FYI: I switched back from Chromium to Firefox. There were a few things that really bothered me in Chromium but I need Java suppport in the browser because Proxmox uses Java for the VM console display.

Jaime Cruz (jaime-cruz) wrote :

Apple's Quicktime also does not work in Chrome. It was pretty much a MONUMENTALLY STUPID decision on Google's part to drop NPAPI support from Chrome before a viable alternative was available for the majority of plug-ins out there. About the only thing that DOES work is their own version of the Flash plug-in. I rarely use Chrome now for just this reason. I use Seamonkey for all of my Web, E-Mail and Usenet access.

Changed in chromium-browser (Ubuntu):
importance: Undecided → High
Changed in icedtea-web (Ubuntu):
importance: Undecided → High
Changed in icedtea-web (Ubuntu):
status: Confirmed → Invalid
Changed in icedtea-web (Ubuntu):
status: Invalid → Triaged
importance: High → Wishlist

Plug-ings will be dropped from both Chromium and Firefox, so fixing this bug won't have any impact in medium term.

Changed in icedtea-web (Ubuntu):
status: Triaged → Won't Fix

ITW provides little fall back in form of "javaws -html some.html.page.url"
But yes, it have to much cases when it is useless.

Long story short, there is no plan for PPAPI.

If you wont one. Please contribute!

Fair enough. Thanks.

Changed in icedtea:
status: Confirmed → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.