chromium-browser does not accept keyboard input with iBus

Bug #1307648 reported by Lyn Perrine on 2014-04-14
346
This bug affects 72 people
Affects Status Importance Assigned to Milestone
chromium-browser (Ubuntu)
High
Unassigned

Bug Description

To reproduce install chromium 34 from proposed with pepperflash. And find a site that you input some text into like indeed.com or some others. Then you hit the keys on the keyboard but no text is seen onscreen.

I expected the text to be entering into chroumium like it is on any other browser. And for the text to be entered into the browser and transfered ot the webpage I am submitting it to.

Instead it did not show up and indeed.com thought I did not enter anything even though I pressed several keys on my keyboard.
Description: Ubuntu 14.04 LTS
Release: 14.04
chromium-browser:
  Installed: 34.0.1847.116-0ubuntu1~pkg1006
  Candidate: 34.0.1847.116-0ubuntu1~pkg1006
  Version table:
 *** 34.0.1847.116-0ubuntu1~pkg1006 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty-proposed/universe amd64 Packages
        100 /var/lib/dpkg/status
     33.0.1750.152-0ubuntu1~pkg995.1 0
        500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: chromium-browser 34.0.1847.116-0ubuntu1~pkg1006
ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
Uname: Linux 3.13.0-24-generic x86_64
NonfreeKernelModules: wl
ApportVersion: 2.14.1-0ubuntu2
Architecture: amd64
CurrentDesktop: LXDE
Date: Mon Apr 14 11:15:07 2014
Desktop-Session:
 DESKTOP_SESSION = Lubuntu
 XDG_CONFIG_DIRS = /etc/xdg/lubuntu:/etc/xdg/xdg-Lubuntu:/usr/share/upstart/xdg:/etc/xdg
 XDG_DATA_DIRS = /etc/xdg/lubuntu:/usr/local/share:/usr/share:/usr/share/gdm:/var/lib/menu-xdg:/usr/share/Lubuntu:/usr/local/share/:/usr/share/
DetectedPlugins:

DiskUsage:
 b'Filesystem Type Size Used Avail Use% Mounted on\n/dev/sdc4 ext4 641G 61G 549G 10% /\nnone tmpfs 4.0K 0 4.0K 0% /sys/fs/cgroup\nudev devtmpfs 1.9G 4.0K 1.9G 1% /dev\ntmpfs tmpfs 386M 1.3M 385M 1% /run\nnone tmpfs 5.0M 0 5.0M 0% /run/lock\nnone tmpfs 1.9G 17M 1.9G 1% /run/shm\nnone tmpfs 100M 16K 100M 1% /run/user\n'

 Inodes:
 b'Filesystem Inodes IUsed IFree IUse% Mounted on\n/dev/sdc4 41M 565K 41M 2% /\nnone 483K 2 483K 1% /sys/fs/cgroup\nudev 480K 612 479K 1% /dev\ntmpfs 483K 643 482K 1% /run\nnone 483K 5 483K 1% /run/lock\nnone 483K 19 483K 1% /run/shm\nnone 483K 13 483K 1% /run/user\n'
Env:
 MOZ_PLUGIN_PATH = None
 LD_LIBRARY_PATH = None
InstallationDate: Installed on 2014-01-02 (102 days ago)
InstallationMedia: Lubuntu 14.04 "Trusty Tahr" - Alpha amd64 (20140101)
SourcePackage: chromium-browser
UpgradeStatus: No upgrade log present (probably fresh install)
gconf-keys: /desktop/gnome/applications/browser/exec = b'firefox\n'/desktop/gnome/url-handlers/https/command = b'sensible-browser %s\n'/desktop/gnome/url-handlers/https/enabled = b'true\n'/desktop/gnome/url-handlers/http/command = b'sensible-browser %s\n'/desktop/gnome/url-handlers/http/enabled = b'true\n'/desktop/gnome/session/required_components/windowmanager = b''/apps/metacity/general/compositing_manager = b''/desktop/gnome/interface/icon_theme = b'gnome\n'/desktop/gnome/interface/gtk_theme = b'Clearlooks\n'
modified.conffile..etc.default.chromium.browser: [deleted]
mtime.conffile..etc.chromium.browser.default: 2014-04-14T10:56:12.681598

Lyn Perrine (walterorlin) wrote :
Chad Miller (cmiller) wrote :

I can't reproduce this. What does it look like? Is there a blinking cursor? Does Page-up/Page-down do anything? How about Control-Tab?

Changed in chromium-browser (Ubuntu):
status: New → Incomplete
Lyn Perrine (walterorlin) wrote :

Yes there is a blinking cursor. Page up and page down works. Page up and page down work as well as space bar to scroll the page. The second box on the screen so if I try to type into the google search bar. It looks like I can type into it with a blinking cursor page.

ypspef (facundo-ariel-perez) wrote :

Can't type anything neither in the address field nor google's search box.
Works ok with firefox.

Albert Kottke (albert-kottke) wrote :

I have the same problem. After I try to enter text into a form Chromimum no longer accepts any input from the keyboard (mouse still works). If I have something in the paste buffer, I can paste text to Chromium.

Timo Harmonen (timo-harmonen) wrote :

I have the same issue on Ubuntu Gnome 14.04 LTS, Chromium 34.0.1847.116. Keyboard shortcuts work fine. Cursor is blinking but still I cannot input any text neither on the address field nor on any other text field. I think this started after installing pepperflash.

/usr/lib/chromium-browser/chromium-browser --ppapi-flash-path=/usr/lib/pepperflashplugin-nonfree/libpepflashplayer.so --ppapi-flash-version=13.0.0.182 --enable-pinch --flag-switches-begin --flag-switches-end

Rick Flynn (flynn1959) wrote :

I have the same problem. No ability to enter text in a text box after the first word or sometimes not at all since installing 14.04. Now using firefox which seems to have no such issue. Using 64 bit edition of 14.04.

Johan Hake (johan-hake) wrote :

I have the same problem. I cannot enter any url or any normal form text. Passwords for one reason works though. This happened after upgrade to 14.04 Kubuntu with chromium 34.0.1847.116

SignedAdam (signedadam) wrote :

kill all IBUS commands with "Tast Manager" or "System Monitor" all problems all most go away, typing does become slower i think

Yeah, definitely ibus related .. terminating, uninstalling, or disabling ibus from the panel applet "fixes" the issue.

xdya (xdya57) wrote :

I have the same problem. Terminating ibus temporarily fixes it.

bisi (fox-hole-bisi) wrote :

After entering in terminal "ibus exit", I'm able to type in here. All keyboard commands work in Chromium, but absolutely no text entry. Actually, occasionally after restarting Chromium, I can type one word. After that, one letter (the first letter typed), or two letters (from the middle of whatever I was typing.) Bad bug.

Chad Miller (cmiller) on 2014-04-24
Changed in chromium-browser (Ubuntu):
status: Incomplete → Confirmed
importance: Undecided → Critical
assignee: nobody → Chad Miller (cmiller)
chayyoo (krvbr) wrote :

I have the same problem with applications based on the Fox-toolkit (latest snapshot) like the Adie and Fxite text editors: impossible to enter any text with the keyboard, problem solved with "ibus exit".

Ant Dickens (antonydickens) wrote :

I'm getting the same behaviour

Can not input text into Chromium text input fields using keyboard. I get blinking cursor and I can paste text.

Problem occured after updating Lubuntu 14.04 to 14.10 development release

Chromium Version 34.0.1847.116 Built on Ubuntu 14.04, running on Ubuntu 14.10 aura (260972)

Killing ibus from a terminal with 'ibus exit' is a temporary fix.

chayyoo (krvbr) wrote :

In im-config, changing input method from ibus to xim solved my problem. By just killing ibus the "dead" accent keys " for ä or ^ for ê stopped working in gnome applications.

NoOp (glgxg) wrote :

The problem is not just in the proposed version, it is in the final release version as well:

$ apt-cache policy chromium-browser
chromium-browser:
  Installed: 34.0.1847.116-0ubuntu2
  Candidate: 34.0.1847.116-0ubuntu2
  Version table:
 *** 34.0.1847.116-0ubuntu2 0
        500 http://archive.ubuntu.com/ubuntu/ trusty/universe i386 Packages
        100 /var/lib/dpkg/status
$ echo $GDMSESSION
gnome-fallback
$ cat /etc/lsb-release
DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=14.04
DISTRIB_CODENAME=trusty
DISTRIB_DESCRIPTION="Ubuntu 14.04 LTS"

Download full text (4.9 KiB)

Version 35.0.1916.114 Ubuntu 14.04 (270117) works fine,

I have asked as to when it will land.... In the meantime you can enable a
temporary ppa with it on.... (you want the Beta PPA).
http://www.webupd8.org/2014/02/how-to-install-chromium-beta-or-dev.html

Regards,

Phill.

On 22 May 2014 18:33, NoOp <email address hidden> wrote:

> The problem is not just in the proposed version, it is in the final
> release version as well:
>
> $ apt-cache policy chromium-browser
> chromium-browser:
> Installed: 34.0.1847.116-0ubuntu2
> Candidate: 34.0.1847.116-0ubuntu2
> Version table:
> *** 34.0.1847.116-0ubuntu2 0
> 500 http://archive.ubuntu.com/ubuntu/ trusty/universe i386
> Packages
> 100 /var/lib/dpkg/status
> $ echo $GDMSESSION
> gnome-fallback
> $ cat /etc/lsb-release
> DISTRIB_ID=Ubuntu
> DISTRIB_RELEASE=14.04
> DISTRIB_CODENAME=trusty
> DISTRIB_DESCRIPTION="Ubuntu 14.04 LTS"
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1307648
>
> Title:
> chromium 34 from proposed does not take input from keyboard in first
> entry point on several webpages
>
> Status in "chromium-browser" package in Ubuntu:
> Confirmed
>
> Bug description:
> To reproduce install chromium 34 from proposed with pepperflash. And
> find a site that you input some text into like indeed.com or some
> others. Then you hit the keys on the keyboard but no text is seen
> onscreen.
>
> I expected the text to be entering into chroumium like it is on any
> other browser. And for the text to be entered into the browser and
> transfered ot the webpage I am submitting it to.
>
> Instead it did not show up and indeed.com thought I did not enter
> anything even though I pressed several keys on my keyboard.
> Description: Ubuntu 14.04 LTS
> Release: 14.04
> chromium-browser:
> Installed: 34.0.1847.116-0ubuntu1~pkg1006
> Candidate: 34.0.1847.116-0ubuntu1~pkg1006
> Version table:
> *** 34.0.1847.116-0ubuntu1~pkg1006 0
> 500 http://us.archive.ubuntu.com/ubuntu/trusty-proposed/universe amd64 Packages
> 100 /var/lib/dpkg/status
> 33.0.1750.152-0ubuntu1~pkg995.1 0
> 500 http://us.archive.ubuntu.com/ubuntu/ trusty/universe amd64
> Packages
>
> ProblemType: Bug
> DistroRelease: Ubuntu 14.04
> Package: chromium-browser 34.0.1847.116-0ubuntu1~pkg1006
> ProcVersionSignature: Ubuntu 3.13.0-24.46-generic 3.13.9
> Uname: Linux 3.13.0-24-generic x86_64
> NonfreeKernelModules: wl
> ApportVersion: 2.14.1-0ubuntu2
> Architecture: amd64
> CurrentDesktop: LXDE
> Date: Mon Apr 14 11:15:07 2014
> Desktop-Session:
> DESKTOP_SESSION = Lubuntu
> XDG_CONFIG_DIRS =
> /etc/xdg/lubuntu:/etc/xdg/xdg-Lubuntu:/usr/share/upstart/xdg:/etc/xdg
> XDG_DATA_DIRS =
> /etc/xdg/lubuntu:/usr/local/share:/usr/share:/usr/share/gdm:/var/lib/menu-xdg:/usr/share/Lubuntu:/usr/local/share/:/usr/share/
> DetectedPlugins:
>
> DiskUsage:
> b'Filesystem Type Size Used Avail Use% Mounted on\n/dev/sdc4
> ext4 641G 61G 549G 10% /\nnone tmpfs 4.0K 0
> 4.0K 0% /sys/fs/cgroup\nude...

Read more...

The address bar doesn't work too (works for every first launch, first only). But pasting did worked.

Lyn Perrine (walterorlin) wrote :

I started utopic in a virtual machine and installed chromium to try to reproduce this bug and was successfully able to.

David Matějček (dmatej) wrote :

FYI, it seems fixed, but still not in (K)Ubuntu:
https://code.google.com/p/chromium/issues/detail?id=360388

Martin Kalén (martin-kalen) wrote :

As a work-around, put the following in ~/.bashrc:

 export GTK_IM_MODULE=ibus
 export QT_IM_MODULE=ibus
 export CLUTTER_IM_MODULE=ibus

When switching from xim to ibus as IM-module, Chromium accepts keyboard input as usual again (in 14.04 LTS upgraded from 12.04 LTS).

A. Eibach (andi3) wrote :

Workaround proposal (can't test with Chromium since I'm not using that)

What about a "less brutal" way of getting ibus out of the way by

Preferences->Language Support->Language->Keyboard input method system: 'none'

I'm on Lubuntu, but I *think* this should also work on the big boss ;)

Phill Whiteside (phillw) wrote :

Keeping iBus and using Version 35.0.1916.153 Ubuntu 14.10 (274914)
 also seems okay. I suggest an SRU be created

Yes, v35 from Utopic works fine in Trusty. I suggest an SRU, too.

Christian González (droetker) wrote :

Also can confirm that Chromium/Utopic works perfectly in Trusty with that issue.

+1 from me for Version 34.0.1847.116 Ubuntu 14.04 aura (260972). Killing ibus solves the problem.

Which ppa should I use if I wanted Chromium 35?

Thanks.

OK. I have installed the chromium-broswer beta using

sudo apt-add-repository ppa:saiarcot895/chromium-beta

and installed Chromium 37. I can confirm that the problem then disappears.

Torsten Bronger (bronger) wrote :

The problem has gone on my system with one of the official updates of this week.

Björn Lindqvist (bjourne) wrote :

What is the reason it has taken over six months? It's a critical bug making chromium useless! Just add the workaround environment variables to the /usr/bin/chromium-browser wrapper script. Push the update, DONE! It's not rocket science.

@ Chad Miller

Because this bug does not render the system unusable or corrupt user data, it does not have a priority of "critical" but "high".

Changed in chromium-browser (Ubuntu):
importance: Critical → High

@ Chad Miller

Because you assigned yourself to this bug more than 6 months ago, and Ubuntu policy is to remove assignees that have not work in a bug for more than that, I am deassigning you.

Changed in chromium-browser (Ubuntu):
assignee: Chad Miller (cmiller) → nobody
status: Confirmed → Triaged
Walter Lapchynski (wxl) wrote :

I agree with bronger. Problem solved. Currently using 39.0.2171.65 in a fresh Lubuntu trusty, which, at this point, is even being used in utopic and vivid. I'm calling this fixed.

Changed in chromium-browser (Ubuntu):
status: Triaged → Fix Released
summary: - chromium 34 from proposed does not take input from keyboard in first
- entry point on several webpages
+ chromium-browser does not accept keyboard input with iBus

Still happening in 40.0.2214.93 (Official Build)

Semi-reproducible by using google docs for any sustained period.

Temporarily resolved via `ibus restart`

Thiago Martins (martinx) wrote :

I'm trying to use Google Chrome 40.0.2214.111-1 in Ubuntu 15.04 (Unity), two, three times in a week, out of nothing, it is impossible to type within Chrome's window.

I need to close chrome and reopen it, until this problem appear again.

I still did not tried to restart ibus, I'll try it next time.

This problem does NOT appear when using Enlightenment DR19.

Problem NOT fixed.

Chad Miller (cmiller) on 2015-02-18
Changed in chromium-browser (Ubuntu):
status: Fix Released → Triaged
zob (zob) wrote :

I have this issue in the current Chrome 40.0.2214.115 (Official Build). Ubuntu 14.10 fully update with kernel 3.16.0-30-generic. IBus version 1.5.8.

And I have had it for quite a while with different versions of google-chrome-stable.

Running:
ibus restart
solves the problem temporarily.

When this happens other programs are NOT affected. I can still type in firefox, another chrome beta (that I also have), and everywhere else, as for as I can tell.

I suspect that it would happen in google-chrome-beta as well, if I used it as much as google-chrome-stable, but I haven't tested it. It seems to happen out of the blue.

For me it doesn't solve the problem restarting chrome.

Elad Hen (eladhen2) wrote :

I have this bug now, running chromium 41.0.2272.76 on lubuntu 14.04. "ibus exit" in the terminal solves it, but the bug is still around.

Olivier Tilloy (osomon) wrote :

Is anyone still seeing this issue? Last comment is two years old, I’m tempted to close.

Olivier Tilloy (osomon) on 2018-07-19
Changed in chromium-browser (Ubuntu):
status: Triaged → Incomplete
abir (ajax13) wrote :

hello, I have the same problem with firefox, chromium and many other applications, noting that for others it works fine.

DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=18.04
DISTRIB_CODENAME=bionic
DISTRIB_DESCRIPTION="Ubuntu 18.04.1 LTS"

 echo $GDMSESSION
ubuntu

Olivier Tilloy (osomon) wrote :

Can you please be more specific? Please list applications that do work, and those that don't.
Can you share the output of the following command?

    env | grep IM_

abir (ajax13) wrote :

@osomon I think this is randomly :/

env | grep IM_

GTK_IM_MODULE=ibus
IM_CONFIG_PHASE=2
CLUTTER_IM_MODULE=ibus
QT4_IM_MODULE=xim
QT_IM_MODULE=xim

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.