webcam doesn't work at 640x480, only resolutions lower than 176x144

Bug #281771 reported by mon on 2008-10-11
30
This bug affects 5 people
Affects Status Importance Assigned to Milestone
cheese (Ubuntu)
Undecided
Unassigned
gstreamer0.10 (Ubuntu)
Undecided
Unassigned

Bug Description

After the recent updates, cheese doesn't work at all. Before I could take photos, but couldn't record video. And in hardy I could do both.

If I launch it with -v:

cheese -v
Detected v4l2 device: Laptop Integrated Webcam
Driver: uvcvideo, version: 256
Bus info: 0000:00:1d.7
Capabilities: 0x04000001
Detected webcam: Laptop Integrated Webcam
device: /dev/video0
video/x-raw-yuv 160 x 120 num_framerates 4
30/1 15/1 10/1 5/1 video/x-raw-yuv 176 x 144 num_framerates 4
30/1 15/1 10/1 5/1 video/x-raw-yuv 320 x 240 num_framerates 4
30/1 15/1 10/1 5/1 video/x-raw-yuv 640 x 480 num_framerates 2
10/1 5/1 video/x-raw-yuv 352 x 288 num_framerates 4
30/1 15/1 10/1 5/1 video/x-raw-yuv 160 x 120 num_framerates 4
30/1 15/1 10/1 5/1 already added, skipping
video/x-raw-yuv 176 x 144 num_framerates 4
30/1 15/1 10/1 5/1 already added, skipping
video/x-raw-yuv 320 x 240 num_framerates 4
30/1 15/1 10/1 5/1 already added, skipping
video/x-raw-yuv 640 x 480 num_framerates 4
30/1 15/1 10/1 5/1 higher framerate replacing existing format
video/x-raw-yuv 352 x 288 num_framerates 4
30/1 15/1 10/1 5/1 already added, skipping
video/x-raw-rgb 160 x 120 num_framerates 4
30/1 15/1 10/1 5/1 already added, skipping
video/x-raw-rgb 176 x 144 num_framerates 4
30/1 15/1 10/1 5/1 already added, skipping
video/x-raw-rgb 320 x 240 num_framerates 4
30/1 15/1 10/1 5/1 already added, skipping
video/x-raw-rgb 640 x 480 num_framerates 4
30/1 15/1 10/1 5/1 already added, skipping
video/x-raw-rgb 352 x 288 num_framerates 4
30/1 15/1 10/1 5/1 already added, skipping
video/x-raw-rgb 160 x 120 num_framerates 4
30/1 15/1 10/1 5/1 already added, skipping
video/x-raw-rgb 176 x 144 num_framerates 4
30/1 15/1 10/1 5/1 already added, skipping
video/x-raw-rgb 320 x 240 num_framerates 4
30/1 15/1 10/1 5/1 already added, skipping
video/x-raw-rgb 640 x 480 num_framerates 4
30/1 15/1 10/1 5/1 already added, skipping
video/x-raw-rgb 352 x 288 num_framerates 4
30/1 15/1 10/1 5/1 already added, skipping
v4l2src name=video_source device=/dev/video0 ! capsfilter name=capsfilter caps=video/x-raw-rgb,width=640,height=480,framerate=30/1;video/x-raw-yuv,width=640,height=480,framerate=30/1 ! identity

And the window is white and if I close the app it hangs.

linux-image:
  Instalados: 2.6.27.7.8
  Candidato: 2.6.27.7.8
  Tabla de versión:
 *** 2.6.27.7.8 0
        500 http://archive.ubuntu.com intrepid/main Packages
        100 /var/lib/dpkg/status

apt-cache policy cheese
cheese:
  Instalados: 2.24.0-0ubuntu1
  Candidato: 2.24.0-0ubuntu1
  Tabla de versión:
 *** 2.24.0-0ubuntu1 0
        500 http://archive.ubuntu.com intrepid/universe Packages
        100 /var/lib/dpkg/status

I don't know if it's relevant, but in /var/log/dmesg I could read this:

[ 11.336341] uvcvideo: Found UVC 1.00 device Laptop Integrated Webcam (05a9:7670)
[ 11.336708] uvcvideo: Failed to query (135) UVC control 1 (unit 0) : -32 (exp. 26).
[ 11.385104] HDA Intel 0000:00:1b.0: PCI INT A -> GSI 21 (level, low) -> IRQ 21
[ 11.385137] HDA Intel 0000:00:1b.0: setting latency timer to 64
[ 11.395570] input: Laptop Integrated Webcam as /devices/pci0000:00/0000:00:1d.7/usb7/7-6/7-6:1.0/input/input9
[ 11.565188] usbcore: registered new interface driver uvcvideo
[ 11.565194] USB Video Class driver (v0.1.0)

If I change the resolution to 176x144 or lower it works.

The laptop is a dell xps m1330.

Hi

I think it's not cheese fault:

This works:
gst-launch-0.10 -v v4l2src ! video/x-raw-yuv,width=176,height=144 ! ffmpegcolorspace ! xvimagesink

but increasing the size of the capture window fails, but --verbose doesn't show anything.

The bug can be reproduced with gst-launch0.10, so the bug is not in cheese.

I have the exact same behaviour with an external USB webcam from Logitech (model "Quickcam Deluxe for Notebooks"). It uses the UVC driver. It works fine in Ekiga and other apps not accessing it over GStreamer. It also worked fine with GStreamer under Hardy. Now I also experience the limitation to 176x144.

Confirmed by Alexander

Changed in gstreamer0.10:
status: New → Confirmed

With today's updates I can launch a first screen with a size of 640x480:

gst-launch-0.10 -v v4l2src ! video/x-raw-yuv,width=640,height=480 ! ffmpegcolorspace ! xvimagesink
Estableciendo el flujo a PAUSADO ...
/GstPipeline:pipeline0/GstV4l2Src:v4l2src0.GstPad:src: caps = video/x-raw-yuv, format=(fourcc)I420, width=(int)640, height=(int)480, framerate=(fraction)30/1
El flujo es en vivo y no necesita PRECACHEADO ...
Estableciendo el flujo para REPRODUCCIÓN ...
New clock: GstSystemClock
libv4lconvert: Error decompressing JPEG: error: more then 63 AC components (65) in huffman unit
/GstPipeline:pipeline0/GstCapsFilter:capsfilter0.GstPad:src: caps = video/x-raw-yuv, format=(fourcc)I420, width=(int)640, height=(int)480, framerate=(fraction)30/1
/GstPipeline:pipeline0/GstCapsFilter:capsfilter0.GstPad:sink: caps = video/x-raw-yuv, format=(fourcc)I420, width=(int)640, height=(int)480, framerate=(fraction)30/1
/GstPipeline:pipeline0/GstFFMpegCsp:ffmpegcsp0.GstPad:src: caps = video/x-raw-yuv, format=(fourcc)I420, width=(int)640, height=(int)480, framerate=(fraction)30/1
/GstPipeline:pipeline0/GstFFMpegCsp:ffmpegcsp0.GstPad:sink: caps = video/x-raw-yuv, format=(fourcc)I420, width=(int)640, height=(int)480, framerate=(fraction)30/1
/GstPipeline:pipeline0/GstXvImageSink:xvimagesink0.GstPad:sink: caps = video/x-raw-yuv, format=(fourcc)I420, width=(int)640, height=(int)480, framerate=(fraction)30/1

But cheese still doesn't work.

Ok, something interesting, If I launch gst-launch it works, then if I launch cheese it doesn't and subsequent launches of gst-launch doesn't work either. weird

Hi

mplayer also works:
mplayer -fps 15 tv:// -tv driver=v4l2:device=/dev/video0

The bug seems to affect only cheese

Same problem here. The webcam works fine in Skype and Ekiga (I guess because of the poor resolution used there). But not in cheese unless I select 176x144 resolution.

This was working fine in Hardy and is a regression in Intrepid for me.

Bus 001 Device 005: ID 0458:705a KYE Systems Corp. (Mouse Systems) Asus USB2.0 Webcam

using uvcvideo module

gst-plugins-good0.10 0.10.10.3-1ubuntu1 has fixed the issue here.

Changed in cheese:
status: Confirmed → Fix Released
Changed in gstreamer0.10:
status: New → Fix Released

fixed for me as well

Alexander or enyone else, could you please see if you have this bug?

https://bugs.launchpad.net/ubuntu/+source/cheese/+bug/277997

If so, confirm it?

thanks

Apparently the reapply of the patch breaks cheese in this laptop.

Changed in gstreamer0.10:
status: Fix Released → Confirmed

gst-plugins-good0.10 (0.10.10.3-1ubuntu2) intrepid; urgency=low

  * debian/patches/10_fedora-use_libv4l.patch:
    - use this change as described in the changelog

This patch that was accidentaly dropped in lastes upload breaks the webcam in cheese.

Shawn vega (svega85-gmail) wrote :

I have this same bug with a Dell inspiron 1420

Changed in cheese:
status: Fix Released → Confirmed
Pedro Villavicencio (pedro) wrote :

not a cheese bug then, more like a gstreamer one.

Changed in cheese:
status: Confirmed → Invalid

Again chesse doesn't work for me - was the problem reintroduced by the latest sync of gstreamer? Can sombody confirm? Here, pure GStreamer works, but Cheese fails, while Cheese had been working a few days ago.

I think the bug is introduced with gstreamer support for libv4l, since the patch was dropped in a recent upload and when reapplied the bug came back. I don't now why since gst-launch does work with lastest gstreamer upload, but cheese doesn't.

I've writen about this in this other bug report:
https://bugs.launchpad.net/ubuntu/+source/libv4l/+bug/260918

Marco Boneff (neffscape) wrote :

Same bug on my XPS M1530, the problem seems to affect only Cheese. It is a clear regression from Hardy, I hope this will be fixed ASAP.

Andres Mujica (andres.mujica) wrote :

Thanks for your bug report, This seem to be a a dup for bug#290506. Any further comments are welcomed in bug #290506.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers