cheese crashed with SIGSEGV in __GI___libc_free()

Bug #1062282 reported by Jan D on 2012-10-05
176
This bug affects 42 people
Affects Status Importance Assigned to Milestone
Cheese
Invalid
Critical
cheese (Ubuntu)
Medium
Unassigned

Bug Description

Cheese (Webcam Booth) crashes when trying to RECORD VIDEO. Live view OK, photo shooting OK.
This happens on 2 different computers, and 3 different webcams.

ProblemType: Crash
DistroRelease: Ubuntu 12.10
Package: cheese 3.6.0-0ubuntu1
ProcVersionSignature: Ubuntu 3.5.0-17.26-generic 3.5.5
Uname: Linux 3.5.0-17-generic x86_64
NonfreeKernelModules: fglrx
ApportVersion: 2.6.1-0ubuntu1
Architecture: amd64
Date: Fri Oct 5 15:11:51 2012
ExecutablePath: /usr/bin/cheese
InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120820)
ProcCmdline: cheese
ProcEnviron:
 TERM=xterm
 SHELL=/bin/bash
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 XDG_RUNTIME_DIR=<set>
SegvAnalysis:
 Segfault happened at: 0x7fdfc23a65bc <__GI___libc_free+60>: mov (%rax),%rdi
 PC (0x7fdfc23a65bc) ok
 source "(%rax)" (0x7fdfc4000000) in non-readable VMA region: 0x7fdfc3f44000-0x7fdfc4143000 ---p /usr/lib/x86_64-linux-gnu/libgee.so.2.0.0
 destination "%rdi" ok
SegvReason: reading VMA /usr/lib/x86_64-linux-gnu/libgee.so.2.0.0
Signal: 11
SourcePackage: cheese
StacktraceTop:
 __GI___libc_free (mem=0x7fdfc4fdbcf5) at malloc.c:2982
 ?? ()
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: cheese crashed with SIGSEGV in __GI___libc_free()
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm cdrom dialout dip lpadmin plugdev sambashare sudo

Jan D (jandeyk-gmail) wrote :

StacktraceTop:
 __GI___libc_free (mem=0x7fdfc4fdbcf5) at malloc.c:2982
 cheese_main_window_update_timeout_layer (self=<optimized out>) at src/cheese-window.c:2757
 _cheese_main_window_update_timeout_layer_gsource_func (self=<error reading variable: value has been optimized out>) at src/cheese-window.c:2655
 g_timeout_dispatch (source=source@entry=0x2d96d60, callback=<optimized out>, user_data=<optimized out>) at /build/buildd/glib2.0-2.34.0/./glib/gmain.c:4026
 g_main_dispatch (context=0x1b62ad0) at /build/buildd/glib2.0-2.34.0/./glib/gmain.c:2715

Changed in cheese (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in cheese (Ubuntu):
status: New → Confirmed
information type: Private → Public
Sasa Paporovic (melchiaros) wrote :

Jup, thank you Dmitry for making public.

Changed in cheese:
importance: Unknown → High
status: Unknown → New
no longer affects: cheese
Changed in cheese:
importance: Unknown → Critical
status: Unknown → New
Emma Marshall (system76chick) wrote :

I don't know if this helps, but I was recording in 1080p. Cheese would record for 1 second but the video playback would be black and says "no data stream" but I could take photos with no problem. I'm using an external Logitech 1080p webcam with USB connection.

Changed in cheese:
status: New → Invalid
Micah Gersten (micahg) wrote :

Taking a look at this.

Changed in cheese (Ubuntu):
assignee: nobody → Micah Gersten (micahg)
status: Confirmed → In Progress
Sasa Paporovic (melchiaros) wrote :

David King has closed the upstream report as dub of

https://bugzilla.gnome.org/show_bug.cgi?id=687042

which has the comment:

David King [cheese developer] 2012-10-30 15:52:45 UTC

Fixed in master and gnome-3-6 branches as commits
82603a97f2a96294167a260f5ff14bbaed2a24b7 and
e2938847c7bca93bd9f59d009de78e0cec8d2745.

Micah Gersten (micahg) wrote :

Well, this fixes the crash, but cheese video still doesn't work, I'm not sure if it's worth the upload just for this.

frenchy82 (cartes) wrote :

With 3.6.0-0ubuntu1.1~ubuntu12.10.1~ppa1 there is a 0 octet file recorded and we have this this message on the console
Cannot connect to server socket err = Aucun fichier ou dossier de ce type
Cannot connect to server request channel
jack server is not running or cannot be started

(cheese:2078): cheese-WARNING **: Jack server not found

(cheese:2078): cheese-WARNING **: Impossible d'initialiser la bibliothèque de prise en charge.

`menu_proxy_module_load': cheese: undefined symbol: menu_proxy_module_load

(cheese:2078): Gtk-WARNING **: Failed to load type module: (null)

TomasHnyk (sup) wrote :

Any updates on this?

TomasHnyk (sup) wrote :

Micah Gersten: BTW, I installed cheese from your PPA and it does not crashes anymore. But it does not record video a needs to be restarted to be able to record video again.

Micah Gersten (micahg) wrote :

Right, that's why I didn't upload this yet since it doesn't record video.

Changed in cheese (Ubuntu):
assignee: Micah Gersten (micahg) → nobody
status: In Progress → Triaged
Corey Bell (of-8ore0-an) wrote :

My Cheese is doing the same thing, is there any help, for this bug?

Oier Mees (oier) wrote :

I also can't record video on Ubuntu 12.10 6 bits and cheese 3.6.0-0ubuntu1.

rotsee (leo-wallentin) wrote :

Does anyone know a good alternative to Cheese, while we are waiting for this bug to be fixed?

TomasHnyk (sup) wrote :
BoD (bod-c) wrote :

This bugzilla link is broken.

Mike Sandfort (cute-moniker) wrote :

This bug also affects me: 12.10 amd64.

I'm using the Youtube webcam recording option to make do until this is fixed. Cheese isn't working on my NC10 netbook or my Intel Core 2 Duo iMac both running 12.10

jkw (jkw) wrote :

Affects me too. Seems to be a issue related to Jack of what I can see in the log.

jimmy the saint (lowid95) wrote :

I spent an afternoon messing around with this - AND I FIGURED OUT THE FIX.

the package "gstreamer1.0-pulseaudio" is not listed as a dependency for cheese, but without it the whole program crashes while complaining about jack server.

After installing gstreamer1.0-pulseaudio, cheese behaves as it should for me.

I will be filing a separate bug, and referencing this bug.

jimmy the saint (lowid95) wrote :

The bug report for the missing dependency is available at

https://bugs.launchpad.net/ubuntu/+source/cheese/+bug/1132316

TomasHnyk (sup) wrote :

Oh yes, you are right, thanks, now it works:-).

No dice for me on the gstreamer installation walkaround

tcaritey (tcaritey) wrote :

It Worked for me

MBi (stretchion) wrote :

How it worked for you no solution is offered here ?? or maybe I'm not seeing it ?

TomasHnyk (sup) wrote :

Hm, I installed gstreamer1.0-pulseaudio on Saucy and it does not help.

TomasHnyk (sup) wrote :

When self-compiling Cheese version 3.10.2, this no longer occurs. (uninstall distribution cheese and libcheese beforehand, they clas otherwise).

TomasHnyk (sup) wrote :

Actually, installing cheese 3.10 from GNOME 3 ppa solves this. So this is going to be fixed whne cheese 3.10 hits ubuntu (I am not sure if that is going to be 14.04 or 14.10).

TomasHnyk (sup) wrote :

(just make sure you upgrade libcheese as well, that is actually the package that needs to be updated)

dazza5000 (darran-kelinske) wrote :

I'm experiencing this in 15.04 Beta again. Please let me know if you need any more deteails from me?

dazza5000 (darran-kelinske) wrote :

Still getting this when starting Cheese.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.