Disable checkbox from filing bugs against X in released versions of the distro

Bug #465447 reported by pupik on 2009-10-30
12
This bug affects 1 person
Affects Status Importance Assigned to Milestone
checkbox (Ubuntu)
Undecided
Marc Tardif
Karmic
Undecided
Mathias Gug

Bug Description

[Impact]
An excessive number of duplicate and/or invalid bug reports are being filed against xorg via checkbox's 'system test' functionality. The test is not collecting sufficient information to diagnose the problems (it currently collects less than if the user had reported the issue via the standard 'ubuntu-bug xorg' approach). This is demanding more triager effort than if the bug had been filed using normal methods.

[Patch]
Attached to this bug report. It simply removes the X source package names from the scripts.

[Reproduction]
Go to the 'xorg' or 'x11-xserver-utils' source packages and do an advanced search for bugs with 'checkbox-bug'. This will display a large number of bug reports about the same problem (limited resolution availability). Click on any of the bugs will show they typically have only 1-2 line descriptions. Xorg.0.log is attached, but no xrandr --verbose, ddcprobe data, or other information documented as necessary for troubleshooting this class of bug.

[Regression Potential]
The video tests in apport are new in the karmic release (in fact they were enabled only briefly before the release), so disabling the functionality is not a regression.

[Discussion]
The procedure for analyzing common X bugs such as reduced resolution availability are documented in detail at https://wiki.ubuntu.com/X/Troubleshooting/.

As a case in point, resolution bugs MUST HAVE 'xrandr --verbose' which displays the monitor's EDID information. If the reporter filed the bug using 'ubuntu-bug xorg' this would automatically be collected and we could diagnose the problem, by looking at the EDID blob and seeing if for example the monitor's EDID is fault. However, checkbox only uses 'xrandr -q' which does not display the EDID. If the user had reported the problem using 'ubuntu-bug xorg', xrandr --verbose would have been collected and we'd have a better shot at diagnosing their problem.

If we wish to expose test suites to end users that they can use for sending bug reports for these kinds of issues, at a minimum the test suite ought to at least include the information recommended by the appropriate troubleshooting guide. A well crafted test could also test out some of the analytical approaches or work arounds suggested by those guides.

Many of these resolution issues are monitor-specific or caused by limitations inherent to the hardware or drivers, so even if we knew the exact fix, the problem might not be severe enough or the fix safe enough to warrant an SRU.

[Original Report]
Binary package hint: xorg

Model number: PP19S

# lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10

# lspci:
00:02.0 VGA compatible controller: Intel Corporation System Controller Hub (SCH Poulsbo) Graphics Controller (rev 07)

# lswh:
        *-display UNCLAIMED
             description: VGA compatible controller
             product: System Controller Hub (SCH Poulsbo) Graphics Controller
             vendor: Intel Corporation
             physical id: 2
             bus info: pci@0000:00:02.0
             version: 07
             width: 32 bits
             clock: 33MHz
             capabilities: pm msi bus_master cap_list
             configuration: latency=0
             resources: memory:d8100000-d817ffff ioport:1800(size=8) memory:d0000000-d7ffffff memory:d8380000-d839ffff

ProblemType: Bug
Architecture: i386
CheckboxCommand: resolution_test
CheckboxDescription:
 This display is using the following resolution:

 $output

 Je toto pro váš displej přijatelné?
CheckboxSubmission: 6d0b18dc6702c4f9251b21e9b1af8d6e
CheckboxSystem: d00f84de8a555815fa1c4660280da308
CheckboxTest: resolution
Date: Fri Oct 30 20:50:52 2009
DistroRelease: Ubuntu 9.10
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
MachineType: Dell Inc. Inspiron 1010
NonfreeKernelModules: wl
Package: xorg 1:7.4+3ubuntu7
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic root=UUID=a199c9e1-43fe-4985-9f49-c7582f91ddb9 ro quiet splash
ProcEnviron:
 SHELL=/bin/bash
 LANG=cs_CZ.UTF-8
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SourcePackage: xorg
Tags: checkbox-bug
Uname: Linux 2.6.31-14-generic i686
XorgConf: Error: [Errno 2] No such file or directory: '/etc/X11/xorg.conf'
dmi.bios.date: 07/23/2009
dmi.bios.vendor: Dell Inc.
dmi.bios.version: A07
dmi.board.name: 0R990K
dmi.board.vendor: Dell Inc.
dmi.board.version: A07
dmi.chassis.asset.tag: **********
dmi.chassis.type: 8
dmi.chassis.vendor: Dell Inc.
dmi.chassis.version: A07
dmi.modalias: dmi:bvnDellInc.:bvrA07:bd07/23/2009:svnDellInc.:pnInspiron1010:pvrA07:rvnDellInc.:rn0R990K:rvrA07:cvnDellInc.:ct8:cvrA07:
dmi.product.name: Inspiron 1010
dmi.product.version: A07
dmi.sys.vendor: Dell Inc.
fglrx: Not loaded
system:
 distro: Ubuntu
 architecture: i686kernel: 2.6.31-14-generic

pupik (moser) wrote :
Bryce Harrington (bryce) wrote :

Checkbox is showing '$output', seems like it's still too buggy, please disable it from filing bugs against xorg.

affects: xorg (Ubuntu) → checkbox (Ubuntu)
Bryce Harrington (bryce) on 2009-11-02
summary: - NB DELL Inspiron mini 10 - resolution too low
+ Disable checkbox from filing bugs against X in released versions of the
+ distro
Bryce Harrington (bryce) on 2009-11-02
description: updated
Bryce Harrington (bryce) wrote :
description: updated
Bryce Harrington (bryce) on 2009-11-02
description: updated
Bryce Harrington (bryce) wrote :

There is also at least one case (bug 468393) where because of checkbox, the user's X got screwed up by running System Testing.

Martin Pitt (pitti) wrote :

Thanks, Bryce. Marc, does that look like a correct/good way for disabling xorg bug filing without breaking something else?

Bryce, please upload (with changing to "karmic-proposed" in changelog), so that it's available in the queue.

Changed in checkbox (Ubuntu Karmic):
status: New → In Progress
Changed in checkbox (Ubuntu):
status: New → Won't Fix
Martin Pitt (pitti) wrote :

actually, let's keep the lucid task as well. Seems checkbox needs to get more clever about collecting data, as well as proposing good default bug titles which work with Launchpad's duplicate proposals, etc.

Changed in checkbox (Ubuntu):
assignee: nobody → Marc Tardif (cr3)
status: Won't Fix → Triaged
Martin Pitt (pitti) wrote :

cr3| pitti: just the package.name == '' lines should be removed
cr3| pitti: yep, there are plenty of tests without a package.name and everything works, so there's precedence for reassurance purposes :)

Bryce, can you please make these adaptions and upload? Thanks!

Marc Tardif (cr3) wrote :

I have reviewed the debdiff which needed a few changes. Then, I merged the resulting changes into the trunk. Finally, I merged this into lp:ubuntu/karmic/checkbox and submitted for review in bug #473185.

Marc Tardif (cr3) wrote :

Following review, I have filed bug #474273 which should be more SRU friendly.

Mathias Gug (mathiaz) wrote :

Note that bug 474273 has the discussion about the actual solution to this issue, while this bug has the SRU instructions for verifying the update to karmic-proposed.

Changed in checkbox (Ubuntu Karmic):
assignee: nobody → Mathias Gug (mathiaz)
Martin Pitt (pitti) wrote :

Ah, thanks Marc; checking /etc/default/apport looks even better.

Changed in checkbox (Ubuntu Karmic):
status: In Progress → Fix Committed
tags: added: verification-needed

Accepted checkbox into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Brian Murray (brian-murray) wrote :

Using checkbox version 0.8.5 from karmic I went through the audio testing and said "No" when asked if I heard a sound. After saying "No" I was asked if I wanted to report a bug. Performing the same steps with package version 0.8.6 from karmic-proposed I was not asked if I wanted to report a bug.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package checkbox - 0.8.6

---------------
checkbox (0.8.6) karmic-proposed; urgency=low

  * Added support for apport default configuration (LP: #465447)
 -- Marc Tardif <email address hidden> Wed, 04 Nov 2009 19:36:09 -0400

Changed in checkbox (Ubuntu Karmic):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Copied karmic-proposed to lucid.

Changed in checkbox (Ubuntu):
status: Triaged → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers