[Hardy] Regression: unable to burn or blank disks (CD-RW specifically)

Bug #226650 reported by Andrew on 2008-05-04
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
cdrkit (Ubuntu)
High
Unassigned

Bug Description

I am no longer able to blank or burn CDs using my IDE CDRW drive after upgrading to Hardy from Gutsy.

Wodim gives me this error:
Errno: 5 (Input/output error), blank unit scsi sendcmd: no error

This used to function fine in Gutsy. The device is properly detected as an HP 9300+ drive.

I'll attach the output to reduce clutter in the bug report.

My Gutsy was i386, but installed Hardy as amd64 if that makes any difference.

Not sure if this is related, but my IDE HD (that has Windows installed it) is now /dev/sdb instead of /dev/hdb after the upgrade, so it seems the kernel is using SCSI or ATA to manage my IDE devices now.

This may be related to 15424, but since that one is for DVDs I was told to post a new bug.

I also have tried adding "combined_mode=libata" to my kernel params and adding a new file to /etc/modprobe.d with this line in it:
options libata atapi_enabled=1.
Neither have helped.

My main, linux HD is a SATA2 drive with NCQ enabled, not sure if that makes any difference. Blanking written and writing blank both fail with the same IO error (see attachment)

Andrew (andrew-rw-robinson) wrote :

FYI, I am on amd64 kernel package linux-image-2.6.24-17-generic

Milan Bouchet-Valat (nalimilan) wrote :

The error appears to be the same with two blanking methods, and when burning an image:
Errno: 5 (Input/output error), write_g1 scsi sendcmd: no error
CDB: 2A 00 00 00 00 00 00 00 1F 00
status: 0x2 (CHECK CONDITION)
Sense Bytes: 70 00 05 00 00 00 00 12 00 00 00 00 27 00 00 00
Sense Key: 0x5 Illegal Request, Segment 0
Sense Code: 0x27 Qual 0x00 (write protected) Fru 0x0
Sense flags: Blk 0 (not valid)
cmd finished after 0.006s timeout 40s
write track data: error after 0 bytes

It's different from that of bug 15424.

If you have two CD readers you may want to boot with a 32 bits version of Hardy and try blanking a CD-RW from the LiveCD to check if that works.

Gave it a shot on the xubuntu hardy i386 disc, same errors.

DavidPerry (d-perry) wrote :

I'm having the same problem. Upgraded from gutsy to hardy, and I can no longer burn CD images. I'm running i86 32-bit on an AMD, trying to burn plain ISO images to a CD-R using K3B. It always gets about 5 megs in, throws the error in the original report, and aborts, leaving me with a coastered CD-R. I've attached debug info that I hope will help.

DavidPerry (d-perry) wrote :

I've done a bit more poking around, and I suspect that this may be a more generic problem than with cdrkit. I get pathetic performance ripping audio CDs (it takes forever, and the ripped song is broken and skippy) so I wonder if the problem might be with the interaction of the new libata with my IDE CD-ROM drive.

Having said that, I've tried disabling libata using the method in bug 175022, but it doesn't seem to have helped. (I don't think I completely disabled libata, more experimentation is in order.)

IgnorantGuru (ignorantguru) wrote :

My suggestion: change broken fork wodim to the original cdrtools... here is what worked for me. Use at your own risk.

Replacing wodim with the genuine cdrtools (tested on Kubuntu hardy)

The issue:
http://cdrecord.berlios.de/private/linux-dist.html

"If you are not running the original software, get recent original software from the "Download recent" or from the "Download latest" location. Unpack, compile by running "make" and install. Make sure that all programs that send (SCSI) commands to CD/DVD/Blu-Ray drives are installed to be suid root.

If you are running cdrtools frontends like k3b and others and do not like to replace these programs with original versions, you should remove files like /usr/bin/wodim, /usr/bin/genisoimage, /usr/bin/icedax, /usr/bin/readom and replace them by links to the original software."

Download latest cdrtools from http://cdrecord.berlios.de/private/linux-dist.html
Unpack
CD to the directory cdrtools is in.
sudo make
sudo make install
sudo make clean

Files are installed to /opt/schily
(you may want to change their ownership to root:root)

Move the following files (some will be links) from /usr/bin to a junk folder...
cdrecord
genisoimage
mkisofs
readom
wodim

Create links:
/usr/bin/cdrecord --> /opt/schily/bin/cdrecord
/usr/bin/genisoimage --> /opt/schily/bin/mkisofs
/usr/bin/mkisofs --> /opt/schily/bin/mkisofs
/usr/bin/readom --> /opt/schily/bin/readcd (correct?)
/usr/bin/wodim --> /opt/schily/bin/cdrecord
/usr/bin/readcd --> /opt/schily/bin/readcd
/usr/bin/mkhybrid --> /opt/schily/bin/mkhybrid
/usr/bin/cdda2wav --> /opt/schily/bin/cdda2wav

Related Links:
http://ge.ubuntuforums.com/showthrea...86#post5216386
https://bugs.launchpad.net/ubuntu/+s...3b/+bug/149076
https://bugs.launchpad.net/ubuntu/+s...it/+bug/226650
http://ubuntuforums.org/showthread.php?p=5552123

Daniel Hahler (blueyed) wrote :

Setting to Triaged/High.

I cannot say when erasing CDRW failed for me, but probably after Hardy, since I have a CDRW with Ubuntu 8.04.1 here..

Changed in cdrkit:
importance: Undecided → High
status: New → Triaged
Craig Chambers (craigchambers) wrote :

This solution fixed my problem where my DVD writer would fail to write to both DVDs and CDs. The problem was on Intrepid.

I can confirm the problems writing on CD-RW with Ubuntu Hardy on my HP ML110. Is there a plan to fix this in Hardy?

On my Thinkpad X60s with Jaunty the same actions do work without any problems.

Schily (schilling-fokus) wrote :

You may like to ask Mark Shuttleworth when he plans to replace the
undistributable "cdrkit" by legal original software:

ftp://ftp.berlios.de/pub/cdrecord/alpha/
http://cdrecord.berlios.de/

I would guess that there are no plans in Ubunto to fix your problem :-(

cryptokid (cryptokid) wrote :

I used
sudo growisofs -Z /dev/scd0=/path/file.iso

and it works.

Schily (schilling-fokus) wrote :

Did you read the original bug report? It seems that
you have been too fast....

The original bug report is related to
problems writing CD-RWs and growisofs does
not write CD-RWs.

Growisofs was written to support DVDs, cdrecord
writes any type of optical media. Growisofs is not
a solution for the problems that are caused by the
fact that Ubuntu distributes a broken fork instead
of the original cdrtools.

Also note that in case you are interested in DVDs and
even if you use growisofs instead cdrecord you would
still need mkisofs. If you use genisoimage from the fork
instead of using the original mkisofs, you will become
a victim of the bugs in genisoimage.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers