The right mouse button menu does not work in Catfish search in Xubuntu 18.04.1

Bug #1788058 reported by Chico Miraglia on 2018-08-20
14
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Catfish
Fix Released
Medium
catfish (Ubuntu)
Undecided
Unassigned

Bug Description

The above stated problem is present in catfish 1.4.4-1 and in version 1.4.5 (seems to be the latest) in Xubuntu 18.04.1

Data: Ubuntu 18.04 (bionic)
      Gnome 3.28.2
      Kernel 4.15.0-32-generic
      GCC version 7 (x86_64-linux-gnu)
      Xorg version 1.19.6 (13 April 2018 08:07:36PM)

I cannot reproduce this.

Please run catfish in debug mode (-vv), and attach the terminal output to this report.

Changed in catfish (Ubuntu):
status: New → Incomplete
Download full text (14.1 KiB)

Dear Theo,

Thanks for your prompt answer.

Observations :

1. The first time one uses catfish and use the right mouse button on a
SINGLE file, the menu does appear;
2. If two or more files are shined on this same session, then the right
mouse button menu disappears and  will not return;
3. I have tested this several times and this is behavior is reproduced
everytime.

Below the debug files you asked for, both for catfish 1.4.4-1 and 1.4.5

With best wishes,

F. Miraglia

%%%%%%%%%%%%%%%   Debug for catfish 1.4.4-1

DEBUG:catfish: set_up_logging() 'logging enabled'

(catfish:1635): Gtk-WARNING **: 09:17:49.875:
../../../../gtk/gtkwidget.c:8584: widget not within a GtkWindow
DEBUG:catfish_lib: __init__() 'consider using a pythonic name instead of
design name 'infobar-action_area1''
DEBUG:catfish_lib: __init__() 'consider using a pythonic name instead of
design name 'infobar-content_area1''
DEBUG:catfish_lib: __init__() 'consider using a pythonic name instead of
design name 'treeview-selection''
DEBUG:catfish_lib: __init__() 'consider using a pythonic name instead of
design name 'treeview-selection3''
DEBUG:catfish_lib: __init__() 'consider using a pythonic name instead of
design name 'infobar-action_area2''
DEBUG:catfish_lib: __init__() 'consider using a pythonic name instead of
design name 'infobar-content_area2''
DEBUG:catfish_lib: connect_signals() 'connect builder by design
'file_menu_open', 'activate', 'on_menu_open_activate''
DEBUG:catfish_lib: connect_signals() 'connect builder by design
'file_menu_open_location', 'activate', 'on_menu_filemanager_activate''
DEBUG:catfish_lib: connect_signals() 'connect builder by design
'file_menu_copy_location', 'activate', 'on_menu_copy_location_activate''
DEBUG:catfish_lib: connect_signals() 'connect builder by design
'file_menu_save', 'activate', 'on_menu_save_activate''
DEBUG:catfish_lib: connect_signals() 'connect builder by design
'file_menu_delete', 'activate', 'on_menu_delete_activate''
DEBUG:catfish_lib: connect_signals() 'connect builder by design
'date_start_today', 'clicked', 'on_calendar_today_button_clicked''
DEBUG:catfish_lib: connect_signals() 'connect builder by design
'date_end_today', 'clicked', 'on_calendar_today_button_clicked''
DEBUG:catfish_lib: connect_signals() 'connect builder by design 'Catfish',
'key-press-event', 'on_catfish_window_key_press_event''
DEBUG:catfish_lib: connect_signals() 'connect builder by design 'Catfish',
'key-release-event', 'on_catfish_window_key_press_event''
DEBUG:catfish_lib: connect_signals() 'connect builder by design 'Catfish',
'window-state-event', 'on_catfish_window_window_state_event''
DEBUG:catfish_lib: connect_signals() 'connect builder by design
'catfish_window_infobar', 'response', 'on_update_infobar_response''
DEBUG:catfish_lib: connect_signals() 'connect builder by design
'results_treeview', 'button-release-event',
'on_treeview_button_press_event''
DEBUG:catfish_lib: connect_signals() 'connect builder by design
'results_treeview', 'cursor-changed', 'on_treeview_cursor_changed''
DEBUG:catfish_lib: connect_signals() 'connect builder by design
'results_treeview', 'drag-begin', 'on_treeview_drag_begin''
DEBUG:catfish_lib: conne...

Now I can confirm this bug (tested with version 1.4.6 in Xubuntu 18.10).

Simply pressing the Shift key will trigger it.

Changed in catfish (Ubuntu):
status: Incomplete → Confirmed
Chico Miraglia (miraglia) wrote :

Dear Theo,

Thanks for your reply. I also noticed that one can no longer use
"force version" in Synaptic in 18.04.1; but I guess that should be
the object of another bug report...

With best wishes,

F. Miraglia

Quoting Theo Linkspfeifer <email address hidden>:

> Now I can confirm this bug (tested with version 1.4.6 in Xubuntu 18.10).
>
> Simply pressing the Shift key will trigger it.
>
> ** Changed in: catfish (Ubuntu)
> Status: Incomplete => Confirmed
>
> --
> You received this bug notification because you are subscribed to the bug
> report.
> https://bugs.launchpad.net/bugs/1788058
>
> Title:
> The right mouse button menu does not work in Catfish search in Xubuntu
> 18.04.1
>
> Status in catfish package in Ubuntu:
> Confirmed
>
> Bug description:
> The above stated problem is present in catfish 1.4.4-1 and in version
> 1.4.5 (seems to be the latest) in Xubuntu 18.04.1
>
> Data: Ubuntu 18.04 (bionic)
> Gnome 3.28.2
> Kernel 4.15.0-32-generic
> GCC version 7 (x86_64-linux-gnu)
> Xorg version 1.19.6 (13 April 2018 08:07:36PM)
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/ubuntu/+source/catfish/+bug/1788058/+subscriptions

The problem affects some basic operation you want to do: Search for some files and move it to another place.

Normally you would search for the files with catfish. After that you would mark them in catfish and let them show in the file manager. Then you would move them.

The problem: Catfish does not allow any rightclick anymore on marked files. After installation of an older version the rightclick worked, but not the function to show the marked files in the file manager.

I am using a Lenovo 110S by the way.

Affecting me too. Has happened on all of my devices, at both Arch Linux and Debian based distros.

Catfish 1.4.4
If I launch alone catfish : no problem.
If I launch Catfish from within Thunar (with the very useful "Custom Action", I bind Control + F on "catfish --path=%f") : I can't rightclick on files found by Catfish.

Changed in catfish-search:
importance: Unknown → Medium
status: Unknown → Confirmed
In , Mimi55 (mimi55) wrote :

Confirmed.

Catfish 1.4.6 on Arch
Wether launching catfish alone or from Thunar (by a hot key such as Ctrl+F), there's no right click menu from search results.

Created attachment 8251
Fix context menu not opening after shift/ctrl key by connecting correct key-release-event (bug #14621, #14743, #14999)

The bug 14743 and the bug 14999 are different manifestations of this bug.

To sum it up: whenever the shift or the control key is pressed or released the context menu will not pop up anymore until catfish is closed and reopened. So even entering a capital letter in the search edit field or multi-selection in the result list is sufficient to reproduce the bug.

The problem appears to have been introduced in catfish 1.4.1
commit 2829d07 Fix click issues in treeview (LP: #1547807, #1523164)

The reason for the bug is that the key-release-event is connected to the key-press handler instead of the key-release handler. Catfish uses this to maintain a list of currently pressed modifier keys and does not allow any custom click actions if shift or control key is in this list. The bug prevents catfish from ever removing any recorded keys.

The FIX is simple. On an installed system just execute this line:

sudo sed -e 's/"key-release-event" handler="on_catfish_window_key_press_event"/"key-release-event" handler="on_catfish_window_key_release_event"/' -i /usr/share/catfish/ui/CatfishWindow.ui

This has been tested on xubuntu 18.04, the first LTS that includes a catfish version that exhibits this problem.

The proper git patch is attached.

The bug 14538 also has the same root cause.

In , Gitbot (gitbot) wrote :

frankzz referenced this bugreport in commit 5fc25f6f97c04ab6e4676d145490229b5380189a

Fix context menu not opening after shift/ctrl key by connecting correct key-release-event (bug #14621, #14743, #14999)

https://git.xfce.org/apps/catfish/commit?id=5fc25f6f97c04ab6e4676d145490229b5380189a

Thanks for the patch! Applied at the above commit.

*** Bug 14743 has been marked as a duplicate of this bug. ***

*** Bug 14999 has been marked as a duplicate of this bug. ***

*** Bug 14538 has been marked as a duplicate of this bug. ***

Changed in catfish-search:
status: Confirmed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package catfish - 1.4.7-1

---------------
catfish (1.4.7-1) unstable; urgency=medium

  * New upstream release.
    - Fixed context menu activation (LP: #1788058)
    - Fixed crash with searching inside /dev (LP: #1772437)
    - Fixed window button placement in LXDE (LP: #1512031)
    - Fixed occasional crash at startup (LP: #1753163)
  * d/control:
    - Bump Standards-Version to 4.3.0, no changes needed.
  * d/copyright:
    - Bump source copyright years to 2019

 -- Sean Davis <email address hidden> Mon, 11 Feb 2019 18:44:12 -0500

Changed in catfish (Ubuntu):
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.