Ubuntu

end_request: I/O error rebooting at end of install

Reported by Colin King on 2010-03-15
142
This bug affects 24 people
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
casper (Ubuntu)
Medium
Unassigned

Bug Description

Lucid daily 20100315, test http://iso.qa.ubuntu.com/qatracker/result/3750/6 (entire disk), AMD64 Dell Inspiron 6400
Maverick daily 20100913, Apple MacBook4,1 (early 2008)

At end of installation, system goes to reboot. CD-ROM is ejected and throws up lots of errors:

end_request: I/O error, dev sr0, sector 437628
end_request: I/O error, dev sr0, sector 437636
..
..
end_request: I/O error, dev sr0, sector 437676
Buffer I/O error on device sr0, logical block 109419
..
..

and the system does not reboot.

Colin King (colin-king) wrote :

Attached: /var/log log files

tags: added: iso-testing
ionash. (janusz-arch) wrote :

I have the same issue after upgrade from karmic. Reboot ends with I/O error. Installation from LiveCD also doesn't start, because lucid don't recognize my hard drive.
In earlier versions (from 8.04 up to 9.10) I used grub command "boot: pci=nomsi" - without this text busybox starts only. In lucid it doesn't matter - I/O error with this command or without it.
I use Asus A8VX motherboard, Athlon 64 3800+ processor, Seagate Barracuda Sata II (ST3500418AS) hard drive and 32bit system.
Apologize for my english.

Colin King (colin-king) wrote :

Update: System did reboot when I pressed <ENTER>, I had not realised it was requesting this key to be pressed.

Colin King (colin-king) wrote :

It's just mighty ugly and the huge amount of kernel messages scrolls off the screen the message telling the user to press enter.

ionash. (janusz-arch) wrote :

Your advice is useless for me - my problem is however not the same, and I/O error appears AFTER update, and AFTER reboot, when system trying to boot from hard drive, not LiveCD. Hovewer, LiveCD starts almost flawless, but don't recognize my disk (in gparted or palimpsest there is no disk appear at all). Installation from alternate CD starts (disk and partitions are recognized properly), but freezing when partitioning program is trying to start.
I think this is kernel or grub (rather kernel) bug - I wrote about "pci=nomsi" command, now, in lucid, it doesn't works.

Colin King (colin-king) wrote :

@ionash, your bug is completely different, I suggest opening up a new bug report.

ionash. (janusz-arch) wrote :

Done some other test (with another disks), and wrote new bug report (Bug #543400).

Erick Brunzell (lbsolost) wrote :

I'm getting the same error sometimes immediately upon completing installation with the pre-Beta2 iso-testing build of the i386 Live CD.

I've actually done five separate installs today due to another bug encountered during iso testing and this behavior is not consistent. Three installs out of the five worked fine, that is producing the expected message: "Remove CD, press enter, etc", but the other two installs were followed by a long list of I/O errors.

But simply ignoring that and removing the disc, closing tray, and pressing Enter takes me through the reboot successfully.

Changed in ubuntu:
status: New → Confirmed
Paul Larson (pwlars) wrote :

This does not seem limited to x86, or to cd installs. I see it on armel netbook image installing from a USB stick as well.

Colin Watson (cjwatson) on 2010-04-07
affects: ubuntu → casper (Ubuntu)
Colin Watson (cjwatson) wrote :

I've made an effort to fix this in casper 1.231 (not yet uploaded, probably post-beta-2), but I'm not sure it will cover everything so I'm not closing the bug yet. Feedback welcome once this lands.

  * Cache /bin/plymouth and /sbin/usplash_write before ejecting the CD, in
    the hope that that helps with I/O errors on reboot (see LP #539027).

We are seeing this in Xubuntu Lucid Beta2, lucid-desktop-i386.iso, dated 2010-04-06, also.

Matthew Eaton (powder) wrote :

Just wanted to mention I am also seeing this bug exactly as described using the official Lucid Beta2 Live CD.

Steve Langasek (vorlon) wrote :

casper 1.231 is in the archive now, an will be included in the 20100410 daily build. Please test and report any results.

Colin King (colin-king) wrote :

I'm travelling this week, so not able to test this as I don't have access to the hardware. Anyone else able to confirm this fix?

I won't be able to test until the nvidia/nouveau bugs are resolved. My LCD monitors are now locked at 800x600 maximum resolution, and everything is blurred.

Okay, thanks to the suggestion on another bug to blacklist vga16fb and nouveau, I was able to install nvidia hardware drivers and get my high resolution lcd back.

Installing using the Xubuntu image dated 2010-04-10, lucid-desktop-i386.iso, results in the same messages after the installation. There is no change in that. However, I did get several other text messages, including "checking for unattended-upgrades" after the installation completed but before the I/O Error messages filled the screen.

Now testing the Ubuntu 386 image for 2010-04-10 to see if the results are different for that.

Errors still happening using the Ubuntu Desktop 386 image, lucid-desktop-i386.iso dated 2010-04-10. It has changed a bit with this image. Now, I can read all the messages on screen, and the message "Please remove the disc and close the tray (if any) then press ENTER: " appears before the I/O errors. I only have 10 of the I/O error messages appearing on screen. It no longer fills the screen.

Matthew Eaton (powder) wrote :

Problem is still present for me also using today's daily. "apt-cache policy casper" reported ver 1.231.

This is still happening testing the pre-RC images on a 386 system. Confirming importance set to medium, removed beta from summary.

summary: - end_request: I/O error rebooting at end of install Lucid beta
+ end_request: I/O error rebooting at end of install Lucid
Changed in casper (Ubuntu):
importance: Undecided → Medium
Tobin Davis (gruemaster) wrote :

This is also still happening on dove arm platforms as of 20100419.1

Erick Brunzell (lbsolost) wrote :

I can also confirm this on the pre-RC i386 image, but it's not consistent! Three out of four installs worked as expected, only the fourth failed with the I/O errors.

But also simply removing the disc and pressing enter continues as though all is well.

So IMO it's largely "cosmetic".

A. Denton (aquina) wrote :

* I can confirm this the same way charlie-tca did when testing. I used Xubuntu daily (20100419), casper 1.236.
* After clicking on restart now Xfce shuts down and you drop to the tty where you see daemons stopping, etc.
* In the end (before the actual reboot) I receive dozens of these I/O errors (screenshot attached).
* Installation from LiveCD was not affected any further.
* My hardware is custum (VM: 1,53 Ghz AMD K7/gen10; 448Mb DDR-SD-RAM (in VM); ATI RV350 AS [Radeon 9550] w/ 256Mib)
* Could this rather be a problem in plymouth?

VSN (vsn-inbox) wrote :

Ubuntu 10.04, i386, RC.
The bug is still present. Removing the disc and pressing enter reboots the system. In spite of that bug the system was instelled successfully.

Erick Brunzell (lbsolost) wrote :

This bug still exists with the first Lucid pre-final iso-testing i386 Live CD 04/26 early PM in the states.

Specifically I get a full screen vertically of I/O errors with no prompt to "close tray" and/or "press enter" to proceed.

If I do remove the CD, close the tray, and press enter all goes ahead as it should but a noob won't know that. So, if this can't be fixed, it must at least be prominently addressed in the release notes.

Otherwise the install was flawless.

Erick Brunzell (lbsolost) wrote :

Once again this is not consistent behavior. That last test was "entire disc". I followed it with an "auto-resize" and had the same behavior. I followed that with a manual partition installation and got the normal notifications.

But that doesn't mean it only happens in certain installation scenarios. I've seen this long enough to know it's simply inconsistent. The same is true of this bug:

https://bugs.launchpad.net/ubuntu/+source/plymouth/+bug/557000

Totally inconsistent! Impossible to nail it down to a specific installation scenario!

I certainly don't envy you at this point, I'm clueless as far as what else I could attach to the bug report to be helpful.

Colin Watson (cjwatson) wrote :

I'd expect it depends on what happens to be in the kernel's buffer cache; inconsistency isn't surprising here ...

Colin Watson (cjwatson) wrote :

I've opened a release notes task for this, as we're not going to be able to make any sufficiently reliable improvements at this point to be able to guarantee that this goes away entirely.

Steve Langasek (vorlon) wrote :

Documented at <https://wiki.ubuntu.com/LucidLynx/ReleaseNotes#I/O%20error%20after%20CD%20is%20ejected%20at%20end%20of%20install>:
In some cases, ejecting the CD at the end of installation will leave errors on the screen such as:

end_request: I/O error, dev sr0, sector 437628

these error messages indicate that the system is still trying to access some files on the CD, and are harmless except that they obscure the message asking the user to press Enter to reboot. You can safely remove the CD from the tray and press Enter at this point to reboot to your new Ubuntu system. (539027)

Changed in ubuntu-release-notes:
status: New → Fix Released
John (johnnybirdman) wrote :

A lot of this presumes you have a CD eject which lets you know the installer is finished.

When I installed from a USB drive on my Dell Mini 9 and got the I/O error I had no indication that the installer was finished.

Nico (nico-laurencin) wrote :

Just to confirm that the bug still happens with the official 10.04 release. Same as described: page filled with
end_request: I/O error, etc...
It happens when the disk gets ejected... (slimline tray drive in my case).
As other people said, it's not a big problem as long as you know that you're supposed to remove the disc, close the drive and press enter (like most people used to ubuntu installs), but for ubuntu noobs it's gotta be scary.

Kalle Tuulos (kalle-tuulos) wrote :

In my case (official 10.04 Ubuntu desktop disk), I get these "end_request: I/O error, dev sr0, sector 506112...606172 (the last ones visible on screen)" messages after CD has been ejected. Pressing Enter on this state does not reboot the system, I have to press the reset key. Also Ctrl-Alt-Del does not work (maybe it even should not work).

I tested this three times (i.e. installed the system three times). The same error message was given on all times after CD was automatically ejected and Enter did not reboot the system in any of these.

cyberfic (cyberfic) wrote :

i was installing ubuntu for the first time - and got the same messages that filled the whole screen - i didnt know that i had to press enter so i had do just switch off the system and boot again...

Erick Brunzell (lbsolost) wrote :

I'm sure it comes as no surprise but thought I should report anyway, this behavior still exists iso-testing the pre-alpha 1 Maverick i386 Live CD.

tags: added: lucid maverick
nomike (michael-postmann) wrote :

I could confirm this one too. I've seen this error on multiple different Systems (x86, amd64).
As far as I could remember I saw this in Lucid, Karmic and Jaunty (I think I saw it even earlier, but as I'm not 100% sure there I don't count them)

frissony (frissony) wrote :

10 JULY 2010.
Ubuntu does not install.
At end of install, I get errors like "end_request: I/O error, dev sr0, sector 437628".
I remove CD, press Enter. Nothing happens.
I h/w reset the PC.
Grub prompt shows up.
During last install attempt, "grub rescue>" prompt showed up.

Please fix this problem. It's time to fix it.

loreen flesch (zicke400) on 2010-08-02
Changed in ubuntu-release-notes:
status: Fix Released → New
loreen flesch (zicke400) on 2010-08-02
Changed in ubuntu-release-notes:
status: New → Opinion
Changed in ubuntu-release-notes:
status: Opinion → Fix Released
tags: added: karmic
Changed in ubuntu-release-notes:
status: Fix Released → Confirmed
tags: added: regression-update
Fabio Marconi (fabiomarconi) wrote :

Still present in Xubuntu maverick 20100831.1

Steve Langasek (vorlon) on 2010-08-31
Changed in ubuntu-release-notes:
status: Confirmed → Fix Released

Fabio: the portion of the bug fix-released is to have this included in the release notes. The bug itself has not been fixed.

summary: - end_request: I/O error rebooting at end of install Lucid
+ end_request: I/O error rebooting at end of install
description: updated
Fabián Rodríguez (magicfab) wrote :

This probably needs to go again in the Maverick release notes as it's still the case.

Changed in ubuntu-release-notes:
status: Fix Released → New
Fabián Rodríguez (magicfab) wrote :

I tested this on the latest Maverick daily (today),, i386 CDROM, I was able to reproduce it. I also tested from a USB key, didn't get the errors.

The following has been added to the Maverick release notes:
* At end of installation, when the system goes to reboot, the CD-ROM is ejected and throws up lots of errors: "end_request: I/O error, dev sr0, sector 437628". Pressing Enter will reboot and resume normally. These errors are harmless and can be ignored. (Bug:539027)

Erick Brunzell (lbsolost) wrote :

Well, iso-testing Ubuntu Desktop i386 [20101006.2] it was a bit worse :^(

I had to Alt > SysReq > b to reboot. It was otherwise just hung.

But that's only happened once out of three trials.

Steve Langasek (vorlon) wrote :
Changed in ubuntu-release-notes:
status: New → Fix Released
Robert Pollak (robert-pollak) wrote :

In the "Known Issues" section of https://wiki.ubuntu.com/MaverickMeerkat/ReleaseNotes , this issue should not be listed twice.

On Sun, Oct 10, 2010 at 03:41:18PM -0000, Robert Pollak wrote:
> In the "Known Issues" section of
> https://wiki.ubuntu.com/MaverickMeerkat/ReleaseNotes , this issue should
> not be listed twice.

Corrected, thanks.

--
Steve Langasek Give me a lever long enough and a Free OS
Debian Developer to set it on, and I can move the world.
Ubuntu Developer http://www.debian.org/
<email address hidden> <email address hidden>

Brian Murray (brian-murray) wrote :

I'm setting this bug report to Won't Fix as there have been no reports of this since Maverick (10.10) and we are currently developing the 12.04 release of Ubuntu.

Changed in casper (Ubuntu):
status: Confirmed → Won't Fix
martin suc (martin-suc) wrote :

unfortunately this problem still exist in 12.10 Ubuntu Quantal

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers