toram does not work

Bug #526305 reported by Kano on 2010-02-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
Undecided
Colin Watson

Bug Description

Binary package hint: casper

Usually i boot via NFS with added toram option, but toram just does nothing. Debian Live works with toram in the same environment. Please fix it.

Related branches

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.230

---------------
casper (1.230) lucid; urgency=low

  * Don't save the hardware clock on live CD reboot; we used to do this in
    the sysvinit world, but it regressed when we switched to Upstart
    (thanks, Norm Pierce; LP: #436535).
  * When running update-initramfs on writable media, update initrd.lz rather
    than initrd.gz if it's present, and make the update process a bit safer
    while we're there (LP: #489736).
  * Handle toram and todisk=DEVICE options on command line (LP: #526305).
  * Policy version 3.8.4: no changes required.
  * Convert to source format 3.0 (native).
 -- Colin Watson <email address hidden> Tue, 30 Mar 2010 11:41:24 +0100

Changed in casper (Ubuntu):
status: New → Fix Released
Kano (master-kanotix) wrote :

This is used for copying:

cp -a ${copyfrom}/* ${copyto} # "cp -a" from busybox also copies hidden files

The problem is that only

cp -a ${copyfrom}/ ${copyto} # "cp -a" from busybox also copies hidden files

without the * copies hidden files, when you add a * it does not. As the .disk dir is not copied a name for the "disk" is asked with the result that it does not boot. So the bug is definitely NOT fixed.

Colin Watson (cjwatson) wrote :

Reopening, then, thanks. Of course it wouldn't be as simple as that because simply removing the * would result in the wrong directory structure.

Changed in casper (Ubuntu):
status: Fix Released → Triaged
Colin Watson (cjwatson) wrote :

And, while the version in live-initramfs is different, it doesn't appear to copy .disk either. Odd.

Kano (master-kanotix) wrote :

That's correct as live-initramfs does not use .disk to identify anything at all (when you cp .disk on usb you do not need to change any option for casper to find it, just as sidenode), on pure live-helper images is no .disk dir nor are those images combined with a repository.

Colin Watson (cjwatson) wrote :

OK. I think it'd be easiest to just explicitly copy .disk, and I'll make that change now.

Changed in casper (Ubuntu):
assignee: nobody → Colin Watson (cjwatson)
status: Triaged → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package casper - 1.231

---------------
casper (1.231) lucid; urgency=low

  [ Jonathan Riddell ]
  * Remove 37kubuntu_netbook_installer_link, now done with a patch in
    kdebase-workspace

  [ Colin Watson ]
  * If copying live media to RAM or disk, explicitly copy .disk, since *
    won't expand to include it (LP: #526305).
  * Cache /bin/plymouth and /sbin/usplash_write before ejecting the CD, in
    the hope that that helps with I/O errors on reboot (see LP #539027).

  [ Luke Yelavich ]
  * ubiquity-hooks/30accessibility: Copy the orca settings directory to the
    gdm home directory, to allow for preferred orca settings to be used in
    gdm (LP: #551515).
 -- Luke Yelavich <email address hidden> Fri, 09 Apr 2010 14:00:51 +1000

Changed in casper (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers