Installing via livecd doesn't localize KDE.

Bug #43683 reported by Oscar on 2006-05-08
48
Affects Status Importance Assigned to Milestone
casper (Ubuntu)
High
Tollef Fog Heen

Bug Description

When using the installcd, if you choose a different language then the default (english), your new system would start with KDE localized in that language.
This doesn't appear to be the case when using the live-cd installer, however it did pick up some things, such as the correct keyboard map and the correct timezone.

Javier Jardón (jjardon) wrote :

Same here (I choose spanish)

Oscar (osh-nbit) wrote :

Since atleast two persons have seen this, I'll confirm it.

Changed in ubiquity:
status: Unconfirmed → Confirmed
Bastian Holst (bastianholst) wrote :

Bug #43211 describes the same issue, so I marked it as a duplicate of this one.

In this report, we found out that the packages language-pack-kde-?? and language-pack-kde-base don't get installed.

Andre Bouillet (andre-bouillet) wrote :

I also find out, that the kde-i18n-* packages for the translations of the core applications is not installed by default after choosing the appropriate language in the installer. We should at least have the option to decide if we want to install them during the installation...

Bastian Holst (bastianholst) wrote :

Which programs are affected by the kde-i18n-* packages?

More important would be the installation of the "k3b-i18n" package.

Colin Watson (cjwatson) wrote :

Part of this was a cdimage bug; the preseed/file argument wasn't getting added to the live CD boot lines.

The rest is a casper bug; preseed/file isn't handled properly because the /cdrom mount point has already been moved by the time the relevant script runs and it doesn't take account of this. Tollef, could you please merge and upload http://people.ubuntu.com/~cjwatson/bzr/casper/preseed/ to fix this? Thanks.

Tollef Fog Heen (tfheen) wrote :

casper (1.54) dapper; urgency=low

  [ Luke Yelavich ]
  * Set large print fonts for the v1 accessibility profile. Closes
    Malone #45376.

  [ Colin Watson ]
  * Fix preseed/file handling (closes: Malone #43683).

 -- Tollef Fog Heen <email address hidden> Thu, 18 May 2006 19:36:24 +0200

Changed in casper:
assignee: nobody → tfheen
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers