Cairo-dock running or having been run corrupts Kdenlive monitor display

Bug #729970 reported by Luke on 2011-03-06
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cairo-dock (Ubuntu)
Undecided
Unassigned

Bug Description

Binary package hint: cairo-dock

If cairo-dock is installed and has been run withing the same X session, Kdenlive running under compiz, with XV video output will display a transparent monitor window, and no video, just transparency, until playback stops.Other window managers with xv output from kdenlive will give a blank monitor (background only) entirely during playback, just as the entire frame is transparent under compiz.

 Using the X11 driver gives semi-transparent (0<alpha<1) video with transparent borders under compiz, normal video playback under window managers other than compiz. Detaching the window returns the semi-transparent playback as though compiz were running. In all cases the image returns to normal when playback stops.

This report is posted on the Kdenlive website:

http://www.kdenlive.org/forum/transparent-monitor-during-playback-uninstall-cairo-dock-and-dependencies

"but the problem seems to be cause by cairo-dock. A number of other qt-base applications have known problems with it, that this workaround fixes:

Others apps based on Qt4 like VirtualBox, Skype, VLC
(for VLC, there was a bug only if the option 'Integrate video in interface' is enabled and vlc devs have added this workaround into the application)
It's the same problem that (S)MPlayer, so you can use this command in order to launch your application, e.g.:
export XLIB_SKIP_ARGB_VISUALS=1 && skype
But you can also make a little script:
Create a file with the extention ".sh" (launch_virtualbox.sh for example)
Add these two lines :
export XLIB_SKIP_ARGB_VISUALS=1
virtualbox
Change the right execution (Right clic on the file / Properties / Permissions / Execution => or directly :
chmod +x launch_virtualbox.sh
Use this file to execute this app.
Or edit the launcher and use a command like this one:
sh -c "env XLIB_SKIP_ARGB_VISUALS=1 kaffeine" "

Unfortunately, this does not help in kdenlive(replacing "kaffeine" with"kdenlive"), where it has no effect and the transparency continues..

Both SMplayer and Kaffeine also report video playback issues when cairo-dock is running:

https://bugs.launchpad.net/cairo-dock-core/+bug/472112 declares that the problem is in qt-but in that case, the bug is being reported to appear in opengl mode. With kdenlive the bug appears under both opengl and cairo backends. I've tested both, restarting X between tests.

The only workaround I have found is to set cairo-dock not to start with the session and start it only when not using Kdenlive. To use kdenlive, X must be restarted. I just removed Docky so I could get rid of mono, now this...

I am using cairo-dock_2.2.0~4-0ubuntu1 in Ubuntu Natty with compiz-unity, gnome-shell, kde, and icewm sessions all installed and working.

Related branches

Download full text (6.4 KiB)

could you please try with the latest version (2.3) ?
I think it fixes the problem

2011/3/6 Luke <email address hidden>

> Public bug reported:
>
> Binary package hint: cairo-dock
>
> If cairo-dock is installed and has been run withing the same X session,
> Kdenlive running under compiz, with XV video output will display a
> transparent monitor window, and no video, just transparency, until
> playback stops.Other window managers with xv output from kdenlive will
> give a blank monitor (background only) entirely during playback, just as
> the entire frame is transparent under compiz.
>
> Using the X11 driver gives semi-transparent (0<alpha<1) video with
> transparent borders under compiz, normal video playback under window
> managers other than compiz. Detaching the window returns the semi-
> transparent playback as though compiz were running. In all cases the
> image returns to normal when playback stops.
>
>
> This report is posted on the Kdenlive website:
>
> http://www.kdenlive.org/forum/transparent-monitor-during-playback-
> uninstall-cairo-dock-and-dependencies
>
> "but the problem seems to be cause by cairo-dock. A number of other qt-
> base applications have known problems with it, that this workaround
> fixes:
>
> Others apps based on Qt4 like VirtualBox, Skype, VLC
> (for VLC, there was a bug only if the option 'Integrate video in interface'
> is enabled and vlc devs have added this workaround into the application)
> It's the same problem that (S)MPlayer, so you can use this command in order
> to launch your application, e.g.:
> export XLIB_SKIP_ARGB_VISUALS=1 && skype
> But you can also make a little script:
> Create a file with the extention ".sh" (launch_virtualbox.sh for example)
> Add these two lines :
> export XLIB_SKIP_ARGB_VISUALS=1
> virtualbox
> Change the right execution (Right clic on the file / Properties /
> Permissions / Execution => or directly :
> chmod +x launch_virtualbox.sh
> Use this file to execute this app.
> Or edit the launcher and use a command like this one:
> sh -c "env XLIB_SKIP_ARGB_VISUALS=1 kaffeine" "
>
> Unfortunately, this does not help in kdenlive(replacing "kaffeine"
> with"kdenlive"), where it has no effect and the transparency continues..
>
> Both SMplayer and Kaffeine also report video playback issues when cairo-
> dock is running:
>
>
> https://bugs.launchpad.net/cairo-dock-core/+bug/472112 declares that the
> problem is in qt-but in that case, the bug is being reported to appear in
> opengl mode. With kdenlive the bug appears under both opengl and cairo
> backends. I've tested both, restarting X between tests.
>
> The only workaround I have found is to set cairo-dock not to start with
> the session and start it only when not using Kdenlive. To use kdenlive,
> X must be restarted. I just removed Docky so I could get rid of mono,
> now this...
>
> I am using cairo-dock_2.2.0~4-0ubuntu1 in Ubuntu Natty with compiz-
> unity, gnome-shell, kde, and icewm sessions all installed and working.
>
> ** Affects: cairo-dock (Ubuntu)
> Importance: Undecided
> Status: New
>
> --
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed ...

Read more...

Luke (lukekuhn) wrote :
Download full text (9.1 KiB)

WORKAROUNDS FOR CAIRO-DOCK WITH KDENLIVE:
Here are the results of further testing last night with version 2.2. It turned out that to use the cairo backend it had to be explicitly called that way and my earlier attempt to specify it in the configuration files did not stop it from using the opengl backend.
Version 2.3 is not yet in the Ubuntu Natty (alpha) repos, will try it as soon as it arrives. Meanwhile, here are two workarounds verified to work on AMD Phenom II/785 chipset/ATI graphics and on Intel Atom with Intel graphics:

I tried calling cairo-dock itself with XLIB_SKIP_ARGB_VISUALS=1, since calling Kdenlive this way does not work. This inversion of the normal fix stopped the Kdenlive problems, at the expense of making it impossible to cover the bottom of the screen with anything else, hiding the dock leaving the dock background (copy of desktop background in fake transparancy or a black rectangle without) on top.
This is done by starting with this command from terminal or in a launcher:
env XLIB_SKIP_ARGB_VISUALS=1 cairo-dock
in configuration of cairo-dock, set to use fake transparancy.
I then realized the choice of backend for cairo-dock was being set by the .desktop file used to launch it, overriding my earlier attempt to specify the cairo backend and invalidating my previous test result that the cairo backend still corrupted kdenlive video playback.
I changed the ~/config/autostart/cairo-dock.desktop file from it's previous cairo-dock -o command for opengl backend to the following:
cairo-dock -c
In testing kdenlive now gave normal video playback, even in compiz, and there was no longer any need for fake transparency and the dock could be hidden in any of the normal ways. This is what I am using now.

This is consistant with the existing bug reports against Kaffeine and other video players in KDE.

> Date: Sun, 6 Mar 2011 10:47:54 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: Re: [Cairo-dock-team] [Bug 729970] [NEW] Cairo-dock running or having been run corrupts Kdenlive monitor display
>
> could you please try with the latest version (2.3) ?
> I think it fixes the problem
>
> 2011/3/6 Luke <email address hidden>
>
> > Public bug reported:
> >
> > Binary package hint: cairo-dock
> >
> > If cairo-dock is installed and has been run withing the same X session,
> > Kdenlive running under compiz, with XV video output will display a
> > transparent monitor window, and no video, just transparency, until
> > playback stops.Other window managers with xv output from kdenlive will
> > give a blank monitor (background only) entirely during playback, just as
> > the entire frame is transparent under compiz.
> >
> > Using the X11 driver gives semi-transparent (0<alpha<1) video with
> > transparent borders under compiz, normal video playback under window
> > managers other than compiz. Detaching the window returns the semi-
> > transparent playback as though compiz were running. In all cases the
> > image returns to normal when playback stops.
> >
> >
> > This report is posted on the Kdenlive website:
> >
> > http://www.kdenlive.org/forum/transparent-monitor-during-playback-
> > uninstall-cairo-dock-and-de...

Read more...

Matthieu Baerts (matttbe) wrote :

Hello,

Can you try with the 2.3.0 and with the OpenGL backend? You can add our weekly ppa => http://www.glx-dock.org/ww_page.php?p=ppa%20Weekly&lang=en

Can you also add a little message on this bug report: https://bugs.launchpad.net/ubuntu/+source/cairo-dock/+bug/723994
Thank you :)

The new 2.3.0 version with the opengl backend did not bother kdenlive in the least!
I just installed it after the day's normal updates(which included changes in Compiz), edited the launcher in ~/.config/autostart to specify -o , killed X to reload everything else, and tested the new version. Just to be sure, I even killed cairo-dock and fired it back up from gmrun, specifying the -o option. More icon effects run in opengl, confirming their presence.

I am running it now, just tested kdenlive, launching if from the icon in cairo-dock, dropping in a video file and playing it, no transparency problems anymore. Whatever code caused the problem in older versions should be published so other opengl developers know what NOT to do if possible.
Meanwhile, goodbye Docky, and goodbye Mono!

> Date: Mon, 7 Mar 2011 13:19:44 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 729970] Re: Cairo-dock running or having been run corrupts Kdenlive monitor display
>
> Hello,
>
> Can you try with the 2.3.0 and with the OpenGL backend? You can add our
> weekly ppa => http://www.glx-dock.org/ww_page.php?p=ppa%20Weekly&lang=en
>
> Can you also add a little message on this bug report: https://bugs.launchpad.net/ubuntu/+source/cairo-dock/+bug/723994
> Thank you :)
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/729970
>
> Title:
> Cairo-dock running or having been run corrupts Kdenlive monitor
> display
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+source/cairo-dock/+bug/729970/+subscribe

Matthieu Baerts (matttbe) wrote :

Thank you for this report!

PS: Arf, wrong click... "Fix Commited" and not "Fix Released" :-/

Changed in cairo-dock (Ubuntu):
status: New → Fix Released
Martin Pitt (pitti) wrote :

Not fixed in Natty yet, reopening. (See bug 723994)

Changed in cairo-dock (Ubuntu):
status: Fix Released → Fix Committed
Launchpad Janitor (janitor) wrote :
Download full text (3.3 KiB)

This bug was fixed in the package cairo-dock - 2.4.0~2-0ubuntu1

---------------
cairo-dock (2.4.0~2-0ubuntu1) oneiric; urgency=low

  [ Matthieu Baerts (matttbe) ]
  * New upstream bug fix release. (LP: #859982)
  * Upstream (short) ChangeLog (2.4.0~0beta2 -> 2.4.0~1):
   - Improved support of the new Gnome 3 session
      (to avoid conflicts with the new Gnome-Panel).
   - Code cleaned and re-organised a few functions
      (e.g. with cairo-dock-overlay, cairo-dock.c, etc.)
   - Updating translations
   - Improved the support of XFCE and LXDE environments
   - Removed invalid launcher desktop files
   - Used a default icon if the path set by the user is wrong
   - Fixed the possibility to sticky a desklet (bug due to a Xorg update)
   - GUI: fixed the list-entry widget
   - Fixed support of the Widget Layer in Compiz >= 0.9
   - Compiz type filter: replaced type=utility by type=Utility
   - Fixed a small refresh bug in cairo mode
      (with icons that are always visible)
   - Improved the placement of icons when avoiding the mouse
      (when something is being dropped onto the dock)
   - Updated the default theme in order to use new applications
   - Gauge implementation: Rewritten to use CairoDockImageBuffer
      and fixed the problem with png images
   - Graphs: Improved the drawing and added more precisions
   - Improved the 'lock' option description
   - GUI simple: fixed a bad update of the parameters
      when switching back to the previous value
   - Fixed the path of the preview for the default view
   - Help: Fixed the problem with tips
   - Default-theme: .conf files: fixed lintian warnings
   - Fixed a few warnings at the compilation
   - Removed a few useless output messages
   - Fixed these LP bugs:
    + Cairo-dock corrupts Kdenlive monitor display LP: #729970
    + Can't play videos in kaffeine LP: #475375
   - And fixed a lot of tiny bugs, please have a look to bzr logs.
  * Upstream (short) ChangeLog (2.4.0~1 -> 2.4.0~2):
   - Fixed a bug with the detection of compiz plugins
   - doc: used the right version
   - Fixed a possible crash with an empty dock LP: #861725
   - FlyingContainer: draw the icon correctly
  * debian/patches:
   - Removed 01-musicPlayer_with_banshee: now in upstream
  * debian/copyright:
   - Updated and fixed lintian warnings: old-fsf-address-in-copyright-file
  * debian/rules and debian/cairo-dock-data.install:
   - Added support of the new Gnome 3 session.
  * debian/control:
   - Fixed lintian warning: description-synopsis-starts-with-article
   - Fixed lintian error: version-substvar-for-external-package
  * debian/cairo-dock-data.lintian-overrides:
   - Removed old warnings (fixed)
   - Added binary-without-manpage (custom scripts used)
  * debian/cairo-dock-core.install and debian/cairo-dock-dev.install:
   - Fixed a lintian warning: non-dev-pkg-with-shlib-symlink
  * debian/patches/01-improved-cairo-dock-session.patch:
   - Improved the launch of our Cairo-Dock session (by removing Unity
      Compiz plugin and by launching the dock with a short delay)
   - Fixed lintian error: shell-script-fails-syntax-check
      (it seems I made wrong manipulation with vim...)
  * debian/patches/02-manpag...

Read more...

Changed in cairo-dock (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers