FFe: Please update Cairo-Dock to 2.3.0~1 version

Bug #723994 reported by Matthieu Baerts on 2011-02-23
54
This bug affects 8 people
Affects Status Importance Assigned to Milestone
cairo-dock (Ubuntu)
Wishlist
Unassigned
Natty
Wishlist
Unassigned

Bug Description

Binary package hint: cairo-dock

The Cairo-Dock team proposes a Release Candidate for the version 2.3.0.
It's a major version, and it brings several improvements and fixes several bugs.

This version has been proposed on Debian too (on mentors.debian.net).

A bzr branch will be linked to this bug report asap.

PS: please don't forget to update our plug-ins too (LP: #723995)

Related branches

description: updated
description: updated
Micah Gersten (micahg) on 2011-02-24
summary: - Please update Cairo-Dock to 2.3.0~0rc1 version
+ FFe: Please update Cairo-Dock to 2.3.0~0rc1 version
Changed in cairo-dock (Ubuntu):
importance: Undecided → Wishlist

Version 2.3.0 fixes a very serious opengl bug

https://bugs.launchpad.net/ubuntu/+source/cairo-dock/+bug/729970

that made video in qt applications turn transparent or disappear entirely, depending on window manager and video backend.

Kdenlive required that cairo-dock use the cairo backend, not the openGL backend, until version2.3.0 came out. Other qt applications involving video reported similar bugs, hope they are also fixed.

by the way how is going the update of cairo-dock in Natty ?
there is no news for 2 weeks now :-/
considering the numbers of fixes this version brings (due to changes in
Ubuntu Natty and to bug-fixes), I think it's really important.
Thanks.

2011/3/8 Luke <email address hidden>

> Version 2.3.0 fixes a very serious opengl bug
>
> https://bugs.launchpad.net/ubuntu/+source/cairo-dock/+bug/729970
>
> that made video in qt applications turn transparent or disappear
> entirely, depending on window manager and video backend.
>
> Kdenlive required that cairo-dock use the cairo backend, not the openGL
> backend, until version2.3.0 came out. Other qt applications involving
> video reported similar bugs, hope they are also fixed.
>
> --
> You received this bug notification because you are a member of Cairo-
> Dock Team, which is subscribed to cairo-dock in ubuntu.
> https://bugs.launchpad.net/bugs/723994
>
> Title:
> FFe: Please update Cairo-Dock to 2.3.0~0rc1 version
>
> Status in “cairo-dock” package in Ubuntu:
> New
>
> Bug description:
> Binary package hint: cairo-dock
>
> The Cairo-Dock team proposes a Release Candidate for the version 2.3.0.
> It's a major version, and it brings several improvements and fixes several
> bugs.
>
> This version has been proposed on Debian too (on mentors.debian.net).
>
> A bzr branch will be linked to this bug report asap.
>
> PS: please don't forget to update our plug-ins too (LP:#723995)
>
> _______________________________________________
> Mailing list: https://launchpad.net/~cairo-dock-team
> Post to : <email address hidden>
> Unsubscribe : https://launchpad.net/~cairo-dock-team
> More help : https://help.launchpad.net/ListHelp
>

Matthieu Baerts (matttbe) wrote :

@ Ubuntu Release Team:
Hello,
It seems I need an ACK.
Please considering the numbers of fixes this version brings (due to changes in Ubuntu Natty and due to bug-fixes). This version has been compiled and tested by Micah Gersten and by me (with pbuilder and a liveUSB). This version has also been uploaded on a PPA (~cairo-dock-team/weekly) and has been tested by a few people.
Cairo-Dock 2.3 (final) should be out within days (should be available this next week, before the beta1 or just after).
Do you need something else?

PS: please don't forget to update our plug-ins too (LP: #723995)

Matthieu Baerts (matttbe) wrote :

I also want to note that we can't use the Debian versions because they don't respect what the upstream want to have (a bug has been reported about that) and the sponsoring said that "the merges were missing the original tarballs from upstream (upstream tag in UDD)" but mvo said on #ubuntu-devel that "this needs a feature freeze exception from the release team, if that is granted I'm happy to sponsor the upload"

Micah Gersten (micahg) wrote :

I have not compiled nor tested this yet.

Matthieu Baerts (matttbe) wrote :

Oh I'm sorry, I thought but I guess you've only compiled LaTeXila.

Matthieu Baerts (matttbe) wrote :

Hello,

What can we have to do in order to have this ACK and to update Cairo-Dock packages on Natty?

description: updated
Martin Pitt (pitti) wrote :

Has this been tested in current natty, with kdenlive? Bug 729970 is already marked as fixed, so that still actually an issue?

There are no other reverse dependencies, so updating is low risk for other packages, but of course it is a risk for cairo-dock itself. But as this request comes from upstream itself, and they seem to test this in an Ubuntu environment, I'm inclined to approve this.

Changed in cairo-dock (Ubuntu Natty):
status: New → Confirmed
Matthieu Baerts (matttbe) wrote :

> Has this been tested in current natty, with kdenlive? Bug 729970 is already marked as fixed, so that still actually an issue?
Yes this bug is fixed in this version 2.3.0. Sorry about this status of this bug report. As I said at the end of it, I wanted to click on "Fix Commited" and not "Fix Released" but it was too late :)

Thank you for your help!

Martin Pitt (pitti) wrote :

Ah, thanks for the clarification. I reopened 729970.

Matthieu Baerts (matttbe) wrote :

Ok it seems the ubuntu branch (lp:ubuntu/cairo-dock) is broken.
The attachment is the debian directory

Matthieu Baerts (matttbe) wrote :

The attachment is the debdiff

Scott Kitterman (kitterman) wrote :

Ack. Approved by the release team. One of the ubuntu-sponsors will still need to assess the details of the proposed packaging.

Scott Kitterman (kitterman) wrote :

Setting back to New so sponsors will review.

Changed in cairo-dock (Ubuntu Natty):
status: Confirmed → New
Jamie Strandboge (jdstrand) wrote :

Debian now has 2.3.0~0rc1-1 which differs from the version included in the debdiff attached to this report (I only looked at the changelog). Would it be better to sync or merge this version? Also, if we are moving to 2.3.0, there should be a full source package prepared somewhere for review/upload. Thanks!

Changed in cairo-dock (Ubuntu Natty):
status: New → Incomplete
Jamie Strandboge (jdstrand) wrote :

@Matthieu,

Also, you said "PS: please don't forget to update our plug-ins too (LP: #723995)". I read that bug but it is not clear to me what needs to be done. Do you need a simple no change rebuild? For what package?

Jamie Strandboge (jdstrand) wrote :

After talking with Mathieu in irc, the delta with Debian is required because they won't accept the packaging changes from upstream. Upstream would like to maintain the packages in Ubuntu. I asked about doing proper merges with Debian, but it sounds like usptream wants to continue to use -0ubuntuX versions that are not based on Debian for the foreseeable future.

As for cairo-dock-plug-ins, it is a separate source package that will need to be updated in tandem with cairo-dock. Mathieu, please update the other bug to more accurately reflect this (or open a new one).

ScottK gave the ACK, and I just added a little clarity to the bug. A member of ubuntu-sponsors can review the packaging when it is available.

Changed in cairo-dock (Ubuntu Natty):
status: Incomplete → In Progress
Matthieu Baerts (matttbe) wrote :

I confirm what said Jamie!

I propose the 2.3.0~1 version. It fixes a few bugs that affected the previous RC1 release.
* The official tarball is available on launchpad: http://launchpad.net/cairo-dock-core/2.3/2.3.0/+download/cairo-dock-2.3.0~1.tar.gz
* I've pushed my modifications on this branch: lp:~cairo-dock-team/ubuntu/natty/cairo-dock/2.3.0-1
* I'm going to join the .debian.tar.gz and the .dsc generated by debuild command.
* If I've to upload new files or comment something, don't hesitate to answer or to contact me on irc.freenode.net!

Thank you for your help!

Matthieu Baerts (matttbe) wrote :
summary: - FFe: Please update Cairo-Dock to 2.3.0~0rc1 version
+ FFe: Please update Cairo-Dock to 2.3.0~1 version
Matthieu Baerts (matttbe) wrote :
Matthieu Baerts (matttbe) wrote :

This is the current debdiff: From "cairo-dock_2.2.0~4-0ubuntu1" to "cairo-dock_2.3.0~1-0ubuntu1"

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cairo-dock - 2.3.0~1-0ubuntu1

---------------
cairo-dock (2.3.0~1-0ubuntu1) natty; urgency=low

  * New Upstream Version (LP: #723994)
  * Upstream short ChangeLog:
   - Updated translations
   - Updated the integration of the new versions of kwin and compiz
   - Updated default theme
   - Fixed a few bugs
   - Updated the man
  * debian/control:
   - Added suggests apps for cairo-dock-core (needed by the default theme)
   - Updated the description (from launchpad.net/cairo-dock)
   - Added cairo-dock-plug-ins as a new suggestion for cairo-dock-core
  * debian/patches:
   - Updated the default theme to use default apps of Ubuntu Natty
  * Switch to dpkg-source 3.0 (quilt) format
  * Removed the desktop-file-category patch (sync with debian packages)
  * debian/rules:
   - Added a CMake flag to disable the gtk grip
   - No longer used simple-patchsys
  * Updated the debian/watch
 -- Matthieu Baerts (matttbe) <email address hidden> Thu, 17 Mar 2011 14:08:48 +0100

Changed in cairo-dock (Ubuntu Natty):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers