Depends on libapache2-mod-php5. This is a bug, as I would like to run PHP5 through apache worker using FCGI, which would run cacti just fine.

Bug #544828 reported by Pieter Steyn on 2010-03-23
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
cacti (Debian)
Fix Released
Unknown
cacti (Ubuntu)
Medium
Mahyuddin Susanto

Bug Description

Binary package hint: cacti

Cacti should not depend on libapache2-mod-php5.

root@news:~# lsb_release -rd
Description: Ubuntu 9.10
Release: 9.10

I prefer to use apache2-mpm-worker along with libapache2-mod-fcgid to run my PHP sites. This combination will run Cacti perfectly fine, but whenever I want to install it I get prompted that Cacti is also going to be removed as it depends on libapache2-mod-php5.

root@news:~# aptitude install libapache2-mod-fcgid apache2-mpm-worker
Reading package lists... Done
Building dependency tree
Reading state information... Done
Reading extended state information
Initializing package states... Done
The following packages are BROKEN:
  libapache2-mod-php5
The following NEW packages will be installed:
  apache2-mpm-worker libapache2-mod-fcgid
The following packages will be REMOVED:
  apache2-mpm-prefork{a}
0 packages upgraded, 2 newly installed, 1 to remove and 5 not upgraded.
Need to get 2,314B/42.1kB of archives. After unpacking 209kB will be used.
The following packages have unmet dependencies:
  libapache2-mod-php5: Depends: apache2-mpm-prefork (> 2.0.52) but it is not installable or
                                apache2-mpm-itk but it is not installable
The following actions will resolve these dependencies:

Remove the following packages:
libapache2-mod-php5

Install the following packages:
php5 [5.2.10.dfsg.1-2ubuntu6.4 (karmic-updates, karmic-security)]

Score is 110

Then, if I want to remove libapache2-mod-php5, I get:

root@news:~# apt-get remove libapache2-mod-php5
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages were automatically installed and are no longer required:
  dbconfig-common php5-snmp libphp-adodb
Use 'apt-get autoremove' to remove them.
The following packages will be REMOVED:
  cacti cacti-spine libapache2-mod-php5
0 upgraded, 0 newly installed, 3 to remove and 5 not upgraded.
After this operation, 11.9MB disk space will be freed.
Do you want to continue [Y/n]? n
Abort.

I understand this is a very tricky bug, as Cacti must depend on some sort of php5/apache being installed.

In the mean time I will just use Cacti from sources instead of the package.

Hope this is enough info.

Related branches

Changed in cacti (Ubuntu):
importance: Undecided → Medium
status: New → Triaged
Nicholas Wiersma (nrwiersma) wrote :

Cacti should not depend on Apache at all. There are a multitude of web servers available, and used by people. I am currently running nginx, and don't need Apache installed to run Cacti. All this is doing is cluttering the system with things that might not be needed.

Mahyuddin Susanto (udienz) wrote :

I suggest to give alternative to spawn-fcgi, php5-cgi, libapache2-mod-fcgid, see below. What your opinion?

$ diff -Nurp control control.after
--- control 2011-12-31 03:32:25.000000000 +0700
+++ control.after 2011-12-31 10:54:32.917899267 +0700
@@ -15,7 +15,7 @@ Package: cacti
 Architecture: all
 Depends: apache2 | apache | apache-ssl | apache-perl | httpd,
          dbconfig-common (>= 1.8.8),
- libapache2-mod-php5 | php5,
+ libapache2-mod-php5 | php5-cgi | spawn-fcgi | libapache2-mod-fcgid,
          libphp-adodb (>= 4.50-1),
          php5-cli,
          php5-mysql,

Changed in cacti (Ubuntu):
assignee: nobody → Mahyuddin Susanto (udienz)
Changed in cacti (Debian):
status: Unknown → New
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package cacti - 0.8.7i-2ubuntu1

---------------
cacti (0.8.7i-2ubuntu1) precise; urgency=low

  * debian/patches/01_config.php.patch: Backports from Debian git repos to
    fix while upgrade because /etc/cacti/debian.php has been rewrite.
    (Closes: #654352)
  * debian/control:
    - Move apache2 to Recommends to allow cacti running to other webserver,
      and fcgi stuff to Depends. (LP: #544828)
    - Remove absolute packages: apache, apache-ssl, apache-perl
 -- Mahyuddin Susanto <email address hidden> Thu, 19 Jan 2012 15:25:27 +0700

Changed in cacti (Ubuntu):
status: Triaged → Fix Released
Changed in cacti (Debian):
status: New → Fix Committed
Changed in cacti (Debian):
status: Fix Committed → Fix Released
Paul Gevers (paul-climbing) wrote :

I don't believe the original report was a bug, but an human error. The report said:

"""
The following actions will resolve these dependencies:

Remove the following packages:
libapache2-mod-php5

Install the following packages:
php5
"""

But the reporter did: "apt-get remove libapache2-mod-php5".

Cacti depends on some php(5) implementation, so that should be present. I believe the original problem could have been fixed by:
apt-get install php5-cgi php5 # Make sure an alternative is available for cacti

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.