Comment 4 for bug 809048

Upstream change is:

At least with that unittest stops storing bound methods in the dict, so the best upstream change would be to also rename the variable from `_type_equality_funcs` to `_type_equality_func_names` or similar. Perhaps Michael Foord could be persuaded to land such a change without me having to go through the pain of being yelled at for breaking the underscore taboo?