Byobu 5.20 makes it almost impossible to select text from the terminal

Bug #1018538 reported by Andreas Ntaflos on 2012-06-27
78
This bug affects 17 people
Affects Status Importance Assigned to Milestone
byobu (Ubuntu)
Medium
Dustin Kirkland 

Bug Description

Using Byobu 5.20 on Ubuntu 12.04. This problem seems to only occur on Ubuntu 12.04, not on 10.04. I can't test others.

After starting a byobu instance it is nigh impossible to use the mouse cursor to do text selections from the terminal window in which byobu runs. The selection is only active for one second maximum, then it vanishes. I have created a screencast to illustrate this. See here: https://daff.ptmx.org/misc/byobu-selection.ogv

If you watch the time display in the lower right corner you can see that the selection vanishes exactly in the moment the seconds count changes.

I have tested this with the time and date display disabled, same result. I have also tested it in a plain Xterm window to make sure it is not my KDE installation that screws things up, same result. And, as I said, it only occurs on Ubuntu 12.04 servers, not 10.04.

Interestingly everything works fine and as expected when I downgrade to Byobu 5.17 from the default Precise repos. So this behaviour change happened some time between 5.17 and 5.20.

What could cause this?

Dustin Kirkland  (kirkland) wrote :

I'm unable to reproduce this. Is this byobu running locally, or over a network ssh session?

Changed in byobu (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Andreas Ntaflos (daff) wrote :

I just reproduced this again, with a byobu 5.20 running locally and a byobu 5.21 running remotely. Using both KDE's konsole as well as a regular xterm. I am running Kubuntu and thus KDE (4.8.4 at the moment), does this matter any?

Ernst Winther (ernstw) wrote :

I'm seeing something similar:

When logging in to my headless server (Ubuntu server 12.10, byobu 5.21, tmux 1.6) from my laptop (running Kubuntu 12.04.1, byobu 5.17, screen 4.00.03jw4) via SSH in Konsole 2.8.5 I get the same behavior as described by Andreas - the selection disappears when the clock is updated.

When running Byobu locally on my laptop selection works as it should and the clock updates while selecting.

When logging in to my server using my netbook (Ubuntu 10.04.4 LTS, byobu 2.68, screen 4.00.03jw4 in Gnome Terminal 2.30.2) I can mark the content in the byoby screen without any problems. I noticed that the clock stops while marking the text. It will resume as soon as I release the mouse button. Same behavior when running Byobu locally on my netbook.

Hope this helps narrowing down the problem.

jedix (howlett) wrote :

I have the same issue. To reproduce:

1. Run byobu in konsole
2. run some command with output such as dmesg
3. try and select a few lines with your mouse.

Please note that I tested this with multiple byobu windows ssh'ed out and both remote and local windows are affected with this very annoying bug.

I'm running byobu version 5.21-0ubuntu1 on kubuntu 12.10.

Changed in byobu (Ubuntu):
status: Incomplete → Confirmed
Peter Antoniac (pan1nx) wrote :

I also confirm this in 12.10 running in amazon ec2...

Philip Muškovac (yofel) wrote :

The workaround for this is using screen as byobu backend.
It would be great if someone finds out how to reliably select text using the mouse in tmux.

zekus (zekus-one) wrote :

another workaround is to disable the tmux status bar

zekus (zekus-one) wrote :

or increase the tmux status-interval to make the problem less recurrent.

Dustin Kirkland  (kirkland) wrote :

Committed revision 1993.

Changed in byobu (Ubuntu):
assignee: nobody → Dustin Kirkland (kirkland)
status: Confirmed → In Progress
status: In Progress → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package byobu - 5.23-0ubuntu1

---------------
byobu (5.23-0ubuntu1) raring; urgency=low

  [ Dustin Kirkland ]
  * configure.ac, debian/control, debian/copyright, README,
    usr/lib/byobu/rcs_cost, usr/share/man/man1/byobu.1,
    usr/share/man/man1/byobu-config.1, usr/share/man/man1/byobu-ctrl-
    a.1, usr/share/man/man1/byobu-enable.1, usr/share/man/man1/byobu-
    janitor.1, usr/share/man/man1/byobu-launcher.1,
    usr/share/man/man1/byobu-launcher-install.1,
    usr/share/man/man1/byobu-launcher-uninstall.1,
    usr/share/man/man1/byobu-layout.1, usr/share/man/man1/byobu-quiet.1,
    usr/share/man/man1/byobu-reconnect-sockets.1,
    usr/share/man/man1/byobu-screen.1, usr/share/man/man1/byobu-select-
    backend.1, usr/share/man/man1/byobu-select-profile.1,
    usr/share/man/man1/byobu-select-session.1, usr/share/man/man1/byobu-
    shell.1, usr/share/man/man1/byobu-silent.1,
    usr/share/man/man1/byobu-status.1, usr/share/man/man1/byobu-status-
    detail.1, usr/share/man/man1/byobu-tmux.1:
    - point to the new byobu.co website rather than the launchpad landing
      page
  * usr/share/byobu/profiles/common: LP: #1089008
    - re-enable shift-pgup/shift-pgdn in the terminal buffer in screen,
      to match our default in tmux
  * === added directory usr/share/byobu/pixmaps/highcontrast,
    debian/install, usr/share/byobu/pixmaps/highcontrast/byobu.svg:
    - add a byobu high contrast icon, LP: #1082241
    - simplify, removing detail
  * usr/lib/byobu/distro, usr/lib/byobu/logo: LP: #1094716
    - try to improve logo printing and distro detection on Mac
  * debian/control, debian/rules, usr/bin/byobu-config, usr/bin/byobu-
    select-session: LP: #1043048
    - get our python code pep8 compliant
      + except use tabs instead of spaces, and allow lines longer than
        80 characters
    - this should get byobu's python code working better with python3
  * debian/postrm:
    - fix lintian error

  [ Dustin Kirkland and Philip Muškovac ]
  * usr/lib/byobu/battery: LP: #1090831
    - some batteries use "CHARGE" while others use "ENERGY"

  [ Antonio Lorusso ]
  * usr/bin/byobu-status: LP: #1018538, #1073145, #1020674
    - fix select/copy/paste in iTerm2 and KDE
 -- Dustin Kirkland <email address hidden> Mon, 05 Nov 2012 13:48:13 +0100

Changed in byobu (Ubuntu):
status: Fix Committed → Fix Released
Hendy Irawan (ceefour) wrote :

Related to Bug #1020674

Hendy Irawan (ceefour) wrote :

Antonio Lorusso, Thanks for fixing this !

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers