Comment 27 for bug 1758243

zubozrout (zubozrout) wrote :

@rockorequin - I seem to be able to launch apps with primusrun setting the correct libGL path, but although apps launch that way they are actually not using Nvidia but only the integrated Intel GPU (at least I don't see any performance improvements). In the bumblebee lok I can then see the following issue:

[ERROR]Module 'nvidia' is not found.

and also this, which seems bad (strangely modprobe seems to be able to load that module just fine but the error in bumblebee is persistent even after restarting the service after modprobe passed):

[ERROR]Module 'bbswitch' not found.
[WARN]No switching method available. The dedicated card will always be on.

I am on 18.10 and so far have been completely unable to use Bumblebee with still not so old Nvidia MX150 GPU. I've tried it with all drivers starting with 390 and ending with 415. So the only solution is to is to switch gpu using prime-select which is quite unpleasant having to re-login after each switch.