GNOME Bug Report Tool missing arguments

Bug #198162 reported by Nikolaus.x on 2008-03-03
48
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bug Buddy
Won't Fix
Medium
bug-buddy (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

[Hardy alpha 5] Under Menu >> Programming there is the item "Bug Report Tool" which seems to be a useful thing for running an alpha OS. However it gives the following error when attempted to launch: "Either --appname or --package arguments are required."

This issue was also reported in: #191631 bug reporting tool gives error

Since that bug was turned into a question, I felt the need to file this one since it really is a bug to have an main OS menu item produce an error dialog and not launch at all. I have included a screen capture.

Nikolaus.x (nikolaus.x) wrote :
Sebastien Bacher (seb128) wrote :

Thank you for your bug report. The menu items is hidden in the default installation. Do you have a bug-buddy in .local/share/applications? Could you attach it to the bug?

Changed in bug-buddy:
assignee: nobody → desktop-bugs
importance: Undecided → Low
status: New → Incomplete
Nikolaus.x (nikolaus.x) wrote :

Sebastien, I am new to Ubuntu/Linux, and so don't know what a bug-buddy is, nor what you mean by .local/share/applications. If you can point me to some documentation I'd be happy to provide you with the info you need.

On Wed, 2008-03-05 at 21:41 +0000, Nikolaus.x wrote:
> Sebastien, I am new to Ubuntu/Linux, and so don't know what a bug-buddy
> is, nor what you mean by .local/share/applications. If you can point me
> to some documentation I'd be happy to provide you with the info you
> need.
>

Bug buddy is the tool that you are launching and getting an error
from.

.local/share/applications is a directory in your home directory. If
you open nautilus file manager in your home directory, and then turn
on display of hidden files you will be able to find .local. Please
then see if you have a share/applications directory in there.

Thanks,

James

Broomer68 (jbezemer) wrote :

I enabled bug buddy because it was useful before... opening launchpad with a new blank bug.

It is in .local/share/applications and there it gives the fault also.

The 'report a problem' also does not work, but does not give an error after it is 'starting'; it just vanishes after some disk-trashing

Sebastien Bacher (seb128) wrote :

the issue seems to be due to some user configuration and not a bug

Changed in bug-buddy:
status: Incomplete → Invalid
James Westby (james-w) wrote :

Hi,

If you have a problem with the "report a problem" menu item
then you should report another bug, as that is a different
tool.

Thanks,

James

Changed in bug-buddy:
status: Invalid → Confirmed

To restore the older functionality of this menu item as found in Gutsy, simply change the command of the new menu item to:

firefox https://launchpad.net/ubuntu/+filebug

This will open Firefox with the new bug window as before.

Does anyone know if it is possible to edit the main menu through the terminal? Then it would be easy to create a script to fix the link.

I've been using this feature for a long time and found it very helpful--on the theory that the Ubuntu people actually wanted to improve the software by making it easy to report bugs. Now I see that this new problem was discovered, reported, and marked to be ignored two months ago.

Excuse me, but making it easy for regular users to help you improve the software ought to be more than "low importance".

I was actually going to report a couple of very serious bugs that I can now confirm have *NOT* been fixed in Hardy. After bouncing into this bug and then struggling into Launchpad, it seems like a waste of time now, and I'm planning to blow it off, except to note:

These three bugs affect at least one model of Sharp computer, but since it's one of their standard Mebius models it probably affects many others. The most annoying old and still unfixed bug is in the network initialization. The most serious and dangerous bug is the white screen of death, which I just encountered for the first time under Hardy. (It does seem that Hardy may have lost less system information in the crash. Either that, or the new crash recovery with the scandisk works better.) The third bug is a fairly serious non-standard configuration of the HDD that impacts gparted. I do have a workaround for this one, so I should try to find that open bug report...

Sebastien Bacher (seb128) wrote :

not a very constructive comment:
- ubuntu uses apport and not bug-buggy to report bugs and apport is working correctly, so your comment about making easy to report bugs doesn't really stand there
- the bug-buddy entry is masked in the default installation because it should not be used by ubuntu users
- users who do know enough to unmask and use it should know how to send a bug on bugzilla.gnome.org
- the desktop team got around 13 000 bug mails the previous month, knowing the team has only few members that makes a lot of informations and work there
- work has to be prioritized and this one is not the only issue and really not a priority since that's not the ubuntu bug tool anyway
- you are welcome to send a patch, the code is open source and contributors are welcome

And your [Sebastien Bacher's] comment was constructive in exactly what fashion?

Since you apparently think this is some sort of debate, I'll deal with it on that basis--but be advised that I do *NOT* regard your approach as constructive and is an excellent example of why I have basically stopped recommending Ubuntu.

My primary point is best stated as: If we assume that Ubuntu is speaking the truth about wanting to reach more users, then Ubuntu should be as open as possible to bug reports from every channel--and *ESPECIALLY* from unsophisticated users.

You apparently think that users are *REALLY* stupid. They are not likely to look at the Main Menu control in the Preferences. They are not going to poke around and notice "Bug Report Tool" and think that it might be useful and therefore be smart enough to click in that little box--when in fact right now that option is not useful--it is nothing but a bug. Trying to use the "Bug Report Tool" does *NOTHING* except pop up an error window. This is *NOT* a low importance bug to people who encounter it. This is evidence that Ubuntu is going backwards from wanting to reach more users.

Gee, I could always submit the patch. That would serve you right. I actually used to make my living as a professional programmer. Unfortunately, I was one of the second stringers of the erratic type. I wrote some witty, perhaps even brilliant code--and some really ugly bugs. In my later projects I was mostly working as a maintenance programmer digging out other people's ugly bugs. During those years I worked with and for some truly first-rate programmers, people who could stream out reams of brilliant code without bugs--but I eventually realized that I'd never reach that level and I moved up and over to a supporting channel. I still work with brilliant programmers, including some people working on open source projects, but I mostly stay out of their way when it comes to doing their programming work. My employer's parent (grandparent?) company is actually regarded as one of the largest supporters of open source software--but with no involvement in Ubuntu. I sometimes discuss Ubuntu with some of those people--but I am unable to recommend that we increase our involvement with Ubuntu.

'This bug is not enabled by default' is right up there with the worst excuses I have ever heard, and I've heard lots.

Sebastien Bacher (seb128) wrote :

nobody denied that's a bug and it's still open, not sure where you have seen than ubuntu is not open to user comments, but when you have thousand of bugs open you have to prioritize the work, and a feature which is not enable by default get a lower priority, you might disagree with that but that's how things are working in most projects, you put ressources first on what your users are running the most and that's normal, the recommended ubuntu bug reporting tool is apport, having bug-buddy bugs fixed is still nice but it's just not a high priority since the tool is not the one ubuntu recommends to its users, that's not a judgement about users being stupid or not but just a tools choice

You make it sound like having thousands of bug reports is a bad thing. Unless you have extremely bug-report-diligent users or extremely bug-filled software, it implies you have tens or even hundreds of thousands of users--which ought to be a good thing. If you can't make plans to deal with and effectively manage your own success, then you're going to fail. That bothers me. Nothing personal. I don't know you from Adam. I just hate Microsoft because I love freedom--which mostly means the freedom to make meaningful and informed choices. I thought Ubuntu was a great idea when I started using it a couple of years ago, but it now seems to me that y'all are losing control of the situation, that each release is more troublesome than the last one, and that you are going to crash and burn--and give Linux a large black eye in the process.

On this particular bug, I should note that it only appears to a problem for a clean install. On a machine with an upgrade installation of 8.04 it seems to be undamaged.

Meanwhile, I have found a couple of additional problems that I should either add to existing bugs or report as new bugs. Or maybe I should offer a constructive suggestion somewhere? (The default non-BitTorrent downloads still annoys me greatly.) Maybe I could get all motivated to help out, or at least write impassioned appeals for support. Sorry, but based on this "discussion", for some reason I don't feel like making the effort on your behalf.

Sebastien Bacher (seb128) wrote :

what in my comment suggest that having users reporting bugs in not good for ubuntu? don't you think there is some exageration discussing the topic that much only because the priority is low? if that bug should be a blocker what setting would you use for system crashes for example? we need a way to prioritize issues and make the difference between applications bugs and things which make systems unusable

anyway enough of this discussion for me, you are welcome to discuss those other issues in other bugs or open new ones

Madmoose (desaad) wrote :

Hello,

All I wanted to do was report a bug, and I found myself in an episode of Jerry Springer. "Throw a chair Shanen!"

Anyway,

I too have this bug, and I always use this tool to report all the bugs I find. It would be very nice if this tool worked, so that I may use it to report any bugs I find. True, I could just make a new launcher pointing to this area. Though, I would rather the tool that was set in place work.

Thanks

Sorry, I don't live in America and I don't know who Jerry Springer is. I hope it's a comedy show, but I'm not even interested enough to run it through Wikipedia. Anyway, I admit that I am too easily annoyed sometimes.

Back on the bug itself, I was interested enough to investigate the fix reported earlier in this thread, and I can report that it works, though the description was incomplete. I did it from the Main Menu preferences, where a right click on the "Bug Report Tool" allows you to access the properties and replace the existing "bug-buddy" with the recommended command:

firefox https://launchpad.net/ubuntu/+filebug

However, the new command bug-buddy caught my interest. Looks like an interesting idea--but a command to report bugs should not in itself be buggy. Based on the error message, it apparently requires at least a package-name, but according to bug-buddy -? there are no required parameters.

<sarcasm>Gee, do you think I should open a bug on bug-buddy?</sarcasm>

Sebastien Bacher (seb128) wrote :
Changed in bug-buddy:
status: Confirmed → Triaged
Changed in bug-buddy:
status: Unknown → New
jcwinnie (jcwinnie) wrote :

Shanen, whether you live in "Merika or not, this is the Internet. Exercise your right to throw a virtual chair.

Having said that, bug-buggy went berzerk when it didn't understand a bug. Had to re-boot to stop an endless loop of saving a text message about the bug, after I had saved it once. Was unable to shut down bug-buddy. Upon re-boot Epiphany crashed when I tried to report to bugs.launchpad.net

Sir, there is a berzerk bug in the bug reporting, sir.

This occurred on current 10.4 after I selected the Preferences tab when using pychess. Rythmbox was running and Google Chrome was open

See attached text

Download full text (3.1 KiB)

I couldn't remember this discussion after a couple of years, but I was amused by the comment and depressed to see that after two (more) years things have NOT turned around. I still want alternatives to Microsoft's awful software, but the major change of the last few years is that Microsoft has apparently lost their drive to be the evil empire and Apple has taken over as the leading contender (though Google is showing increasing signs of evil ambitions and capabilities).

Comment 1: I have basically given up on Ubuntu, though I am still using OLD versions on two machines. I have experimented with later versions on several machines, and Ubuntu has become less and less ready for prime time. I managed to avoid ever buying a Vista machine, Apple has dropped out of my consideration, but I increasingly doubt any acceptable alternatives will appear before I am obliged to buy a Windows 7 box... Right now Google's Chrome looks to be the best alternative, but I feel like I've wasted a LOT of time with Ubuntu, and that casts a shadow on all of the Linux alternatives. (My company uses RHEL, which I've never managed to like. If it was actually offered as an option on a machine, I'd probably take it over Windows--but so far it has not been competitive in the real-world market.)

Comment 2: I think the REAL problem is Ubuntu's financial model doesn't provide sufficient push for regression testing against the pushes for the development of new features. The most serious problems I've encountered over the years are almost always breakage in old features. The problems with new features are annoying, but rarely show stoppers. Ergo, I suggest Ubuntu might be salvaged with an alternative funding model that supported MUCH more testing, especially boring old regression testing. Perhaps something like this:

http://eco-epistemology.blogspot.com/2009/11/economics-of-small-donors-reverse.html

In applying the model to Ubuntu's situation, I think that the project models should have substantial allocations for testing in their budgets--but the virtual shareholders would also become the highest-priority candidates to become testers. In other words, if you bought a share in a particular project, you could also volunteer as a tester at that time, and record your configuration. At that point it would be a bit of a lottery, but essentially the Ubuntu people would be picking testers to maximize coverage, and the winners would be paid for their testing work. The value paid for testing would probably be more than the cost of shares, so the winners would be happy and it would be yet another motivation to support a development project. I think the main advantage is that the projects would be buying testing from normal users--but perhaps that's because I think that the earliest users of most programs tend to be on the strange side or stranger. (The main risk might actually be a kind of gambling by people who think they have especially useful configurations for testing...)

I still want more options, and I wouldn't mind a bit if the Ubuntu people could turn things around--but I'm not worrying about it at this point, and I even resent the loss of capabilities and increasing bugginess ...

Read more...

Sebastien Bacher (seb128) wrote :

interesting that people still care about this bug reporting softwares which is not installed by default, in universe and sending crashes to a GNOME website nobody is using for some years, why not just using the default ubuntu bug reporting one? it could be Ubuntu's fault to still ship that software in universe rather than just cleaning it though

Changed in bug-buddy:
importance: Unknown → Medium
Changed in bug-buddy:
status: New → Won't Fix
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.