brltty daemon prevents creation of ttyUSB0 device link

Bug #874181 reported by Berend Dekens on 2011-10-14
92
This bug affects 16 people
Affects Status Importance Assigned to Milestone
brltty (Ubuntu)
Undecided
Unassigned
Oneiric
Undecided
Unassigned

Bug Description

Impact:
This bug is somewhat hardware specific, affecting all users of the USB serial controller, device 10c4:ea60.

Test case:
With the current version of brltty in Oneiric, brltty takes over any device using the above mentioned USB serial controller, whether it is a Braille display or not. This is because one of Brltty's supported displays uses this USB serial control internally for ocmmunication. The brltty package in oneiric-proposed has the udev rule for this controller commented out, allowing other users of devices based on this controller to work properly.

Regression potential:
All users of the supported Seika will have to load Brltty manually, as the udev rule for their device is commented out, to allow other USB serial controller users to use their device as a proper serial device.

Original description follows:

After upgrading from Ubuntu 11.04 to 11.10, I no longer found a '/dev/ttyUSB0' for my serial-to-USB converter. The device is part of a Xilinx FPGA board and is a "10c4:ea60 Cygnal Integrated Products, Inc. CP210x Composite Device".

Every time I plugged in the device, dmesg showed the device coming up and 'brltty' did *something* to it. At this point, no device was present in '/dev'.

[ 5181.130942] cp210x 1-1.4:1.0: cp210x converter detected
[ 5181.203658] usb 1-1.4: reset full speed USB device number 5 using ehci_hcd
[ 5181.296637] usb 1-1.4: cp210x converter now attached to ttyUSB0
[ 5181.623749] usb 1-1.4: usbfs: interface 0 claimed by cp210x while 'brltty' sets config #1

After removing 'brltty', the '/dev/ttyUSB0' device appears again like it used to.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: brltty (not installed)
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
Uname: Linux 3.0.0-12-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Fri Oct 14 14:39:29 2011
InstallationMedia: Ubuntu 10.10 "Maverick Meerkat" - Release amd64 (20101007)
ProcEnviron:
 LANGUAGE=
 LC_TIME=C
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: brltty
UpgradeStatus: Upgraded to oneiric on 2011-10-13 (0 days ago)

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in brltty (Ubuntu):
status: New → Confirmed
Pascal de Bruijn (pmjdebruijn) wrote :

http://shop.myavr.com/index.php?sp=article.sp.php&artID=200006

This device uses the same chipset, and subsequently has the same problem.

Matthew Geier (matthew-sleeper) wrote :

Removing the brltty daemon fixes this. Unless you really do use a Braille tty of course.

If the software actually finds a Braille tty to talk to, it may then leave other usb tty devices alone. not being a Braille user I couldn't say.

Berend Dekens, le Fri 14 Oct 2011 12:45:29 -0000, a écrit :
> After upgrading from Ubuntu 11.04 to 11.10, I no longer found a
> '/dev/ttyUSB0' for my serial-to-USB converter. The device is part of a
> Xilinx FPGA board and is a "10c4:ea60 Cygnal Integrated Products, Inc.
> CP210x Composite Device".

Grmbl. This is yet another case of
https://bugs.launchpad.net/ubuntu/+source/brltty/+bug/153662
https://bugs.launchpad.net/ubuntu/+source/hal/+bug/175182
and similar. Yes, the "fix" is to remove brltty. As I explained in
153662, it's hard for blind people do debug why their braille device
doesn't work since it's that precise braille device which allows them to
access the machine...

Luke, you need to comment that entry from the udev rules file too.

BTW, I see that you have commented the 0401:6001 entry from the udeb
version of the udev rules too. I don't think it's really necessary:
will really people use a usb-to-serial converter to install Ubuntu
nowadays? While people using Seika or some HandyTech devices do need to
install Ubuntu with them.

Samuel

Christian Weiske (cweiske) wrote :

Same problem here with an ELV USB-WDE1 weather data receiver.

Christian Weiske, le Sun 16 Oct 2011 09:09:15 -0000, a écrit :
> Same problem here with an ELV USB-WDE1 weather data receiver.

What is its USB ID?

Samuel

Harry Bloomberg (hbloomb) wrote :

I'm seeing the exact same thing with an Icom IC-7200 amateur radio tranceiver. Removing brltty resolved the problem, but I really think the default configuration should be to not run brltty. This took me quite a while to resolve after an upgrade from 11.04. I even did a clean reinstall of 11.10 thinking that maybe something went wrong with the upgrade.

Harry Bloomberg, le Sat 22 Oct 2011 01:09:47 -0000, a écrit :
> I'm seeing the exact same thing with an Icom IC-7200 amateur radio
> tranceiver.

What is the USB ID of that device?

Samuel

Harry Bloomberg (hbloomb) wrote :

I think it's usb 2. I'm not a Linux developer, so below is part of the kernel log showing the problem.

Oct 21 19:59:29 hpb-Latitude-2120 kernel: [ 2340.040136] usb 2-1: new full speed
USB device number 12 using uhci_hcd
Oct 21 19:59:29 hpb-Latitude-2120 kernel: [ 2340.193734] hub 2-1:1.0: USB hub
found
Oct 21 19:59:29 hpb-Latitude-2120 kernel: [ 2340.195488] hub 2-1:1.0: 2 ports
detected
Oct 21 19:59:29 hpb-Latitude-2120 kernel: [ 2340.489457] usb 2-1.1: new full
speed USB device number 13 using uhci_hcd
Oct 21 19:59:30 hpb-Latitude-2120 kernel: [ 2340.826696] input: Burr-Brown from
TI USB Audio CODEC as
/devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1:1.3/input/input18
Oct 21 19:59:30 hpb-Latitude-2120 kernel: [ 2340.827062] generic-usb
0003:08BB:2901.0009: input,hidraw2: USB HID v1.00 Device [Burr-Brown from TI
USB Audio CODEC ] on usb-0000:00:1d.0-1.1/input3
Oct 21 19:59:30 hpb-Latitude-2120 kernel: [ 2340.901453] usb 2-1.2: new full
speed USB device number 14 using uhci_hcd
Oct 21 19:59:30 hpb-Latitude-2120 kernel: [ 2341.047932] cp210x 2-1.2:1.0:
cp210x converter detected
Oct 21 19:59:30 hpb-Latitude-2120 kernel: [ 2341.121456] usb 2-1.2: reset full
speed USB device number 14 using uhci_hcd
Oct 21 19:59:30 hpb-Latitude-2120 kernel: [ 2341.246793] usb 2-1.2: cp210x
converter now attached to ttyUSB0
Oct 21 19:59:32 hpb-Latitude-2120 kernel: [ 2342.858163] usb 2-1.2: usbfs:
interface 0 claimed by cp210x while 'brltty' sets config #1
Oct 21 19:59:32 hpb-Latitude-2120 kernel: [ 2342.861068] cp210x ttyUSB0: cp210x
converter now disconnected from ttyUSB0
Oct 21 19:59:32 hpb-Latitude-2120 kernel: [ 2342.861134] cp210x 2-1.2:1.0:
device disconnected

Harry Bloomberg (hbloomb) wrote :

If it will help...the USB device from the ham radio serves two purposes:

1) Audio input and output. There was no problem with this.
2) Control of the radio through commands sent through the USB port. This was not working until I uninstalled brltty.

Harry Bloomberg, le Sat 22 Oct 2011 18:00:13 -0000, a écrit :
> I think it's usb 2.

I mean the output of lsusb, e.g.

Bus 002 Device 008: ID 046d:c050 Logitech, Inc. RX 250 Optical Mouse

my mouse has USB ID 046d:c050.

Samuel

Harry Bloomberg (hbloomb) wrote :

Here's the output of my system's lsusb:

hpb@hpb-Latitude-2120:~$ lsusb
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 003 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 004 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 005 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
Bus 002 Device 002: ID 046d:c52f Logitech, Inc. Wireless Mouse M305
Bus 003 Device 003: ID 0424:2502 Standard Microsystems Corp.
Bus 003 Device 004: ID 08bb:2901 Texas Instruments Japan PCM2901 Audio Codec
Bus 003 Device 005: ID 10c4:ea60 Cygnal Integrated Products, Inc. CP210x Composite Device

This is a Dell Latitude 2120 netbook.

Harry Bloomberg, le Mon 24 Oct 2011 01:21:32 -0000, a écrit :
> Bus 003 Device 005: ID 10c4:ea60 Cygnal Integrated Products, Inc. CP210x Composite Device

Ok, it's indeed the same.

Samuel

ironfisher (dgvalde) wrote :

This is solved by uninstalling "brltty" as posted in this question (https://answers.launchpad.net/ubuntu/+question/5503) So, you should do this:

sudo apt-get uninstall brltty

This problem is happening again in Ubuntu 11.10 with Xilinx ML605 developtment board.

Something must be done because this is not normal. It's really annoying having to figure out what the problem is every time you use a USB UART device. And even more annoying to find the problem and find this solution.

I took me about 4 hours to find and solve this problem, even I am related to computers, Ubuntu and Linux. Imagine how annoying it is for anyone not related to linux and how many devices using UART through USB there are.

Let's deactivate BRLTTY default or contact with BRLTTY developers to not claim the USB interface by default.

ironfisher, le Tue 08 Nov 2011 18:12:59 -0000, a écrit :
> Let's deactivate BRLTTY default

Please don't do that. It'd make way harder for blind people to use
Ubuntu.

> or contact with BRLTTY developers to not claim the USB interface by
> default.

That is already what I proposed: comment the entry in the udev rule
file, just like is already done for some of the handytech devices.

Samuel

>> Let's deactivate BRLTTY default

>Please don't do that. It'd make way harder for blind people to use Ubuntu.

 But at the moment it's causing a much larger population of people have their USB serial devices stop working for no apparent reason. And many devices are implemented by USB serial interfaces, some people are quite likely to have - GPS devices for example.

 brltty should only claim the USB serial interfaces used by Braille teletypes - although having been exposed briefly to this technology (supporting a blind staff member), I can imagine many are just 'write only' serial devices and thus undetectable. The modern ones probably use the SAME usb to serial chips that other non Braille devices also use, interfaced to the older 'write only' back end.

 As it stands, a much larger population are finding their GPS logger doesn't work, their 'ICE debugger' doesn't work, their home automation interface doesn't work, etc, etc.
 There are a truck load of USB devices out there that are implemented via a USB-serial bridge chip.

 The only compromise I can see is to use brltty during the install process so a blind user can install and throw up a question asking 'do you need Braille tty support ?' and hope most sensible sighted people will say no.

ironfisher (dgvalde) wrote :

Samuel thibault (samuel-thibault) wrote:
>That is already what I proposed: comment the entry in the udev rule
>file, just like is already done for some of the handytech devices.

This error has been going on for years.

Any solution is fine if this error does not happen again. I do not want more people to waste their time solving this problem.
Let us make Ubuntu easier to use. It has no sense the need to uninstall a software for blind people in order to use the USB as an UART. It sounds completely stupid.

This issue should be solved for next release. So, you can use either "brltty" or your default software to comunicate with your device through /dev/ttyUSB

Thanks.

Luke Yelavich (themuso) on 2011-11-09
description: updated
Hazuki Amamiya (quofei) wrote :

I wasted over a week's time to find out why my LCD display not working properly before I get to here. I's say the brltty is too aggressive and since brltty has no intention to fix this problem (this issue repeat and repeat and repeat again for past few years!) so I agree that brltty should be disable by default. I understand that the people with visual impairment might find it difficult to use Ubuntu by disabling brltty by default, but which group has more population? The normal user or the blind people? For the people with visual impairment they can call the assistance right away, but how about us!? I spent a week! Yes, a week! And how about the GPS device company? I can imagine they are frustrated by this problem and probably might want to tell the customer that Ubuntu is not a good OS for use with GPS.

Hazuki Amamiya, le Wed 09 Nov 2011 01:20:22 -0000, a écrit :
> I wasted over a week's time to find out why my LCD display not working
> properly before I get to here. I's say the brltty is too aggressive and
> since brltty has no intention to fix this problem (this issue repeat and
> repeat and repeat again for past few years!)

brltty is no culprit at all. There is just no way for us to know whether
braille manufacturer sanely label their USB device with a unique USB ID.
It's only when people report conflict that we can know about it, and
disable it, which is what Luke has just done. "brltty has no intention
to fix this problem" is thus just FUD.

> so I agree that brltty should be disable by default.

Simply, no. It may have taken you a week to solve the issue, but for
blind people it's eternity that would take them to manage to use their
computer without brltty.

> I understand that the people with visual
> impairment might find it difficult to use Ubuntu by disabling brltty by
> default, but which group has more population?

Please don't just count oranges & apples.

> For the people with visual impairment they can call the
> assistance right away,

Simply, no. There's not always somebody that is able to make sense of
what is displayed on the screen.

> but how about us!? I spent a week! Yes, a week!

And blind people would spend way more time.

> And how about the GPS device company? I can imagine they are frustrated
> by this problem and probably might want to tell the customer that Ubuntu
> is not a good OS for use with GPS.

They should simply have *tested* ubuntu before its release, so that the
bug would have been spotted earlier, and fixed *before* the release.

Samuel

Harry Bloomberg (hbloomb) wrote :

I too wasted a week of my finite life chasing after this. I know of no other operating system in widespread usage that comes configured by default like this. I'm already not very happy with Ubuntu over Unity, this does not help my opinion of the distribution. I'm also trying to convince other amateur operators to use Linux and this issue is a real stumbling block. With issues like this, is it any wonder most of them are using some variant of Windows?

I think a worthwhile compromise would be a sub-distribution of Ubuntu aimed specifically at the sightless accompanied with an easy-to-follow document on how to make mainstream Ubuntu usable for the sightless.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brltty - 4.3-1ubuntu2

---------------
brltty (4.3-1ubuntu2) precise; urgency=low

  * Comment out the udev rule line for device 10c4:ea60, as it is a generic
    USB serial controller used by many other pieces of hardware (LP: #874181)
 -- Luke Yelavich <email address hidden> Wed, 09 Nov 2011 14:38:55 +1100

Changed in brltty (Ubuntu):
status: Confirmed → Fix Released

Harry Bloomberg, le Wed 09 Nov 2011 03:56:09 -0000, a écrit :
> I too wasted a week of my finite life chasing after this. I know of no
> other operating system in widespread usage that comes configured by
> default like this.

Yes, and that's a shame. There is no reason why a braille device
shouldn't be recognized automatically by an operating system, just like
the VGA screen, a USB key, etc.

Of course, I *don't* mean that in the case where there is a USB ID
conflict brltty should be triggered. Luke has just commited the change
to fix that in the current case.

But it's not because there are some conflicts sometimes that the whole
thing should be dropped!! People should just test Ubuntu before it gets
released, to fix such bugs.

> I think a worthwhile compromise would be a sub-distribution of Ubuntu
> aimed specifically at the sightless accompanied with an easy-to-follow
> document on how to make mainstream Ubuntu usable for the sightless.

No, no, and again, no. That has been done for years, and no, it does not
work on the long term.

Samuel

ironfisher (dgvalde) wrote :

I mailed the developer of "brltty" about this bug and he has proposed the next solution:

Dave Mielke <email address hidden> wrote:
>Strictly speaking, yes, brltty is causing the problem. An easy solution,
>though, would be for Ubuntu to give brltty's udev file an earlier position in
>the udev rules file processing order so that the generic rule will take
>precedence. Then there'd only be a conflict if a brltty user also has one of
>those other devices. That could happen, of course, but it'd be far less common
>than all users being impacted by the current problem.

Anyway thank you all for fixing this bug. Love this community.

ironfisher, le Wed 09 Nov 2011 13:11:06 -0000, a écrit :
> Dave Mielke <email address hidden> wrote:
> >Strictly speaking, yes, brltty is causing the problem. An easy solution,
> >though, would be for Ubuntu to give brltty's udev file an earlier position in
> >the udev rules file processing order so that the generic rule will take
> >precedence.

Err, precedence, really? Won't that let brltty still start?

Samuel

tags: added: a11y

Hello Berend, or anyone else affected,

Accepted brltty into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in brltty (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed

Dave Mielke, le Wed 09 Nov 2011 10:44:57 -0500, a écrit :
> I wonder if there's a way to figure out which serial device is associated with
> a given USB device.

I believe so: I've just plugged a converter:

[161835.668469] usb 2-1.1.1: new full speed USB device number 9 using ehci_hcd
[161835.765607] usb 2-1.1.1: New USB device found, idVendor=0403, idProduct=6001
[161835.765612] usb 2-1.1.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[161835.765616] usb 2-1.1.1: Product: USB SERIAL CONVERTER
[161835.765618] usb 2-1.1.1: Manufacturer: FTDI
[161835.765621] usb 2-1.1.1: SerialNumber: ftCEGJTT
[161835.893841] usbcore: registered new interface driver usbserial
[161835.893866] USB Serial support registered for generic
[161835.893926] usbcore: registered new interface driver usbserial_generic
[161835.893928] usbserial: USB Serial Driver core
[161835.899462] USB Serial support registered for FTDI USB Serial Device
[161835.899774] ftdi_sio 2-1.1.1:1.0: FTDI USB Serial Device converter detected
[161835.899813] usb 2-1.1.1: Detected FT232BM
[161835.899815] usb 2-1.1.1: Number of endpoints 2
[161835.899818] usb 2-1.1.1: Endpoint 1 MaxPacketSize 64
[161835.899821] usb 2-1.1.1: Endpoint 2 MaxPacketSize 64
[161835.899823] usb 2-1.1.1: Setting MaxPacketSize 64
[161835.900162] usb 2-1.1.1: FTDI USB Serial Device converter now attached to ttyUSB0
[161835.900178] usbcore: registered new interface driver ftdi_sio
[161835.900181] ftdi_sio: v1.6.0:USB FTDI Serial Converters Driver

and there is a /sys/bus/usb/devices/2-1.1.1/2-1.1.1:1.0/ttyUSB0
directory. Conversely, /sys/dev/char/188:0 is a symlink to
../../devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1.1/2-1.1.1:1.0/ttyUSB0/tty/ttyUSB0/

> If so, perhaps brltty could make that translation and then
> automatically switch to sertal I/O using the device.

That however will still let brltty emit some characters to the device,
which can probably upset it.

> I don't have a USB to serial adapter here to check. Maybe I should
> just go spend some money and get one.

That's a useful thing to have under hand anyway :)

Samuel

Dave Mielke, le Wed 09 Nov 2011 10:06:24 -0500, a écrit :
> [quoted lines by Samuel Thibault on 2011/11/09 at 15:14 +0100]
>
> >Err, precedence, really? Won't that let brltty still start?
>
> Sure. It'd only be a problem for that one particular model of braille device.
> In that particular case, users could still manually start brltty, in which case
> it'd still claim the device.

Err, there must be a misunderstanding.

I was suggesting that the solution you propose will actually *not*
prevent brltty from starting, since the brltty udev rules will still set
RUN, and I don't think the generic rule for serial ports will clear it.

Samuel

Dave Mielke, le Mon 14 Nov 2011 09:38:57 -0500, a écrit :
> I'm going to try to figure out if we can get to the virtual serial device from
> knowledge of which USB device is being used. If we can, that should solve the
> problem. If anyone already knows how to do it, please let me know.

Mmm, didn't you receive my mail dated
Date: Sat, 12 Nov 2011 17:13:21 +0100
?


there is a /sys/bus/usb/devices/2-1.1.1/2-1.1.1:1.0/ttyUSB0
directory. Conversely, /sys/dev/char/188:0 is a symlink to
../../devices/pci0000:00/0000:00:1d.0/usb2/2-1/2-1.1/2-1.1.1/2-1.1.1:1.0/ttyUSB0/tty/ttyUSB0/


That however will still let brltty emit some characters to the device,
which can probably upset it.

and the latter is probably already a very bad thing for whatever device
is connected to the serial converter.

Samuel

Olivier Brousse (obrousse) wrote :

I have the same problem with an avnet development board based on cp210x. brltty disconnected my board form ttyUSBx until I removed this package.

I hope that there will be a solution to make brltty only select the appropriated device and not all cp210x based one. So I wonder if in brltty there may be a filter on cp210x that must be modified to only grab the good devices.

Olivier Brousse (obrousse) wrote :

I forgot to mention my USB device ID:
ID 10c4:ea60 Cygnal Integrated Products, Inc. CP210x Composite Device

Regards.

Luke Yelavich (themuso) wrote :

For those experiencing this bug, please read Martin Pitt's post on how you can test the proposed fix in oneiric-proposed. The sooner its tested, teh sooner we can release the fix for everyone.

Hazuki Amamiya (quofei) wrote :

The problems is I already fixed the problem by removing brltty and there is no sense on install it back to my production server as it's not a key package. Probably those people who read this post with brltty uninstalled feeling the same. Yet, hopefully some guys with a development server with the said device installed can test it.

Marius B. Kotsbak (mariusko) wrote :

I enabled proposed and installed just the brltty package, but then its init script does not seem to work. Are there any other dependencies in proposed? Else the fix does not seem to work.

Luke Yelavich (themuso) wrote :

Brltty doesn't run, unless either it is enabled in /etc/default/brltty, or udev finds a device that is supposedly a Braille display, which is what this bug is about. Unless you have USB hardware that uses the vendor and product IDs given in the bug description, then there is no point in testing the brltty package in oneiric-proposed.

Marius B. Kotsbak (mariusko) wrote :

I reproduced the bug, probably because of having a USB-serial converter connected, but could not reproduce the fix.

Jonas Norling (norling) wrote :

Re #25:
I tested the updated brltty package with Ubuntu 11.10 and a cp210x converter (USB id 10c4:ea60).
*It works fine for me now.*

Test procedure:
* Installed brltty (I had removed it as a workaround for this bug)
* Verified that the bug was still there
* Enabled oneiric-proposed
* "sudo apt-get update; sudo apt-get install brltty" (it installed version 4.2-8ubuntu5.1)
* Rebooted
* Plugged in the USB device. Syslog no longer indicates any ambitions from brltty to bind to the device. There is now a /dev/ttyUSB0 device node.

Luke Yelavich (themuso) on 2011-11-21
tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brltty - 4.2-8ubuntu5.1

---------------
brltty (4.2-8ubuntu5.1) oneiric-proposed; urgency=low

  * Comment out the udev rule line for device 10c4:ea60, as it is a generic
    USB serial controller used by many other pieces of hardware (LP: #874181)
 -- Luke Yelavich <email address hidden> Wed, 09 Nov 2011 14:36:27 +1100

Changed in brltty (Ubuntu Oneiric):
status: Fix Committed → Fix Released
Lasakro (lasakro) wrote :

After upgrading from 16.04 to 16.10 I'm now seeing this issue. Removing brltty was a fix for my system. Below were the results before removing brltty:

:~/Desktop$ dmesg | grep tty
[ 0.000000] console [tty0] enabled
[ 1.222490] 00:06: ttyS0 at I/O 0x3f8 (irq = 4, base_baud = 115200) is a 16550A
[ 5.862329] usb 4-3: cp210x converter now attached to ttyUSB0
[ 8.030587] usb 4-3: usbfs: interface 0 claimed by cp210x while 'brltty' sets config #1
[ 8.032694] cp210x ttyUSB0: cp210x converter now disconnected from ttyUSB0
[ 804.989176] usb 5-5: usbfs: USBDEVFS_CONTROL failed cmd brltty rqt 128 rq 6 len 255 ret -62

stu (stuartwesterman) wrote :

Can confirm 17.10 has this issue. Removing brltty was a fix for my system as well.

lasakro, stu: which USB ID does your device have?
(otherwise we can't know what to fix in brltty)

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers