Brasero keeps on asking for libdvdcss.so.2

Bug #611590 reported by Jaap-Willem Dooge on 2010-07-30
70
This bug affects 15 people
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: brasero

I added the medibuntu sources and installed the libdvdcss2 package.

Output of locate:
doogej@WVUN002:/$ sudo locate libdvdcss
/home/doogej/VMShared/brasero_libdvdcss.png
/usr/lib/libdvdcss.so.2
/usr/lib/libdvdcss.so.2.1.0
/usr/share/app-install/desktop/libdvdcss.desktop
/usr/share/doc/libdvdcss2
/usr/share/doc/libdvdcss2/NEWS.gz
/usr/share/doc/libdvdcss2/README
/usr/share/doc/libdvdcss2/changelog.Debian.gz
/usr/share/doc/libdvdcss2/changelog.gz
/usr/share/doc/libdvdcss2/copyright
/var/cache/apt/archives/libdvdcss2_1.2.10-0.3medibuntu1_amd64.deb
/var/lib/dpkg/info/libdvdcss2.list
/var/lib/dpkg/info/libdvdcss2.md5sums
/var/lib/dpkg/info/libdvdcss2.postinst
/var/lib/dpkg/info/libdvdcss2.postrm
/var/lib/dpkg/info/libdvdcss2.shlibs

Too bad Brasero keeps on 'whining' about missing this file.

Jaap-Willem Dooge (japydooge) wrote :
Jaap-Willem Dooge (japydooge) wrote :

Btw, i did find https://bugs.launchpad.net/ubuntu/+source/brasero/+bug/134828 but that should be fixed.

On my system, starting Brasero and then using the Copy Disc function works. However, using the right-click Copy Disc... option from the CD's context menu in GNOME doesn't.

Relevant information:

$ apt-cache policy libdvdcss2
libdvdcss2:
  Installed: 1.2.10-0.3medibuntu1
  Candidate: 1.2.10-0.3medibuntu1
  Version table:
 *** 1.2.10-0.3medibuntu1 0
        100 /var/lib/dpkg/status

$ whereis libdvdcss.so.2
libdvdcss.so: /usr/lib/libdvdcss.so.2

Error message:

* All required applications and libraries are not installed. *
Please install the following manually and try again:
libdvdcss.so.2 (library).

Jaap-Willem Dooge (japydooge) wrote :

I had the problem when copying a DVD with documentation (no video) of some software package to an .iso file.

Some more information from my side:
doogej@WVUN002:~$ apt-cache policy libdvdcss2
libdvdcss2:
  Installed: 1.2.10-0.3medibuntu1
  Candidate: 1.2.10-0.3medibuntu1
  Version table:
 *** 1.2.10-0.3medibuntu1 0
        500 http://packages.medibuntu.org/ lucid/free Packages
        100 /var/lib/dpkg/status
doogej@WVUN002:~$ whereis libdvdcss.so.2
libdvdcss.so: /usr/lib/libdvdcss.so.2 /usr/lib64/libdvdcss.so.2

Walter K (walter-korvemaker) wrote :

Try: (This step should not be needed if Ubuntu is up to date)

sudo apt-get install libdvdread4

Then:

sudo /usr/share/doc/libdvdread4/install-css.sh

Worked for me, hope this helps others.

Walter

TonyR (rooneyo) wrote :

Hi

This worked for me even though the 1st command returned the notice that I had already got libdvdread4 installed.

I ran the 2nd command regardless and was able to copy DVD without error after this.

Thanks for the useful tip Walter, most appreciated.

Regards

Anthony

Luke Schlather (luke2760) wrote :

Seems related to this question:

https://answers.launchpad.net/ubuntu/+source/brasero/+question/67154

Walter's workaround netted me "Error reading video DVD (fatal error in vts css key)"

Walter K (walter-korvemaker) wrote :

Not sure if this is similar, but shawnboy might be onto something here...

http://ubuntuforums.org/showthread.php?t=1440147&page=2

tekn1x (ac.mack) wrote :

Many Thanks Walter - the script you gave worked for me!!

Cheers,
AC

heian (heian12) wrote :

Thanks from me too, Walter.

Couldn't make an image of my dvd, but your solution
works very well !

Regards,
heian

sudo /usr/share/doc/libdvdread4/install-css.sh worked for me
thanks walter
:)

Alan Johnson (nilgiri) wrote :

Walter's fix worked for me to, but had to reboot first. Maybe a log-out-and-back-in was all that was needed, but I rebooted.

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. The issue that you reported is one that should be reproducible with the live environment of the Desktop CD of the development release - Oneiric Ocelot. It would help us greatly if you could test with it so we can work on getting it fixed in the next release of Ubuntu. You can find out more about the development release at http://www.ubuntu.com/testing/ . Thanks again and we appreciate your help.

Changed in brasero (Ubuntu):
importance: Undecided → Low
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in brasero (Ubuntu):
status: Incomplete → Expired

I can confirm that the error still exists in 11.10, and the commands at https://bugs.launchpad.net/ubuntu/+source/brasero/+bug/611590/comments/5 correct the problem

Changed in brasero (Ubuntu):
status: Expired → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in brasero (Ubuntu):
status: New → Confirmed
Gabriel Mazetto (brodock) wrote :

This error still exists in Ubuntu 12.04. Is it too dificult to download the dpkg file and install it by hand automatically?

The5thHorseman (rickccna-d) wrote :

Walter's solution (#5) solved this problem on my system as well. Thank you Walter...

Jeremy Bicha (jbicha) wrote :

Ubuntu doesn't support Medibuntu.

I believe the "not really official but vaguely recommended" way to install libdvdcss is to basically do what comment #5 says. See also https://help.ubuntu.com/lts/ubuntu-help/video-dvd-restricted.html

Changed in brasero (Ubuntu):
status: Confirmed → Invalid
Phillip Pether (roofox) wrote :

libdvdcss2 is nowhere to be found at all.

$ apt-cache policy libdvdcss2
libdvdcss2:
Installed: (none)
Candidate: (none)
Version table:

libdvdcss.so:

Nowhere.... I have all the packages installed that are suppose to use it, but it's not anywhere. It's gone. Brasero should of had that package in it. Heck... even VLC doesn't even have it, and I can't even play any DVD's from other regions without it. Where is the package and why is it missing from all the other packages I've tried installing? ubuntu-restricted-extras didn't even have it at all.

Changed in brasero (Ubuntu):
status: Invalid → Confirmed
quequotion (quequotion) wrote :

I have another solution for you.

Like most of you I had libdvdcss installed but brasero refused to recognize it.

It turns out brasero expects a somewhat specifc, outdated version of libdvdcss (possibly 1.2.0).

I patched brasero to ignore the version of libdvdcss:

http://pastie.org/10227736

This makes it possible to use brasero with newer versions of libdvdcss (or any version).

Alister Hood (alister-hood) wrote :

That pastie link doesn't work.

I'm seeing the same problem in ubuntu 14.04.

my (hopefully temporary) solution is to run brasero from the commandline like so:

LD_PRELOAD=/usr/lib/libdvdcss.so.2.1.0 brasero

quequotion (quequotion) wrote :

>Alister Hood

Yes it does.

Followup to my #23, I traced:

strace -e open brasero 2>&1 | grep libdvdcss

and found that I had a copy of libdvdcss.so in /usr/local/lib

After removing this, it finds the library in /usr/lib, and I no longer experience this problem.

J@n (6-launchpad-niftie-nl) wrote :

Tried to rip one of my (owned) dvd's today but got the libdvdcss erroe.

This:

Then:

sudo /usr/share/doc/libdvdread4/install-css.sh

Worked for me, hope this helps others.

Solved my problem so:
 Kudos to https://launchpad.net/~walter-korvemaker :)

Phillip Beynon (phillipbeynon) wrote :

This is a version issue. When you install from the ubuntu repository you receive a very old copy which does not know where to find the library, upgrade to the newest version and you'll be fine. http://www.ubuntuupdates.org/package/core/xenial/universe/updates/brasero

quequotion (quequotion) wrote :

Bringing in bug 1577268 as a duplicate (reported six years later than this one).

Either my idea caught on or someone came to the same conclusion independently; the patch resolving this in xenial's version removes the version check completely (rather than just commenting it out). Not sure what's keeping the brasero devs from implementing it upstream.

https://github.com/GNOME/brasero/pull/3

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers