Broken libdvdcss support, patch included

Bug #134828 reported by Conn O Griofa on 2007-08-26
2
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)
Low
Lionel Le Folgoc

Bug Description

Binary package hint: brasero

By default, brasero tries to access /usr/lib/libdvdcss.so to enable reading of encrypted DVDs, but most users' systems will not have this file (or symlink) present even when the libdvdcss2 package is installed. For example, the contents of libdvdcss2 from the medibuntu repository:

root@inspiron:~/work# dpkg -L libdvdcss2 | grep /usr/lib
/usr/lib
/usr/lib/libdvdcss.so.2.0.8
/usr/lib/libdvdcss.so.2

Steps to reproduce:
1. Install libdvdcss2 package (requires medibuntu repositories or manual download from videolan.org site)
2. Insert an encrypted DVD, open brasero and choose "Disc copy"

Expected results:
1. Disc begins copying

Actual results:
1. Error message displays: "encrypted DVD: please install libdvdcss version 1.2.x"

Other applications (e.g. totem. vlc, mplayer) seem content to access libdvdcss.so.2, so I believe it's better to patch brasero rather than repackaging libdvdcss2 with another symlink - for the sake of consistency. I'm attaching the proposed patch against brasero 0.6.0 that fixes the issue on my system. I also checked version 0.6.1 and it will require this patch too.

Conn O Griofa (psyke83) wrote :

Here's a quick build including the proposed fix if anybody wants to confirm.

Lionel Le Folgoc (mrpouit) wrote :

Thanks for the patch, I'll add it to the next upload.

Changed in brasero:
assignee: nobody → mrpouit
importance: Undecided → Low
status: New → In Progress
Lionel Le Folgoc (mrpouit) wrote :

brasero (0.6.1-0ubuntu1) gutsy; urgency=low

  * New upstream release, UVFe granted. (LP: #133742)
  * Upstream changes:
    - Fixed the filter crasher UI.
    - Fix scsi library bug with memset with swapped arguments bug #466290.
    - Workaround the main window bug #459939.
    - Fixed a small bug where closed rewritable discs with data were flagged
      as not writable
    - Don't run update-desktop-database if we're installing in a not full
      system.
    - Added complete support for cdrkit bug #456860.
    - Removed DISABLE_DEPRECATED from the Makefile to avoid problems with
      Gtk+ API.
    - Fix 2 sec between tracks on audiocd bug #459023.
    - Added more mimetype to file chooser filter.
    - Added support for libisofs 0.2.8 but it requires at minimum 0.2.4
      version.
  * debian/patches/
    - 000_cdrtools2cdrkit.patch, 003_dont-run-update-desktop-database.patch:
      dropped, included upstream
    - 006-fix-libdvdcss.patch: fix broken libdvdcss runtime detection. (LP: #134828)
    - series: updated.

 -- Lionel Le Folgoc <email address hidden> Fri, 31 Aug 2007 20:53:36 +0200

Changed in brasero:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers