Brasero disk burner won't get past "Preparing to write."

Bug #486960 reported by Stephen on 2009-11-23
62
This bug affects 13 people
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: brasero

I recently updated Ubuntu and now when I try to burn CDs using Brasero the process gets stuck at the first stage, "Preparing to write." I left it there for a couple hours and it never moved on.
I am running Ubuntu 9.10
Brasero 2.28.2

ProblemType: Bug
Architecture: i386
Date: Sun Nov 22 22:35:08 2009
DistroRelease: Ubuntu 9.10
ExecutablePath: /usr/bin/brasero
Package: brasero 2.28.2-0ubuntu1
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
SourcePackage: brasero
Uname: Linux 2.6.31-14-generic i686

Stephen (stephen-wilfong) wrote :
Steve McGrath (smcgrath23) wrote :

I just had this very same thing happen to me. I'm not sure if you're having the same issue or not, but here's what happened in my case:

Earlier, I had ejected a CD via the eject button, not through the UI.
The CD remained mounted, and still showed up in the Nautilus sidebar.
I tried to burn an Ubuntu disc and got exactly the result you're describing here.
As soon as I unmounted the phantom CD, I was able to burn again.

Check and see if you still have a CD filesystem mounted, it'll show in the nautilus sidebar. If not, then you're having a different issue and we'll go from there.

Changed in brasero (Ubuntu):
status: New → Incomplete
Stephen (stephen-wilfong) wrote :

Nope, no phantom disk, that would make sense though. Anyway, it must be something else.

Changed in brasero (Ubuntu):
importance: Undecided → Low
baba (babaji) wrote :

Just happened to me also.... decided to run Brasero from terminal as root, worked great!, could be a p[permissions issue?

Brandon (bradshaw) wrote :

I was able to resolve this issue by unmounting the media with the CD still in the drive. I then ejected the CD from the CD ROM drive, then reinserted the media into the CD ROM and closed it.

It mounted the black disk and I was able to burn as usual. Hope this helps!

Doug Bradshaw
Carson Rose & Associates, Inc.

Koen Beek (koen-beek) wrote :

Also had this problem on Karmic.
First burn a DVD, no problem
Then tried to burn a CD and cancelled and tried again and cancelled and after minutes Brasero was still preparing to burn
launching brasero from terminal as root solved the problem

I also have this problem in 9.10 with Brasero 2.28.2.

I inserted a blank CD-R into my drive, right-clicked on an ubuntu iso image, and clicked "write to disc". The "Brasero - Burning CD" dialog then appears, and hangs at "Preparing to write" with the progress bar bouncing back and forth.

Kalisto (marcford) wrote :

I can confirm this bug, on 2.6.31-17-generic #54-Ubuntu Karmic

With Brasero version: 2.28.2

Workaround: launch brasero from console as root.

ramorrismorris (morris-bob) wrote :

Ditto Kalisto as to problem, kernel, distro, Brasero and workaround.
Hardware is Dell Inspiron 530n.

Damus (kevin-fling) wrote :

I was having the same issue here with both Jaunty and Karmic -- I read the replies here and it turned out my LG DVD-RW drive has a second filesystem that mounts called "Bluebird" which I assume contains setup information from the manufacturer for the drive. After I unmounted that, Brasero burned the ISO just fine.

gjlopeman (gjlopeman) wrote :

Karmic Koala same issue , running as root took care of it.

jglenn (jglenn-uga) wrote :

Just wanted to say that I ran into the same thing under 9.10 using Brasero 2.28.2. Running as root resolved the issue.

Doug (doug-m) wrote :

I had same issue. Mine was a phantom DVD that was removed but not unmounted.
Ubuntu 9.10 x64

Would be nice if Brasero check permissions (for the root issue) and check for conflicting filesystems (phantom mounted image).
Then it could either fix the issue or at least warn people to check these things.

Marty Vowles (mvowles311) wrote :

I think that some of the people affected, myself included, might have issues with this due to Bug #448921. It is a bug where DVD discs aren't always unmounted when they are ejected. My issue was that I still had a disc "mounted" in the drive, along with the mount for the blank disc. All I had to to was what Steve McGrath suggested and unmount the phantom disc.

Rogerborg (rogerborg) wrote :

Same issue for me on 9.10, running brasero as root solved it. I couldn't see any phantom mount.

dei (cephos) wrote :

Can confirm it too on current karmic. Think was related to Bug #448921 too. It showed 3.5 MB free on the empty 700MB disk.
thx Brandon for the workaround worked for me.

wizodd (wizodd-gmail) wrote :

I think that Marty (#14) is right in my case.

And it seems to be related to the bug which prevents ejection after burning, in that when that happens I often have to resort to the paperclip to eject, which then leaves the image mounted, even though an empty burner is added to the list.

babygenius55 (babygenius55a) wrote :

Checked bug 486960 https://lists.ubuntu.com/archives/ubuntu-burning/2009-December/012017.html

Works fine when run with "sudo brasero" What's that about?

babygenius55 (babygenius55a) wrote :

God! I wish I could edit my retarded posts. ^ bug link just refers right back to this. full link however gave me the kick in the head I needed to run brasero as root.

Andrew Porter (ape1980) wrote :

same problem, due to Bug #448921 ('phantom' disc). Thanks to Steve McGrath, I wasn't sure if there was actually a problem for a few minutes, then thought maybe there was, then I found this page. Just got to remember to check my desktop to see if ejected disc is still mounted if I get the same issue again. Thanks again!

Vidar (vidar-nostvold) wrote :

Same problem here, Ubuntu 9.10 x64

Prior to attempting burn I just unmounted /media/cdrom0 -> burning ok!

John Hildebrand (hildebrandj) wrote :

Same. Work-around running Brasero as root also confirmed as a work around.

Matt Harrison (mattharrison) wrote :

I just had the same thing. Ejecting the phantom disc fixed the issue for me.

freetolio (maxwell-clayton) wrote :

Same issue is occurring in Ubuntu 10.04 LTS 32-bit when attempting an ISO burn. It is was resolved when I unmounted /media/cdrom and/media/cdrom0 prior to burning.

Launchpad Janitor (janitor) wrote :

[Expired for brasero (Ubuntu) because there has been no activity for 60 days.]

Changed in brasero (Ubuntu):
status: Incomplete → Expired
David Beswick (dlbeswick) wrote :

This is still happening for me in 11.10

Aisano (info-ais-sanmarino) wrote :

I have experienced similar problems, and I think they are caused by previously mounted optical disks. In the past I used to insert DVDs and expect them to be mounted (which worked fine) and ejected them by pushing the EJECT button on the drive, expecting them to be unmounted (they are not writable, so why not). The latter does not seem to work on my present system (Ubuntu 11.11). When I manually eject a video disk Nautilus (or "mount") still show it as mounted.

Worse, when I then insert a raw disk it is still displayed as the previously ejected disk in Nautilus, while brasero displays it as an empty disk. The latter only works while the "target" selection box has the focus; it disappears as soon as I click on anything else. I suppose that could be a problem of GTK, a system I never managed to understand.

I downloaded the current source package of brasero and noticed that the main if-cascade in brasero-project.c (brasero_project_is_valid) has no "else" branch, so some unexpected situation might get lost there. On the other hand when I try to reproduce the situation I get the (german) equivalent of "Please replace the disc with a supported CD or DVD". So obviously brasero or, much more likely, Ubuntu thinks there's still the old DVD in the drive.

I think it's this inconsistency that causes this kind of problems. I dont't know why Nautilus and Brasero still think the old DVD hasn't been unmounted, while brasero happily goes on trying to burn the empty disc -- and fails.

Aisano (info-ais-sanmarino) wrote :

Since this bug has expired it is just possible that nobody cares about it. Still I just managed to reproduce the situation that a video disk I ejected is still mounted, and natutilus displays this video disk as well as the empty DVD I just inserted. "mount", however, shows me only the video disk.

In this situation, brasero 3.2.0-0ubuntu1 (installed on my system) allows me to selected a disk image and start "burning" it. After a while it gets stuck "generating a checksum".

If, however, I recompile brasero from source (3.2.0) and start it then all five options in the start dialogue are shown as blocked (red circle with diagonal stroke). I can still select "image" and am allowed the ".iso" file but then I get the message "Please replace the disc with a supported CD or DVD" (which I would consider sensible). Code inspection shows that "brasero_track_type_get_has_medium()" returns 0.

When I alternate between the installed brasero and my recompiled version this is reproducible. So it looks like a fix has been made, though the version number is still 3.2.0. Or there is a difference in the Ubuntu version.

Still I seem to remember a time when automatic unmounting of ejected r/o disks worked better... or not? But this has got nothing to do with brasero.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers