Brasero hangs at Normalizing tracks

Bug #374101 reported by Uqbar on 2009-05-09
444
This bug affects 94 people
Affects Status Importance Assigned to Milestone
Brasero
Fix Released
Medium
brasero (Ubuntu)
Low
Ubuntu Desktop Bugs

Bug Description

Binary package hint: brasero

After defining an audio project with a number of MP3 files, the "BURN" action does nothing.
It says "Normalizing tracks" but nothing actually happens for more than 15 minutes.
The CPU load stays low (should rise because normalisation requires both I/O and CPU resources).
I would expect the project to be burnt onto an audio CD.

Workaround: Disable the normalize plugin.

ProblemType: Bug
Architecture: amd64
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/brasero
NonfreeKernelModules: nvidia
Package: brasero 2.26.1-0ubuntu1
ProcEnviron:
 LC_COLLATE=C
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: brasero
Uname: Linux 2.6.28-12-generic x86_64

Uqbar (uqbar) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for your report, could you run brasero from the command line as: brasero --brasero-media-debug &> brasero-debug.txt perform the operation to reproduce the bug and attach the resulting file to the report?. Thanks in advance

Changed in brasero (Ubuntu):
assignee: nobody → Ubuntu Desktop Bugs (desktop-bugs)
importance: Undecided → Low
status: New → Incomplete
Uqbar (uqbar) wrote :

I did what has been requested (debug transcipt is attached).
I simply loaded a pre-made audio project.
After inserting the empty medium, GNOME popped up a dialog asking for actions and I hit the "cancel" button.
Then "Burn" and nothing happened after 15 minutes: "Normalizing tracks" with the moving progress bar.
Then I canceled the action and got the medium ejected.

Travis Carter (princemanfred) wrote :

I can confirm this. It just stays at "Normalizing Tracks" and nothing happens. If I disable the normalize plugin it burns the cd with no problem.

Uqbar (uqbar) wrote :

And I confirm the "workaround" by Travis, at least on 64bit Ubuntu.

Uqbar (uqbar) wrote :

By the way, brasero goes on asking whether I want to save the project despite no change has been done.

summary: - Audio projects are not done at all
+ Brasero hangs at Normalizing tracks
Pedro Villavicencio (pedro) wrote :

I've sent this upstream at: http://bugzilla.gnome.org/show_bug.cgi?id=582461 , feel free to subscribe and make comments there.

Changed in brasero (Ubuntu):
status: Incomplete → Triaged
description: updated
Changed in brasero:
status: Unknown → New
tmsbrdrs (tmsbrdrs) wrote :

Problem and workaround both confirmed for Ubuntu 9.04 x86. Perhaps it might be a good idea not to include the normalize plugin until a fix has been found.

itslindseytime (itslindseytime) wrote :

the workaround works but im still frustrated that this is a problem to begin with. hopefully someone will fix it.

ExileInParadise (exile) wrote :

Confirmed occurring on Fedora 11 (Leonidas) as well.
Rhythmbox calls brasero internally to write CD burns, and would seem to "hang" at the normalization step.

Noted some interesting behavior:
brasero was set to use /tmp for building the normalized image.
In the temp directory, a brasero file appeared and slowly grew.
After 10-15 minutes, the file was only 130KB or so.
So, it seems something was being written, just at painfully slow speeds.

Started brasero directly to disable the normalization plugin and was able to burn from rhythmbox successfully by skipping that step.

I think you should add higher importance to this bug cause it is installed by default on Jaunty and the bug obviously appear for many, with default settings.

Download full text (4.9 KiB)

From terminal this is the log I get:

(brasero:28349): BraseroMedia-DEBUG: At brasero-medium-monitor.c:436: Polling for drives
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium-monitor.c:446: Found 1 drives
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium-monitor.c:449: Probing /org/freedesktop/Hal/devices/storage_model_DVDRW_LH_18A1P
(brasero:28349): BraseroMedia-DEBUG: At brasero-drive.c:960: Drive caps are 639
(brasero:28349): BraseroMedia-DEBUG: At brasero-drive.c:981: Drive /dev/sr0 has bus,target,lun = 6 0 0
(brasero:28349): BraseroMedia-DEBUG: At brasero-drive.c:831: Contents changed
(brasero:28349): BraseroMedia-DEBUG: At brasero-drive.c:831: Contents changed
(brasero:28349): BraseroMedia-DEBUG: At brasero-drive.c:846: Medium inserted
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:2983: Trying to open device /dev/sr0
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:3004: Open () succeeded
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:3019: Device ready
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:2877: Initializing information for medium in DVDRW LH-18A1P
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:2330: Retrieving media profile
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:1458: Retrieving media available speeds
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:1286: Retrieving speed (Get Performance)
(brasero:28349): BraseroMedia-DEBUG: At scsi-get-performance.c:127: Unaligned data (8) setting to max (2048)
(brasero:28349): BraseroMedia-DEBUG: At scsi-get-performance.c:202: Sizes mismatch asked 8 / received 72
Re-issuing the command with received size
(brasero:28349): BraseroMedia-DEBUG: At scsi-get-performance.c:127: Unaligned data (72) setting to max (2048)
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:1301: Successfully retrieved a header: size 72, address 0x8436b98
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:1305: Updated header size = 72
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:1318: Got 4 descriptor(s)
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:1332: Descriptor n° 0, address = 0x8436ba0
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:1339: RD = 1411 / WRT = 7056
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:1332: Descriptor n° 1, address = 0x8436bb0
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:1339: RD = 1411 / WRT = 5645
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:1332: Descriptor n° 2, address = 0x8436bc0
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:1339: RD = 1411 / WRT = 4234
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:1332: Descriptor n° 3, address = 0x8436bd0
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:1339: RD = 1411 / WRT = 2822
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:1348: Maximum Speed (mmc3) 7056
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:2254: Retrieving media status
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:2218: Empty media
(brasero:28349): BraseroMedia-DEBUG: At brasero-medium.c:2224: First open track 1
(brasero:28349): BraseroMedia-DEBUG: At brasero-...

Read more...

agustus (freddybob) wrote :

Also experiencing same issue, thought I'd share a little extra information. The temporary file created in /tmp (in my case it was brasero_tmp_CUA2VU) may hold some clues to this problem. Find attached. Basically, it seems to have run well for the first two tracks, then just repeated over and over the line "BraseroNormalize called brasero_job_get_tracks". There were just over 5000 of these when I cancelled the burn, I trimmed it to 500 lines.

Running Ubuntu Jaunty 64bit

Aldo Nogueira (aldo-nogueira) wrote :

It seems this bug has been fixed.
Take a look in http://bugzilla.gnome.org/show_bug.cgi?id=582461
All we need now is a new package for Jaunty.
The tag 2.26.2 has this fix.
http://git.gnome.org/cgit/brasero/tag/?id=gnome-2-26-2

Leon Nardella (leon.nardella) wrote :

Merely using Brasero's master branch doesn't fix this.
When I try to export mp3 to CD from Banshee, I get this in the terminal:

/usr/local/bin/brasero: symbol lookup error: /usr/local/lib/libbrasero-burn.so.0: undefined symbol: brasero_medium_selection_update_used_space

Ole Jon Bjørkum (oj88) wrote :

Bug confirmed on 9.04. This should be an important bug to fix. New users will not like Ubuntu with bugs like this (that can be easily fixed with a workaround, which is not default).

ktulu77 (ktulu-highwaytoacdc) wrote :

I can confirm this bug on my computer on jaunty x64. I cannot burn an audio project, it hangs on "normalizing tracks".

Changed in brasero:
status: New → Fix Released
Chris Coulson (chrisccoulson) wrote :

This is fixed in Karmic already

Changed in brasero (Ubuntu):
status: Triaged → Fix Released
Uqbar (uqbar) wrote :

This WILL be fixed in Karmic when Karmic WILL be released.
What about making a small effort to fix it in the current (Jaunty) version?
I feel a release in the feature as a no release at all.

Narcis Garcia (narcisgarcia) wrote :

For the moment you can deactivate the "Normalize" plugin in the Edit menu.

Eric Hedekar (stochastic) wrote :

Running a fully up to date Karmic and my Brasero hung at 'Normalizing tracks' for over an hour. I didn't research the cause, but it looks like this bug is NOT fixed. Can anyone on Karmic confirm this?

Am Donnerstag, den 12.11.2009, 22:16 +0000 schrieb Eric Hedekar
(stochastic):
> Running a fully up to date Karmic and my Brasero hung at 'Normalizing
> tracks' for over an hour. I didn't research the cause, but it looks
> like this bug is NOT fixed. Can anyone on Karmic confirm this?

No I can't confirm this. This bug is fixed for me.

Regards
Achim

epictete (p-latreyte) wrote :

I do agree with Uqbar: what about those who use Jaunty? they can only cry?

This idea that when a new Ubuntu version occurs there is no more need to fix the bugs of the preceding version is unrational because a new version is always full of new bugs and one should always wait a few months before upgrading its system.

It's undecent too regarding the users of the preceding version who are considered negligibles!

So you can get:

- either the preceding version with bugs that developpers consider there is no need to fix them
- or the new version with new bugs whose solutions haven't been found yet

but not a STABLE DEBUGGED SYSTEM.

nomnex (nomnex) wrote :

 Jaunty 9.04 2 computers, same Brasero settings (mainly default): burn audio tracks using the same external USB CD-DVD-RAM (Logitec)

First notebook: Panasonic Let'note CF-W2 burn audio tracks without problem (normalization plug-in enabled) on the external drive
Second notebook: Fujitsu FMV-Biblo NH28D does not burn and hangs in the process while displaying "normalization track" message on and on. Will burn only with the normalization plug-in disabled.

Can I provide a log? I am wondering if the cause could be CODEC related? I can't explain why, on one default config it works but not on the other.

nomnex (nomnex) wrote :

Edit: Brasero 2.26.1

nomnex (nomnex) wrote :

Log: second notebook Fujitus FMV-Biblo NH28D - CD audio burning attempt (several tracks)

the log is similar to the previous logs above on the thread. I launch an audio burning session and it hangs until I cancel it. NB: if I burn ONE single track only, the burning completes just fine. Anytime I attempt to burn 2 tracks or more, I reproduce the bug.

confirmed in 9.10 32 bit

akaalanamyles (akaalanamyles) wrote :

I have this problem also, using 9.10 32 bit. I have tried disabling the Normalize plugin but it now seems to hang on "Preparing to write". Does anyone have any ideas for a workaround I could try?

Kristian Kißling (kkissling) wrote :

Normalizing works for me (Ubuntu 9.10, 32-Bit), but takes quite a long time. Maybe some sort of progress bar could be helpful for the waiting user. Until then, have a little patience ;)

Changed in brasero:
importance: Unknown → Medium
walec51 (me-adamwalczak) wrote :

Same thing started happening again after Ubuntu 13.04 update.
It worked fine on Ubuntu 12.10.

walec51 (me-adamwalczak) wrote :

disabling the normalize plugin was also a valid workaround for me

Sander Jonkers (jonkers) wrote :

Yes, I can confirm: happens for me on fully updated Ubuntu 13.04.

Paul Mulders (justinkb) wrote :

Same here, amd64 13.04

Kibi Hofmann (kibi-hofmann) wrote :

This happens for me in 13.04

zaphodbblx (zaphodbblx) wrote :

thanks for posting the workaround...seems so common sense now!

Happens to me too on 13.04.

jervin (jervin) wrote :

Yup, happening to me to on 13.04 at current maintenance, brasero 3.6.1. Seemingly same in the /tmp subdir, disabling normalize circumvents problem (and normalization)

John Friction (johnfriction19) wrote :

Same bug on Linux Mint 15 (based on 13.04 Raring).

This still happens on 13.10. Could somebody with proper rights please re-open the bug report.

Milo van der Linden (milo-l) wrote :

Confirmed on Archlinux 3.9.6-1-ARCH #1 SMP PREEMPT Fri Jun 14 08:12:55 CEST 2013 x86_64 GNU/Linux
With Brasero 3.8.0. Workaround (diable normalize plugin) also confirmed

CaptainMark (imark-skinner) wrote :

Same on Linux Mint 15 (Ubuntu 13.04) when launched from Banshee, the above workaround still does the job

Daniel Quirk (1ws) wrote :

I have this problem in 13.04, 64 bit, confirm the same workaround. Cant believe this bug has been open for four years!

Andreas Moog (ampelbein) wrote :

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

On 07/17/2013 07:41 PM, Daniel Quirk wrote:
> Cant believe this bug has been open for four years!
>

Your message seems to be missing the patch, can you resend it so that
we can check your fix? Thank you very much!

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with undefined - http://www.enigmail.net/

iQIcBAEBAgAGBQJR5um0AAoJEGHzRCZ03mYk9DkP/2gq10RBW+i870BbfK62NJeb
h3prX8xTPHLxAlnXPY5UDCFP2ycFtehy4Fs/k/FwP5ySQ6ubYfiPmQzknhijtebE
MfcNbDXkDYSJZaEM+7e1QN/ItqeWuAFTubjP+GI2oY+26pNyf5wjHtlQ1sxpBCCA
YOiNWJdtZyxtB9I1JvV7wkL95S9IpQwtMcqY5TO7ZwZowp96OU8HzxCMUrrNOS7T
grxWHN5AzmpH2daJoJc+MGQCfvZSwLb08Kto8ZqMOWMdKVmBMcdWDwjEebzirVwP
86RQaZW3ym7JKTirsOdS4A4SeWQCj5lDxmQOrAbRdEMC9s8htulPtuNwYOIDkKAS
gl5+LRQISqy5g+t3DQkErUOQ7g5Rmtjcn+NT+Tc0+exwCfdLomvligS8TbBZ9zuj
QcIS1I58wWHulZx1DrXY4d+S5zGboxxA+/tNZSdHVWvyZx4LxBX97mlTge9YvLE+
Vx42Db/omCk39tV9J0Hbz6ptrW5+0VF2KrVQf//LQB3c/Z4gyNdnZ4Gs/Yq6xMrq
Ol95txHf4KKsnXtNLxeWIYlxNSReKoPWgzY3YCcHP/uBiEBOZTJo1q8p7MZ0LYvX
HYSNvRwXQIhfnGwodPg+fIycffAobyL7h3B1hRduXSMii34y+ZqHM089wMUMEIdv
hnEBxMPuGlRpKCf1UDfw
=67dx
-----END PGP SIGNATURE-----

Bart van Andel (bavanandel) wrote :

Happens to me too, I'm on Linux Mint 15 Olivia (based on Ubuntu raring).

I inspected the file being (slowly) generated in /tmp only to find loads and loads of repeating messages:
"BraseroNormalize called brasero_job_get_tracks"

The first track has been processed fine (with just a few of these lines per track, also before this track got processed by the way), but after that: zero progress.

Part of the dump, maybe this helps:

$ cat /tmp/brasero_tmp_whatever

Checking session consistency (brasero_burn_check_session_consistency brasero-burn.c:1739)
BraseroNormalize called brasero_job_get_action
BraseroNormalize called brasero_job_get_action
BraseroNormalize called brasero_job_get_tracks
BraseroNormalize called brasero_job_get_action
BraseroNormalize called brasero_job_get_session_output_size
BraseroNormalize Output set (AUDIO) image = /tmp/brasero_tmp_26L30W.cdr
BraseroNormalize called brasero_job_get_session_output_size
BraseroNormalize called brasero_job_get_tracks
BraseroNormalize called brasero_job_tag_lookup
BraseroNormalize Analysing track file:///home/bart/path/to/first_track.mp3
BraseroNormalize Creating new pipeline
BraseroNormalize called brasero_job_set_current_action
BraseroNormalize New decoded pad linked
BraseroNormalize called brasero_job_get_tracks
BraseroNormalize called brasero_job_get_tracks
BraseroNormalize called brasero_job_get_tracks
BraseroNormalize called brasero_job_get_tracks
BraseroNormalize called brasero_job_get_tracks
BraseroNormalize called brasero_job_get_tracks
BraseroNormalize Setting track peak (1.000000) and gain (-8.840000)
BraseroNormalize called brasero_job_tag_lookup
BraseroNormalize Analysing track file:///home/bart/path/to/second_track.mp3
BraseroNormalize Creating new pipeline
BraseroNormalize New decoded pad linked
BraseroNormalize called brasero_job_get_tracks
BraseroNormalize called brasero_job_get_tracks
BraseroNormalize called brasero_job_get_tracks
[... repeated ad infinitum ...]

kimus (kimus) wrote :

This issue is marked has fixed but it's NOT fixed! I'm using 13.04 and it does hang! Please change the status of this.

Colin Norris (sirrontm) wrote :

I'm also experiencing this issue with 13.04. I have all updates installed.

Afterlifesol (afterlifesol) wrote :

Yep still not fixed on 13.04 64bit.

raphzahn (raphael-ku) wrote :

I can agree, its not fixed on 13.04 64bit

Markcortbass (markcortbass) wrote :

Confirm, still not fixed in Ubuntu 13.04 64bit

Krzysztof Kosinski (tweenk) wrote :

This bug is fixed. The hangs occuring in Raring are a new issue unrelated to this one. For the new problem see bug #1176509.

Scott (scott-l-barlow) wrote :

Happens to me on 12.10...."workaround" works too. Fully updated.

hurelhuyag (hurelhuyag) wrote :

Ubuntu 13.04 amd64 with brasero 3.6.1 same problem.

Michele Olivo (micheleolivo) wrote :

Installing the package "normalize-audio" start to work, i suggest to add it to the dependencies.
(Ubuntu 13.04, freshly installed)

Lorenzo M (lorenzom) wrote :

I've got the same problem with Mint 16 PETRA 64bit

Dennis (dennis-u) wrote :

There is still a problem with "normalize tracks". I use a fresh installed Ubuntu 13.10 (64 bit) with Brasero 3.8.0.
Cannot believe, that this is a nearly 5 years old bug and the plugin is still enabled as default.

Mario Gomez (magomar) wrote :

I am having the same issue in Linux Mint 16 Cinnamon 64 bit.

Chris Cowan (agentme49) wrote :

On Ubuntu 13.10, have this same issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.