brasero crashed with SIGSEGV in brasero_image_format_get_cdrdao_size()

Bug #346784 reported by Stéphane Maniaci on 2009-03-22
64
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Brasero
Fix Released
Critical
brasero (Ubuntu)
Medium
Ubuntu Desktop Bugs
Jaunty
Undecided
Pedro Fragoso

Bug Description

Binary package hint: brasero

Binary package hint: brasero

As one-the-fly copy of my Audio CD didn't work (I've submitted the bug via Apport), I first ripped my Audio CD into a *.toc file, /home/steph/brasero.toc (which is the default path and name when ripping CDs). Then I put a blank CD-R in, launch Brasero, select "Burn an image" (don't know the exact translation in English), select my .toc image file and it crashes.

This is brasero 2.26.0-0ubuntu1 on updated Jaunty.

ProblemType: Crash
Architecture: i386
CrashCounter: 1
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/brasero
Package: brasero 2.26.0-0ubuntu1
ProcCmdline: brasero
ProcEnviron:
 LANG=fr_FR.UTF-8
 SHELL=/bin/bash
Signal: 11
SourcePackage: brasero
StacktraceTop:
 ?? ()
 ?? ()
 brasero_image_format_get_cdrdao_size ()
 brasero_track_get_image_size ()
 ?? ()
Title: brasero crashed with SIGSEGV in brasero_image_format_get_cdrdao_size()
Uname: Linux 2.6.28-11-generic i686
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare

Stéphane Maniaci (stephh) wrote :

StacktraceTop:brasero_image_format_read_path (ptr=0x0, path=0xbfe5ac64)
brasero_image_format_get_FILE_info (
brasero_image_format_get_cdrdao_size (
brasero_track_get_image_size (track=0x8759dd0,
brasero_session_cfg_update (self=0x8758808, update=1,

Changed in brasero:
importance: Undecided → Medium
Pedro Villavicencio (pedro) wrote :

Thanks for your bug report. This bug has been reported to the developers of the software. You can track it and make comments here: http://bugzilla.gnome.org/show_bug.cgi?id=576564

Changed in brasero (Ubuntu):
assignee: nobody → desktop-bugs
status: New → Triaged
visibility: private → public
Changed in brasero:
status: Unknown → New

I had the same problem. The upstream change fixed it for me.

Stéphane Maniaci (stephh) wrote :

This was fixed upstream, please update Jaunty package, thanks !

Changed in brasero:
status: Triaged → Fix Committed
Jon Arnold (jonarnoldsemail) wrote :

Has this been packaged yet? I'm still having the error in package version 2.26.0-0ubuntu3

Changed in brasero:
status: New → Fix Released
Marco Simonelli (sumydi) wrote :

This bug isn't fixed yet. It requires a urgent fix.

John Stiles (john-isabelle) wrote :

Still outstanding on Brasero 2.26.0

Pedro Villavicencio (pedro) wrote :

it will be fixed with the inclusion of brasero 2.26.1 (bug 361224) next weeks so not need to worry the fix is going to land there. thanks.

In next weeks? There's only one week remaining at the final release!

Martin Schaaf (mascha) wrote :

Ubuntu 9.04 is released and can't copy audio cds.

Stéphane Maniaci (stephh) wrote :

'apt-cache policy' brasero returns me '2.26.0-0ubuntu3', and it seems to work for me (at least, loading my .toc file doesn't crash Brasero).

Martin Pitt (pitti) wrote :

Accepted brasero into jaunty-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in brasero (Ubuntu Jaunty):
assignee: nobody → Pedro Fragoso (ember)
status: New → Fix Committed
tags: added: verification-needed
Jon Arnold (jonarnoldsemail) wrote :

Seems to be working fine for me with 2.26.1-0ubuntu1 from jaunty-proposed. Thanks, Martin.
Please let us know if you want any detailed test.

Martin Pitt (pitti) on 2009-04-28
tags: added: verification-done
removed: verification-needed
Anand Kumria (wildfire) wrote :

Also confirmed the same bug occurred for me, and upgrading to brasero in jaunty-proposed fixed the issue.

Anand

Petr Šplíchal (psss) wrote :

Works for me too, with the new package from proposed.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.26.1-0ubuntu1

---------------
brasero (2.26.1-0ubuntu1) jaunty-proposed; urgency=low

  * New upstream release (LP: #361224)
    - Fix bgo #576439 – nautilus crash because of probable double g_free in
      brasero_medium_get_css_feature (Philippe Rouquier)
    - Fix bgo #575904 - Remove unneeded signal connection and rename callback.
      Fixes crash on Rhythmbox playlist import. (Luis Medinas) (LP: #288392)
    - Fix bgo #576564 – brasero crashed with SIGSEGV in brasero_image_format_get_cdrdao_size()
      (LP: #346784)
    - Fix bgo #576928 – Brasero crashes when pasting empty clipboard. (LP: #345177)
    - Fix bgo #573929 – nautilus crashed with SIGSEGV in start_thread() (Philippe
      Rouquier) (LP: #335942)
    - Fix bgo 573859 – Several 'Make Cover' buttons in Disc Copy dialog (LP: #347637)
    - Fix bgo #578677 - Registered property name in BraseroDriveSelectionClass is
      translated on runtime. (Luis Medinas) (LP: #578677) (LP: #360884)
  * debian/patches/02_css_double_free.patch:
    - Removed, the change is in the tarball

 -- Pedro Fragoso <email address hidden> Tue, 14 Apr 2009 17:59:04 +0100

Changed in brasero (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Martin Pitt (pitti) wrote :

Sorry, this is a Launchpad bug. I copied the jaunty-proposed update to karmic. Fixing tasks accordingly.

Changed in brasero (Ubuntu Jaunty):
status: Fix Released → Fix Committed
Changed in brasero (Ubuntu):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.26.1-0ubuntu1

---------------
brasero (2.26.1-0ubuntu1) jaunty-proposed; urgency=low

  * New upstream release (LP: #361224)
    - Fix bgo #576439 – nautilus crash because of probable double g_free in
      brasero_medium_get_css_feature (Philippe Rouquier)
    - Fix bgo #575904 - Remove unneeded signal connection and rename callback.
      Fixes crash on Rhythmbox playlist import. (Luis Medinas) (LP: #288392)
    - Fix bgo #576564 – brasero crashed with SIGSEGV in brasero_image_format_get_cdrdao_size()
      (LP: #346784)
    - Fix bgo #576928 – Brasero crashes when pasting empty clipboard. (LP: #345177)
    - Fix bgo #573929 – nautilus crashed with SIGSEGV in start_thread() (Philippe
      Rouquier) (LP: #335942)
    - Fix bgo 573859 – Several 'Make Cover' buttons in Disc Copy dialog (LP: #347637)
    - Fix bgo #578677 - Registered property name in BraseroDriveSelectionClass is
      translated on runtime. (Luis Medinas) (LP: #578677) (LP: #360884)
  * debian/patches/02_css_double_free.patch:
    - Removed, the change is in the tarball

 -- Pedro Fragoso <email address hidden> Tue, 14 Apr 2009 17:59:04 +0100

Changed in brasero (Ubuntu Jaunty):
status: Fix Committed → Fix Released
Changed in brasero:
importance: Unknown → Critical
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.