Brasero documentation does not appear in Yelp search results

Bug #264314 reported by Phil Bull on 2008-09-03
22
Affects Status Importance Assigned to Milestone
brasero (Ubuntu)
Medium
Ubuntu Desktop Bugs

Bug Description

Binary package hint: brasero

To reproduce:

 1. Click System -> Help and Support
 2. Type "brasero" into the search box and hit Return
 3. Two search results are shown, neither of which are the Brasero manual

(N.B. I'm referring to the DocBook manual, not the man page.)

Expected: The Brasero manual is shown in the search results.

The Brasero manual can be accessed by opening Brasero and clicking Help -> Contents, so it's definitely installed. It's probably not being added to the scrollkeeper DB when the package is installed, so can't be accessed normally through Yelp.

If you open a Terminal and type "yelp ghelp:brasero", the file can't be found. However, other properly-installed documentation can be (e.g. "yelp ghelp:rhythmbox").

brasero 0.8.1-0ubuntu2
Up-to-date Ubuntu Intrepid (Wednesday 3-Sep-08).

Related branches

Phil Bull (philbull) wrote :

A fix for this issue would be useful for the Documentation Team (we need to link to the Brasero manual).

Changed in brasero:
importance: Undecided → Low
Pedro Villavicencio (pedro) wrote :

works fine for me as today, can you try and report back? thanks.

Changed in brasero:
assignee: nobody → desktop-bugs
status: New → Incomplete
Sebastien Bacher (seb128) wrote :

We are closing this bug report as it lacks the information, described in the previous comments, we need to investigate the problem further. However, please reopen it if you can give us the missing information and don't hesitate to submit bug reports in the future.

Changed in brasero:
status: Incomplete → Invalid
Phil Bull (philbull) wrote :

I still have this issue with up-to-date Intrepid, brasero 0.8.2-0ubuntu1.

Changed in brasero:
status: Invalid → New
Pedro Villavicencio (pedro) wrote :

Confirmed on Jaunty, yelp ghelp:brasero doesn't work and going to the application Help->contents doesn't either.

Changed in brasero:
milestone: none → jaunty-alpha-6
status: New → Confirmed
Matthew East (mdke) wrote :

Yes, the problem is now more serious because it's impossible to open the brasero manual at all with yelp at ghelp:brasero. Opening it manually from /usr/share/gnome/help/brasero/C/brasero.xml works ok.

I think the reason is that brasero doesn't install an omf file in /usr/share/omf as the other documents do.

Changed in brasero (Ubuntu):
importance: Low → Medium
milestone: jaunty-alpha-6 → ubuntu-9.04
Matthew East (mdke) wrote :

I tried adding scrollkeeper as a build-dep and depends with yelp as suggests (as with other gnome packages), but this doesn't seem to have resolved the problem.

In the build various files exist in ./debian/tmp/usr/share/omf/brasero/ but these don't get installed on the system, I'm not clear why.

Hopefully this is enough information for someone to fix the bug.

Remove the --disable-scrollkeeper in debian/rules.

Matthew East (mdke) wrote :

Bruce - can you explain a bit more about your suggestion?

Other packages (e.g. gnome-user-docs) use --disable-scrollkeeper in debian/rules and still install their omf files in the appropriate way. Why do you say that this will fix the problem? Have you tested this fix and does it have any side effects?

Sebastien Bacher (seb128) wrote :

the directory should just be listed in a .install it seems

Matthew East (mdke) wrote :

Sebastien's suggestion certainly fixes this bug - I've tested the fix.

I've created a debdiff but for some reason it is contaminated by the pot file for the help. I'll attach it but would appreciate it if anyone can tell me why that has happened.

Matthew East (mdke) wrote :

Looks like the pot file was there because the clean target failed to clean it up after I built the binary package.

I'm attaching a revised debdiff which hopefully is good to go.

Matthew East (mdke) wrote :

ubuntu-main-sponsors subscribed

Sebastien Bacher (seb128) wrote :

thank you for your work there

Changed in brasero (Ubuntu):
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package brasero - 2.26.0-0ubuntu3

---------------
brasero (2.26.0-0ubuntu3) jaunty; urgency=low

  * debian/brasero.install - add /usr/share/omf (LP: #264314)

 -- Matthew East <email address hidden> Mon, 30 Mar 2009 23:36:51 +0100

Changed in brasero (Ubuntu):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers