BOINC GPU not found, needs a sudo /etc/init.d/boinc-client restart

Bug #933354 reported by Timothy Arceri
46
This bug affects 8 people
Affects Status Importance Assigned to Milestone
BOINC
New
Unknown
boinc (Ubuntu)
Undecided
Unassigned

Bug Description

ATI Driver / X-session can not be accessed by user “boinc” results in GPU not found with Hdxxxx series cards (this may have started with v10.04 of Ubuntu).

Work around is to run "sudo /etc/init.d/boinc-client restart" but problem returns once Ubuntu is restarted

description: updated
Changed in boinc:
status: Unknown → New
Revision history for this message
Bryan Quigley (bryanquigley) wrote :

This appears like it is fixed for me in Precise with BOINC 7.
I get,
Sun 01 Apr 2012 03:52:39 PM EDT | | ATI GPU 0: ATI Radeon HD 3800 (RV670) (CAL version 1.4.1720, 512MB, 489MB available, 50 GFLOPS peak)

Although, nothing can actually use it. Is this what you are referring to?
Sun 01 Apr 2012 10:55:25 PM EDT | Milkyway@Home | Message from server: Catalyst driver version is not OK for CAL application with this GPU
Sun 01 Apr 2012 10:55:25 PM EDT | Milkyway@Home | Message from server: ATI GPU R600 (R38xx) does not support OpenCL

Revision history for this message
Matt Arsenault (mattarsenault) wrote :

I just did a fresh install of the nightly precise build, and I still have a problem with it not being detected out of the box. It works if I run xhost local:boinc before I start the boinc-client service.

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in boinc (Ubuntu):
status: New → Confirmed
Revision history for this message
ebi72 (ebi72) wrote :

This is a problem that have boinc on my PC since a few years. I use ubuntu 12.04 with an ATI GPU (Radeon HD4830). The workaround with "sudo /etc/init.d/boinc-client restart" works fine. You can find some Bugdescriptions in random forums. I think the problem is boinc starts too fast. Boinc should start 30 seconds or one minute after the Ubuntu is FULL rebootet.

Links:
https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/587426
http://www.rechenkraft.net/phpBB/viewtopic.php?f=19&t=12076
https://boinc.berkeley.edu/dev/forum_thread.php?id=5425

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :
Changed in boinc (Ubuntu):
status: Confirmed → Incomplete
Revision history for this message
Timothy Arceri (t-fridey) wrote :

If you have a working ops it doesn't make the bug report incomplete.

Changed in boinc (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Timothy Arceri (t-fridey) wrote :

sorry a working ppa

Revision history for this message
Dave (xclusive585) wrote : Re: [Bug 933354] Re: GPU not found with ATI Hdxxxx series cards

Ain't that the truth... too bad precise doesn't just use the ppa, cause
with the 7.xx development of boinc there continues to be improvements far
beyond the repository version.
On Aug 31, 2012 2:51 AM, "Timothy Arceri" <email address hidden> wrote:

> sorry a working ppa
>
> --
> You received this bug notification because you are a member of Debian
> BOINC Maintainers, which is subscribed to BOINC.
> https://bugs.launchpad.net/bugs/933354
>
> Title:
> GPU not found with ATI Hdxxxx series cards
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/boinc/+bug/933354/+subscriptions
>
> --
> pkg-boinc-devel mailing list
> <email address hidden>
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-boinc-devel
>

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote : Re: GPU not found with ATI Hdxxxx series cards

This is the truth, but a working ppa is better than nothing...
Unfortunately there is a big problem (and partially my fault):

the latest boinc officially stable is the .28 release, while the .34 is only for testing purposes.

So ubuntu MOTU's could not easily (especially for a LTS release) update boinc, since they cannot update it with an unstable release.
The .34 in my opinion is really a good release, and it should become a stable one (I have to report my testcases on boinc alpha site), but we cannot ask for a SRU if we have no fix for an high importance bug or an updated version in debian (now debian is at .27 too).

So in the meanwhile I suggest to use my ppa [1] if you want to "test" always the latest *unstable* release (I can release more than a version each day and no versions at all for weeks) or maybe use [2] if you want a more stable release

there is a version released in [3] wich is the more stable one, but eg it's still at .27 for now, I don't know when Daniel will update it.

Sorry for not giving an appropriate explanation, but for now this is the best we can do, maybe one day I'll apply for bug control and I'll have a closer connection with the MOTU's but now I really have no time to apply.

[1] https://code.launchpad.net/~costamagnagianfranco/+archive/boinc
[2] https://code.launchpad.net/~costamagnagianfranco/+archive/locutusofborg-ppa
[3] https://launchpad.net/~pkg-boinc/+archive/ppa
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Revision history for this message
MestreLion (mestrelion) wrote :

This bug is annoying, a true paper cut, and really bad for new users:

- Install boinc, open it, works fine, GPU detected, add a lot of GPU tasks, crunch happily
- After reboot, Manager (*if* you care to open it) shows error for all GPU-related tasks, "GPU not available"
- Exit Manager (selecting to exit tasks too, in attempt to re-try)
- Open Manager again... Manager does not work (client is down, and Manager does *not* auto-start it)
- Reboot. Manager works again, but GPU is still not found.
- Frustrated, new users purge boinc, not before giving negative feedback on Software Center

Problems and Workarounds:

- boinc starts too early in boot sequence, before GPU drivers (or X, or DE) is active. Workaround is to restart the service after log in in each boot. In terminal: sudo service boinc-client restart

- Manager can stop boinc (if user choose to exit tasks), but it cannot start it (lame!). Terminal again: sudo service boinc-client start

If any of the above is already fixed upstream, is there any chance to backport the fixes to Precise? LocutusOfBorg is correct to say an LTS will not upgrade to an unreleased version, but maybe these fixes can be chery-picked and patched in ubuntu and warrant an SRU, something like boinc_7.0.27-1ubuntu1.

Also, how come the ppa version is 7.0.53 if the official upstream is still 7.0.28?

Revision history for this message
Dave (xclusive585) wrote : Re: [Bug 933354] Re: GPU not found with ATI Hdxxxx series cards

The ppa uses the development release.

-Dave
On Mar 2, 2013 11:45 AM, "MestreLion" <email address hidden> wrote:

> This bug is annoying, a true paper cut, and really bad for new users:
>
> - Install boinc, open it, works fine, GPU detected, add a lot of GPU
> tasks, crunch happily
> - After reboot, Manager (*if* you care to open it) shows error for all
> GPU-related tasks, "GPU not available"
> - Exit Manager (selecting to exit tasks too, in attempt to re-try)
> - Open Manager again... Manager does not work (client is down, and Manager
> does *not* auto-start it)
> - Reboot. Manager works again, but GPU is still not found.
> - Frustrated, new users purge boinc, not before giving negative feedback
> on Software Center
>
> Problems and Workarounds:
>
> - boinc starts too early in boot sequence, before GPU drivers (or X, or
> DE) is active. Workaround is to restart the service after log in in each
> boot. In terminal: sudo service boinc-client restart
>
> - Manager can stop boinc (if user choose to exit tasks), but it cannot
> start it (lame!). Terminal again: sudo service boinc-client start
>
> If any of the above is already fixed upstream, is there any chance to
> backport the fixes to Precise? LocutusOfBorg is correct to say an LTS
> will not upgrade to an unreleased version, but maybe these fixes can be
> chery-picked and patched in ubuntu and warrant an SRU, something like
> boinc_7.0.27-1ubuntu1.
>
> Also, how come the ppa version is 7.0.53 if the official upstream is
> still 7.0.28?
>
> --
> You received this bug notification because you are a member of Debian
> BOINC Maintainers, which is subscribed to BOINC.
> https://bugs.launchpad.net/bugs/933354
>
> Title:
> GPU not found with ATI Hdxxxx series cards
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/boinc/+bug/933354/+subscriptions
>
> --
> pkg-boinc-devel mailing list
> <email address hidden>
> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-boinc-devel
>

Revision history for this message
Dave (xclusive585) wrote :

Though, note to locutus, a ppa dedicated to the current stable, with your
fixes, would be of great use...

-Dave
On Mar 2, 2013 12:34 PM, "Xclusive Technology" <email address hidden>
wrote:

> The ppa uses the development release.
>
> -Dave
> On Mar 2, 2013 11:45 AM, "MestreLion" <email address hidden> wrote:
>
>> This bug is annoying, a true paper cut, and really bad for new users:
>>
>> - Install boinc, open it, works fine, GPU detected, add a lot of GPU
>> tasks, crunch happily
>> - After reboot, Manager (*if* you care to open it) shows error for all
>> GPU-related tasks, "GPU not available"
>> - Exit Manager (selecting to exit tasks too, in attempt to re-try)
>> - Open Manager again... Manager does not work (client is down, and
>> Manager does *not* auto-start it)
>> - Reboot. Manager works again, but GPU is still not found.
>> - Frustrated, new users purge boinc, not before giving negative feedback
>> on Software Center
>>
>> Problems and Workarounds:
>>
>> - boinc starts too early in boot sequence, before GPU drivers (or X, or
>> DE) is active. Workaround is to restart the service after log in in each
>> boot. In terminal: sudo service boinc-client restart
>>
>> - Manager can stop boinc (if user choose to exit tasks), but it cannot
>> start it (lame!). Terminal again: sudo service boinc-client start
>>
>> If any of the above is already fixed upstream, is there any chance to
>> backport the fixes to Precise? LocutusOfBorg is correct to say an LTS
>> will not upgrade to an unreleased version, but maybe these fixes can be
>> chery-picked and patched in ubuntu and warrant an SRU, something like
>> boinc_7.0.27-1ubuntu1.
>>
>> Also, how come the ppa version is 7.0.53 if the official upstream is
>> still 7.0.28?
>>
>> --
>> You received this bug notification because you are a member of Debian
>> BOINC Maintainers, which is subscribed to BOINC.
>> https://bugs.launchpad.net/bugs/933354
>>
>> Title:
>> GPU not found with ATI Hdxxxx series cards
>>
>> To manage notifications about this bug go to:
>> https://bugs.launchpad.net/boinc/+bug/933354/+subscriptions
>>
>> --
>> pkg-boinc-devel mailing list
>> <email address hidden>
>> http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-boinc-devel
>>
>

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote : Re: GPU not found with ATI Hdxxxx series cards

First thanks Dave for the prompt answer :-)
Second the fixes are not coming from me, but from a real GREAT community of users and developers, Steffen, Guo and so on (too many to remember).
Third I put a delay in boinc start function, I hope it will *fix* this bug (I always HOPE that someone with more knowledge than me will find a better fix)
Forth upstream people told me (I sent them a mail asking why they don't release any newer version as stable anymore since almost one year) that ANY newer release in 7.0 branch could be considered as stable, because of no new features and only bug fix.
Until they will start with 7.2 branch I can package updates with not so many problems :-)

Bests

Gianfranco

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Hi Everyone affected by this bug.

I'm building now boinc 7.0.53 revision 1028 for precise, quantal and raring, and will be available in a few hours.

It may contain a fix for this bug, could anybody help me in testing it?
https://code.launchpad.net/~costamagnagianfranco/+archive/boinc

thanks

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Could anybody test it? Now the package is built

Revision history for this message
LAZA (laza74) wrote :

Installed and does not work as expected! (GPU not found)

Also got problems after the installation, that the client (localhost) does not find the data - i had to restart the machine.
After the restart, i opened up boinc and GPU was not found...
Now it works and will postphone if i experience problems

Revision history for this message
LAZA (laza74) wrote :

I positive difference from version .27 and .52/53 i can say:

No more errors in
World Community Grid - Help Conquer Cancer for AMD GPUs

Don't know if they changed anything or the changes in boinc-manager did this...

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :
summary: - GPU not found with ATI Hdxxxx series cards
+ BOINC GPU not found, needs a sudo /etc/init.d/boinc-client restart
Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package boinc - 7.0.65+dfsg-1

---------------
boinc (7.0.65+dfsg-1) unstable; urgency=low

  [ Gianfranco Costamagna ]
  * New upstream release.
  * debian/control.in dropped version check
      - pkg-config (>= 0.15) (version 0.25 in stable)
      - autoconf (>= 2.59) (version 2.67 in stable)
      - automake1.9 (>= 1.9.3) (version 1.9.6 in stable)
      - libcurl4-openssl-dev (>= 7.17.1) (version 7.21.0 in stable)
      - python (>= 2.3) (version 2.6.6 in stable)
      - Breaks: udev (<< 136-1) (version 164 in stable)
      - removed boinc-app-seti from boinc-client Suggests field
      - Bumped debhelper required version to 8
    debian/compat
      - Bumped to version 8

  [ Steffen Moeller ]
  * Merged work on packaging of BOINC server code
  * boinc-cgi-stripchart package now built together with server parts

 -- Gianfranco Costamagna <email address hidden> Tue, 30 Apr 2013 21:45:44 +0200

Changed in boinc (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
LAZA (laza74) wrote :
Download full text (3.5 KiB)

Does not work for me!

Did an restart today, with fresh installed version from http://ppa.launchpad.net/pkg-boinc/ppa/ubuntu precise main:
ii boinc 7.0.65+dfsg-2~precise3
ii boinc-client 7.0.65+dfsg-2~precise3
ii boinc-manager 7.0.65+dfsg-2~precise3
ii libboinc7 7.0.65+dfsg-2~precise3

Attached is the original message after reboot and starting BOINC.

After restarting BOINC the GPU ist found:

Mo 06 Mai 2013 20:20:12 CEST | | Starting BOINC client version 7.0.65 for x86_64-pc-linux-gnu
Mo 06 Mai 2013 20:20:12 CEST | | log flags: file_xfer, sched_ops, task
Mo 06 Mai 2013 20:20:12 CEST | | Libraries: libcurl/7.29.0 OpenSSL/1.0.1 zlib/1.2.3.4 libidn/1.23 librtmp/2.3
Mo 06 Mai 2013 20:20:12 CEST | | Data directory: /var/lib/boinc-client
Mo 06 Mai 2013 20:20:12 CEST | | Processor: 4 AuthenticAMD AMD Phenom(tm) II X4 810 Processor [Family 16 Model 4 Stepping 2]
Mo 06 Mai 2013 20:20:12 CEST | | Processor features: fpu vme de pse tsc msr pae mce cx8 apic sep mtrr pge mca cmov pat pse36 clflush mmx fxsr sse sse2 ht syscall nx mmxext fxsr_opt pdpe1gb rdtscp lm 3dnowext 3dnow constant_tsc rep_good nopl nonstop_tsc extd_apicid pni monitor cx16 popcnt lahf_lm cmp_legacy svm extapic cr8_legacy abm sse4a misalignsse 3dnowprefetch osvw ibs skinit wdt hw_pstate npt lbrv svm_lock nrip_save
Mo 06 Mai 2013 20:20:12 CEST | | OS: Linux: 3.5.0-28-generic
Mo 06 Mai 2013 20:20:12 CEST | | Memory: 7.80 GB physical, 2.00 GB virtual
Mo 06 Mai 2013 20:20:12 CEST | | Disk: 11.81 GB total, 5.57 GB free
Mo 06 Mai 2013 20:20:12 CEST | | Local time is UTC +2 hours
Mo 06 Mai 2013 20:20:12 CEST | | VirtualBox version: 4.2.12r84980
Mo 06 Mai 2013 20:20:12 CEST | | CAL: ATI GPU 0: AMD Radeon HD 6570/6670/7570/7670 series (Turks) (CAL version 1.4.1741, 2048MB, 1916MB available, 1536 GFLOPS peak)
Mo 06 Mai 2013 20:20:12 CEST | | OpenCL: AMD/ATI GPU 0: AMD Radeon HD 6570/6670/7570/7670 series (Turks) (driver version 1016.4, device version OpenCL 1.2 AMD-APP (1016.4), 2048MB, 1916MB available, 1536 GFLOPS peak)
Mo 06 Mai 2013 20:20:12 CEST | | Config: GUI RPCs allowed from:
Mo 06 Mai 2013 20:20:12 CEST | Leiden Classical | URL http://boinc.gorlaeus.net/; Computer ID 106412; resource share 12
Mo 06 Mai 2013 20:20:12 CEST | eon2 | URL http://eon.ices.utexas.edu/eon2/; Computer ID 37056; resource share 2
Mo 06 Mai 2013 20:20:12 CEST | World Community Grid | URL http://www.worldcommunitygrid.org/; Computer ID 2295986; resource share 100
Mo 06 Mai 2013 20:20:12 CEST | World Community Grid | General prefs: from World Community Grid (last modified 29-Mar-2013 11:47:41)
Mo 06 Mai 2013 20:20:12 CEST | World Community Grid | Host location: none
Mo 06 Mai 2013 20:20:12 CEST | World Community Grid | General prefs: using your defaults
Mo 06 Mai 2013 20:20:12 CEST | | Reading preferences override file
Mo 06 Mai 2013 20:20:12 CEST | | Preferences:
Mo 06 Mai 2013 20:20:12 CEST | | max memory usage when active: 7904.02MB
Mo 06 Mai 2013 20:20:12 CEST | | max memory usage when idle: 7904.02MB
Mo 06 Mai 2013 20:20:12 CEST | | max disk usage: 0.00GB
Mo 06 Mai 2013 20:20:...

Read more...

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

I cannot find any 7.0.65 on pkg-boinc ppa
http://ppa.launchpad.net/pkg-boinc/ppa/ubuntu/pool/main/b/boinc/

could you please try with boinc from saucy or my ppa?

Otherwise please open a new bug report.

Revision history for this message
LAZA (laza74) wrote :

Sorry Costa, that was my fault!

Source for BOINC ppa is:
http://ppa.launchpad.net/costamagnagianfranco/locutusofborg-ppa/ubuntu precise
Installed version numbers are correct.

The other one _was_ once the recommended on ubuntuusers.de and is still in my sources.list...

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Anyway no problem, please just report a new bug, Rodrigo I think will take care soon of this problem.

Revision history for this message
LAZA (laza74) wrote :

Opened up a new bug report as requested:
https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1177433

Revision history for this message
LAZA (laza74) wrote :
tags: added: trusty
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.