No usable GPUs (AMD) found

Bug #1177433 reported by LAZA
28
This bug affects 5 people
Affects Status Importance Assigned to Milestone
boinc (Ubuntu)
Undecided
Unassigned

Bug Description

This is a new bug report about the old problem, that BOINC starts to early - which leads to a now functional GPU for BOINC.
See original here:
https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/933354

Installed version is from:
http://ppa.launchpad.net/costamagnagianfranco/locutusofborg-ppa/ubuntu precise

The message after starting BOINC manager is attached.

.

Xubuntu 12.04.2

ii boinc 7.0.65+dfsg-2~precise3
ii boinc-client 7.0.65+dfsg-2~precise3
ii boinc-manager 7.0.65+dfsg-2~precise3
ii libboinc7 7.0.65+dfsg-2~precise3

Revision history for this message
LAZA (laza74) wrote :
Revision history for this message
LAZA (laza74) wrote :

This is the output after restarting the boinc client, when GPU is found (BOINC with GPU)

Changed in boinc (Ubuntu):
status: New → Confirmed
Revision history for this message
ChristianB (djangofett) wrote :

The underlying problem here is not with BOINC but with the way the driver initializes the GPU. It seems that for newer AMD/ATI GPU's you need an active x-session (aka logged in user). Usually BOINC is started via init-script at boot time but there is no user logged in. What you can do is to deactivate the init-script and somehow transform this into an autostart skript after you login to your desktop manager. The init process can't help us here as it has no information about logged in users.

@laza74: Can you post what driver you have installed for your GPU?

@costamagnagianfranco: can you add the driver package to this bug as the reason is clearly in the driver.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Thanks for the clarification. Anyway MANY people runs boinc on servers, or on machines even without any gui.

How can we handle this?

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Anyway I didn't got this problem anymore with nvidia cards...
Maybe the driver is fixed now

Revision history for this message
LAZA (laza74) wrote :

AtM is the updated fglrx driver from the Ubuntu repo active:
ii fglrx-amdcccle-updates 2:9.000-0ubuntu0.3
ii fglrx-updates 2:9.000-0ubuntu0.3

The other drivers in the repo (for testing?) are:
1. fglrx -- 2:8.960-0ubuntu1.1
2. fglrx-experimental-9 -- 2:9.010-0ubuntu0.3
3. fglrx-experminetal-12 -- 2:12.100-0ubuntu0.1

IF it is a problem inthe initalization, the dmesg will be helpful - there are a lot of messages from the GPU in it.

Please be warned:
I also have an onboard AMD GPU in this machine, but it should be set "Off" in BIOS. (if this could be a troublemaker)

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Hi LAZA, I think I found a clue for this bug.

Could you please add in your boinc-client init script the "lightdm" word?

I think you are running lightdm as dm, and when it was introduced nobody updated the init script.
I feel stupid, the solution was in the first 10 lines and I missed it for a loooong time!
# Should-Start: x11-common network-manager gdm kdm dbus lightdm

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

Hi LAZA again, I'm building right now a boinc version that will likely fix this bug.
boinc - 7.0.65+dfsg-0~1082~

would you like to give it a spin and report here?

many thanks

Revision history for this message
LAZA (laza74) wrote :

Ok, step by step:

1. Add in BOINC-Client init script lightdm
- open up /etc/default/boinc-client
- nothing about the login manager

1b.
- open up /etc/init.d/boinc-client
- add "lightdm" to line 6 - now
-- # Should-Start: x11-common network-manager gdm kdm dbus lightdm

2. Updated version 7.0.65+dfsg-0~1082 is still now available.

I will reboot and test the experience here...

Revision history for this message
LAZA (laza74) wrote :

Does not work for me:

Do 16 Mai 2013 18:34:11 CEST | | No usable GPUs found
Do 16 Mai 2013 18:34:11 CEST | | app version refers to missing GPU type ATI

I wait for the new uploaded version an will comment if something changes.

Thanks Costa for the time and work so far!

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

and the /etc/init.d/boinc-client restart works?

Revision history for this message
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package boinc - 7.0.65+dfsg-3

---------------
boinc (7.0.65+dfsg-3) unstable; urgency=low

  [ Gianfranco Costamagna ]
  * Added lightdm to init script (lp: #1177433)
  * Removed the 5 sec sleep in init script.

  [ Guo Yixuan ]
  * Removed unused lintian override for boinc-manager.

 -- Gianfranco Costamagna <email address hidden> Wed, 15 May 2013 17:33:13 +0200

Changed in boinc (Ubuntu):
status: Confirmed → Fix Released
Revision history for this message
LAZA (laza74) wrote :

Sorry, i don't understand what you mean with "and the /etc/init.d/boinc-client restart works?" ?

If you think about the command "sudo /etc/init.d/boinc-client restart" - after this, BOINC works well with GPU!

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

That was my meaning, could we please continue the conversation offline? I need to ask you to change something in boinc-client init script, I don't want to spare builders time for this kind of debugging, since this is just one line change!

could you please send me a mail? (I have already sent you a mail from lp)

Revision history for this message
MestreLion (mestrelion) wrote : Re: [Bug 1177433] Re: No usable GPUs (AMD) found

Whatever discussions you do about this subject, please add me too! I'm very interested in this bug, since I also have an ATI HD 7770, and I can help with tests.

Currently, boinc starts without any GPU, and I must restart the client once I log in so it detect my GPU. I do so in a wrapper script for boinc manager, but that is a workaround, not a solution. Also, something weird I noticed: using "sudo /etc/init.d/bloinc-client restart" always work, but "sudo service boinc-client restart" sometimes does NOT (it restarts service, but boinc still does not find GPU. Weren't both commands supposed to be the same thing? Why is there a difference?

Btw, the approach of LocusOfBorg of adding "lightdm" to init script sounded VERY promising. Did it work?

Please CC me in emails about this subject.

ML
At 12:11 17/05/2013, LocutusOfBorg wrote:
>That was my meaning, could we please continue the conversation offline?
>I need to ask you to change something in boinc-client init script, I
>don't want to spare builders time for this kind of debugging, since this
>is just one line change!
>
>could you please send me a mail? (I have already sent you a mail from
>lp)
>
>--
>You received this bug notification because you are a member of Debian
>BOINC Maintainers, which is subscribed to boinc in Ubuntu.
>https://bugs.launchpad.net/bugs/1177433
>
>Title:
> No usable GPUs (AMD) found
>
>To manage notifications about this bug go to:
>https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/1177433/+subscriptions
>
>--
>pkg-boinc-devel mailing list
><email address hidden>
>http://lists.alioth.debian.org/cgi-bin/mailman/listinfo/pkg-boinc-devel

Revision history for this message
LAZA (laza74) wrote :

Bug reproducable with upcoming Trusty 14.04 beta1 (Xubuntu) and BOINC 7.2.42

tags: added: precise trusty
Revision history for this message
EliasAlucard (eliasalucard) wrote :

Yes, this bug is still there with Trusty Tahr (I'm on Ubuntu 14.04.1 right now). I can confirm that "sudo /etc/init.d/boinc-client restart" works, and GPU is recognised after that. However, while GPU is recognised, now the problem is, "App version needs OpenCL, but GPU doesn't support it". I installed the boinc-amd-opencl package (and its fglrx proprietary drivers) through Synaptic, but it's not working. I'm using BOINC 7.2.42 and my CPU (which works fine) is an AMD Fusion Trinity A10-4600M, and my GPU is AMD Radeon HD 7660G+7670M.

Of course, ultimately, this isn't the fault of Linux/FOSS developers; the real problem here is crappy GPU drivers; all this would work so much better if AMD fully open sourced their GPU drivers. Anyway, when installing the official AMD Catalyst drivers from AMD's website, the GPU works fine in BOINC. For some reason, the proprietary AMD GPU drivers in Synaptic are outdated or something, and they don't recognise my GPU properly, but installing the latest Catalyst from AMD's website, solves it.

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

the libraries handled by boinc are:
libOpenCL.so (opencl)
libaticalrt.so (amd)
libcuda.so (nvidia)
libnvidia-ml.so (nvidia, driver version).

Can you please look if the packaged driver gives you the correct library file? You might need the -dev package to get boinc work with the repository driver.

thanks

Revision history for this message
EliasAlucard (eliasalucard) wrote :

I'm on Utopic Unicorn right now, using the standard open source GPU drivers, and "sudo /etc/init.d/boinc-client restart" doesn't recognise my GPU as it did on Trusty. How do I check those libraries?

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

sudo updatedb
locate "filename"

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers