upgrade to 5.10

Bug #118916 reported by Shirish Agarwal
4
Affects Status Importance Assigned to Milestone
boinc (Ubuntu)
Wishlist
Unassigned

Bug Description

Hi all,
      Please upgrade to the latest version 5.10 http://boinc.berkeley.edu/trac/roadmap

Revision history for this message
Frank S. Thomas (fst) wrote : Re: [Bug 118916] upgrade to 5.10

On Wednesday 06 June 2007, Shirish Agarwal wrote:
> Hi all,
> Please upgrade to the latest version 5.10
> http://boinc.berkeley.edu/trac/roadmap

I won't as long as upstream calls 5.10 an unstable development version.
Current source code even doesn't build on Debian and Ubuntu:
http://boinc.berkeley.edu/trac/ticket/237

Revision history for this message
Shirish Agarwal (shirishag75) wrote :

The patch seems to have been fixed, hope you're keeping an eye out on it as I am.

Revision history for this message
Steffen Möller (moeller-debian) wrote : Re: [Bug 118916] Re: upgrade to 5.10

The problem that I as a mere Debian user have is that there is no wxWidgets
2.8 in my distribution yet that is officially required for 5.10. Debian is at
2.6.0. However, 2.8 is apparently part of Ubuntu and you may hence not care
overly much, particularly since Frank is using Ubuntu, too :o)

I am glad that Frank cares about it all so much and that he invests so much of
his time, but to upgrade to 5.10 is would not see on my personal priorities
list, so I must admit. Is there anything gained science-wise? Admittedly
though there are some nice features from the user's perspective that
nevertheless can wait a bit longer, that IMHO can wait for wxWidgets 2.8 in
Debian at least.

Many greetings

Steffen

On Sunday 10 June 2007 11:36:36 Shirish Agarwal wrote:
> The patch seems to have been fixed, hope you're keeping an eye out on it
> as I am.
>
> --
> upgrade to 5.10
> https://bugs.launchpad.net/bugs/118916
> You received this bug notification because you are a member of Debian
> BOINC Maintainers, which is a bug contact for boinc in ubuntu.

Revision history for this message
Frank S. Thomas (fst) wrote :

Moin moin Steffen,

On Sunday 10 June 2007, Steffen Moeller wrote:
> The problem that I as a mere Debian user have is that there is no wxWidgets
> 2.8 in my distribution yet that is officially required for 5.10.

Upstream reverted the requirement on wxWidgets 2.8 before releasing 5.9.12
IIRC. Hence it is possible to have 5.10 in Debian and Ubuntu soon. In fact
I'm currently running the 5.10.4 BOINC client, which I built a few hours ago,
on my Debian box. Now I'm waiting for the 5.10 branch to stabilize before
I'll upload it to unstable (or better: before I'll ask Christoph to upload it
for me :-).

> [...] particularly since Frank is using Ubuntu, too :o)

Not really, I just care about the state of the BOINC packages in Debian _and_
Ubuntu.

Viele Grüße,
Frank

Changed in boinc:
importance: Undecided → Wishlist
status: Unconfirmed → Confirmed
Revision history for this message
martalli (drsiegfried) wrote : Re: upgrade to 5.10 for Cosmology@Home

I am just another user, but would second the call for version 5.10. Sciencewise, the new Cosmology@Home project requires 5.8 or newer.

<code>
Sat 07 Jul 2007 09:18:39 PM CDT||Fetching configuration file from http://cosmos.astro.uiuc.edu/cosmohome/get_project_config.php
Sat 07 Jul 2007 09:19:02 PM CDT|http://cosmos.astro.uiuc.edu/cosmohome/|Scheduler list download succeeded
Sat 07 Jul 2007 09:19:02 PM CDT|http://cosmos.astro.uiuc.edu/cosmohome/|Sending scheduler request to http://cosmos.astro.uiuc.edu/cosmohome_cgi/cgi
Sat 07 Jul 2007 09:19:02 PM CDT|http://cosmos.astro.uiuc.edu/cosmohome/|Reason: Requested by user
Sat 07 Jul 2007 09:19:02 PM CDT|http://cosmos.astro.uiuc.edu/cosmohome/|Requesting 17280 seconds of new work
Sat 07 Jul 2007 09:19:03 PM CDT|http://cosmos.astro.uiuc.edu/cosmohome/|Scheduler request succeeded
Sat 07 Jul 2007 09:19:03 PM CDT|Cosmology@Home|Message from server: Need version 5.8 or higher of the BOINC core client. You have 5.4.
Sat 07 Jul 2007 09:19:03 PM CDT|Cosmology@Home|Resetting project
</code>

Cosmology@Home is still a relatively minor project, but at least there is one project that needs the higher version (for some reason or another). However, I strongly appreciate the effort that you have made to bring boinc to debian and ubuntu. Your work has made boinc much easier to use for the masses of people. Even though I had successfully followed a howto in order to make it run automatically on a machine or two, your project makes it work cleanly and was easy to install on all the machines at my clinic and home. I don't know if the p2-300 music jukebox has many cycles to contribute, but at least it gets a last chance at computing glory =).

Bryan

Revision history for this message
martalli (drsiegfried) wrote :

Would it be possible to upgrade to 5.8? While 5.10 is a development version, 5.8 is stable. My experience may not be as broad as others' experiences, but Cosmology @ Home only requires 5.8 at this time.

Revision history for this message
martalli (drsiegfried) wrote :

Apparently Predictor at Home also requires 5.8 or better, too. I would be willing to offer a $25 bounty on an upgrade of the package. Now, I am sure it is worth more than that...but I'm hoping other boinc users would join in the bounty, too.

Is there a place to formally set bounties on ubuntu packages?

Revision history for this message
Frank S. Thomas (fst) wrote :

Bryan,

BOINC 5.8 has been backported to Feisty, maybe this is of interest for you.
See https://bugs.launchpad.net/feisty-backports/+bug/112570 for details.

Grüße,
Frank

Revision history for this message
martalli (drsiegfried) wrote :

Frank,

Vielen Danken!

Bryan

Revision history for this message
martalli (drsiegfried) wrote :

Now that it is fixed, who gets my reward? If no one claims it, I will send it in to the debian project...Since as far as I understood, this is essentially originating from the debian project.

Revision history for this message
Frank S. Thomas (fst) wrote : Re: [Bug 118916] Re: upgrade to 5.10

On Tuesday 17 July 2007, martalli wrote:
> [...] If no one claims it, I will
> send it in to the debian project...Since as far as I understood, this is
> essentially originating from the debian project.

I think is is a wonderful idea and money well spent!

Grüße,
Frank
--
Anmut bringen wir ins Leben;
 Leget Anmut in das Geben.

Revision history for this message
Frank S. Thomas (fst) wrote :

BOINC 5.10.8 has now been synced from Debian, see https://bugs.launchpad.net/ubuntu/+source/boinc/+bug/128045

Changed in boinc:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers