Ubuntu

qemu completely broken with current version of bochbios

Reported by Edmundo on 2007-06-30
62
Affects Status Importance Assigned to Milestone
bochs (Ubuntu)
Medium
Unassigned
Declined for Gutsy by Luca Falavigna
qemu (Debian)
Fix Released
Unknown

Bug Description

Qemu in Debian and Ubuntu are built to use BIOS images from the bochsbios package instead of the builtin ones. Unfortunately, the bochsbios images currently shipped with gutsy do not work with a Windows XP guest in qemu. A comment below states that they do not work with certain Linux distributions either. The current Debian/testing or Debian/unstable packages ship with a more recent BIOS and work fine. So all that's needed to fix this bug is a backport from the development version of Ubuntu.

Original bug description below:

> Binary package hint: qemu
>
> After updating to gutsy, qemu doesn't want to start an XP instance. I tried with Damn Small Linux (from the CD ISO) and it works flawlessly.
>
> It fails during XP's boottime. The qemu windows hangs up and can't even switch to the qemu's console.
>
> I checked by downloading the source code (the "vanilla" code), compiling it and running.. and found it works (with the same XP image).

Related branches

Changed in qemu:
importance: Undecided → Medium
Laurent Bigonville (bigon) wrote :

Is your image in NTFS? I have problems with qemu and the ntfs driver of winxp

Changed in qemu:
status: New → Incomplete

From outside:
$ fdisk -lu xp.iso
You must set cylinders.
You can do this from the extra functions menu.

Disk xp.iso: 0 MB, 0 bytes
128 heads, 63 sectors/track, 0 cylinders, total 0 sectors
Units = sectors of 1 * 512 = 512 bytes

 Device Boot Start End Blocks Id System
xp.iso1 * 63 6128639 3064288+ 7 HPFS/NTFS

From inside:
$ sudo fdisk -lu /dev/hda

Disk /dev/hda: 3045 MB, 3145728000 bytes
128 heads, 63 sectors/track, 761 cylinders, total 6144000 sectors
Units = sectors of 1 * 512 = 512 bytes

   Device Boot Start End Blocks Id System
/dev/hda1 * 63 6128639 3064288+ 7 HPFS/NTFS

I'm experiencing this issue as well. Worked fine until upgrade to Gutsy.

Paul van Genderen (paulvg) wrote :

I moved an image from an Ubuntu 6.10 box to 7.10 and it fails to boot. When I press F8 and choose Safe Mode, it hangs at about 33% of the (text-based) progress meter.

Daniel Elstner (daniel-elstner) wrote :

I think I have the same problem. I had a look at the package and noticed that it doesn't use the BIOS which ships with qemu but the one from bochs instead. Replacing the file /usr/share/bochs/BIOS-bochs-latest with the BIOS image from the latest bochs CVS snapshot fixed it for me. So it seems the bochs package needs an update.

Changed in qemu:
status: Incomplete → Confirmed
Simon Ruggier (simon80) wrote :

Is someone working on this?

Daniel Elstner (daniel-elstner) wrote :

OK. To help out a bit I reassigned the bug to bochs, and gave the current bochsbios package from Debian/testing [1] a try. It works just fine for me on amd64. So all that's need is a new merge from Debian.

[1] http://packages.debian.org/lenny/bochsbios

description: updated

I just tested with version 2.3+20070705, and it works for me on i386 as well.

I experienced the same problem with Gutsy, replacing the BOCHS-BIOS fixed the problem.

Chow Loong Jin (hyperair) wrote :

I can't seem to start up Ubuntu Gutsy or Linux Mint in qemu either. Is that to do with the BIOS as well?

Chow Loong Jin (hyperair) wrote :

Nevermind, I installed the new Bochs BIOS and it boots up fine now. ^^

Simon Ruggier (simon80) on 2007-11-29
description: updated
c_t (chefturner) wrote :

Yes, installing bochsbios from hardy ( http://archive.ubuntu.com/ubuntu/pool/universe/b/bochs/bochsbios_2.3+20070705-2ubuntu1_all.deb ) also made my XP-VM work again! Thanks Daniel, for the hint!

michael301080 (michael-oxopia) wrote :

I had issues with a win2k image on a gutsy host.
Installing http://archive.ubuntu.com/ubuntu/pool/universe/b/bochs/bochsbios_2.3.5-1ubuntu1_all.deb fixed my problem. (the package bochsbios_2.3+20070705-2ubuntu1_all.deb wasn't available anymore)

Anyway, keep up the good work guys.

Kind regards,

Michael Van Wesenbeeck

hangy (hangy) wrote :

Seems like I still got the problem with bochsbios-qemu 2.3.5-1ubuntu1 (hardy) when I try to run FreeBSD with kqemu.

Changed in qemu:
status: Unknown → New
Brian Pitts (bpitts) wrote :

This solved my problem with Zenwalk 5.0. Previously, it worked with kvm but not qemu.

Changed in qemu:
status: New → Fix Committed
Changed in qemu:
status: Fix Committed → Fix Released
Diane Trout (diane-trout) wrote :

When trying to install hardy server alpha3 into a qemu session on a amd64 host, it kept failing when trying to detect the virtual cdrom. Upgrading from gutsy's bochsbios-2.3-2etch1 to lenny's bochsbios-2.3.5-1 fixed the cdrom detection problem.

David Benjamin (davidben) wrote :

So, are there any plans to backport this to Gutsy? It seems strange that a fix has been in Hardy and for quite some time now, and yet Gutsy still doesn't have it.

I can hardly imagine that "stable users" want the old package, seeing as it doesn't work.

David Benjamin wrote:
> So, are there any plans to backport this to Gutsy? It seems strange that
> a fix has been in Hardy and for quite some time now, and yet Gutsy still
> doesn't have it.
>
> I can hardly imagine that "stable users" want the old package, seeing as
> it doesn't work.

Well, a broken package is very stable... :) Yes, in this case, the
system is what is broken.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.