[SRU] bluetooth send malformed files

Bug #421684 reported by Artur Rona on 2009-08-30
60
This bug affects 15 people
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)
Undecided
Unassigned
Karmic
Undecided
Unassigned
obexd (Ubuntu)
High
Unassigned
Karmic
High
Unassigned

Bug Description

Binary package hint: bluez

Files sent by Ubuntu are malformed. I'll attach a file which is on my disc and file was sent by bluetooth. I don't have time for test, but I checked that bluez 4.45 is too affected.
kernel - 2.6.31-8-generic

SRU - karmic is need to fix.

Related branches

Artur Rona (ari-tczew) wrote :
Artur Rona (ari-tczew) wrote :
affects: linux (Ubuntu) → obexd (Ubuntu)

Hello Artur,

the corruption happens when you sent the file from your computer to another device right?
How do you sent the file?

Thanks

Artur Rona (ari-tczew) wrote :

Hello Baptiste,

Thanks for the reply. If I send file on another phone, then works good, so my phone is affected.
However, if I'll send file on my phone @ WindowsXP then works good, so problem affects linux.
Procedure:
- plug-in bluetooth @ USB
- turn on bluetooth on phone
- use bluetooth-applet (gnome-bluetooth) to send file
- play received file on phone = malformed
Now I have lucid and problem isn't fixed with bluez 4.60.

Regards,
Artur

Hi Artur,

does the problem is reproducible each time with this audio file?
Are you able to reproduce the problem with the script /usr/share/doc/obexd-client/examples/send-files xx:xx:xx:xx:xx:xx your-file? (where xx:xx:xx:xx:xx:xx is the address of your remote device)

Artur Rona (ari-tczew) wrote :

I can't send file by this command: /usr/share/doc/obexd-client/examples/send-files xx:xx:xx:xx:xx:xx your-file
because phone says: Transfer has been cancelled.

Hmm, I have another problem with send-files, it returns a time-out even I authorized the reception on my phone.

Artur Rona (ari-tczew) wrote :

If I'll send file by gnome-bluetooth, then phone can receive files with no problems. But what about malformed files?

Hi Artur,

could you test the obex-client package I did in my ppa (0.22-0ubuntu1~karmic), there is a fix available for file corruption.

Thanks.

Artur,

I forgot to say to add a ppa you can read https://help.launchpad.net/Packaging/PPA/InstallingSoftware my ppa id is ppa:bmillemathias/ppa.
Just install the obexd-client package and not the other bluetooth related package (because they could cause other defect).

kill all obex processes, and try sending the file as you did before.

Thanks.

Changed in bluez (Ubuntu):
status: New → Invalid
Artur Rona (ari-tczew) wrote :

Huh! Fixed! A long time waiting for this! Thanks!

However, obexd-client 0.22 causes that gnome-bluetooth doesn't close window after 100% sent file. Could you check this issue?
Could you get a patch to fix this bug? I want to get patch for karmic and karmic should be sheduled in this bug.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package obexd - 0.22-0ubuntu1

---------------
obexd (0.22-0ubuntu1) lucid; urgency=low

  * New upstream release (LP: #539914):
    - Fix file corruption during PUT operation. (LP: #421684]
    - Fix the response of PUT requests for PBAP.
    - Fix blocking while waiting capability script to exit.
    - Fix compilation issues with driver and plugin options.
    - Fix service driver selection when WHO header is informed.
    - Fix issue with PC-Suite WHO header.
    - Fix issue when mime type exists but is unknown.
    - Fix issue when opening file fails during SendFiles.
    - Fix error code response when there is no default vCard.
    - Fix a memory leak when opening a folder for listing.
 -- Baptiste Mille-Mathias <email address hidden> Mon, 15 Mar 2010 20:43:06 +0100

Changed in obexd (Ubuntu):
status: New → Fix Released
Daniel T Chen (crimsun) on 2010-03-21
Changed in bluez (Ubuntu Karmic):
status: New → Invalid
Artur Rona (ari-tczew) on 2010-03-21
Changed in obexd (Ubuntu Karmic):
assignee: nobody → Artur Rona (ari-tczew)
Artur Rona (ari-tczew) on 2010-03-23
Changed in obexd (Ubuntu Karmic):
assignee: Artur Rona (ari-tczew) → nobody
status: New → Confirmed
tags: added: karmic patch sru
John Dong (jdong) wrote :

ACK from the SRU team for the linked bzr branch. Note that the bug description should be updated with SRU information as mentioned at https://wiki.ubuntu.com/StableReleaseUpdates#Procedure

Artur Rona (ari-tczew) on 2010-03-27
summary: - bluetooth send malformed files
+ [SRU] bluetooth send malformed files
description: updated
Benjamin Drung (bdrung) wrote :

uploaded

Changed in obexd (Ubuntu Karmic):
status: Confirmed → Fix Committed

Accepted obexd into karmic-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Artur Rona (ari-tczew) wrote :

It works!

tags: added: verification-done
removed: verification-needed
Changed in obexd (Ubuntu Karmic):
importance: Undecided → High
milestone: none → karmic-updates
Changed in obexd (Ubuntu):
importance: Undecided → Medium
importance: Medium → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package obexd - 0.14-0ubuntu1.1

---------------
obexd (0.14-0ubuntu1.1) karmic-proposed; urgency=low

  * debian/patches/01-fix_file_corruption_during_PUT.patch:
    - Fix file corruption during PUT operation. (LP: #421684)
 -- Artur Rona <email address hidden> Sat, 27 Mar 2010 23:25:14 +0100

Changed in obexd (Ubuntu Karmic):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers