Dell Wireless 355 Bluetooth card can't turned on in Ubuntu

Bug #277211 reported by Sewar on 2008-10-02
70
This bug affects 13 people
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)
Low
Unassigned

Bug Description

On some Dell laptops which have Dell Wireless 355 Bluetooth card if you turn off the card you have to enable it before you can install it again, this affects both Windows and Linux. You have to use [[http://support.euro.dell.com/support/topics/global.aspx/support/dsn/en/document?docid=2D785CBB1BBFF5F1E040A68F5B282502|an utility]] in Windows to turn it on before you can install its driver again. If you turn the card off in Windows you have to enable it again or Ubuntu won't recognize it.

Card name: Dell Wireless 355 Bluetooth Module (Bluetooth 2.0 + EDR)

You also can't turn it off in Ubuntu to safe power.

Mario Limonciello (superm1) wrote :

although this bug is acknowledged, it won't likely ever be fixed. When machines ship with Ubuntu, they ship in the correct mode. How to change the device from mode to mode is proprietary information obfuscated in the Windows driver.

Changed in dell:
importance: Undecided → Wishlist
status: New → Triaged
Changed in dell:
status: Triaged → Won't Fix
Mario Limonciello (superm1) wrote :

I was thinking about this some more. Can you try this from Ubuntu:

To turn it on:

sudo dellWirelessCtl --sw_bt 1 --bt 1

To turn if off:

sudo dellWirelessCtl --sw_bt 1 --bt 0

If that works, I think I might know what's going on...

Pedro P. Ayala (ppayala) wrote :

It hasn't worked for me. I have tried to turn it on, then off, and on again. after that i have done 'hcitool scan' and I obtain "Device is not available: No such device", also the Bluetooth LED hasn't turned on during the process.

Although my case might be a different one (I don't know if this should be a new bug report) given that I have Ubuntu Intrepid on a XPS M1530.

Tell me if I should proceed in a different way...

Nicolò Chieffo (yelo3) wrote :

I can confirm this bug. (latitude E6400)
When I disable BT from windows, both the BIOS and the dellWirelessCtl think that it is enabled and working.

Nicolò Chieffo (yelo3) wrote :

Pedro can you try this? I don't have windows now so I can't do it by myself:
activateCmosToken 010C

the documentation says: Enable radio transmission from MiniPCI Wireless or Bluetooth module.

There is also another option documented as "This feature will allow users to enable Bluetooth devices so that they will function within the operating system." but the token is listed as "152" which does not seem to be a valid one.

Changed in bluez:
status: Incomplete → Confirmed

Get a Dell Latitude D530 with an Intel Corporation PRO/Wireless 3945ABG [Golan].

Can confirm this. I have fought 1 entire day with this problem trying also solution on Ubuntu forums and launchpad bugs to not having to boot to Windows. I finally boot to Windows, activate the bluetooth and it works in Ubuntu then.

I can confirm that sudo dellWirelessCtl --info give me the same information than the BIOS, but this information seems false because the bluetooth was really off. It seems that's a very specific problem of the wireless card driver.

Note: This also have activated the bluetooth LED that was off before, only indication of the real status of bluetooth it seems.

SjB (s.bahmani) wrote :

I use Dell E6400 and this problem in my laptop occurred .

Geoff Goehle (goehle) wrote :

Is there a workaround for this that doesn't need a windows partition?

Stefan Fleiter (stefan-fleiter) wrote :

I had the same problem.
I always thought that the following line from lsusb would be my bluetooth device
Bus 003 Device 002: ID 0a5c:4500 Broadcom Corp. BCM2046B1 USB 2.0 Hub (part of BCM2046 Bluetooth)
but in reality the following line
Bus 003 Device 003: ID 413c:8126 Dell Computer Corp. Wireless 355 Bluetooth
is the bluetooth adapter and only appeared after having enabled bluetooth in vista.

To find that out a lot of research was needed.

Changed in somerville:
importance: Undecided → Wishlist
status: New → Won't Fix
no longer affects: dell
Timothy R. Chavez (timrchavez) wrote :

The bug task for the somerville project has been removed by an automated script. This bug has been cloned on that project and is available here: https://bugs.launchpad.net/bugs/1305460

no longer affects: somerville
tags: added: bluez-classic

This is reported against an old version of Ubuntu and many things has changed since then. Because of that we won't fix this issue however if this behavior repeats on a modern version please fill a bug report against it and we will take it from there.

Changed in bluez (Ubuntu):
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers