Bluetooth audio skips while the settings dialog is open

Bug #1797002 reported by Ivan on 2018-10-09
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
bluez (Ubuntu)
Low
Unassigned
gnome-control-center (Ubuntu)
Low
Unassigned
pulseaudio (Ubuntu)
Low
Unassigned

Bug Description

all my bluetooth headsets skips terribly after today's system update.
it is heavy noticeable even on audio setting test form.
it work just fine today before i applied updates.

even reinstall ubuntu from scratch - didn't help.

ProblemType: Bug
DistroRelease: Ubuntu 18.04
Package: bluetooth (not installed)
ProcVersionSignature: Ubuntu 4.15.0-36.39-generic 4.15.18
Uname: Linux 4.15.0-36-generic x86_64
ApportVersion: 2.20.9-0ubuntu7.4
Architecture: amd64
CurrentDesktop: ubuntu:GNOME
Date: Tue Oct 9 18:40:44 2018
EcryptfsInUse: Yes
InstallationDate: Installed on 2018-10-09 (0 days ago)
InstallationMedia: Ubuntu 18.04.1 LTS "Bionic Beaver" - Release amd64 (20180725)
InterestingModules: rfcomm bnep btusb bluetooth
MachineType: Hewlett-Packard HP ENVY 17 Notebook PC
ProcEnviron:
 PATH=(custom, no user)
 XDG_RUNTIME_DIR=<set>
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-4.15.0-36-generic root=UUID=fc44a9dc-e173-43fb-ac3a-fdeadb1066e0 ro quiet splash vt.handoff=1
SourcePackage: bluez
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 09/22/2015
dmi.bios.vendor: Insyde
dmi.bios.version: F.66
dmi.board.asset.tag: Type2 - Board Asset Tag
dmi.board.name: 1968
dmi.board.vendor: Hewlett-Packard
dmi.board.version: KBC Version 93.52
dmi.chassis.asset.tag: 5CG32907G7
dmi.chassis.type: 10
dmi.chassis.vendor: Hewlett-Packard
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnInsyde:bvrF.66:bd09/22/2015:svnHewlett-Packard:pnHPENVY17NotebookPC:pvr0885100000305B00000610100:rvnHewlett-Packard:rn1968:rvrKBCVersion93.52:cvnHewlett-Packard:ct10:cvrChassisVersion:
dmi.product.family: 103C_5335KV G=N L=CON B=HP S=ENV
dmi.product.name: HP ENVY 17 Notebook PC
dmi.product.version: 0885100000305B00000610100
dmi.sys.vendor: Hewlett-Packard
hciconfig:
 hci0: Type: Primary Bus: USB
  BD Address: 68:17:29:62:BE:6A ACL MTU: 310:10 SCO MTU: 64:8
  UP RUNNING PSCAN ISCAN INQUIRY
  RX bytes:16831 acl:64 sco:0 events:1798 errors:0
  TX bytes:688571 acl:2399 sco:0 commands:125 errors:0

Ivan (ivmbusiness) wrote :
Ivan (ivmbusiness) wrote :

Also side comment:
`Architecture: amd64` - though i am using: Intel(R) Core(TM) i7-4702MQ CPU @ 2.20GHz

Daniel van Vugt (vanvugt) wrote :

The last bluez update was 3 months ago, so whatever changed for you recently it's not bluez. It's also not pulseaudio (4 months ago).

Most likely this is related to the kernel update that was released 8 days ago.

Changed in bluez (Ubuntu):
status: New → Invalid

This change was made by a bot.

Changed in linux (Ubuntu):
status: New → Confirmed

I'm experiencing this as well. After rebooting today for the first time since September 25, I noticed somewhat choppy audio over bluetooth, first with mp3s on disk, then tried Youtube and it was significantly worse. Same audio content over laptop speakers seems to play without problems. Attaching a pulseaudio verbose log in case that helps.

Daniel van Vugt (vanvugt) wrote :

Ivan:

Please attach a copy of your:
  /var/log/apt/history.log
  /var/log/dpkg.log
So that we can see what packages changed around 10 October.

------

anlag:

Please open a new bug by running:
  ubuntu-bug pulseaudio
and also attach the same files requested above to your new bug.

Changed in linux (Ubuntu):
status: Confirmed → Incomplete
Changed in bluez (Ubuntu):
status: Invalid → Incomplete
Ivan (ivmbusiness) wrote :

Here they are, bu today I've tried to update with check box pre-release updates

Ivan (ivmbusiness) wrote :

and dpkg.log

but again, it doesn't work even with fresh installation over formatted partition, can try it again tomorrow

Daniel van Vugt (vanvugt) wrote :

Thanks Ivan. It appears your bluez and pulseaudio packages last updated on 2018-07-25, so they won't be the cause of any recent regressions.

I think this kernel upgrade on 2018-10-09 might be what changed:
linux-generic:amd64 (4.15.0.29.31 --> 4.15.0.36.38)

Please try downgrading your kernel, like to version 4.14:
http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.14/

Changed in bluez (Ubuntu):
status: Incomplete → Invalid
Daniel van Vugt (vanvugt) wrote :

The change could also be a coincidence and environmental, like:

 * a new 2.4GHz wifi network or device was recently introduced nearby, degrading Bluetooth signal quality.

 * a new Bluetooth device was introduced nearby, degrading the signal quality of audio.

Ivan (ivmbusiness) wrote :

Thanks for you help.

doubt about environmental reason because this laptop also has windows and everything continue to work fine in windows. even tried to reconnect my headsets in windows - still works. but it not convenient to boot in to win in order to use my headset.
Anyway- trying to downgrade my kernel, will key you posted.

Ivan (ivmbusiness) wrote :

After downgrading core bluetooth device disappeared, and installing most recent one didn't help to bring it back.
I am just not enough familiar with linux to be able reinstall it manually.
had to reinstall whole ubuntu from scratch - still have same problems.

Daniel van Vugt (vanvugt) wrote :

That's strange. Your Bluetooth chip looks like a common one that any Linux kernel version should support:
  https://ark.intel.com/products/66889/Intel-Centrino-Wireless-N-2230-Single-Band

As a quick check, please live boot the original 18.04.0 release:
  http://old-releases.ubuntu.com/releases/18.04.0/
and verify it was working in that version before any updates.

Ivan (ivmbusiness) wrote :

Hi,
it was a great idea to test by running without installation,
and i test it on:
ubuntu-16.04.1-desktop-amd64 - don't see my Bluetooth headset
ubuntu-17.10.1-desktop-amd64 - same problems with skipping as with current version
ubuntu-18.04-desktop-amd64 - same problems with skipping as with current version

so basically it doesn't work at all and the biggest mystery as for me is why i was able to use my headset on ubuntu at least for half a day when i installed it first time? and why it works perfect right now on windows...

so i guess the fact that bluetooth works under windows - excluded hardware problem.

Ivan (ivmbusiness) wrote :

hi,
FINALLY, i was able to localize problem :)

all my headsets are skipping only when setting window is open!
so basically when you click test left or test right - it is in settings window and thus it sounds terribly.
But, if you close setting window - every headset works just fine (on online radio for example).

my guess would be that while settings window is open - system constantly looking for available devices and thus interfere with present devices.

Sorry guys for all these troubles, meanwhile solution was so simple.

Thanks

summary: - all my bluetooth headsets skips terribly after todays update
+ Bluetooth audio skips while the settings dialog is open
Changed in bluez (Ubuntu):
status: Invalid → New
no longer affects: linux (Ubuntu)
Changed in bluez (Ubuntu):
importance: Undecided → Low
Changed in gnome-control-center (Ubuntu):
importance: Undecided → Low
Changed in pulseaudio (Ubuntu):
importance: Undecided → Low
tags: added: a2dp a2dp-skip
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers