1310:0001 Bluetooth Dongle does not work anymore in Ubuntu 12.04

Bug #984299 reported by Al Tarakanoff on 2012-04-17
160
This bug affects 55 people
Affects Status Importance Assigned to Milestone
bluez-tools (Ubuntu)
Undecided
Unassigned

Bug Description

I have Bluetooth Dongle:
Bus 008 Device 003: ID 1310:0001 Roper Class 1 Bluetooth Dongle
It was always worked in all Ubuntu distribution, BUT in Ubuntu 12.04 it does not work anymore. Please, fix this regression.

I can see it:
user@machine:~$ hciconfig
hci0: Type: BR/EDR Bus: USB
 BD Address: 00:0B:0D:09:8F:5B ACL MTU: 120:20 SCO MTU: 0:0
 DOWN
 RX bytes:724 acl:0 sco:0 events:26 errors:0
 TX bytes:114 acl:0 sco:0 commands:26 errors:0

It is not blocked:
user@machine:~$ rfkill list
1: hci0: Bluetooth
 Soft blocked: no
 Hard blocked: no

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: bluez-tools 0.1.38+git662e-2ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-22.35-generic-pae 3.2.14
Uname: Linux 3.2.0-22-generic-pae i686
ApportVersion: 2.0.1-0ubuntu4
Architecture: i386
Date: Wed Apr 18 02:11:42 2012
ProcEnviron:
 TERM=xterm
 PATH=(custom, user)
 LANG=ru_RU.utf8
 SHELL=/bin/bash
SourcePackage: bluez-tools
UpgradeStatus: No upgrade log present (probably fresh install)

Al Tarakanoff (al-tarakanoff) wrote :
Vladimir Smagin (belon-ms) wrote :

I confirm this bug. regression in last linux distributions: ubuntu 11.10, 12.04, fedora 16 gnome, fedora 16 kde.

windows and ubuntu 11.04 works fine.

dmesg:
[ 1575.956046] usb 4-1: new full-speed USB device number 4 using uhci_hcd
[ 1576.107126] usb 4-1: New USB device found, idVendor=1310, idProduct=0001
[ 1576.107131] usb 4-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1576.107134] usb 4-1: Product: SiW
[ 1576.107136] usb 4-1: Manufacturer: SiW
[ 1576.107139] usb 4-1: SerialNumber: 9005070D0B00

----

lsusb:
Bus 004 Device 004: ID 1310:0001 Roper Class 1 Bluetooth Dongle

----

hciconfig:
hci0: Type: BR/EDR Bus: USB
BD Address: 00:0B:0D:07:05:90 ACL MTU: 120:20 SCO MTU: 0:0
DOWN
RX bytes:724 acl:0 sco:0 events:26 errors:0
TX bytes:114 acl:0 sco:0 commands:26 errors:0

----

hciconfig hci0 up
Can't init device hci0: Connection timed out (110)

uname -a
Linux laptop.home 3.3.1-5.fc16.i686 #1 SMP Tue Apr 10 20:55:58 UTC 2012 i686 i686 i386 GNU/Linux

CrimInalA (bimbambols) wrote :

Problems with my bluetooth usb dongle here too since 12.04 .
Rarely it works but mostly it doesnt .

This is from a boot which detected the dongle :

Bus 002 Device 002: ID 0a12:0001 Cambridge Silicon Radio, Ltd Bluetooth Dongle (HCI mode)

CrimInalA (bimbambols) wrote :
CrimInalA (bimbambols) wrote :
CrimInalA (bimbambols) wrote :
CrimInalA (bimbambols) wrote :

please understand that the above logs with a working dongle are very very rare . I rebooted and show you now the non working logs

CrimInalA (bimbambols) wrote :
CrimInalA (bimbambols) wrote :

cant upload hciconfig as its not showing anything in this situation .

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bluez-tools (Ubuntu):
status: New → Confirmed
TroubleMakerDV (grayman2000) wrote :

Many dongles stopped to work after 2.6.38-14 or so. I have three different dongles with different IDs, all of these works in vanilla 11.04 and stopped with latest 2.6.x or 3.x (3.0.x .. 3.3.x tested)

summary: - 1310:0001 Bluetooth Dongle does not work anymore in Ubuntu 12.03
+ 1310:0001 Bluetooth Dongle does not work anymore in Ubuntu 12.04
lena lotti (lena-lotti) wrote :

I got exactly the same problem whith the 1310:0001 Bluetooth device stopping working in the new Ubuntu. At the same time my internal HP-bluetooth 03f0:171d still works whithout any problems.

Sergey Golovin (golovin-sv) wrote :

I have the 1310:0001 Bluetooth device working on 2.6.38-13 (kept through some upgrades) and not working on 3.2.0-26 too.
This is with Ubuntu 12.04.

glennric (glennric) wrote :

I have a dongle with the vendor:product id of 0c10:0000 that works fine with natty, but not with oneiric or precise. I just booted a live cd of natty to check that it still works and it does. I also have an HP bluetooth dongle with vendor:product id of 03f0:d404 that still works fine with precise.

From the sound of things this is a kernel module issue that affects quite a few bluetooth dongles. It really seems that someone should be assigned to this bug, and the priority increased.

glennric (glennric) wrote :

I think that this bug and bug #992757 are duplicates of bug #947762. In the latter bug it has been determined that this is a kernel regression, and is reported as kernel bug #42985.

davide (linuxdavide) wrote :

I have a problem with a bluetooth USB-adapter with Ubuntu 12.04 LTS: the bluetooth is on but it is always disabled.
I described that problem in Ubuntu-It.org (http://forum.ubuntu-it.org/viewtopic.php?f=9&t=531009) but the bluetooth doesn't work.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers