Click in folder browser does not draw new selection bar until a file from that folder is loaded.

Bug #45927 reported by Ryan Pavlik on 2006-05-21
14
Affects Status Importance Assigned to Milestone
bluefish (Ubuntu)
Medium
Unassigned

Bug Description

Binary package hint: bluefish

Reproduce:

Open bluefish and a file.
Navigate using the folder browser to another folder - just click on one.
(Optional - you can also go deeper in to child folders with the arrow)
Notice that the blue (or whichever color) bar is not moved from your original folder.
Double-click on a file in the new folder to open it.
Now notice that the selection is in the right place.

This bug makes it difficult to know exactly what file will be opened, especially in a structure where filenames in a folder are similar between several folders. (e.g. a web site with a single index.php in each folder)

Dapper on AMD 64

sam tygier (samtygier) wrote :

confirmed on dapper powerpc

Changed in bluefish:
status: Unconfirmed → Confirmed

I known this issue introduced with (IIRC) GTK 2.8.x. Upstream is not planning to fix those bugs related to the old filebrowser code. The upcoming major release 1.2.x uses new code for the filebrowser, so these issues will disappear. I will have a look at this issue. But I cannot give any guaranteee, that there will be a fix for it.

This issue has been fixed in the upcoming 1.0.6 release.

Changed in bluefish (Ubuntu):
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluefish - 2.0.1-1

---------------
bluefish (2.0.1-1) unstable; urgency=low

  * New upstream release - the first release of the 2.0 series for Debian
    (closes: #570731; LP: #540126). This release fixes these reported issues:
    - Better settings handling (closes: #548272).
    - Improved filebrowser (LP: #45927).
    - Improved syntax highlighting engine (LP: #108628).
    - Improved file operations (LP: #181110).
    - Translated menu descriptions (LP: #371318, #371322). The chosen menu
      name is fine.
    - Improved browser commands and handling (LP: #158891, #348408).
  * Updated and adjusted packaging files.
  * debian/bluefish_icon.xpm: Renamed to debian/bluefish.xpm.
  * debian/bluefish.install: Adjusted.
  * debian/bluefish.menu (icon): Adjusted.
  * debian/bluefish-data.install, debian/bluefish-plugins.install: Added.
  * debian/control: Added bluefish-data, bluefish-dbg and bluefish-plugins.
    (Build-Depends): Dropped deprecated build-dependencies libaspell-dev,
    libgnomeui-dev, libgnomevfs2-dev, libpcre3-dev and dpatch. Added intltool,
    libtool, libenchant-dev and libgucharmap2-dev.
    (Standards-Version): Bumped to 3.8.4.
    (Depends, Suggests): Adjusted. Added gvfs-backends as dependency.
  * debian/copyright: Updated.
  * debian/rules: Rewritten. Dropped dpatch.
    (LDFLAGS): Dropped -Wl,-z,defs because of plugins.
    (config.status:): Adjusted configure switches.
    (install): Install to debian/tmp and list missing files.
    (binary-indep): Added for bluefish-data.
    (binary-arch): Adjusted. Put debugging symbols into bluefish-dbg.
  * debian/watch: Added support for RCs.
  * debian/README.Debian: Dropped (useless with 2.0).
  * debian/README.source: Dropped together with dpatch.
  * debian/patches/: Dropped (obsolete).
  * debian/reportbug/: Dropped.
 -- Lorenzo De Liso <email address hidden> Tue, 29 Jun 2010 21:40:10 +0200

Changed in bluefish (Ubuntu):
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers