Syntax coloration stops when using ""

Bug #108628 reported by Vivien Taillandier on 2007-04-21
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Bluefish
Fix Released
Medium
bluefish (Ubuntu)
Low
Unassigned

Bug Description

When typing code in Bluefish, an error occurs when using the character " to close a line.
You need to refresh the page manually using F5 to force the syntax coloration to restart.

Can you please provide a screenshot or at least a detailed explanation of what exactly you do to reproduce the issue?

Vivien Taillandier (vivien) wrote :

  Sorry for being so long to answer.
  I don't know how to attach several screenshots, but here is the issue.
  Once I wrote the text you can see on the picture in a file called "test.php", I try to insert the line :
     echo "this is a test";

  but before the end, the whole text becomes plain black.

   Hope it helps you to reproduce the issue.

MargaretW (magsandick) wrote :

Hello,
I have been using bluefish for a while and the colouring disappears and then reappears regularly so I just put up with it. However, I'll watch out to see if I can reproduce the issue and if so, I'll let you know.
Margaret

Basilio Kublik (sourcercito) wrote :

Vivien
Thank you for taking the time to report this bug and helping to make Ubuntu better. You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Can you try with development release of Ubuntu, Hardy Heron?

Thanks in advance.

Changed in bluefish:
assignee: nobody → sourcercito
importance: Undecided → Low
status: New → Incomplete
Cesare Tirabassi (norsetto) wrote :

Yes, syntax highlighting is a bit picky, and as Margaret said, I also just put up with it (that's with 1.0.7-4).

Changed in bluefish:
status: Incomplete → Confirmed

I cannot reproduce this issue. My screen never goes black. Maybe you have some old and broken highlighting pattern. These can be updated from the Preferences > Syntax Highlighting menu. The steps are also described in the documentation shipped with the package.

Cesare Tirabassi (norsetto) wrote :

Nope, patterns are default ones, never touched them.
If you take the example above, as soon as I hit the opening brace after else the highlight disappears.
It happens very often with html too, usually after cutting and pasting and in several other occasions which I never cared to record. Can do that if it helps of course.

But did you *update* the pattern via the reset button after updating bluefish?

I tested with a clean bluefish installation and I cannot reproduce the issue.

What is the value of "Highlight #lines" in Edit > Preferences > Editor?

Cesare Tirabassi (norsetto) wrote :

>But did you *update* the pattern via the reset button after updating bluefish?

I never updated, I simply did a clean install of 1.0.7-4 few weeks ago (1 month perhaps).
I did use the reset for the first time when you told me about it (I don't think I ever touched anything in Preferences) and the problem (or rather, the annoying behaviour) is still there.
In the example above, as soon as return is entered after } else { the highlighting disappear.

>What is the value of "Highlight #lines" in Edit > Preferences > Editor?

5, never touched it so I guess it must be the default value.

Anything else I can do to try to clarify this?

Cesare Tirabassi (norsetto) wrote :

Same behaviour when installing from scratch on a virgin Gnome Hardy.

Unassigning Basilio as per a discussion in #ubuntu-bugs.

Changed in bluefish:
assignee: sourcercito → nobody
Changed in bluefish:
status: Unknown → Confirmed
Changed in bluefish:
status: Confirmed → Fix Released
Changed in bluefish (Ubuntu):
status: Confirmed → In Progress
Adrian (akb1982) wrote :

Just though I would mention that I have bluefish version 2.0.0 on Ubuntu 10.04 and this bug dose not happen, maybe upgrade bluefish version? ( Note: the repo version is OLD I think 1.0 and this dose have this problem )

I also thought I had this problem until I realised that I had missed a closing " ; " on the end of a CSS style in the head tags. This coursed all the text in the body tag to be seen as plain text. This could be the course?
Example: - "<head><style type="text/css"> body { color:blue background: black; } </style></head><body>" etc.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bluefish - 2.0.1-1

---------------
bluefish (2.0.1-1) unstable; urgency=low

  * New upstream release - the first release of the 2.0 series for Debian
    (closes: #570731; LP: #540126). This release fixes these reported issues:
    - Better settings handling (closes: #548272).
    - Improved filebrowser (LP: #45927).
    - Improved syntax highlighting engine (LP: #108628).
    - Improved file operations (LP: #181110).
    - Translated menu descriptions (LP: #371318, #371322). The chosen menu
      name is fine.
    - Improved browser commands and handling (LP: #158891, #348408).
  * Updated and adjusted packaging files.
  * debian/bluefish_icon.xpm: Renamed to debian/bluefish.xpm.
  * debian/bluefish.install: Adjusted.
  * debian/bluefish.menu (icon): Adjusted.
  * debian/bluefish-data.install, debian/bluefish-plugins.install: Added.
  * debian/control: Added bluefish-data, bluefish-dbg and bluefish-plugins.
    (Build-Depends): Dropped deprecated build-dependencies libaspell-dev,
    libgnomeui-dev, libgnomevfs2-dev, libpcre3-dev and dpatch. Added intltool,
    libtool, libenchant-dev and libgucharmap2-dev.
    (Standards-Version): Bumped to 3.8.4.
    (Depends, Suggests): Adjusted. Added gvfs-backends as dependency.
  * debian/copyright: Updated.
  * debian/rules: Rewritten. Dropped dpatch.
    (LDFLAGS): Dropped -Wl,-z,defs because of plugins.
    (config.status:): Adjusted configure switches.
    (install): Install to debian/tmp and list missing files.
    (binary-indep): Added for bluefish-data.
    (binary-arch): Adjusted. Put debugging symbols into bluefish-dbg.
  * debian/watch: Added support for RCs.
  * debian/README.Debian: Dropped (useless with 2.0).
  * debian/README.source: Dropped together with dpatch.
  * debian/patches/: Dropped (obsolete).
  * debian/reportbug/: Dropped.
 -- Lorenzo De Liso <email address hidden> Tue, 29 Jun 2010 21:40:10 +0200

Changed in bluefish (Ubuntu):
status: In Progress → Fix Released
Changed in bluefish:
importance: Unknown → Medium
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments

Remote bug watches

Bug watches keep track of this bug in other bug trackers.