bind9-dlz-mysql - Please make a package with this option turned on

Bug #316283 reported by The Nutcracker on 2009-01-12
22
This bug affects 4 people
Affects Status Importance Assigned to Milestone
bind9 (CentOS)
New
Undecided
Unassigned
bind9 (Ubuntu)
Wishlist
Unassigned
Declined for Lucid by Mathias Gug

Bug Description

Binary package hint: bind9

This is not a bug, but a WISHLIST. (I don't know where else to submit this)

Turn the dlz on for mysql and possibly even postgre. For 9.5.0 it is currently in the debian/rules config file, but it is currently set to no on both options.
I have been trying to figure out how to get bind9 to work with mysql and have been pulling my hair out for a week now. The only way to do this is to recompile bind9 from source... and I must be too stupid to do so, because I get about 95 percent of the way through the build, and it complains about something regarding mysql that I don't have on my system.
From what I understand with dlz, is that it is an option you have to actually enable in the zone file to use it. If you don't, it just ignores that part of the system.

Could you please release a package with the option turned ON. If there is a negative performance issue for the majority of bind users by having it compiled with it turned on, please release a new package called bind9-dlz or something like that with the options turned on to work with the mysql and/or postgre databases that can be installed as packages in ubuntu. All other options could be the same as this bind9 package, so maintenance of a 2nd sub package could be minimal/none.

If this is placed in the wrong section, please forgive me as I am not completely familiar with how all this works. Sorry for wasting your time as well as my own, but I am at my wits end.

If this is the right place and you don't want to do it, Why? I don't want to be using apt-get install for some packages and have to compile from code for others. This is to make Ubuntu the best and most useful platform for all, right?

Regards,
Nut

Stephan Ruegamer (sadig) on 2009-01-12
Changed in bind9:
importance: Undecided → Wishlist
Chuck Short (zulcss) wrote :

Thanks for the bug report this will probbaly be considered for karmic + 1.

Regards
chuck

Changed in bind9 (Ubuntu):
status: New → Confirmed
robs (roberto-sebastiano) wrote :

Badly needed.

As now, it means recompiling bind with dlz from source everytime there is a security update on bind

Please put a bind-dlz package in 10.04

Thank,
Roberto

Simone Desantis (s-desantis) wrote :

Yes please add support, it will be usefull for many people.

THX

Jean Claveau (jean-claveau-g) wrote :

Even if it's simple to recompile, it's a pain to keep the packages consistency as bind is often updated.

It would really help for server migration if we could store zones in db.

Thanks in advance.

alex (adrelanex) wrote :

Yes please, we need it !
thanks
alex

Ozzie (ozmedicdoc) wrote :

Yes please! We need:

apt-get bind9-dlz

nabeel (nabeelshikder) wrote :

This still has not been implemented. It would be very useful to have a dlz version of bind9.

Requesting for CentOS and Ubuntu.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers