No text visible after recent updates in Raring

Bug #1132479 reported by Barry Drake
This bug affects 16 people
Affects Status Importance Assigned to Milestone
bibletime (Ubuntu)

Bug Description

No text is visible in any module loaded since recent Raring updates. Text seems to show for a fraction of a second on starting - but then I am left with empty windows. The engine is working Ok and Xiphos shows all installed modules with no problem. Bibletime was working OK just a few days ago under Raring.

Please let me know if any further information is needed.

ProblemType: Bug
DistroRelease: Ubuntu 13.04
Package: bibletime 2.9.1-2ubuntu1
ProcVersionSignature: Ubuntu 3.8.0-7.15-generic 3.8.0
Uname: Linux 3.8.0-7-generic i686
NonfreeKernelModules: fglrx
ApportVersion: 2.8-0ubuntu4
Architecture: i386
Date: Sun Feb 24 15:19:27 2013
InstallationDate: Installed on 2013-02-14 (10 days ago)
InstallationMedia: Ubuntu 13.04 "Raring Ringtail" - Alpha i386 (20130210)
MarkForUpload: True
SourcePackage: bibletime
UpgradeStatus: No upgrade log present (probably fresh install)

Revision history for this message
Barry Drake (b-drake) wrote :
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bibletime (Ubuntu):
status: New → Confirmed
Revision history for this message
Thierry Seewald (thierry-seewald) wrote :

April 17th, ubuntu raring final beta, the bug is this affecting this version of ubuntu.

Revision history for this message
DEFHol (dfleener) wrote :

April 27, 2013, this bug is still affecting the final version (release).

Revision history for this message
DEFHol (dfleener) wrote :

I think I may have found a clue. I've been trying to workaround this issue. It seems to have something to do with the fonts. I opened Bibletime, went into the settings and changed it to a custom font for English language. Any choice made in the column for "Font style" doesn't stay after applying, closing the Configure Bibletime window, and opening it again. It defaults back to the top of the list, whether it be Bold, Italics, or whatever. If any "style" further down the list is chosen, it also doesn't remember the size, and the column of numbers in the "Size" column disappear. If the top choice in the "Font style" column is chosen, the settings, including the size, are remembered, but it doesn't workaround the bug. When the text flashes for a moment, as described in the original Bug Description, it shows the correct font, as chosen in the Configure Bibletime dialogue.

Revision history for this message
HinzundKunz (martin-tlustos) wrote :

When choosing a font and then clicking "apply" quickly several times, the text appears for a second or so until you stop keeping clicking...

Revision history for this message
djmccorrie (djmccorrie) wrote :

This also affects me too

Revision history for this message
Mathieu Agopian (mathieu-agopian) wrote :

It seems like it could be linked to

Revision history for this message
Barry Drake (b-drake) wrote : Re: [Bug 1132479] Re: No text visible after recent updates in Raring

On 06/05/13 13:07, Mathieu Agopian wrote:
> It seems like it could be linked to
> Thoughts?

This seems to be the identical bug to the Ubuntu version. It might be
worth converting the RPM Fedora version to test. Maybe the packager
could take a look?

Regards, Barry.

Barry Drake is a member of the the Ubuntu Advertising team.

Revision history for this message
Barry Drake (b-drake) wrote :

Problem is still there under Saucy Salamander (13.10 testing).

Revision history for this message
Glenn Fletcher (w6-glenn-hz) wrote :

yep ubuntu 13.04 64bit same problem

Revision history for this message
HinzundKunz (martin-tlustos) wrote :

Is there any update? Will Ubuntu fix this issue, or should we talk to the developers instead? They have a crosswire ppa here: (although there isn't a package for raring - yet).

Revision history for this message
Greg Supina (salttalk) wrote :

I have the same problem with the downloaded version in Xubuntu 13.04 (raring).

Also, I cannot compile a version. The build shell scripts do not work. It says it finds CLucene, then it says it cannot find the library, etc.

So there is no version of Bibletime available to use. And I really need Bibletime, since it is one of the most useful tools I have for my work.

But, enough complaining. God bless the guys who created it! It has been extremely useful. I hope you can fix it soon.

Revision history for this message
Nigel Cundy (nigel-cundy) wrote :

I've managed to apply the patch in the fedora bug report, and it seems to work (atleast for me), which was a relief since xiphos just isn't the same.

Save the attachment, then run
tar -xvzf patch.tar.gz
chmod u+x

This will install the various dependencies required to build it -- hopefully I have them all, and build and install the new version

The tarball also contains the output of diff describing the change made to the source, and the modified source file

Revision history for this message
Ubuntu Foundations Team Bug Bot (crichton) wrote :

The attachment "The corrected code and a script to build the working version" seems to be a patch. If it isn't, please remove the "patch" flag from the attachment, remove the "patch" tag, and if you are a member of the ~ubuntu-reviewers, unsubscribe the team.

[This is an automated message performed by a Launchpad user owned by ~brian-murray, for any issues please contact him.]

tags: added: patch
Revision history for this message
Craig McQueen (cmcqueen1975) wrote :

That patch worked for me on Ubuntu 13.04 64-bit.

Revision history for this message
djmccorrie (djmccorrie) wrote :

Patch works for me too thanks!!!

Revision history for this message
ray klassen (rayklassen) wrote :

For your reference.

This bug has been fixed upstream. Maintainers here just have to package bibletime 2.9.2 if at all possible.

Have downloaded and built that version and it doesn't have the problem.

Revision history for this message
Ludek (lusmo) wrote :

Patch works for me (Ubuntu 13.0464 bit) and Bible Time from repository wroks again too! thank You!

Revision history for this message
gmcpheden (gmcpheden) wrote :
Download full text (3.6 KiB)

I ran the patch but it didn't quite work like I hoped it would:


--cut for brevity--
Setting up qt4-linguist-tools (4:4.8.4+dfsg-0ubuntu9.2) ...
Setting up qt4-qmake (4:4.8.4+dfsg-0ubuntu9.2) ...
Setting up qt4-default (4:4.8.4+dfsg-0ubuntu9.2) ...
Setting up libqt4-dev (4:4.8.4+dfsg-0ubuntu9.2) ...
Setting up libqt4-opengl-dev (4:4.8.4+dfsg-0ubuntu9.2) ...
Setting up libqtwebkit-dev (2.3.0-0ubuntu2) ...
Setting up libsword-dev (1.6.2+dfsg-5ubuntu1) ...
Setting up libsword-utils (1.6.2+dfsg-5ubuntu1) ...
Setting up libx11-doc (2:1.5.0-1ubuntu1.1) ...
Setting up manpages-dev (3.44-0ubuntu1) ...
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
./ 8: cd: can't cd to bibletime-2.9.1
cp: cannot create regular file ‘/root/tmp/bibletime-2.9.1/src/frontend/display/bthtmlreaddisplay.cpp’: No such file or directory
sudo: ./ command not found


I tried creating "bibletime-2.9.1/src/frontend/display/" dir tree manually and placed the .cpp file there to no avail. Q.Why is my file missing? The patch doesn't generate it so where is it supposed to come from? Now earlier I inadvertently uninstalled libqt4 and upgraded to libqt5. That was before I found the patch. Do you think that has something to do with it?


|root@lubuntu: dpkg --get-selections | grep libqt
libqt4-dbus:i386 install
libqt4-declarative:i386 install
libqt4-designer:i386 install
libqt4-dev install
libqt4-dev-bin install
libqt4-help:i386 install
libqt4-network:i386 install
libqt4-opengl:i386 install
libqt4-opengl-dev install
libqt4-qt3support:i386 install
libqt4-script:i386 install
libqt4-scripttools:i386 install
libqt4-sql:i386 install
libqt4-sql-mysql:i386 install
libqt4-sql-sqlite:i386 install
libqt4-svg:i386 install
libqt4-test:i386 install
libqt4-xml:i386 install
libqt4-xmlpatterns:i386 install
libqt53d5:i386 install
libqt5core5:i386 install
libqt5dbus5:i386 install
libqt5gui5:i386 install
libqt5location5:i386 install
libqt5network5:i386 install
libqt5opengl5:i386 install
libqt5printsupport5:i386 install
libqt5qml5:i386 install
libqt5quick5:i386 install
libqt5sensors5:i386 install
libqt5sql5:i386 install
libqt5sql5-mysql:i386 install
libqt5v8-5:i386 install
libqt5webkit5:i386 install
libqt5webkit5-dbg install
libqt5widgets5:i386 install
libqtcore4:i386 install
libqtgui4:i386 install
libqtwebkit-dev install
libqtwebkit4:i386 install


So I went ahead and uninstalled libqt5 to see if it would help to no avail. Any suggestions?


|root@lubuntu: dpkg --get-selections | grep libqt5
libqt5gui5:i386 deinstall
libqt5location5:i386 deinstall
libqt5network5:i386 deinstall
libqt5opengl5:i386 deinstall
libqt5printsupport5:i386 deinstall
libqt5qml5:i386 deinstall
libqt5quick5:i386 dein...


Revision history for this message
John Zaitseff (zaitseff) wrote :

I have to admit that this bug has annoyed me: it should have been easy to either apply the patch or package Bibletime 2.9.2, which fixes this problem. So I decided to do so myself.

I have taken the Debian package of Bibletime 2.9.2-1 (in sid) and back-ported to Debian Wheezy, Ubuntu Precise and Ubuntu Raring, both i386 and amd64. No changes were needed to the package itself. I can confirm that it solves this bug; I have tested on Kubuntu Raring i386.

If you would like to use this package, add ONE of the following lines to /etc/apt/sources.list, depending on your distribution:

  deb zapgroup-wheezy main contrib non-free
  deb zapgroup-sid main contrib non-free
  deb zapgroup-precise main restricted
  deb zapgroup-raring main restricted

For more information on this repository, please see . I hope this helps others get around this annoying bug!

Revision history for this message
Barry Drake (b-drake) wrote :

I find the last comment a little odd as the problem has been fixed in the Saucy 11.10 package - update included about a week ago.

Revision history for this message
John Zaitseff (zaitseff) wrote :

Ah, yes, but not all of us are using an unreleased version of Ubuntu! :-)

Revision history for this message
Matthew Ong (matt-d3s0l) wrote :

Hi John,

I tried and added this line to the source.list file

  deb zapgroup-raring main restricted

When I do this: sudo apt-get -yf update<Enter>
Get:42 zapgroup-raring/main Translation-en
Ign raring-updates/restricted Translation-en_US
Ign raring-updates/universe Translation-en_US
Ign zapgroup-raring/main Translation-en
Get:43 zapgroup-raring/restricted Translation-en_US
Ign zapgroup-raring/restricted Translation-en_US
Get:44 zapgroup-raring/restricted Translation-en
Ign zapgroup-raring/restricted Translation-en
Fetched 951 kB in 26s (35.4 kB/s)
Reading package lists... Done
W: GPG error: zapgroup-raring Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 99863C75BBBFE3F5

I saw a Public key here:
and also tried instructions from:

sudo apt-key adv --keyserver --recv-keys
This is returned:
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.LDKIgG6qsp --trustdb-name /etc/apt//trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver --recv-keys
and this
sudo apt-key adv --keyserver --recv-keys
Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.LDKIgG6qsp --trustdb-name /etc/apt//trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver --recv-keys

Still having the same public key error.

How do I add the the public key to be added.

Appreciate your help and thanks in advance.

Revision history for this message
John Zaitseff (zaitseff) wrote :

Hi, Matthew,

> [...]
> I saw a Public key here:
> [...] How do I add the the public key to be added.

1. Download the key:
     wget -N

2. As root, add it to your APT keylist:
     sudo apt-key add aptkey-zapgroup.asc

3. Rerun "sudo apt-get -yf update".

Hope this helps!

Yours truly,

John Zaitseff

John Zaitseff ,--_|\ The ZAP Group
Phone: +61 2 9643 7737 / \ Sydney, Australia
E-mail: <email address hidden> \_,--._*

Revision history for this message
Matthew Ong (matt-d3s0l) wrote :


Thanks very much, the bibletime is finally showing the text on my mint 15 xfce.
Had been hard without this tool.


Revision history for this message
Rodolfo Mendoza (rodolfomendozag) wrote :

No se muestran las palabras (El texto) en Bibletime usando Ubuntu 13.04 (Zorin OS 7)

Revision history for this message
Stan Williams (stanwmusic) wrote :

it is fixed in bibletime 2.9.2-1 but isn't in the software center.

I got Bibletime working on 13.04 Saucy by first completely removing Bibletime and Bibletime- data in Synaptic.
Then I went here here and downloaded bibletime-data_2.5-1_all.deb and secondly at the bottom of page bibletime_2.9.2-1_i386.deb
Install them with GDebi package installer.

Be sure to install bibletime-data_2.5-1_all.deb FIRST so that dependencies will be met,
 then install bibletime_2.9.2-1_i386.deb

It works great and I can SEE the text now!
it gave a notice on each install that an Older package was available and generally desirable or whatever i installed anyway and it works great! I hope this helps.

Revision history for this message
Stan Williams (stanwmusic) wrote :

Oops! I fotgot to post the link to get it at get it here:

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.