Broadcom STA driver from bcmwl-kernel-source should blacklist other Broadcom drivers

Bug #873117 reported by Brian Teague on 2011-10-12
88
This bug affects 14 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
High
Alberto Milone
Nominated for Oneiric by Anthony Wong
Precise
High
Alberto Milone
Quantal
High
Alberto Milone

Bug Description

Hardware:
Broadcom BCM43224 a/b/g/n wireless card on a Macbook Air 3,2.

Bug description:
Because of bug #863799, I'm using the Broadcom proprietary driver from the bcmwl-kernel-source. However, the bcmwl package does not blacklist the new open source drivers for this hardware. Thus, the wl module fails (silently!) and wireless networking stops working.

Proposed solution:
Add the "brcmsmac" and "bcma" drivers to the blacklist file that's created by bcmwl-kernel-source's postinst script. Please find attached a patch that does just that.
---
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.24.
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: NVidia [HDA NVidia], device 0: Cirrus Analog [Cirrus Analog]
   Subdevices: 1/1
   Subdevice #0: subdevice #0
AudioDevicesInUse:
 USER PID ACCESS COMMAND
 /dev/snd/controlC0: brian 1828 F.... pulseaudio
CRDA: Error: [Errno 2] No such file or directory
Card0.Amixer.info:
 Card hw:0 'NVidia'/'HDA NVidia at 0xd3280000 irq 17'
   Mixer name : 'Nvidia MCP89 HDMI'
   Components : 'HDA:10134206,106b3d00,00100301 HDA:10de000c,10de0101,00100200'
   Controls : 29
   Simple ctrls : 13
DistroRelease: Ubuntu 11.10
HibernationDevice: RESUME=UUID=a4a8f872-071a-47a4-900e-31f0b8e3a5f8
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111011)
IwConfig:
 lo no wireless extensions.

 eth0 IEEE 802.11 Access Point: Not-Associated
           Link Quality:5 Signal level:229 Noise level:166
           Rx invalid nwid:0 invalid crypt:0 invalid misc:0
MachineType: Apple Inc. MacBookAir3,2
NonfreeKernelModules: nvidia wl
Package: linux (not installed)
ProcEnviron:
 PATH=(custom, no user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/boot/vmlinuz-3.0.0-12-generic root=UUID=39e6b31c-bc7f-4d9c-ad3f-7e17f9d833ba ro
ProcVersionSignature: Ubuntu 3.0.0-12.20-generic 3.0.4
RelatedPackageVersions:
 linux-restricted-modules-3.0.0-12-generic N/A
 linux-backports-modules-3.0.0-12-generic N/A
 linux-firmware 1.60
Tags: oneiric running-unity
Uname: Linux 3.0.0-12-generic x86_64
UpgradeStatus: No upgrade log present (probably fresh install)
UserGroups: adm admin cdrom dialout lpadmin plugdev sambashare
dmi.bios.date: 11/18/10
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MBA31.88Z.0061.B01.1011181342
dmi.board.asset.tag: Base Board Asset Tag#
dmi.board.name: Mac-942C5DF58193131B
dmi.board.vendor: Apple Inc.
dmi.board.version: MacBookAir3,2
dmi.chassis.type: 10
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-942C5DF58193131B
dmi.modalias: dmi:bvnAppleInc.:bvrMBA31.88Z.0061.B01.1011181342:bd11/18/10:svnAppleInc.:pnMacBookAir3,2:pvr1.0:rvnAppleInc.:rnMac-942C5DF58193131B:rvrMacBookAir3,2:cvnAppleInc.:ct10:cvrMac-942C5DF58193131B:
dmi.product.name: MacBookAir3,2
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.

This bug is missing log files that will aid in diagnosing the problem. From a terminal window please run:

apport-collect 873117

and then change the status of the bug to 'Confirmed'.

If, due to the nature of the issue you have encountered, you are unable to run this command, please add a comment stating that fact and change the bug status to 'Confirmed'.

This change has been made by an automated script, maintained by the Ubuntu Kernel Team.

Changed in linux (Ubuntu):
status: New → Incomplete

apport information

tags: added: apport-collected running-unity
description: updated

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

apport information

Brian Teague (bteague) wrote :

apport logs added

Changed in linux (Ubuntu):
status: Incomplete → Confirmed
affects: linux (Ubuntu) → bcmwl (Ubuntu)

The attachment "Add brcmsmac and bcma to bcmwl's module blacklist" of this bug report has been identified as being a patch. The ubuntu-reviewers team has been subscribed to the bug report so that they can review the patch. In the event that this is in fact not a patch you can resolve this situation by removing the tag 'patch' from the bug report and editing the attachment so that it is not flagged as a patch. Additionally, if you are member of the ubuntu-sponsors please also unsubscribe the team from this bug report.

[This is an automated message performed by a Launchpad user owned by Brian Murray. Please contact him regarding any issues with the action taken in this bug report.]

tags: added: patch
Andrey Zaytsev (andzaytsev) wrote :

My BCM4313 doesn't even work until I blacklist bcma and brcmsmac.
I think the patch that in the first comment should work. Maybe it should be added to the package?

tags: added: blocks-hwcert-enablement
tags: added: blocks-hwcert
Anthony Wong (anthonywong) wrote :

Also affects Thinkpad X121e which uses 14e4:0576 broadcom wifi BCM43224, see bug 914983.

Changed in bcmwl (Ubuntu):
assignee: nobody → Alberto Milone (albertomilone)
importance: Undecided → High
tags: added: precise
tags: added: rls-mgr-p-tracking
Brian Teague (bteague) wrote :

Still an issue in precise beta2.

Greg Vallande (gvallande) wrote :

Hi All,

   I retested this with Precise's daily image and it looks to still be an issue. I've included some logs below:

[jockey log]

Unpacking patch (from .../patch_2.6.1-3_i386.deb) ...
Selecting previously unselected package dkms.
Unpacking dkms (from .../dkms_2.2.0.3-1ubuntu2_all.deb) ...
Selecting previously unselected package bcmwl-kernel-source.
Unpacking bcmwl-kernel-source (from .../bcmwl-kernel-source_5.100.82.38+bdcom-0ubuntu5_i386.deb) ...
Selecting previously unselected package fakeroot.
Unpacking fakeroot (from .../fakeroot_1.18.2-1_i386.deb) ...
Processing triggers for man-db ...
Setting up patch (2.6.1-3) ...
Setting up dkms (2.2.0.3-1ubuntu2) ...
Setting up bcmwl-kernel-source (5.100.82.38+bdcom-0ubuntu5) ...
Loading new bcmwl-5.100.82.38+bdcom DKMS files...
First Installation: checking all kernels...
Building only for 3.2.0-23-generic-pae
Building for architecture i686
Building initial module for 3.2.0-23-generic-pae
Done.

wl:
Running module version sanity check.
 - Original module
   - No original module exists within this kernel
 - Installation
   - Installing to /lib/modules/3.2.0-23-generic-pae/updates/dkms/

depmod......

DKMS: install completed.
update-initramfs: deferring update (trigger activated)
Setting up fakeroot (1.18.2-1) ...
update-alternatives: using /usr/bin/fakeroot-sysv to provide /usr/bin/fakeroot (fakeroot) in auto mode.
Processing triggers for initramfs-tools ...
update-initramfs: Generating /boot/initrd.img-3.2.0-23-generic-pae

2012-04-19 13:38:58,088 DEBUG: BroadcomWLHandler enabled(): kmod enabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2012-04-19 13:38:58,307 DEBUG: BroadcomWLHandler enabled(): kmod enabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2012-04-19 13:38:58,461 DEBUG: BroadcomWLHandler enabled(): kmod enabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2012-04-19 13:38:58,680 DEBUG: BroadcomWLHandler enabled(): kmod enabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2012-04-19 13:38:58,871 DEBUG: BroadcomWLHandler enabled(): kmod enabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2012-04-19 13:38:59,089 DEBUG: BroadcomWLHandler enabled(): kmod enabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2012-04-19 13:38:59,246 DEBUG: BroadcomWLHandler enabled(): kmod enabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2012-04-19 13:38:59,461 DEBUG: BroadcomWLHandler enabled(): kmod enabled, bcm43xx: blacklisted, b43: blacklisted, b43legacy: blacklisted
2012-04-19 13:39:14,933 DEBUG: Shutting down

[rfkill output]

1: tpacpi_bluetooth_sw: Bluetooth
 Soft blocked: yes
 Hard blocked: yes
2: tpacpi_wwan_sw: Wireless WAN
 Soft blocked: yes
 Hard blocked: yes
3: phy0: Wireless LAN
 Soft blocked: yes
 Hard blocked: no

[lspci output]

02:00.0 Network controller: Broadcom Corporation BCM43224 802.11a/b/g/n (rev 01)

Changed in bcmwl (Ubuntu Precise):
status: Confirmed → In Progress
Alberto Milone (albertomilone) wrote :

SRU request:

Please accept bcmwl (5.100.82.38+bdcom-0ubuntu6.1) in proposed:
  * debian/bcmwl-kernel-source.postinst:
    - Blacklist brcmfmac, brcmsmac and bcma so that they don't
      conflict with the closed driver (LP: #873117)

Testing this change it's very straightforward since it will allow the close broadcom to load properly when the open drivers are blacklisted.

Alberto Milone (albertomilone) wrote :

subscribed the SRU team for review

Hello Brian, or anyone else affected,

Accepted bcmwl into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in bcmwl (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Brian Teague (bteague) wrote :

Fixed with the new bcmwl package in -proposed. Good to see this going into Precise.

tags: added: verification-done
removed: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 5.100.82.38+bdcom-0ubuntu6.1

---------------
bcmwl (5.100.82.38+bdcom-0ubuntu6.1) precise-proposed; urgency=low

  * debian/bcmwl-kernel-source.postinst:
    - Blacklist brcmfmac, brcmsmac and bcma so that they don't
      conflict with the closed driver (LP: #873117)
 -- Alberto Milone <email address hidden> Mon, 23 Apr 2012 16:11:56 +0200

Changed in bcmwl (Ubuntu Precise):
status: Fix Committed → Fix Released
Changed in bcmwl (Ubuntu Quantal):
status: Fix Committed → Fix Released
To post a comment you must log in.