doing dist-upgrade got error related do Broadcom

Bug #1878045 reported by joaorami on 2020-05-11
46
This bug affects 7 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
Undecided
Unassigned

Bug Description

I had a working 20.04 installation running, including the Broadcom Wifi. After upgrade to 20.10 the Broadcom Wifi is not working. I tried several suggestions and always end to an error similiar to this one:
...
Building initial module for 5.4.0-30-generic
ERROR (dkms apport): kernel package linux-headers-5.4.0-30-generic is not supported
Error! Application of patch 0028-add-support-for-linux-5.6.patch failed.
Check /var/lib/dkms/bcmwl/6.30.223.271+bdcom/build/ for more information.
dpkg: error processing package bcmwl-kernel-source (--configure):
 installed bcmwl-kernel-source package post-installation script subprocess returned error exit status 6
Errors were encountered while processing:
 bcmwl-kernel-source
E: Sub-process /usr/bin/dpkg returned an error code (1)
...

ProblemType: Bug
DistroRelease: Ubuntu 20.10
Package: ubuntu-release-upgrader-core 1:20.10.1
ProcVersionSignature: Ubuntu 5.4.0-30.34-generic 5.4.34
Uname: Linux 5.4.0-30-generic x86_64
ApportVersion: 2.20.11-0ubuntu33
Architecture: amd64
CasperMD5CheckResult: skip
CrashDB: ubuntu
Date: Mon May 11 17:16:43 2020
InstallationDate: Installed on 2020-02-22 (78 days ago)
InstallationMedia: Ubuntu 19.10 "Eoan Ermine" - Release amd64 (20191017)
PackageArchitecture: all
SourcePackage: ubuntu-release-upgrader
Symptom: dist-upgrade
UpgradeStatus: Upgraded to groovy on 2020-05-07 (3 days ago)
VarLogDistupgradeXorgFixuplog:
 INFO:root:/usr/bin/do-release-upgrade running
 INFO:root:No xorg.conf, exiting
mtime.conffile..etc.update-manager.release-upgrades: 2020-05-07T09:26:37.178586

joaorami (joaomppr) wrote :
affects: ubuntu-release-upgrader (Ubuntu) → bcmwl (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bcmwl (Ubuntu):
status: New → Confirmed
Garth McDermott (garthm) wrote :

Fresh 20.10 install, experienced the same issue caused when attempting either manually attempting to install "bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu6_amd64.deb" or using "Additional Drivers".

sudo apt-get remove --purge bcmwl-kernel-source

Synaptic Package Manager installed:
broadcom-sta-source
broadcom-sta-dkms
broadcom-sta-common

(It also added some dependencies)

Works again!

joaorami (joaomppr) wrote :

I did same and its working again, thanks! What I did:

apt purge bcmwl-kernel-source
apt-get install broadcom-sta-source
apt-get install broadcom-sta-dkms
apt-get install broadcom-sta-common

Wladimir Mutel (mwg) wrote :

Thanks, this eliminated the problem.
The only unexplained thing is what was the urge to break the "old" package which perfectly worked before. If Ubuntu planned to reorder/restructure package names, the reasonable way would be to turn 'bcmwl-kernel-source' into a dummy/transitional package which would pull new broadcom-sta-* packages as its dependencies. But probably Ubuntu plans were more mysterial than that.

apt-ghetto (apt-ghetto) wrote :

Thank you for this solution. It is working again.

Petr Janecek (janecekp) wrote :

There seems to be a bug in

/usr/src/bcmwl-6.30.223.271+bdcom/patches/0028-add-support-for-linux-5.6.patch

-- all the paths have the 'src' component doubled. Changed
all 'src/src' to just 'src' and it compiles and works for
me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers