bcmwl 6.30.223.271+bdcom-0ubuntu1~1.1 ADT test failure with linux-hwe-edge 4.13.0-16.19~16.04.3 [error: ‘struct net_device’ has no member named ‘last_rx’]

Bug #1724863 reported by Seth Forshee on 2017-10-19
80
This bug affects 21 people
Affects Status Importance Assigned to Milestone
bcmwl (Ubuntu)
Undecided
Marcelo Cerri
Xenial
Undecided
Unassigned

Bug Description

[Impact]

Currently the DKMS package bcmwl-kernel-source fails to install in
supported custom kernels that are based on 4.11 or 4.13. That includes
the current 4.11 hwe-edge and the upcoming 4.13 hwe-edge kernels and
some of the custom and cloud kernels as well.

[Test Case]

Install the bcmwl-kernel-source package with the 4.13 hwe-edge kernel
from -proposed. The package installation should proceed without any
errors.

[Regression Potential]

Although new patches were added, the regression risk is very low since
the new changes are conditionally compiled based on the kernel version.

Besides that the new package was tested with the following kernels in an
amd64 environment:

- linux-generic 4.4
- linux-hwe 4.10
- linux-hwe-edge 4.11
- linux-hwe-edge 4.13 (from xenial-proposed)
- linux-azure 4.11
- linux-azure-edge 4.13 (which is in process of getting promoted to
  xenial-proposed)

[Original Description]

Testing failed on:
    amd64: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/amd64/b/bcmwl/20171018_120646_2caa6@/log.gz
    i386: https://objectstorage.prodstack4-5.canonical.com/v1/AUTH_77e2ada1e7a84929a74ba3b87153c0ac/autopkgtest-xenial/xenial/i386/b/bcmwl/20171018_120820_2caa6@/log.gz

Seth Forshee (sforshee) wrote :
tags: added: kernel-adt-failure
Seth Forshee (sforshee) on 2017-10-25
tags: added: kernel-adt-failure-hwe-edge-4.11
removed: kernel-adt-failure
tags: added: kernel-adt-failure-hwe-edge-4.13
removed: kernel-adt-failure-hwe-edge-4.11
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bcmwl (Ubuntu):
status: New → Confirmed
Marcelo Cerri (mhcerri) on 2017-10-26
Changed in bcmwl (Ubuntu):
assignee: nobody → Marcelo Cerri (mhcerri)
status: Confirmed → In Progress
Andy Whitcroft (apw) wrote :

SRU template please.

Marcelo Cerri (mhcerri) on 2017-10-27
description: updated

you can now use wifi you need to enter in console commands
sudo modprobe -r b43
sudo modprobe b43

there might be a connection with
https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bug/1728353

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bcmwl (Ubuntu Xenial):
status: New → Confirmed
Stephan Springer (geryon) wrote :

This has already been reported months ago, see bug 1713638.

Stephan Springer (geryon) wrote :

Actually, there are two bugs here:
 * Build for 4.11 fails, see bug 1713638 (patch included there).
 * Build for 4.13 fails: I can confirm that, but a different patch is needed. I personally can't run this kernel yet because of that bug.

Lots of similar bugs have been reported, see https://bugs.launchpad.net/ubuntu/+source/bcmwl/+bugs?orderby=-date_last_updated&start=0 (for different kernel versions, including also 4.4 and 4.10).

Hello Seth, or anyone else affected,

Accepted bcmwl into xenial-proposed. The package will build now and be available at https://launchpad.net/ubuntu/+source/bcmwl/6.30.223.271+bdcom-0ubuntu1~1.2 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation on how to enable and use -proposed.Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested and change the tag from verification-needed-xenial to verification-done-xenial. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed-xenial. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in bcmwl (Ubuntu Xenial):
status: Confirmed → Fix Committed
tags: added: verification-needed verification-needed-xenial

I've tested it with kernel 4.11.0-14-generic and 4.13.0-16-generic, and it works for both: It compiles and after booting that kernel, Wifi works.

Thanks!

dpkg -l | egrep 'bcmwl|linux-image-4'
ii bcmwl-kernel-source 6.30.223.271+bdcom-0ubuntu1~1.2 amd64…
ii linux-image-4.10.0-38-generic 4.10.0-38.42~16.04.1 amd64…
ii linux-image-4.11.0-14-generic 4.11.0-14.20~16.04.1 amd64…
ii linux-image-4.13.0-16-generic 4.13.0-16.19~16.04.3 amd64…

tags: added: verification-done-xenial
removed: verification-needed-xenial
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bcmwl - 6.30.223.271+bdcom-0ubuntu1~1.2

---------------
bcmwl (6.30.223.271+bdcom-0ubuntu1~1.2) xenial; urgency=medium

  * debian/dkms.conf.in,
    debian/patches/0024-add-support-for-linux-4.12.patch (LP: #1724863):
    - Add support for Linux 4.12.
      Thanks to Dmitriy Budnik for reporting the problem and for pointing
      to part of the solution.
  * debian/dkms.conf.in,
    debian/patches/0023-add-support-for-linux-4.11.patch (LP: #1724863):
    - Add support for Linux 4.11.
      Credit for the patch goes to Krzysztof Kolasa.

 -- Marcelo Henrique Cerri <email address hidden> Mon, 16 Oct 2017 11:20:40 -0200

Changed in bcmwl (Ubuntu Xenial):
status: Fix Committed → Fix Released

The verification of the Stable Release Update for bcmwl has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regressions.

I tried to install the latest bcmwl-kernel-source and got the following ...

sudo apt install bcmwl-kernel-source
Reading package lists... Done
Building dependency tree
Reading state information... Done
The following packages will be upgraded:
  bcmwl-kernel-source
1 upgraded, 0 newly installed, 0 to remove and 282 not upgraded.
Need to get 1,544 kB of archives.
After this operation, 5,120 B of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com/ubuntu xenial-updates/restricted amd64 bcmwl-kernel-source amd64 6.30.223.271+bdcom-0ubuntu1~1.2 [1,544 kB]
Fetched 1,544 kB in 0s (5,683 kB/s)
(Reading database ... 177392 files and directories currently installed.)
Preparing to unpack .../bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu1~1.2_amd64.deb ...
Removing all DKMS Modules
Done.
Unpacking bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.2) over (6.30.223.271+bdcom-0ubuntu1~1.1) ...
Setting up bcmwl-kernel-source (6.30.223.271+bdcom-0ubuntu1~1.2) ...
Loading new bcmwl-6.30.223.271+bdcom DKMS files...
Building only for 4.13.0-26-generic
Building for architecture x86_64
Module build for the currently running kernel was skipped since the
kernel source for this kernel does not seem to be installed.
modprobe: ERROR: ../libkmod/libkmod.c:586 kmod_search_moddep() could not open moddep file '/lib/modules/4.13.0-26-generic/modules.dep.bin'
modprobe: FATAL: Module wl not found in directory /lib/modules/4.13.0-26-generic
update-initramfs: deferring update (trigger activated)
Processing triggers for initramfs-tools (0.122ubuntu8.8) ...
update-initramfs: Generating /boot/initrd.img-4.10.0-28-generic
W: Possible missing firmware /lib/firmware/i915/kbl_dmc_ver1_01.bin for module i915

I tested with the kernel 4.13.0-32 and It works!!!!

summary: bcmwl 6.30.223.271+bdcom-0ubuntu1~1.1 ADT test failure with linux-hwe-
- edge 4.13.0-16.19~16.04.3
+ edge 4.13.0-16.19~16.04.3 [error: ‘struct net_device’ has no member
+ named ‘last_rx’]
Diego (diego-luna-1711) wrote :

I had this problem WITH the package bcmwl-kernel-source 6.30.223.271+bdcom-0ubuntu1~1.2. But found the solution here: https://elementaryos.stackexchange.com/questions/15842/bcm43142-and-linux-kernel-4-15-0-24-generic

"I had to download the package for 18.04LTS (https://packages.ubuntu.com/bionic/bcmwl-kernel-source) and install it using:

sudo apt-get remove --purge bcmwl-kernel-source
sudo dpkg -i bcmwl-kernel-source_6.30.223.271+bdcom-0ubuntu4_amd64.deb"

That worked perfectly for me. Fortunately, I found this solution before rebooting so I've never lost conection in the process.
My ubuntu kernel is 16.04.13. My wifi card is BCM4313 802.11bgn.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments