Comment 12 for bug 1358966

@Aldo Yes, you can fix it even on 14.04. You can download this new package from http://packages.ubuntu.com/vivid/bcmwl-kernel-source and install it directly typing: dpkg -i bcmwl-kernel-source_6.30.223.248+bdcom-0ubuntu2_amd64.deb and then it should be ok. Package has not any other dependencies therefore there shouldnt be any risk to your system.

I have tried it for myself and it solved me the kernel 3.17 installation problem od Ubuntu 14.04