bash completion broken with '~' expansion

Bug #1288314 reported by Scott Moser on 2014-03-05
48
This bug affects 10 people
Affects Status Importance Assigned to Milestone
bash-completion (Ubuntu)
High
Unassigned

Bug Description

After bash upgrade, I'm now not able to tab complete things like this:

$ whoami
smoser
$ echo ~/
/home/smoser/
$ mkdir ~/x
$ echo "hi mom" > ~/x/greeting.txt
$ echo "by mom" > ~/x/salutation.txt
$ echo "filed bug" > ~/x/work.log
$ ls ~/x/<tab><tab>
  # shows nothing

$ ls /home/smoser/x/<tab><tab>
greeting.txt salutation.txt work.log

$ cd
$ ls ./x/<tab><tab>
greeting.txt salutation.txt work.log

So it seems that the ~/ is not getting resolved by the tab completion.

ProblemType: Bug
DistroRelease: Ubuntu 14.04
Package: bash 4.3-2ubuntu1
ProcVersionSignature: Ubuntu 3.13.0-15.35-generic 3.13.5
Uname: Linux 3.13.0-15-generic x86_64
ApportVersion: 2.13.2-0ubuntu5
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Mar 5 11:02:52 2014
EcryptfsInUse: Yes
InstallationDate: Installed on 2011-10-19 (868 days ago)
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release amd64 (20111012)
SourcePackage: bash
UpgradeStatus: Upgraded to trusty on 2013-05-20 (289 days ago)

Related branches

Scott Moser (smoser) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bash (Ubuntu):
status: New → Confirmed
Mathew Hodson (mathew-hodson) wrote :

This bug was fixed in the package bash-completion - 1:2.1-2ubuntu4

---------------
bash-completion (1:2.1-2ubuntu4) trusty; urgency=medium

  * fix _quote_readline_by_ref to:
    - avoid escaping 1st '~' (lp: #1288314)
    - avoid quoting if empty, else expansion without args only shows dirs
      (lp: #1288031)
    - replace double escaping to single (eg for completing file/paths with
      spaces)
 -- JuanJo Ciarlante <email address hidden> Thu, 13 Mar 2014 19:43:22 -0300

affects: bash (Ubuntu) → bash-completion (Ubuntu)
Changed in bash-completion (Ubuntu):
importance: Undecided → High
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers