Ubuntu

When network is unreachable, banshee spins 200% cpu (and may lock entire system if unlucky, requiring unclean reboot)

Reported by Alan Jenkins on 2011-10-16
236
This bug affects 49 people
Affects Status Importance Assigned to Milestone
Banshee
Fix Released
Critical
banshee (Ubuntu)
High
Rodney Dawes
Oneiric
Undecided
Unassigned
Precise
High
Rodney Dawes

Bug Description

System Settings -> Network -> Network proxy
You can set e.g. "localhost", port "9090", assuming you're not running any service on that port.

Now run Banshee, and attempt to use the Online Media->Internet Archive.

Banshee will stop responding to any input, and go into an infinite loop (on at least two different threads).

It is possible to reproduce situations where Banshee will hang while a context menu is open. It is then not possible to switch to a different application. An inexperienced user would be forced to hard-reboot the machine, which could cause data loss.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: banshee 2.2.0-1ubuntu2
ProcVersionSignature: Ubuntu 2.6.38-11.50-generic 2.6.38.8
Uname: Linux 2.6.38-11-generic x86_64
ApportVersion: 1.23-0ubuntu3
Architecture: amd64
Date: Sun Oct 16 11:29:30 2011
ProcEnviron:
 PATH=(custom, user)
 SHELL=/bin/bash
SourcePackage: banshee
UpgradeStatus: Upgraded to oneiric on 2011-10-14 (2 days ago)

Alan Jenkins (aj504) wrote :

Could you run this test with Banshee executed in a terminal as "banshee
--debug", then in a separate terminal, run "killall -SIGQUIT banshee" after it
starts hanging?

Thanks.

  status incomplete

--
Kind regards,
Loong Jin

Changed in banshee (Ubuntu):
status: New → Incomplete
Changed in banshee:
importance: Unknown → Medium
status: Unknown → New
Download full text (27.1 KiB)

k! I discovered that this happens without performing any action at all. You just have to wait a few seconds after the Banshee window has appeared.

Here is the full output. I typed you a MARK before I sent the SIGQUIT.

[1 Debug 16:23:29.902] Core service started (NereidPlayerInterface, 0.476668)
[1 Debug 16:23:29.904] Extension service started (DapService, 0.001555)
[1 Info 16:23:29.910] Updating web proxy from GConf
[1 Debug 16:23:29.920] Direct connection, no proxy in use
[1 Debug 16:23:29.935] Extension service started (GnomeService, 0.029964)
[1 Debug 16:23:29.940] Extension service started (AmazonMp3DownloaderService, 0.005363)
[1 Debug 16:23:29.943] Extension service started (PodcastService, 0.002514)
[1 Debug 16:23:29.946] Extension service started (CoverArtService, 0.003202)
[1 Debug 16:23:29.958] Extension service started (GStreamerCoreService, 0.011784)
[1 Debug 16:23:29.959] Extension service started (DaapService, 0.000998)
[1 Debug 16:23:29.967] Using GNOME 2.22 API for Multimedia Keys
[1 Debug 16:23:29.967] Extension service started (MultimediaKeysService, 0.007902)
[1 Debug 16:23:29.988] Extension service started (MprisService, 0.013786)
[1 Debug 16:23:30.059] Extension service started (SoundMenuService, 0.070891)
[1 Debug 16:23:30.084] Extension service started (EmusicService, 0.025282)
[1 Debug 16:23:30.102] Extension service started (AudioCdService, 0.017732)
[1 Debug 16:23:30.111] Extension service started (BpmService, 0.009302)
[1 Debug 16:23:30.131] Audioscrobbler state: connected
[1 Debug 16:23:30.133] Extension service started (AudioscrobblerService, 0.021696)
[1 Info 16:23:30.134] All services are started 1.080751
[1 Debug 16:23:30.440] Creating Pango.Layout, configuring Cairo.Context
[1 Debug 16:23:30.527] Extension source loaded: Now Playing
[1 Debug 16:23:30.541] Extension source loaded: Radio
[1 Debug 16:23:30.552] Extension source loaded: Internet Archive
[1 Debug 16:23:30.583] Extension source loaded: Audiobooks
[1 Info 16:23:30.589] AmazonMP3 store redirect URL: https://one.ubuntu.com/music/store/amz/
[1 Debug 16:23:30.590] Extension source loaded: Amazon MP3 Store
[1 Debug 16:23:30.594] Extension source loaded: Miro Guide
[1 Debug 16:23:30.624] Extension source loaded: Last.fm
** (Banshee:24966): DEBUG: SyncDaemon already running, initializing SyncdaemonDaemon object

(Banshee:24966): libsoup-WARNING **: No feature manager for feature of type 'U1RequestChrome'
[1 Debug 16:23:30.729] Extension source loaded: Ubuntu One Music Store
[1 Debug 16:23:30.778] Extension source loaded: Magnatune
[1 Debug 16:23:30.784] Starting GTK main loop
[1 Debug 16:23:30.996] Creating Pango.Layout, configuring Cairo.Context
[1 Debug 16:23:31.042] Creating Pango.Layout, configuring Cairo.Context
[1 Info 16:23:31.155] nereid Client Started
[1 Debug 16:23:31.157] Delayed Initializating Banshee.MediaEngine.PlayerEngineService
[1 Debug 16:23:31.178] (libbanshee:player) Audiosink has volume: YES
[1 Debug 16:23:31.186] (libbanshee:player) Using system (gst-plugins-good) equalizer element
[1 Debug 16:23:31.240] Player state change: NotReady -> Ready
[1 Debug 16:23:31.244] Loaded equalizer presets: 0.000224
[1 Debug 16:23:31.250] Se...

Alan Jenkins (aj504) wrote :

Ah. Disabling the Ubuntu music store plugin avoids the problem.

Alan Jenkins (aj504) on 2011-10-17
Changed in banshee (Ubuntu):
status: Incomplete → New

On 18/10/2011 00:26, Alan Jenkins wrote:
> Ah. Disabling the Ubuntu music store plugin avoids the problem.
>

  subscribe rodney.dawes
--
Kind regards,
Loong Jin

Chow Loong Jin (hyperair) wrote :

On 18/10/2011 00:26, Alan Jenkins wrote:
> Ah. Disabling the Ubuntu music store plugin avoids the problem.
>

Whoops, looks like he changed his username.

  subscribe dobey
--
Kind regards,
Loong Jin

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in banshee (Ubuntu):
status: New → Confirmed
Changed in banshee:
status: New → Invalid
Changed in banshee:
importance: Medium → Unknown
status: Invalid → Unknown
Changed in banshee:
importance: Unknown → Critical
status: Unknown → New
Changed in banshee:
status: New → Incomplete
Chow Loong Jin (hyperair) wrote :

As I mentioned in https://bugs.launchpad.net/banshee/+bug/865697/comments/9, please try seeing if the Banshee package from the banshee-daily PPA fixes the issue.

Adauto Serpa (adautoserpa) wrote :

The bug occurs when the PC is not connected to internet. The extension that causes the bug is Ubuntu One Music Store, extension tested each one. Just do not know how to solve : )
After disable the extension is working perfectly so far.
Sorry my English.

Rodney Dawes (dobey) on 2011-10-24
Changed in banshee (Ubuntu):
assignee: nobody → Rodney Dawes (dobey)
Changed in banshee (Ubuntu):
importance: Undecided → High
status: Confirmed → Triaged
Rodney Dawes (dobey) on 2011-10-24
Changed in banshee (Ubuntu):
status: Triaged → In Progress
steviedons (steviedons) wrote :

I am seeing the same issue with banshee whilst not connected to the internet the Ubuntu One extension causes either banshee to crash or to start taking all system resources:

  PID USER PR NI VIRT RES SHR S %CPU %MEM TIME+ COMMAND
 7507 steve 20 0 2062m 96m 42m S 341 2.4 1:36.42 banshee
 1821 steve 20 0 828m 272m 45m R 11 6.9 17:25.95 compiz
 1272 root 20 0 195m 69m 18m S 1 1.8 17:13.83 Xorg

Log attached for banshee started with --debug

steviedons (steviedons) wrote :

Tried the daily build for banshee but still the same issue:

Get:6 http://ppa.launchpad.net/banshee-team/banshee-daily/ubuntu/ oneiric/main banshee-extension-soundmenu amd64 2.2.0+git20111024.r1.61b7d4a-0ubuntu1+oneiric [52.0 kB]
Get:7 http://ppa.launchpad.net/banshee-team/banshee-daily/ubuntu/ oneiric/main banshee-extension-ubuntuonemusicstore amd64 2.2.0+git20111024.r1.61b7d4a-0ubuntu1+oneiric [48.7 kB]

I have disabled the extension for now so I can use Banshee.

Hello Alan, or anyone else affected,

Accepted banshee into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in banshee (Ubuntu Oneiric):
status: New → Fix Committed
tags: added: verification-needed

Hi, I just installed the update from proposed, now Banshee uses 200% CPU whenever I try to select any of the "Online Media" choices in the menu, not just Ubuntu One Music Store. I am connected to teh Internetz, no proxies or anything. First time I started Banshee after update it asked me to register on U1, even though I already am and have been in there from Banshee before, and then crashed.

I need to killall -15 banshee to close it. Never had any problems with Banshee before but found this bug now when this problem appeared after updating.

Changed in banshee:
status: Incomplete → Fix Released
Vadim Rutkovsky (roignac) wrote :

Ubuntu One Music Store seems to work with incorrect proxy.
However, this update breaks Miro Guide and Amazon MP3 Store plugins - CPU usage is up to 100% and these plugins are unusable.

banshee --debug ouput after clicking on Amazon Store:
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.NullReferenceException: Object reference not set to an instance of an object
  at Banshee.WebSource.WebSource.Activate () [0x00000] in <filename unknown>:0
  at Banshee.Sources.SourceManager.SetActiveSource (Banshee.Sources.Source source, Boolean notify) [0x00000] in <filename unknown>:0
  at Banshee.Sources.SourceManager.SetActiveSource (Banshee.Sources.Source source) [0x00000] in <filename unknown>:0
  at Banshee.Sources.Gui.SourceView.OnButtonPressEvent (Gdk.EventButton press) [0x00000] in <filename unknown>:0
  at Gtk.Widget.buttonpressevent_cb (IntPtr widget, IntPtr evnt) [0x00000] in <filename unknown>:0
   at GLib.ExceptionManager.RaiseUnhandledException(System.Exception e, Boolean is_terminal)
   at Gtk.Widget.buttonpressevent_cb(IntPtr widget, IntPtr evnt)
   at Gtk.Application.gtk_main()
   at Gtk.Application.Run()
   at Banshee.Gui.GtkBaseClient.Run()
   at Banshee.Gui.GtkBaseClient.Startup()
   at Hyena.Gui.CleanRoomStartup.Startup(Hyena.Gui.StartupInvocationHandler startup)
   at Banshee.Gui.GtkBaseClient.Startup()
   at Banshee.Gui.GtkBaseClient.Startup(System.String[] args)
   at Nereid.Client.Main(System.String[] args)
   at System.AppDomain.ExecuteAssembly(System.AppDomain , System.Reflection.Assembly , System.String[] )
   at System.AppDomain.ExecuteAssemblyInternal(System.Reflection.Assembly a, System.String[] args)
   at System.AppDomain.ExecuteAssembly(System.String assemblyFile, System.Security.Policy.Evidence assemblySecurity, System.String[] args)
   at System.AppDomain.ExecuteAssembly(System.String assemblyFile)
   at Booter.Booter.BootClient(System.String clientName)
   at Booter.Booter.Main()

I realize that the -1ubuntu3 was just uploaded with a fix for these bugs, but
2.2.1 was just released and will be uploaded shortly (as soon as it gets
uploaded into Debian). It would be nice if we could have the users test against
this version instead.

--
Kind regards,
Loong Jin

Download full text (6.5 KiB)

I just updated my system and it is not fixed yet, or released yet. But I found some more information that might give some more clues on what actually happens. Because it is not just people that are disconnected from the internet, it affects also people that did not sign up for the ubuntu one service as well, whether they are connected to the internet or not.
If I turn off the ubuntu one store, Banshee works fine, but as soon as I hit the ubuntu store option it starts spinning at 341% (!) CPU (on a quadcore, most probably it just starts using all available processor power), and Banshee is completely stuck. (I once tried to leave it for a while, but that just drained my battery)
This is the debug output that immediately arises when I hit the option. It searches for a folder that does not exist on my computer. Despite the warnings that occur, it apparently continues nevertheless, trying to resolve a NULL somewhere....

(Banshee:3546): libsoup-WARNING **: No feature manager for feature of type 'U1RequestChrome'
[1 Debug 16:02:26.942] Extension source loaded: Ubuntu One-muziekwinkel

** (Banshee:3546): WARNING **: Error calling get_info: Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/dbus/service.py", line 702, in _message_cb
    retval = candidate_method(self, *args, **keywords)
  File "/usr/lib/python2.7/dist-packages/ubuntuone-client/ubuntuone/platform/linux/dbus_interface.py", line 1041, in get_info
    return self.syncdaemon_folders.get_info(path)
  File "/usr/lib/python2.7/dist-packages/ubuntuone-client/ubuntuone/syncdaemon/interaction_interfaces.py", line 640, in get_info
    mdobj = self.fs.get_by_path(path.encode('utf-8'))
  File "/usr/lib/python2.7/dist-packages/ubuntuone-client/ubuntuone/syncdaemon/filesystem_manager.py", line 781, in get_by_path
    mdid = self._idx_path[path]
KeyError: '/home/bdekoning/.ubuntuone/Purchased from Ubuntu One'

** (Banshee:3546): CRITICAL **: syncdaemon_folder_info_get_subscribed: assertion `SYNCDAEMON_IS_FOLDER_INFO (finfo)' failed
** (Banshee:3546): DEBUG: Loading the real store page

** (Banshee:3546): WARNING **: Got less number of items in credentials hash table than expected!

** (Banshee:3546): WARNING **: Error rescanning Purchased Music: Bestand of map bestaat niet

(Banshee:3546): GLib-CRITICAL **: g_str_has_prefix: assertion `str != NULL' failed
[1 Debug 16:02:37.459] U1MS: Url Loaded:
Marshaling url-loaded signal
Exception in Gtk# callback delegate
  Note: Applications can use GLib.ExceptionManager.UnhandledException to handle the exception.
System.Reflection.TargetInvocationException: Exception has been thrown by the target of an invocation. ---> System.NullReferenceException: Object reference not set to an instance of an object
  at Banshee.UbuntuOneMusicStore.UbuntuOneMusicStoreSource.OnDefaultStoreUrlLoaded (System.Object o, UbuntuOne.UrlLoadedArgs args) [0x00000] in <filename unknown>:0
  at (wrapper managed-to-native) System.Reflection.MonoMethod:InternalInvoke (System.Reflection.MonoMethod,object,object[],System.Exception&)
  at System.Reflection.MonoMethod.Invoke (System.Object obj, BindingFlags invokeAttr, System.Reflection.Binder binder, System.Object[...

Read more...

It would seem that the update does not fix the problem, but widens its scope instead.
Before the update, having an Internet connection but not having an Ubuntu One account was fine.
According to Bart (above), after the update, that scenario is now broken too.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package banshee - 2.3.1-1ubuntu1

---------------
banshee (2.3.1-1ubuntu1) precise; urgency=low

  * Merge from Debian Experimental, remaining changes:
    + Enable SoundMenu and Disable NotificationArea by default
    + Disable boo and karma extensions
    + Enable and recommnd u1ms and soundmenu extensions
    + Move desktop file for Meego UI to /usr/share/une/applications
    + Change the url for the Amazon store redirector
    + [08dea2c] Revert "Fix invalid cast causing ftbfs with libgpod"

banshee (2.3.1-1) experimental; urgency=low

  * [1b4437e] Bump libgpod-cil-dev build-dep version
  * [fb16a3c] Imported Upstream version 2.3.1:
    + Enhancements:
      - Several improvements to Muinshee, our alternative UI:
        + Add a Clear button to the toolba
        + Make double+click on an album do the same as the Play button
        + Don't close the dialog when pressing Enqueue
        + Make the Esc key close the dialog if there is no search text
        + Use better icons for the Play and Enqueue buttons
      - Add separate options for writing ratings and play counts to files
      - Update values for the Smiley Face equalizer preset
      - Set the PulseAudio media.role property
    + Notable bug fixes:
      - UbuntuOneMusicStore: Ensure u1ms URIs passed at startup get loaded
      - Daap: Fix crash while resolving the address of a DAAP service
      - DatabaseImportManager: Support importing .mka files
      - Notify playlists on rating change through d-bus or command line
      - bgo#661467: AmazonMp3: Handle plain text AMZ files now sent by Amazon
        (LP: #882347)
      - bgo#662906: AudiobookLibrarySource: Fix crash when adding tracks
      - bgo#659841: GnomeBackend: Be more robust against GConf failures
        (LP: #854845)
      - bgo#656533: Notification: Fix application name used in internal notify#
        (LP: #825769)
      - bgo#649277: NotificationArea: Only use supported tags in the
        notification message (Closes: #588999)
      - bgo#647898: Try to fetch coverart without an internet connection
      - bgo#658803: Prune CoverArtDownloads table when removing tracks
    + Other LP bugs fixed:
      - Crash on rescanning library (LP: #744257)
      - UbuntuOne Music Store hang when Internet connection not present
        (LP: #875632)
      - Update error message for Banshee DAAP non-connectivity (LP: #864838)
      - bgo#661467: AmazonMp3: Handle plain text AMZ files now sent by Amazon
        (LP: #882347)
  * [e180004] Bump mono-addins build-dep (0.3.1 → 0.6.2)
  * [6dc2a9b] Fix unused-but-set wanted_size variable
 -- Chow Loong Jin <email address hidden> Tue, 08 Nov 2011 13:15:58 +0800

Changed in banshee (Ubuntu Precise):
status: In Progress → Fix Released

Hello Alan, or anyone else affected,

Accepted banshee into oneiric-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Yes, like the daily PPA I tried, the hang is gone in -proposed.

When this is due to the proxy setting, the Ubuntu Music pane shows an error message "Cannot connect to proxy (localhost)", which seems pretty helpful.

When this is due to the network cable being unplugged, the pane shows first a blank grey screen, then a blank white screen, with no error information.

So much better for people with intermittent connections. And hopefully it'll be fixed _properly_ at some point :).
Thanks!

Martin Pitt (pitti) on 2011-11-10
tags: added: verification-done
removed: verification-needed

On 10/11/2011 22:29, Alan Jenkins wrote:
> So much better for people with intermittent connections. And hopefully it'll
> be fixed _properly_ at some point :).

Thanks for the feedback. I think that should go into a new bug report though. :-)

--
Kind regards,
Loong Jin

This bug was fixed in the package banshee - 2.2.1-1ubuntu1

---------------
banshee (2.2.1-1ubuntu1) oneiric-proposed; urgency=low

  * Merge from Debian Unstable, remaining changes:
    + Enable SoundMenu and Disable NotificationArea by default
    + Disable boo and karma extensions
    + Enable and recommnd u1ms and soundmenu extensions
    + Move desktop file for Meego UI to /usr/share/une/applications
    + Change the url for the Amazon store redirector
    + [08dea2c] Revert "Fix invalid cast causing ftbfs with libgpod"

banshee (2.2.1-1) unstable; urgency=low

  * [1b4437e] Bump libgpod-cil-dev build-dep version
  * [cbddc03] Imported Upstream version 2.2.1:
    + Notable bug fixes:
      - bgo#661467: AmazonMp3: Handle plain text AMZ files now sent by Amazon
        (LP: #882347)
      - UbuntuOneMusicStore: Ensure u1ms URIs passed at startup get loaded
      - Daap: Fix crash while resolving the address of a DAAP service
      - DatabaseImportManager: Support importing .mka files
      - bgo#662906: AudiobookLibrarySource: Fix crash when adding tracks
      - bgo#659841: GnomeBackend: Be more robust against GConf failures
        (LP: #854845)
      - bgo#656533: Notification: Fix application name used in internal notify#
        (LP: #825769)
      - bgo#649277: NotificationArea: Only use supported tags in the
        notification message (Closes: #588999)
    + Other Launchpad bugs fixed:
      - Crash on rescanning library (LP: #744257)
      - UbuntuOne Music Store hang when Internet connection not present
        (LP: #875632)
      - Update error message for Banshee DAAP non-connectivity (LP: #864838)
  * [2cbb9a0] Fix unused-but-set wanted_size variable
 -- Chow Loong Jin <email address hidden> Thu, 03 Nov 2011 10:15:09 +0800

Changed in banshee (Ubuntu Oneiric):
status: Fix Committed → Fix Released
PeterPall (peterpall) on 2012-01-19
summary: - When http_proxy is unreachable, banshee spins 200% cpu (and may lock
- entire system if unlucky, requiring unclean reboot)
+ When network is unreachable, banshee spins 200% cpu (and may lock entire
+ system if unlucky, requiring unclean reboot)
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.