Banshe crashes on startup with 'BadMatch (invalid parameter attributes)'

Bug #689505 reported by David Grossberg on 2010-12-13
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Banshee
Unknown
Unknown
banshee (Ubuntu)
Medium
Unassigned
Maverick
Undecided
Unassigned

Bug Description

Binary package hint: banshee

When I try to start Banshee the window appears for a split second and then vanishes, leaving the following terminal output:

$ banshee --sync
[Info 21:03:40.546] Running Banshee 1.8.0: [Ubuntu 10.10 (linux-gnu, x86_64) @ 2010-11-26 14:10:54 UTC]
[Info 21:03:42.174] Updating web proxy from GConf
[Info 21:03:42.252] All services are started 1.336868
The program 'Banshee' received an X Window System error.
This probably reflects a bug in the program.
The error was 'BadMatch (invalid parameter attributes)'.
  (Details: serial 1578 error_code 8 request_code 2 minor_code 0)
  (Note to programmers: normally, X errors are reported asynchronously;
   that is, you will receive the error a while after causing it.
   To debug your program, run it with the --sync command line
   option to change this behavior. You can then get a meaningful
   backtrace from your debugger if you break on the gdk_x_error() function.)

I tried using kdbg to get the backtrace mentioned and gave up due to complications with Mono.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: banshee 1.8.0-2ubuntu1~maverick2
ProcVersionSignature: Ubuntu 2.6.35-23.41-generic 2.6.35.7
Uname: Linux 2.6.35-23-generic x86_64
NonfreeKernelModules: nvidia
Architecture: amd64
Date: Sun Dec 12 21:05:01 2010
ProcEnviron:
 LANGUAGE=en_US:en
 PATH=(custom, user)
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: banshee

David Grossberg (davidgro) wrote :
Kamus (kamus) wrote :

Please could you run in a terminal "banshee --debug" and then attach all the output information into a text file. I tried to reproduce this problem using 1.9.0 release (from ppa daily) and works fine for me (with --sync flag). Thanks

Changed in banshee (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete

This might be the same issue as the following upstream bug, which was fixed recently in git master :
https://bugzilla.gnome.org/show_bug.cgi?id=638477

Could you try to run banshee with the following command :
XLIB_SKIP_ARGB_VISUALS=1 banshee

If banshee doesn't crash it means that it's the same issue.

David Grossberg (davidgro) wrote :

Yup, same issue, that environment variable works.
And my conditions are exactly as described in the gnome bug: KDE4, x86_64, and moving Banshee.NotificationArea.* out of /usr/lib/banshee-1/Extensions is another workaround I had found but forgotten to update the bug (sorry!)

Is a backport of that patch likely in the near future? (it's not as important since there are now workarounds - that don't need root even, but it would be nice)

Kamus (kamus) wrote :

Please could somebody check if this patch is working with latest release of banshee 1.9.2 from daily ppa repository? Thanks!

Kamus (kamus) wrote :

According to upstream, this patch http://bugzilla-attachments.gnome.org/attachment.cgi?id=177374 should fix this issue, by the way, is already applied in master repository I guess.

Changed in banshee (Ubuntu):
status: Incomplete → Fix Committed
tags: added: patch
Changed in banshee (Ubuntu):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
status: Fix Committed → Fix Released

Accepted banshee into maverick-proposed, the package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Changed in banshee (Ubuntu Maverick):
status: New → Fix Committed
tags: added: verification-needed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package banshee - 1.8.1-0ubuntu1

---------------
banshee (1.8.1-0ubuntu1) maverick-proposed; urgency=low

  * [338f8fe] New upstream bugfix release:
    + Sync dialog would sometimes be displayed forever
    + Nereid: Always grab search entry focus on ctrl+f
    + Lastfm: Fix NRE in LastfmRequest when the request times out
    + bgo#486543: Playlists: Fix parsing when started from root directory
      (LP: #674116)
    + bgo#540394: AudioCdRipper: Don't overwrite existing files when
      ripping (LP: #348502)
    + bgo#540525: TrackActions: Stop when the playing track is deleted
      (LP: #366893)
    + bgo#587936: AppleDevice: Sync the Sort+ fields
    + bgo#609463: Equalizer: Fix distortion by using floating math
    + bgo#620010: Fix displaying random image for "All Albums"
    + bgo#623441: DatabaseImportManager: Fix duplicates on import
    + bgo#624734: InternetRadio: Allow editing stations again
    + bgo#629005: FullscreenWindow: Fix full-screen on multi-head displays
    + bgo#630209: AppleDevice: Fix podcast flag for video podcasts
    + bgo#631172: AppleDevice: Fix podcast support
    + bgo#631961: Gio: Fix InvalidCastException
    + bgo#632114: Fix hang when replaying video
    + bgo#632196: AlbumListView: Fix MissingIntPtrCtorException
    + bgo#632246: ThickClient: Fix IntPtr ctor issue in SourceComboBox
      (LP: #669857)
    + bgo#632420: Booter: Use the MeeGo client if appropriate
    + bgo#632715: Bookmarks: Fix UI not getting loaded
    + bgo#633764: Dap: Fix not transcoding some files when we should
    + bgo#633841: StreamTagger: Recognize webm as video (LP: #669682)
    + bgo#634652: AppleDevice: Remove invalid tracks before syncing
    + bgo#634686: Streaming: Fix streaming broken after first play
    + bgo#635453: Importing: Fix regression with importing mkv
    + bgo#635776: build: Ensure karma-sharp's DLLmap is copied in the
      build
    + bgo#635791: Metrics: Fix translation of the preference label
    + bgo#637303: FileChooserDialog: Fix error message on first launch
      (LP: #687402)
    + bgo#637627: FullscreenWindow: Keep fullscreen when showing volume
      osd
    + bgo#637991: SourceRowRenderer: Fix vertical alignment calculation
    + bgo#638477: X11NotificationArea: Enhance check for RGBA visual
      (LP: #689505)
    + bgo#638755: Dap.MassStorage: Add support for Xperia X10 mini pro
    + bgo#638989: Dap.MassStorage: Add support for Nexus S
    + bgo#635088: Dap.MassStorage: Add support for the LG Ally phone
    + bgo#633551: Dap.MassStorage: Add support for Huawei Ideos Android
      phones
    + bgo#631687: Dap.MassStorage: Fix extensionless files
    + bgo#639603: PlayerEngine: Fix NRE when current track doesn't have a
      Uri
    + bnc#642505: Fix insecure LD_LIBRARY_PATH
  * [7fd9862] Drop patch for bgo#623441 (applied upstream)
 -- Chow Loong Jin <email address hidden> Sun, 30 Jan 2011 02:42:20 +0800

Changed in banshee (Ubuntu Maverick):
status: Fix Committed → Fix Released
David Grossberg (davidgro) wrote :

I just tested the new version and I would like to confirm that this is indeed fixed in Kubuntu 10.10 amd64. Thanks.

Martin Pitt (pitti) on 2011-04-10
tags: added: verification-done
removed: verification-needed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.