Banshee streaming video podcasts leaks memory... a lot!

Bug #365630 reported by Dekar on 2009-04-23
18
This bug affects 3 people
Affects Status Importance Assigned to Milestone
banshee (Ubuntu)
Medium
Unassigned

Bug Description

Stream a videopodcast (like: http://www.prosieben.de/podcast/galileo/index.xml) with Banshee and after some minutes you will see the memory usage go up and up and up. I often had it using 1,5gb at the end of the day. Only a restart fixes that. On their bugtracker they said it'd be caused by the gstreamer usage and they'd have fixed it on their GIT.

Dekar (dekar-wc3edit) wrote :
Pedro Villavicencio (pedro) wrote :

Thanks for the report, may you tell us the bug number at the upstream bug tracker? may you test the same with the banshee version from the ppa? https://edge.launchpad.net/~banshee-unstable-team/+archive/ppa ; Thanks in advance.

Changed in banshee (Ubuntu):
importance: Undecided → Medium
status: New → Incomplete
Pedro Villavicencio (pedro) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to New. Thanks again!.

Changed in banshee (Ubuntu):
status: Incomplete → Invalid
Sean Dague (sdague) wrote :

This bug can be consistently reproduced on any stream played in banshee in Jaunty 9.04. Banshee never seems to reclaim memory off the audio stream so grows without bounds. Eventually you just need to kill it off to get the memory back.

I'm happy to provide additional info and testing, please just let me know what you need.

Changed in banshee (Ubuntu):
status: Invalid → Confirmed
status: Confirmed → New
enedene (enedene) wrote :

Same problem on 9.10, x64, banshee 1.51.

Cyril Jaquier (cyril-jaquier) wrote :

Same here.

rejac 6760 1.1 19.8 1577276 804828 ? Dl Nov09 38:32 banshee-1 /usr/lib/banshee-1/Banshee.exe --redirect-log --play-enqueued

ii banshee 1.5.1-1 Media Management and Playback application

I was unable to reproduce this issue using Banshee from Git with the xml podcast subscription mentioned in the original report. Banshee's memory usage was originally around 55MiB for me. I subscribed to the podcast that was mentioned in the report, downloaded the most recent 5 episodes, and watched the video podcast for a little over 10 minutes. Banshee's memory usage leveled off at about 73MiB for me and any growth while watching the downloaded podcast was negligible.

For those who are seeing this issue:

Are there specific podcast subscriptions that cause this issue for you? I'm more than willing to test other subscriptions.
Is it always video podcasts, or do audio-only podcasts cause the issue as well?
At what point is the memory leaking? when you download the podcasts? when Banshee switches between podcasts? during playback?
If the issue is happening during playback, as the reporter said, how many megabytes are leaking per minute?

If you're experiencing this issue, it would be helpful if you would download a development build of Banshee, more recent than 1.5.1. If you're using Karmic, you can update your Banshee by adding the Banshee Daily PPA[1] to your Software Sources and checking for updates. In my experience, the development version of Banshee is very stable, but if you want to be safe, you may want to back up your Banshee database before updating (run in terminal "cd ~/.config/banshee-1/ && cp banshee.db banshee.db.backup" without quotes).

[1] https://launchpad.net/~banshee-team/+archive/banshee-daily

Changed in banshee (Ubuntu):
status: New → Incomplete
Cyril Jaquier (cyril-jaquier) wrote :

Here is an example. Banshee streamed during 7 hours a web radio. This is using the latest banshee package from banshee-daily's PPA.

rejac 5081 21.3 2.1 706284 88300 ? Sl 10:31 0:07 banshee-1 /usr/lib/banshee-1/Banshee.exe --redirect-log --play-enqueued
rejac 5081 4.6 2.3 711616 97264 ? Sl 10:31 1:33 banshee-1 /usr/lib/banshee-1/Banshee.exe --redirect-log --play-enqueued
rejac 5081 4.6 2.4 712012 100772 ? Sl 10:31 2:04 banshee-1 /usr/lib/banshee-1/Banshee.exe --redirect-log --play-enqueued
rejac 5081 4.6 3.1 721900 125988 ? Rl 10:31 4:49 banshee-1 /usr/lib/banshee-1/Banshee.exe --redirect-log --play-enqueued
rejac 5081 4.6 3.5 729504 142088 ? Sl 10:31 6:54 banshee-1 /usr/lib/banshee-1/Banshee.exe --redirect-log --play-enqueued
rejac 5081 4.6 5.2 820288 213928 ? Sl 10:31 17:10 banshee-1 /usr/lib/banshee-1/Banshee.exe --redirect-log --play-enqueued
rejac 5081 4.6 5.3 821260 217544 ? Sl 10:31 17:29 banshee-1 /usr/lib/banshee-1/Banshee.exe --redirect-log --play-enqueued
rejac 5081 4.6 6.1 831304 251468 ? Sl 10:31 20:41 banshee-1 /usr/lib/banshee-1/Banshee.exe --redirect-log --play-enqueued

dmuir (dmuir) wrote :

Michael, try leaving Banshee running overnight. I just found it using 1.2GB this morning.

The same bug can be found here on Debian
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=545562

And upstream:
https://bugzilla.gnome.org/show_bug.cgi?id=555365

Victor Vargas (kamus) wrote :

According to upstream comments banshee has included lot of improvements to solved problems related to memory leaks, please could you check if this behaviour is still affecting you under latest release of banshee included in Ubuntu Lucid (or even better Maverick)? Thanks in advance.

Victor Vargas (kamus) wrote :

Dekar, any news about this issue?

Dekar (dekar-wc3edit) wrote :

Stopped using Banshee as well as Ubuntu (returned to Debian). But thanks for caring anyway :) Bug may be closed, I won't mind. Funny how long my reports survived though :D

Victor Vargas (kamus) wrote :

Thanks for your feedback, please if any other person is facing this behaviour under latest release of banshee fill a new report instead, Thanks again.

Changed in banshee (Ubuntu):
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.