empty 'grouping' tag can't be used as a criteria for smart playlists

Bug #357417 reported by perroazul on 2009-04-08
2
Affects Status Importance Assigned to Milestone
banshee (Ubuntu)
Low
Unassigned

Bug Description

Binary package hint: banshee

try to create a smart playlist that checks for empty 'Grouping' tag in the songs.
save the playlist
open it again, and the criteria is not saved and is changed to something else. banshee picks "Artist" and "contains" by itself

Neil Munro (neilmunro) wrote :

Can you please tell us what version of Ubuntu and Banshee you are using, we need this information to be able to help you with your problem. Once we have that we can further investigate.

Thank you for reporting this bug and help make Ubuntu better.

Changed in banshee (Ubuntu):
status: New → Incomplete
perroazul (perroazull) wrote :

sure thing.
because of the date I add this bug, I know that was using a previous version of banshee which one, I don't remember. however I tried replicating the bug and it has changed to the following: repeat the same procedure. apparently the smart playlist works correctly, it picks up the songs with empty grouping, but if then you go and try to edit the playlist, it doesn't show the right information and instead of showing the criteria used (check for songs with empty grouping tag) it shows what is displayed below in the attachment.

the version of banshee that I'm using is 1.4.3
thanks

Pedro Villavicencio (pedro) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.You reported this bug a while ago and there hasn't been any activity in it recently. We were wondering is this still an issue for you? Do you get the same with Lucid or Maverick? Thanks in advance.

perroazul (perroazull) wrote :

hi,
I just replicated the bug, and is still there (I'm using Lucid right now). a bit more information: I noticed that if you change the criteria to say 'grouping is 3', the smart list will work correctly. It seems that if you leave the text dialog empty, and ill-formed database query produces the error.

Victor Vargas (kamus) wrote :

perroazul, Please can you run in a terminal "banshee --debug" and attach all the output information in a text file, following your steps to reproduce this problem (try to reproduce it with 1.8.0 release would be great)? Thanks.

Changed in banshee (Ubuntu):
importance: Undecided → Low
perroazul (perroazull) wrote :

Hi,
I just did that. I'm attaching the text file

Victor Vargas (kamus) wrote :

perroazul, which model and firmware of your ipod/iphone do you have? because this is an issue when you tried to sync right?

Launchpad Janitor (janitor) wrote :

[Expired for banshee (Ubuntu) because there has been no activity for 60 days.]

Changed in banshee (Ubuntu):
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers