Ubuntu

No launcher icon or Alt+Tab entry for Gimp windows

Reported by Jan Rathmann on 2012-05-07
576
This bug affects 141 people
Affects Status Importance Assigned to Milestone
BAMF
High
Marco Trevisan (Treviño)
Unity
High
Marco Trevisan (Treviño)
5.0
High
Marco Trevisan (Treviño)
bamf (Ubuntu)
High
Marco Trevisan (Treviño)
Precise
High
Unassigned
Quantal
Undecided
Unassigned
unity (Ubuntu)
High
Unassigned
Precise
High
Unassigned

Bug Description

[Test Case]
1. Ensure that the Gimp icon is not in the launcher.
2. Start Gimp.
3. Close Gimp.
4. Start Gimp again.
   -> Verify that the Gimp icon remains in the launcher after a 30 seconds or so.
   -> Verify that the Gimp icon also appears in the alt-tab window switcher.

[Regression Potential]
No regression potential.

Original description:

Hello,

today I came across a weird bug of Unity when I tried to use Gimp.

Here is how I can reproduce it on a clean guest session:
- Start Gimp. It will show a launcher icon as expected.
- Close Gimp.
- Start Gimp again.

Result: The Gimp-icon appears in the launcher for a short time and then vanishes even though Gimp is still running of course (see also attached screenshot)! Also Gimp windows are not listed in the window switcher (Alt+Tab).

I have found no way so far to make the launcher show a Gimp icon as usual. This bug was not present in Oneric's version of Unity. Unity-2D seems to be not affected.

Kind regards,
Jan

ProblemType: Bug
DistroRelease: Ubuntu 12.04
Package: unity 5.12-0ubuntu1
ProcVersionSignature: Ubuntu 3.2.0-24.38-generic 3.2.16
Uname: Linux 3.2.0-24-generic x86_64
NonfreeKernelModules: nvidia
ApportVersion: 2.0.1-0ubuntu7
Architecture: amd64
CheckboxSubmission: b37fefbc97df4ba6a5f7edd504648fe4
CheckboxSystem: 4ed15c40009aa6f7770f606350a390a2
CompizPlugins: No value set for `/apps/compiz-1/general/screen0/options/active_plugins'
Date: Mon May 7 13:44:08 2012
InstallationMedia: Ubuntu 12.04 LTS "Precise Pangolin" - Beta amd64 (20120421)
SourcePackage: unity
UpgradeStatus: No upgrade log present (probably fresh install)

Jan Rathmann (kaiserclaudius) wrote :
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Argyris (tail-of-the-squonk) wrote :

I just noticed this, too. In fact, I just tried installing GIMP 2.8 from a ppa, where I first noticed the icon not appearing in the Launcher. Figuring it was a 2.8 bug I purged that version and reinstalled 2.6 from the Precise repos. I can report that the icon disappears for version 2.6 as well, and I know I used GIMP 2.6 in the past on Precise and it didn't do this, so I don't think it's a problem with GIMP (2.6.12-1ubuntu1 hasn't changed over the Precise dev cycle, I don't think).

dafreez (dafreez-gmail) wrote :

I am also affected by this bug, but only when I exit Gimp by closing all windows. I I use the quit option under the file' menu and then restart the launcher icon reappears.

ThomasRutter (trr) wrote :

Any chance this is a regression in unity 5.12 which was pushed to precise-updates/main relatively recently?

ThomasRutter (trr) wrote :

After downgrading to unity 5.10.0-0ubuntu6, I don't have this problem.

With 5.12-0ubuntu1, I had the problem as described - after closing and restarting GIMP once, it no longer appeared in the launcher or in ALT+TAB. Switching to it required closing/minimising all windows in front of it.

ThomasRutter (trr) on 2012-05-13
summary: - No launcher icon for Gimp windows
+ No launcher icon or Alt+Tab entry for Gimp windows
Jan Rathmann (kaiserclaudius) wrote :

I can also confirm that this only seems to happen with Unity 5.12, not with 5.10. I checked this by booting the Ubuntu-12.04 desktop image into a live session, and started Gimp first with default Unity 5.10 and then with Unity 5.12 after installing updates and logging out and in again.
So there seems to be some regression in Unity 5.12 that causes this bug.

tags: added: regression-update
Sascha (konradsa) wrote :

Same here, shows up for a couple of seconds and then just disappears.

Happy Penguin (happyp3nguin) wrote :

Same here;
Happens with Gimp and KeePassX (so far)...

dogmatic69 (dogmatic69) wrote :

Same for me. Running 12.04 and noticed that when gimp (2.8) is open but there is no launcher icon, opening a file does not bring gimp into focus even though the file opened.

Using the quit option and restarting does not make a difference for me.

Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity:
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
milestone: none → 5.14.0
importance: Undecided → High
status: New → Confirmed
Sebastien Bacher (seb128) wrote :

Bug confirmed, I hit the issue with gimp recently as well, other bugs report similar problem with xchat-gnome though I didn't see those

Marco, could you have a look? The new bamf didn't go out yet so not sure if that would make a difference

The same problem, but it is not obligatory reproducible in the described way. Today I launched GIMP several times before it started disappearing from taskbar — it started do this only in an hour.

It also seems to be not gimp-specific: I experienced this first with TopCoder java applet (javaws from icedtea-7-plugin).

P.S. Came here from a duplicate bug #999100. Thanks, Sebastien.

Daniel van Vugt (vanvugt) wrote :

See also: bug 762193 which is still unresolved. Likely exactly the same issue.

Mariano Draghi (chaghi) wrote :

I experienced this with KeePassX and KMyMoney. I also can confirm that this went broken in a very recent update.

For everybody affected by this bug: I've found that META-W reveals all windows, even the hidden/broken ones. So you can use META-W as a temporary workaround to switch to Gimp/KeePassX/whatever until a fix is released.

Daniel van Vugt (vanvugt) wrote :

See also:
Bug 999171: No launcher icon or Alt+Tab entry for Scribus windows
Bug 762193: No launcher icon or Alt+Tab entry for xchat/xchat-gnome windows
Bug 951929: Unity launcher and Alt-Tab switcher missing entry for gnome-terminal

I hope they're all the same bug, but we won't really know until a fix is proposed.

ThomasRutter (trr) wrote :

Re Bug #762193:

That bug referred to unity 3.8.8-0ubuntu2 which was in Ubuntu 11.04 and was fixed at the time, whereas this bug refers to something that regressed in 5.12-0ubuntu1. The descriptions do sound similar, though.

Note that comments from Bug #762193 Comment #13 onwards seem to refer to this latest incarnation. So there is some confusion there.

Experienced this also with GIMP and KeepassX.

You can use Super+W to switch to those "hidden" applications.

Changed in unity:
status: Confirmed → In Progress
Changed in unity (Ubuntu):
status: Confirmed → In Progress
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
digobs (lester-davidm) on 2012-05-15
Changed in unity:
status: In Progress → Confirmed
status: Confirmed → In Progress
eros2 (eros2) wrote :

Seen same problem with some Wine apps.

digobs (lester-davidm) wrote :

This bug has already been reported by members, but I want to add others applications such as wireshark and google earth which have exactly the same problem.

My system configurations;

architecture----->amd64
ubuntu 12.04 lts
dell inspiron 1545
unity 5.12.0

Changed in unity:
status: In Progress → Fix Committed
Changed in unity (Ubuntu):
status: In Progress → Fix Committed
Changed in bamf:
status: New → In Progress
importance: Undecided → High
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
biddster (luke-biddell) wrote :

I'd like to app Java Swing apps to this too. I use cassandra-gui a lot and if I accidentally minimise it, there's no way to restore the window again, it's gone from the panel and the window switcher list.

Ted Felix (tedfelix) wrote :

Confirmed with rosegarden and kstars.

Omer Akram (om26er) on 2012-05-18
Changed in bamf:
status: In Progress → Fix Committed
Eugene v. Sitnikov (fasdalf) wrote :
stianst (stianst) wrote :

I have the same problem with Eclipse and Digikam. Happens very frequently.

Dan Jared (danjaredg) wrote :

exists a work arround?

On 20/05/12 21:17, Dan Jared wrote:
> exists a work arround?
>

yes, when you see the gimp icon in the launcher, lock it to the launcher
(i.e. permanently) - then it seems to behave as expected.

Damir (tresikopljic) wrote :

I also have the same problem.

I manage to fix it by going to 2D Ubuntu. Just launch the GIMP and if it shows on the launcher just lock it down. Log in back to regular Ubuntu.

Schmankerl (schmankerl) wrote :

@Damir just search it in the dash and drag it to the launcher :-)

Alan Pope ㋛ (popey) on 2012-05-22
affects: unity (Ubuntu) → bamf (Ubuntu)
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu Precise):
status: New → Confirmed

If from /usr/share/applications I drag the Gimp icon to the launcher, I could launch the program from there, however, there is no arrow indicating when the program is the active one. Also, I could change between the windows open, but every time I change to Gimp it seems it is loading another instance (although that doesn't happen).

I continued to look for a possible workaround, and it appears that the solution from http://<email address hidden>/msg116110.html worked.

So, what I did:

- I looked for Gimp in the Dash and dragged the icon to the Launcher. Where it should appear the icon I saw just a space, from where the program could be launched.

- Then I tried to restart Unity (Alt-F2 and write unity)

That just made my system go crazy, without unity or any window composite (I wonder if a log-off or a restart would be a better solution). I just forced a restart, but now gimp behaves more consistently with the whole system. It even show the Gimp icon in the Alt-Tab switcher.

I hope this help anyone to find a solution.

Changed in bamf (Ubuntu Precise):
importance: Undecided → High
status: Confirmed → In Progress
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.12-0ubuntu2

---------------
unity (5.12-0ubuntu2) quantal; urgency=low

  * Cherry pick upstream fixes.
    - Fix UnityViewWindow background when blur is disabled (LP: #989291)
    - App icon on the Unity Launcher lost track of running
      instance (LP: #772063)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running
      status (LP: #999820)
    - Fix dash search field hidden by tooltips (LP: #978030)
    - Launcher is silent to screen reader users (LP: #949448)
    - Fix 3D apps running much slower under Unity (LP: #987304)
    - Reduced number of calls to ResultViewGrid::QueueDraw
    - Reduced number of calls to BGHash::RefreshColor
 -- Alan Pope <email address hidden> Wed, 23 May 2012 18:10:49 +0100

Changed in unity (Ubuntu):
status: New → Fix Released
Changed in unity (Ubuntu Precise):
status: New → Fix Committed
Changed in unity (Ubuntu):
importance: Undecided → High
Changed in unity (Ubuntu Precise):
importance: Undecided → High
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.118-0ubuntu1

---------------
bamf (0.2.118-0ubuntu1) quantal; urgency=low

  [ Didier Roche ]
  * New upstream release. (0.2.116)
    - multiple instances or double icons of application detected on bamfdaemon
      respawn (LP: #928912)
    - unity confused with chrome/chromium web apps (LP: #692462)
    - BamfView's dispose() method doesn't invoke the superclass' dispose()
      (LP: #986888)
  * debian/control:
    - remove Multi-Arch: same for the -dbg package
      (Closes: #669980, #658057)

  [ Alan Pope ]
  * New upstream release.
    - Unity crashed in bamf_application_on_window_removed (LP: #1000577)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - the RunningApplicationsChanged signal is no longer emitted when an
      application is closed since r460 (LP: #989551)
 -- Alan Pope <email address hidden> Wed, 23 May 2012 09:10:08 +0100

Changed in bamf (Ubuntu):
status: Fix Committed → Fix Released
Changed in bamf (Ubuntu Precise):
status: In Progress → Fix Committed
Changed in bamf:
status: Fix Committed → Fix Released
Changed in unity:
status: Fix Committed → Fix Released

Hello Jan, or anyone else affected,

Accepted unity into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

tags: added: verification-needed
Steve Langasek (vorlon) wrote :

Hello Jan, or anyone else affected,

Accepted bamf into precise-proposed. The package will build now and be available in a few hours. Please test and give feedback here. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Thank you in advance!

Mariano Draghi (chaghi) wrote :

Steve, I can no longer reproduce the bug affter installing the precise-proposed versions of unity and bamf. For me it was always reproducible with KMyMoney, and now I tried opening and closing several times and its working as expected every single time.
It seems to be fixed.

Rocko (rockorequin) wrote :

The fix works for me (at least with the test case in the bug description), but it breaks my Thunderbird launcher icon. I'm running a modified Thunderbird.desktop file that executes a script to run davmail as well as thunderbird, and the launcher now shows a second Thunderbird launcher icon for the running Thunderbird. It used to match it correctly with the launcher icon that I have pinned to the launcher.

Jan Rathmann (kaiserclaudius) wrote :

@Steve
I tested with Gimp and Eclipse (vanilla, not the version from Ubuntu repositorys) and everything works as expected so far.

Sebastien Bacher (seb128) wrote :

@Rocko: could you open a new bug about the issue, your usecase is a bit specific and we should look at it but it's quite different from the gimp issue

tags: added: verification-done
removed: verification-needed
florin (florin-arjocu) wrote :

I can also confirm that proposed packages work for GIMP.

@Rocko: you probably just need to define the proper StartupWMClass in your .desktop file.

Rocko (rockorequin) wrote :

@Marco: I have "StartupWMClass=Thunderbird" in my desktop file (I just copied the thunderbird.desktop file and modified the exec line). Isn't that what it should be? It used to work until this latest update. I'll log another bug.

ThomasRutter (trr) wrote :

Fixed for me too.

Installed the -proposed updates for both bamf and unity related packages.

Interestingly this not only fixes the brokenness in the Unity 5.12 -updates package, but it also fixes a slight cosmetic glitch from the Unity 5.10 (previous version in precise) package too: on that version, upon opening Gimp two icons would momentary show on the launcher, then one would disappear a moment later.

On 25/05/12 14:51, ThomasRutter wrote:
> Fixed for me too.
>
> Installed the -proposed updates for both bamf and unity related
> packages.

can someone clarify how to upgrade "bamf" as this does not appear to be
a package name?

i just did

 $ sudo apt-get -t precise-proposed install unity

and this appears to have installed this bug fix correctly.

@paddy the bamf's package is bamfdaemon

@Thomas: yes that's what I also tried to achieve ;)

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package unity - 5.12-0ubuntu1.1

---------------
unity (5.12-0ubuntu1.1) precise-proposed; urgency=low

  * Cherry pick upstream fixes.
    - Fix UnityViewWindow background when blur is disabled (LP: #989291)
    - App icon on the Unity Launcher lost track of running
      instance (LP: #772063)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - Locked smuxi launcher icon does not indicate smuxi running
      status (LP: #999820)
    - Fix dash search field hidden by tooltips (LP: #978030)
    - Launcher is silent to screen reader users (LP: #949448)
    - Fix 3D apps running much slower under Unity (LP: #987304)
    - Reduced number of calls to ResultViewGrid::QueueDraw
    - Reduced number of calls to BGHash::RefreshColor
 -- Alan Pope <email address hidden> Wed, 23 May 2012 18:10:49 +0100

Changed in unity (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package bamf - 0.2.118-0ubuntu0.1

---------------
bamf (0.2.118-0ubuntu0.1) precise-proposed; urgency=low

  [ Didier Roche ]
  * New upstream release. (0.2.116)
    - multiple instances or double icons of application detected on bamfdaemon
      respawn (LP: #928912)
    - unity confused with chrome/chromium web apps (LP: #692462)
    - BamfView's dispose() method doesn't invoke the superclass' dispose()
      (LP: #986888)
  * debian/control:
    - remove Multi-Arch: same for the -dbg package
      (Closes: #669980, #658057)

  [ Alan Pope ]
  * New upstream release.
    - Unity crashed in bamf_application_on_window_removed (LP: #1000577)
    - Locked smuxi launcher icon does not indicate smuxi running status
      (LP: #999820)
    - No launcher icon or Alt+Tab entry for Gimp windows (LP: #995916)
    - the RunningApplicationsChanged signal is no longer emitted when an
      application is closed since r460 (LP: #989551)
 -- Alan Pope <email address hidden> Wed, 23 May 2012 09:10:08 +0100

Changed in bamf (Ubuntu Precise):
status: Fix Committed → Fix Released
kapetr (kapetr) wrote :

... the Error appears by Wireshark too.

Will be these "High Importance" fixes released to standard U12.04 update ? Not just precise-proposed ?
If YES (I hope so) - when ?

Omer Akram (om26er) wrote :

@kapetr, they did, 3hours ago :-)

I also have this problem...

Josep (pepmanuel) wrote :

@emerson, enable precise-proposed repositories as described here: https://wiki.ubuntu.com/Testing/EnableProposed

Then execute:

sudo apt-get update
sudo apt-get -t precise-proposed install bamfdaemon
sudo apt-get -t precise-proposed install unity

And restart.

Nicolas_Raoul (nicolas-raoul) wrote :

Nobody mentioned it also happens with: gjiten

Changed in unity:
milestone: 5.14.0 → 6.0
status: Fix Released → Fix Committed
Didier Roche (didrocks) on 2012-07-10
Changed in unity:
status: Fix Committed → Fix Released
description: updated
Robi (rogadora) wrote :

Hi, I have the same problem with Libre Offcie Calc. I followed the instruction here and updated unity and bamf.
I have these:
unity 5.14.0-0ubuntu1,
bamfdaemon 0.2.118-0ubuntu0.2
but I still have the issue. Somtimes it works well, somtimes have the original issue.
Did I failed something? Thx.

Berte (berte) wrote :

same problem with libreoffice calc.
I randomly got (at least it seems random to me): the correct icon, a blank icon or no icon in combination with or without the small triangle carret.

Ubuntu 12.04

bamfdaemon 0.2.118-0ubuntu0.2
unity 5.14.0-0ubuntu1

Giordano Battilana (jordan83) wrote :

I experience the same problem with LibreOffice Impress

Same problem with any libreoffice program.

Jan Nekvasil (jan-nekvasil) wrote :

Should we reopen this bug because of LibreOffice issue or is the right way to file a new one?

Artur de Sousa Rocha (adsr) wrote :

It's not just LibreOffice. I've had the same happen with Terminal, darktable, geeqie. When this happens the applications also aren't added to the last used list in the main panel.

Ubuntu 12.04.1
bamfdaemon 0.2.118-0ubuntu0.2
unity 5.16.0-0ubuntu1

kwoot (jbaten) wrote :

Happens to me all the time with 12.04.1 and Libreoffice. sw is uptodate. Icon for calc show up to the left but clicking gives no system respons. super-w works great as a workaround.

Omer Akram (om26er) wrote :

report a new bug so that we could better track it

Manfred Grabherr (grabherr) wrote :

Still not fixed. I reported this several times. I'm done with Unity. Basta. Sorry, but you can't even get the most basic things right...

An Drey (zvezda-aldebaran) wrote :

Started to happen to me when I upgraded to 12.10. The programm that disappears 100% of times after lunch is Firefox.

Sindisil (greg-jandl) wrote :

I'm seeing this in 12.10, with gimp 2.8 not showing up in either the launcher, nor in the task switcher (alt-tab).

Worked fine yesterday, before "upgraded" to 12.10.

Noticing way shorter battery life, too, but that's off topic here.

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu Quantal):
status: New → Confirmed
Walkinraven (walkinraven) wrote :

For me, libreOffice calc disappeared sometimes. Hope be fixed soon.

Ez Aton (ezaton) wrote :

Unfortunately, I have encountered this problem several times just few days ago, especially with LibreOffice. I am affraid this bug has not been solved yet.

benste (benste) wrote :

jsut checked bot libreoffice and GIMP for you - neither of them has problems within the latest STABLE ubuntu release (12.10 with libre 3.5x ? => NOT 4.0 !)

you might wanna consider to post a new bug as this one here as definetly been fixed

Alex Orlando (2-alex) wrote :

I'm seeing this regularly in 12.04 with both Firefox and GEdit: missing entries in the ALT+Tab switcher and no icons in the dash. C'mon guys...

Ubuntu 12.04.2
bamfdaemon 0.2.124.2-0ubuntu1
unity 5.18.0-0ubuntu2

Alex Orlando (2-alex) wrote :

I think I've finally figured it out why some icons are disappearing from the launcher.

Another test case:
* Make sure you have no browser running
* Install Netbeans 7.2.1: prefer the JavaEE version
* If everything went fine, you should end up with a desktop shortcut. Run it.
* It should add two icons to the launcher: only the second one points to the real app, while the first is useless (this is very annoying by itself, but that's not the main point)
* Create a new web application: File -> New project -> Java Web -> Web Application
* Run the project: Run -> Run project

Supposing you already have Firefox locked to the launcher (and again, it wasn't running before you started this test), surprise: Firefox starts, but nowhere you can find its icon, neither at the launcher nor at the alt+tab list. The only way you can focus Firefox again is using Super + w.

Update: as if it wasn't odd enough... Turns out if I click the first Netbeans icon (the useless one), Firefox shows up. So it seems that, at least for a Unity point of view, the parent process (Netbeans) somewhat "owns" the child process (Firefox).

Thomas Hotz (thotz) on 2013-06-10
Changed in bamf (Ubuntu Quantal):
status: Confirmed → Invalid
Thomas Hotz (thotz) wrote :

Please add a screenshot of the problem with GIMP and Libreoffice. Thank you!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions