bamfdaemon crashed with SIGABRT in g_assertion_message()

Bug #926208 reported by Daniel Holbach on 2012-02-03
This bug affects 598 people
Affects Status Importance Assigned to Milestone
BAMF
Critical
Marco Trevisan (Treviño)
GLib
Fix Released
High
Unity
Fix Released
Critical
Marco Trevisan (Treviño)
Unity Distro Priority
Critical
Unassigned
bamf (Ubuntu)
Critical
Marco Trevisan (Treviño)
Precise
Critical
Marco Trevisan (Treviño)
glib2.0 (Ubuntu)
High
Unassigned
Precise
High
Unassigned
unity (Ubuntu)
Undecided
Unassigned
Precise
Undecided
Unassigned

Bug Description

No idea what happened.

TEST CASE
1. Launch gnome-control-center
2. select the 1rst configuration applet
3. click on 'all settings' to go back to the main screen
4. select next applet
5. click on 'all settings' to go back to the main screen
6. Repeat steps 4 and 5 until it crashes

EXPECT RESULT:
Launcher is updated with the right icons and no crash

ProblemType: Crash
DistroRelease: Ubuntu 12.04
Package: bamfdaemon 0.2.108-0ubuntu2
ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2
Uname: Linux 3.2.0-12-generic x86_64
ApportVersion: 1.91-0ubuntu1
Architecture: amd64
CheckboxSubmission: 2f383a1679e8525d7196eb2518a1921f
CheckboxSystem: bb422ca46d02494cdbc459927a98bc2f
Date: Fri Feb 3 18:11:15 2012
ExecutablePath: /usr/lib/bamf/bamfdaemon
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110817)
ProcCmdline: /usr/lib/bamf/bamfdaemon
Signal: 6
SourcePackage: bamf
StacktraceTop:
 g_assertion_message () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 g_assertion_message_expr () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
 g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
 ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
Title: bamfdaemon crashed with SIGABRT in g_assertion_message()
UpgradeStatus: Upgraded to precise on 2012-01-12 (22 days ago)
UserGroups: adm admin audio cdrom dialout lpadmin plugdev sambashare

Daniel Holbach (dholbach) wrote :

StacktraceTop:
 g_assertion_message (domain=<optimized out>, file=<optimized out>, line=<optimized out>, func=0x7fc4cb345000 "call_in_idle_cb", message=0x7fc4bc0267a0 "assertion failed: (vtable != NULL && vtable->method_call != NULL)") at /build/buildd/glib2.0-2.31.14/./glib/gtestutils.c:1860
 g_assertion_message_expr (domain=0x7fc4cb322401 "GLib-GIO", file=0x7fc4cb3438c8 "/build/buildd/glib2.0-2.31.14/./gio/gdbusconnection.c", line=4678, func=0x7fc4cb345000 "call_in_idle_cb", expr=<optimized out>) at /build/buildd/glib2.0-2.31.14/./glib/gtestutils.c:1871
 call_in_idle_cb (user_data=<optimized out>) at /build/buildd/glib2.0-2.31.14/./gio/gdbusconnection.c:4678
 g_main_dispatch (context=0x1110190) at /build/buildd/glib2.0-2.31.14/./glib/gmain.c:2510
 g_main_context_dispatch (context=0x1110190) at /build/buildd/glib2.0-2.31.14/./glib/gmain.c:3047

Changed in bamf (Ubuntu):
importance: Undecided → Medium
tags: removed: need-amd64-retrace
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in bamf (Ubuntu):
status: New → Confirmed
visibility: private → public
Changed in bamf (Ubuntu Precise):
assignee: nobody → Canonical Desktop Experience Team (canonical-dx-team)
importance: Medium → High
tags: added: qa-manual-testing rsl-mgr-p-tracking
Evan Huus (eapache) wrote :

I was playing with the System Settings (opening and closing panels and watching the icon in the launcher change) when the crash popped notification up. My launcher then looked like the screenshot, despite only having one window of system settings open.

I also had a firefox icon with two window-tags (is there a better name for those?) even though there was only one firefox window open.

Ian Ross (iankross) wrote :

Just closed my Firefox finishing of some browsing and the crash notification popped up.

description: updated
Changed in bamf (Ubuntu Precise):
assignee: Canonical Desktop Experience Team (canonical-dx-team) → Marco Trevisan (Treviño) (3v1n0)
Evan Huus (eapache) wrote :

Found an even better reproduction method: there is a program (in universe) called "Dr. Racket" that, due to its use of a loading-bar splash window, causes all sorts of havoc. Simply opening the program results in a launcher item with two tags, even though only one window is open.

(Dr. Racket is an IDE for a variant of LISP)

Evan Huus (eapache) wrote :

Search software center for "DrRacket" to find it, since that's the name its registered under.

Sebastien Bacher (seb128) wrote :

bug #926135 is likely the same bug

Achim Behrens (k1l) wrote :

had same apport message while just browsing in chromium.

uptodate precise, 64bit
didnt see any wrong behaviour though.

Logan Rosen (logan) wrote :

Has happened to me twice when closing programs in 12.04 Alpha 2, namely LibreOffice Writer and XChat.

Thomi Richards (thomir) wrote :

Happens to me about once a day, even while I'm not launching any applications.

I just got this today on my Precise install after closing GNOME Documents. It also duplicated several of my launcher icons.

Darren Weslow (dazw2001) wrote :

After converting a cd using Asunder, and also having Rhythmbox playing a track and using Libreoffice Writer to create a new document at the same time caused this bug to pop up. Using 12.04 Alternative DVD version.

Sorry, I really can't reproduce this, so please who is affected should help in debugging.
You can just install bamf-dev from repositories, and download and extract the latest bamfdaemon .tar.gz you can find at http://packages.ubuntu.com/precise/bamfdaemon

Then, a way to get a more helpful stack trace should be:
 - Open a terminal, and keep it always on top, so you can do something else when the daemon will crash
 - cd to the bamfdaemon source directory (i.e. the "src" .tar.gz directory, where the main.c file is)
 - The point above can be done also setting manually the bamf's src directory on gdb using the "directory" command
 - Do: sudo gdb -p $(pidof bamfdaemon) 2>&1 | tee gdb-bamf.txt
 - Wait gdb to be loaded and press "c", then Return.
 - Now the daemon will continue running, start playing with your application until you get a crash.
 - At that point go back to gdb, write "bt full", press Return and attach the generated gdb-bamf.txt stacktrace file to this bug ;)
 - Then exit gdb with Ctrl+D bamfdaemon should be reloaded automatically, if it doesn't a "killall -9 bamfdaemon" could help

You can get more informations about gdb at https://wiki.ubuntu.com/Backtrace

Changed in bamf:
status: New → Triaged
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Evan Huus (eapache) wrote :

I haven't been able to reproduce since the fix for bug #928014 landed. Dupe?

Yuri Glushaev (y-glushaev) wrote :

Bamfdaemon had crashed directly after crash of soffice.bin (Libreoffice Writer 3.5.b2)

tags: added: bugpattern-needed
SignedAdam (signedadam) wrote :

I had the same problem, so its effecting more than one user

I have seen this happen several times over the past few days on two different machines, including just a moment ago (on a fully updated install).

I'm running gdb per Marco's instructions now, but I don't know how long it will take to crash as I've never been doing the same thing when it happens (nor can I recreate it at will). The last time the crash happened for me, I wasn't doing anything in particular - just browsing with Firefox on this machine. Maybe it was triggered by some service I had running.

Manuel Trujillo (toomany) wrote :

I just pretend to change from one workspace to another, and suffer this bug.

Michael Hope (michaelh1) wrote :

Happened just now. I updated Precise yesterday. I wan't doing anything at the time - perhaps switching workspaces.

Bryn Hughes (linux-nashira) wrote :

Happened to me today - absolutely nothing was going on - I was reading through text on a web site, not opening or closing anything at the time.

John Belton (jbelton1950) wrote :

This happened to me as I opened a file to edit with LibreOffice Writer in a new installation under Wubi (upgraded from the current 11.10 release). I don't know if this gives any help as it has been repoted before, but I thought it was worth sending incase the problem had been fixed but has recured on today's daily build.
John

John Chadwick (johnwchadwick) wrote :

Happened when I closed a window. Sadly, I wasn't paying much attention, so I don't have much details, but it was a gedit window, and I am running 12.12 up-to-date. I noticed that I had a couple duplicate entries in my sidebar after the crash, closing the windows solved that.

Mossroy (mossroy) wrote :

It happened to me just after closing a LibreOffice Calc document, on Ubuntu Precise beta 1 with all current updates.

Mark Kelley (mcellius) wrote :

I was using Nautilus to open a file via SSH on another computer. It seemed to be running very slowly, making me wonder if the network might be down, but eventually things opened. Then from nowhere I got the error message, leading me to this bug.

As I wrote before, the problem with this bug is finding a way to reproduce it all the times. I've maybe experienced it once, but never when running bamf on gdb.
So, without a valid stacktrace that mentions the bamf sources, is way hard to fix this crash.

Evan Huus (eapache) wrote :

Okay, I've seen it a couple of times now, the problem being that each time it crashed X so hard I couldn't get back to gdb (which was running in a gnome-terminal instance).

The X crash is probably due to my running buggy fglrx drivers, since I've seen the bamf issue before (while on the open-source radeon drivers) without that symptom. Unfortunately, I wasn't running under gdb at the time.

I'll set gdb up to run under a tty (which is accessible post-crash) instead and post back when it happens again.

Evan Huus (eapache) wrote :

For what it's worth, this looks like a memory corruption issue to me, given the randomness and symptoms. Is it worth running under valgrind as well as gdb?

[http://valgrind.org/docs/manual/manual-core-adv.html#manual-core-adv.gdbserver]

I'm sorry I am simply an everyday user who enjoys the idea of helping
others however I can. I will continue using the beta to try create the bug
again. The report was filed automatically.
On Mar 6, 2012 9:41 PM, "Evan Huus" <email address hidden> wrote:

> For what it's worth, this looks like a memory corruption issue to me,
> given the randomness and symptoms. Is it worth running under valgrind as
> well as gdb?
>
> [http://valgrind.org/docs/manual/manual-core-adv.html#manual-core-
> adv.gdbserver]
>
> --
> You received this bug notification because you are subscribed to a
> duplicate bug report (947710).
> https://bugs.launchpad.net/bugs/926208
>
> Title:
> bamfdaemon crashed with SIGABRT in g_assertion_message()
>
> Status in BAMF Application Matching Framework:
> Triaged
> Status in “bamf” package in Ubuntu:
> Confirmed
> Status in “bamf” source package in Precise:
> Confirmed
>
> Bug description:
> No idea what happened.
>
> TEST CASE
> 1. Launch gnome-control-center
> 2. select the 1rst configuration applet
> 3. click on 'all settings' to go back to the main screen
> 4. select next applet
> 5. click on 'all settings' to go back to the main screen
> 6. Repeat steps 4 and 5 until it crashes
>
> EXPECT RESULT:
> Launcher is updated with the right icons and no crash
>
> ProblemType: Crash
> DistroRelease: Ubuntu 12.04
> Package: bamfdaemon 0.2.108-0ubuntu2
> ProcVersionSignature: Ubuntu 3.2.0-12.21-generic 3.2.2
> Uname: Linux 3.2.0-12-generic x86_64
> ApportVersion: 1.91-0ubuntu1
> Architecture: amd64
> CheckboxSubmission: 2f383a1679e8525d7196eb2518a1921f
> CheckboxSystem: bb422ca46d02494cdbc459927a98bc2f
> Date: Fri Feb 3 18:11:15 2012
> ExecutablePath: /usr/lib/bamf/bamfdaemon
> InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Alpha amd64 (20110817)
> ProcCmdline: /usr/lib/bamf/bamfdaemon
> Signal: 6
> SourcePackage: bamf
> StacktraceTop:
> g_assertion_message () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> g_assertion_message_expr () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> ?? () from /usr/lib/x86_64-linux-gnu/libgio-2.0.so.0
> g_main_context_dispatch () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> ?? () from /lib/x86_64-linux-gnu/libglib-2.0.so.0
> Title: bamfdaemon crashed with SIGABRT in g_assertion_message()
> UpgradeStatus: Upgraded to precise on 2012-01-12 (22 days ago)
> UserGroups: adm admin audio cdrom dialout lpadmin plugdev sambashare
>
> To manage notifications about this bug go to:
> https://bugs.launchpad.net/bamf/+bug/926208/+subscriptions
>

Damas (mlabwa) wrote :

Crashed when I was changing theme. Happens often when I'm in System settings

Frans Slothouber (rfsber) wrote :

Crashed when I was doing nothing. (Read a page in firefox).
It crashed with a with SIGABRT in raise() instead of g_assertion_message() though.

Now running it in the debugger.

S-cimer (s-cimer) wrote :

Got the crash message while lightly using Libre office calc and banshee running in the background.

Sean Badoud (seanbadoud) wrote :

Crashed while opening Libre office with Google Chrome and Thunderbird open in the background

Adrián (jaksi) wrote :

Crashed when opened Appearance!

Deric Stowell (dericnsd) wrote :

crashed while using Chrome!

Norman Haikal (normanh38) wrote :

crashed when opened Appearance too! same problem like Adrián!

lordhulk (jefersondossantos) wrote :

I got this problem all time i try activate my ati proprietary driver.
he try download the driver, so he close and show error message
(sorry my bad english)

Got this bug, or something close enough that apport thought so, running LibreOffice on 12.04 Beta 1. (No idea if LibreOffice was actually involved, but it's what I was using at the time). Also had Thunderbird and Firefox open at the time.

Frans Slothouber (rfsber) wrote :

Managed to reproduce this bug once with opening 'Systsem Setting' and then quicky opening and closing the various settings.

While doing this I also managed to trigger a number of other bugs:

https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/943013

https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/951570

https://bugs.launchpad.net/ubuntu/+source/jockey/+bug/734376

Looks like the infra structure under 'system settings' is a bit flaky.

Frans Slothouber (rfsber) wrote :
Download full text (8.9 KiB)

This is a full stacktrace as per instructions in #16. Get this about once a day.

(gdb) c
Continuing.
[Thread 0x7f5c266c9700 (LWP 19540) exited]

Program received signal SIGABRT, Aborted.
0x00007f5c2e27a445 in __GI_raise (sig=<optimized out>)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
64 ../nptl/sysdeps/unix/sysv/linux/raise.c: No such file or directory.
(gdb) backtrace full
#0 0x00007f5c2e27a445 in __GI_raise (sig=<optimized out>)
    at ../nptl/sysdeps/unix/sysv/linux/raise.c:64
        resultvar = 0
        pid = <optimized out>
        selftid = 19539
#1 0x00007f5c2e27dbab in __GI_abort () at abort.c:91
        save_stage = 2
        act = {__sigaction_handler = {sa_handler = 0x18, sa_sigaction = 0x18},
          sa_mask = {__val = {140033894512617, 140033887874120,
              140033925032400, 1024, 0, 24539680, 4294967296, 4294967295, 0,
              180, 23858832, 3092568, 0, 140033897068960, 22044768,
              140033893974016}}, sa_flags = 809260916, sa_restorer = 0x5}
        sigs = {__val = {32, 0 <repeats 15 times>}}
#2 0x00007f5c2e883dad in g_assertion_message (domain=<optimized out>,
    file=<optimized out>, line=<optimized out>,
    func=0x7f5c2f2ac9a0 "call_in_idle_cb",
    message=0x16a9840 "assertion failed: (vtable != NULL && vtable->method_call != NULL)") at /build/buildd/glib2.0-2.31.20/./glib/gtestutils.c:1860
        lstr = "4678\000\177\000\000\360ٶr\377\177\000\000\000\000\000\000\000\000\000\000н*/\\\177\000"
        s = 0x16c0e90 "\260\275j\001"
#3 0x00007f5c2e8842d2 in g_assertion_message_expr (
    domain=0x7f5c2f289ce1 "GLib-GIO",
    file=0x7f5c2f2ab268 "/build/buildd/glib2.0-2.31.20/./gio/gdbusconnection.c", line=4678, func=0x7f5c2f2ac9a0 "call_in_idle_cb", expr=<optimized out>)
    at /build/buildd/glib2.0-2.31.20/./glib/gtestutils.c:1871
        s = <optimized out>
#4 0x00007f5c2f256c26 in call_in_idle_cb (user_data=<optimized out>)
    at /build/buildd/glib2.0-2.31.20/./gio/gdbusconnection.c:4678
        invocation = 0x164d700
        vtable = 0x1669010
        registration_id = <optimized out>
        subtree_registration_id = <optimized out>
        __PRETTY_FUNCTION__ = "call_in_idle_cb"
#5 0x00007f5c2e863dda in g_main_dispatch (context=0x1506060)
    at /build/buildd/glib2.0-2.31.20/./glib/gmain.c:2510
        dispatch = 0x7f5c2e861a30 <g_idle_dispatch>
        was_in_call = 0
        user_data = 0x164d700
        callback = 0x7f5c2f256a10 <call_in_idle_cb>
        cb_funcs = 0x7f5c2eb0f9a0
        cb_data = 0x7f5c18008b50
        current_source_link = {data = 0x7f5c18002e40, next = 0x0}
        need_destroy = <optimized out>
        source = 0x7f5c18002e40
        current = 0x15ef030
        i = <optimized out>
#6 g_main_context_dispatch (context=0x1506060)
    at /build/buildd/glib2.0-2.31.20/./glib/gmain.c:3047
No locals.
#7 0x00007f5c2e8641a0 in g_main_context_iterate (dispatch=1,
    block=<optimized out>, context=0x1506060, self=<optimized out>)
    at /build/buildd/glib2.0-2.31.20/./glib/gmain.c:3118
        timeout = 0
        some_ready = 1
        fds = <optimized out>
        max_priority = 0
        nfds = 4
        allocated_nfds = <optimized out>
#8 g_main...

Read more...

RobWilkens (robwilkens) wrote :

Was either Libre Writer or Thunderbird. I was using both when this error happened with me (opening an attahment, then closing it and returning to e-mail).

Didier Roche (didrocks) on 2012-03-13
Changed in bamf:
importance: Undecided → Critical
Changed in bamf (Ubuntu Precise):
importance: High → Critical
Changed in unity:
milestone: none → 5.8.0
importance: Undecided → Critical
status: New → Triaged
assignee: nobody → Marco Trevisan (Treviño) (3v1n0)
Changed in unity-distro-priority:
status: New → Fix Committed
importance: Undecided → Critical
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed

Frans, thanks a lot for your stacktrace, it seems related to a glib issue.

We're looking at it now.

Changed in glib:
importance: Unknown → High
status: Unknown → New

Open an odf file from thunderbird when error appear.

Devin (8basepairs) wrote :

Here is the attachment Marco Trevisan asked for.

Devin (8basepairs) wrote :

Comment #47 that I made is for another bug. But, apport didn't open it up this time; I think because I did the debugging this time. I hope Marco knows which bug it is for; it is one where he linked to comment #16 here from the other bug that it belongs to. Next time it happens and opens up the proper bug in my web browser I'll add the dbg-bamf.txt file to it too. But, if Marco knows which one it is already (the one he commented in with a link to the instructions of this bug's 16th comment), then he could start working on it sooner or just know that a debugging backtrace is coming for that bug soon, too.

deu erro

Frans Slothouber (rfsber) wrote :

On 03/13/2012 02:53 PM, Marco Trevisan (Treviño) wrote:
> Frans, thanks a lot for your stacktrace, it seems related to a glib
> issue.
>
> We're looking at it now.
>

Hey Marco,

Great to hear and glad to be of help!
If I can help with any other bugs let me know.

Have fun,
Frans.

Changed in bamf (Ubuntu Precise):
milestone: none → ubuntu-12.04-beta-2
Devin (8basepairs) wrote :

Followup for comments #47-48. Apport brought up the bug in launchpad that the attachment I gave in those comments belongs to. I now correctly placed the gdb attachment in bug #926135. Please ignore said comments, now that they are filed to the correct bug, thank you.

adredz (red-adaya) wrote :

Experienced this too mins ago when I opened truecrypt. I updated my system yesterday.

Stephen G (stephengroat) wrote :

experienced when running apt-get upgrade command line and using Eclipse and Android SDK Manager

Ubuntu QA Website (ubuntuqa) wrote :

This bug has been reported on the Ubuntu ISO testing tracker.

A list of all reports related to this bug can be found here:
http://iso.qa.ubuntu.com/qatracker/reports/bugs/926135

tags: added: iso-testing
Changed in glib:
status: New → Incomplete
Michael (amemain) wrote :

This happens to me within the first minute of a fresh reboot.

Happens to me too.

*john robert sion* | www.twitter.com/arjei26

On Saturday, 17 March, 2012 02:26 AM, Michael wrote:
> This happens to me within the first minute of a fresh reboot.
>

Ahmet SARI (ahmsar04) wrote :

had same crash report again after waking from suspend while exiting libre office writer

Adi Ratiu (adirat) wrote :

happened when trying to close transmission client

Happens a few times a day for no apparent reason.

Martijn vdS (martijn) wrote :

Happens a lot when tha "arduino" IDE is running.

Dimitr (ne0g3n) wrote :

That happened just after I closed my document in Writer.

Tristen (tristen-wentling) wrote :

first time I've seen this particular crash, updates installed about 30 min ago and now if I go into settings and change something it gives me this result, been having some crashes here and there but mostly related to eclipse which seems to be buggin out on me, first update in last two days, there were some 60 updates installed. Hope this is of help!

tags: added: rls-p-tracking
Changed in glib:
status: Incomplete → Confirmed
Paul (p37307) wrote :

This issue had cleared up for me until updates a few hours ago. Then the auto update notifier ran and it occurred again.

Brad G (brad-goold) wrote :

Happened when I tried to open a template in LibreOffice when it was already opened.

Michael (amemain) wrote :

Happened with only Chromium interaction (Back Paging etc.). Nothing else running.

affects: unity (Ubuntu Precise) → glib2.0 (Ubuntu Precise)
Changed in glib2.0 (Ubuntu Precise):
importance: Undecided → High
status: Confirmed → Fix Committed
Launchpad Janitor (janitor) wrote :

This bug was fixed in the package glib2.0 - 2.31.22-0ubuntu1

---------------
glib2.0 (2.31.22-0ubuntu1) precise; urgency=low

  * New upstream version:
    - should fix gstreamer locking issues (lp: #941229)
  * debian/patches/bugzilla_gdbus_use_reliable_cancellation.patch,
    debian/patches/bugzilla_reliable_cancellable.patch:
    - dropped, the fixes are in the new version
  * debian/patches/90_revert_git_stricter_types.patch:
    - dropped, it shouldn't be needed, the issue got resolved
  * debian/patches/git_gdbus_avoid_assert_bug.patch:
    - should fix a gdbus assert hit sometimes by nautilus (lp: #898231),
      gsd (lp: #898994), or bamf (lp: #926208), thanks Marco Trevisan
 -- Sebastien Bacher <email address hidden> Tue, 20 Mar 2012 11:35:24 +0100

Changed in glib2.0 (Ubuntu Precise):
status: Fix Committed → Fix Released
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in unity (Ubuntu):
status: New → Confirmed
Changed in glib:
status: Confirmed → Fix Released
fantab (fantab) wrote :

This crash occured when I tried to change 'gtk-theme' in dconf-editor.

Please, who has reported this bug, please check if it still happens using new glib2.0 (version 2.31.22-0ubuntu1).

tags: added: rls-mgr-p-tracking
removed: rsl-mgr-p-tracking
Didier Roche (didrocks) on 2012-03-23
Changed in unity:
milestone: 5.8.0 → 5.10.0
David Barth (dbarth) wrote :

Considered fixed by the glib update. Re-open if the issue can still be reproduced.

Changed in bamf (Ubuntu Precise):
status: Confirmed → Fix Released
Tim Penhey (thumper) on 2012-03-26
Changed in bamf:
status: Triaged → Fix Released
Changed in unity-distro-priority:
status: Fix Committed → Fix Released
Changed in unity (Ubuntu Precise):
status: Confirmed → Fix Released
Changed in unity:
status: Triaged → Fix Released

Just installed Precise Beta 2 on a MacBook Air 2010 and I've got this issue.
I simply pressed the title bar of a window with 3 fingers, and the whole system hanged.
Hope this helps.
Thanks for the amaizing work though!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.